Instable applications that using cairo

Bug #129816 reported by signalat on 2007-08-01
20
Affects Status Importance Assigned to Milestone
Software Updater
Invalid
Undecided
Unassigned
libcairo
Won't Fix
Medium
compizconfig-settings-manager (Ubuntu)
Undecided
Unassigned
pycairo (Ubuntu)
Low
Unassigned
software-properties (Ubuntu)
Undecided
Unassigned

Bug Description

sudo update-manager

Traceback (most recent call last):
File "/usr/bin/update-manager", line 28, in <module>
import gtk
File "/var/lib/python-support/python2.5/gtk-2.0/gtk/__init__.py", line 48, in <module>
from gtk import _gtk
File "/usr/lib/python2.5/site-packages/cairo/__init__.py", line 1, in <module>
from _cairo import *
ImportError: /usr/lib/python2.5/site-packages/cairo/_cairo.so: undefined symbol: cairo_clip_extents

actually all programs using python crash and give the same error message.

signalat (signalat) wrote :

the bug is for gesty.

signalat (signalat) wrote :

the bug is for gusty.

sometimes this happen to me using 7.04..
if i use apt-get update/upgrade command it works.. sometimes if i use update manager to update it does not work.. It freeze! it rimains minutes and minutes to load but then i have to reboot my pc.. Sometimes it works correctly
I really don't understand what is the problem!
Other people have the same problem?
Thanks and bye

One of our users reported this error when launching any application using pycairo:
Traceback (most recent call last):
  File "exaile.py", line 44, in <module>
    import gtk, gtk.glade, pango, dbus
  File "/var/lib/python-support/python2.5/gtk-2.0/gtk/__init__.py", line 48, in <module>
    from gtk import _gtk
  File "/usr/lib/python2.5/site-packages/cairo/__init__.py", line 1, in <module>
    from _cairo import *
ImportError: /usr/lib/python2.5/site-packages/cairo/_cairo.so: undefined symbol: cairo_clip_extents

This bug has been reported to Ubuntu too: https://launchpad.net/bugs/129816/.

Thank you.

likely an old version installed to a local directory

I have the same problem.
Example for Exaile:
Traceback (most recent call last):
  File "exaile.py", line 44, in <module>
    import gtk, gtk.glade, pango, dbus
  File "/var/lib/python-support/python2.5/gtk-2.0/gtk/__init__.py", line 48, in <module>
    from gtk import _gtk
  File "/usr/lib/python2.5/site-packages/cairo/__init__.py", line 1, in <module>
    from _cairo import *
ImportError: /usr/lib/python2.5/site-packages/cairo/_cairo.so: undefined symbol: cairo_clip_extents

That happens for all programs that use cairo

Sebastien Bacher (seb128) wrote :

Could you run "ldd -r "/usr/lib/python2.5/site-packages/cairo/_cairo.so" and copy that to a comment? What version of libcairo2 and python-cairo are installed?

Paolo Naldini (hattory) wrote :

I have libcairo2 1.4.10-1 and python-cairo 1.4.0-2
In attached there is output of the command.

Changed in libcairo:
status: Unknown → Invalid
Sebastien Bacher (seb128) wrote :

" libcairo.so.2 => /usr/local/lib/libcairo.so.2 (0xb7f5b000)", you install a local version which is taking over the Ubuntu one and creating your issues, not a bug, you should use the distribution version

Changed in pycairo:
importance: Undecided → Low
status: New → Invalid
Sebastien Bacher (seb128) wrote :

not an update-manager bug

Changed in update-manager:
status: New → Invalid
Paolo Naldini (hattory) wrote :

Thanks for replay, but i don't understand what i must to do.
Which package I must change with the distribution version?

Sebastien Bacher (seb128) wrote :

you installed a custom libcairo out of the packaging system, you should know why you did it, if not I would suggest delete it and use the Ubuntu version

Paolo Naldini (hattory) wrote :

I have solved the problem in this way:

I removed all the libraries present in /usr/local/lib and then I launched ldconfig command.

pintas (pintas) wrote :

I'm sorry, but i have no libs in /usr/local/lib and running the ldconfig command alone won't do any good.
I've also tried to remove the libcairo2 package, wich removed all dependencies (many packages), i uncomented all third party repositories from my sources-list and then installed libcairo2 again, then i installed all packages again, runned ldconfig, and still have the same error.

/usr/lib/python2.5/site-packages/apt/__init__.py:18: FutureWarning: apt API not stable yet
  warnings.warn("apt API not stable yet", FutureWarning)
/usr/lib/python2.5/site-packages/GDebi/GDebi.py:95: GtkWarning: gdk_window_set_cursor: assertion `GDK_IS_WINDOW (window)' failed
  self.window_main.set_sensitive(False)
Traceback (most recent call last):
  File "/usr/bin/gdebi-gtk", line 67, in <module>
    self.show_alert(gtk.MESSAGE_ERROR, err_header, err_body)
NameError: name 'self' is not defined

Can someone please provide a logical solution for this?

Thank you.

Audun Sæther (auduns) wrote :

Removing everything inside /usr/local/lib and running ldconfig worked for me, ccsm now works again.

slavojzizek (slavojzizek) wrote :

lzte's comment/fix worked in Ubuntu 7.10

solved my issues- these programs wouldn't load

System > Administration > Restricted Drivers Manager
System > Administration > Screens and Graphics
System > Administration > Software Sources
The GUI for my System Updates.

Sebastian Heinlein (glatzor) wrote :

It is very clear that you messed up your system.

Changed in software-properties:
status: New → Invalid
Zrimal (prabodha007) wrote :

I did some workaround and it solved for me (in Gutsy).

backup all files starting with libcairo.* in /usr/local/lib and remove them
Then create links

# ln -s /usr/lib/libcairo.so.2 /usr/local/lib/libcairo.so.2
# ln -s /usr/lib/libcairo.so /usr/local/lib/libcairo.so
# ln -s /usr/lib/libcairo.a /usr/local/lib/libcairo.a
# ln -s /usr/lib/libcairo.la /usr/local/lib/libcairo.la

Now everything works!

sudo rm /usr/local/lib/libcairo* (may or may not be nessessary)
sudo apt-get install --reinstall libcairo2 (with offical repos)

That

or if it doesn't work:

sudo mv /etc/apt/sources.list /etc/apt/sources-backup.list.bak
sudo touch /etc/apt/sources.list
sudo rm /usr/local/lib/libcairo* #(again, may or may not be nessessary)
sudo apt-get update
sudo apt-get install --reinstall libcairo2
sudo mv /etc/apt/sources.list /etc/apt/sources.list.clean
sudo mv /etc/apt/sources-backup.list.bak

That might provide partial relief from this bug.

Daniel T Chen (crimsun) on 2008-11-12
Changed in compizconfig-settings-manager:
status: New → Invalid
Changed in libcairo:
importance: Unknown → Medium
status: Invalid → Won't Fix
Changed in libcairo:
importance: Medium → Unknown
Changed in libcairo:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.