Ubuntu

Bootchart/pybootchartgui started with live CD

Reported by Hernando Torque on 2010-06-14
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
pybootchartgui (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pybootchartgui

It's the same bug as #512172 or #343215 but it occurred during installing the Maverick daily build. Is bootchart (and pybootchartgui) really supposed to run off of the live CD?

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: pybootchartgui 0+r139-2
ProcVersionSignature: Ubuntu 2.6.35-2.3-generic 2.6.35-rc2
Uname: Linux 2.6.35-2-generic i686
Architecture: i386
Date: Mon Jun 14 21:28:38 2010
ExecutablePath: /usr/bin/pybootchartgui
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100614)
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/bootchart --format=png --crop-after=compiz,metacity,mutter,kwin,xfwm4 --annotate=ureadahead,mountall,hostname,hwclock --annotate=Xorg --annotate=gdm-session-worker --output=/var/log/bootchart /var/log/bootchart/hostname-maverick-20100614-1.tgz
ProcEnviron:

PythonArgs: ['/usr/bin/bootchart', '--format=png', '--crop-after=compiz,metacity,mutter,kwin,xfwm4', '--annotate=ureadahead,mountall,hostname,hwclock', '--annotate=Xorg', '--annotate=gdm-session-worker', '--output=/var/log/bootchart', '/var/log/bootchart/hostname-maverick-20100614-1.tgz']
SourcePackage: pybootchartgui
Title: pybootchartgui crashed with ValueError in get_proc_state()
UserGroups:

Hernando Torque (htorque) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #512172, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check
visibility: private → public
summary: - pybootchartgui crashed with ValueError in get_proc_state()
+ Bootchart/pybootchartgui started with live CD
Louis Simard (louis-simard) wrote :

According to Jamie Bennett, bootchart on the LiveCD was useful (if not instrumental) for optimisation work in Ubuntu Lucid's LiveCD boot time; it's how Jamie discovered that debconf was being started more than once to get its configuration values.

I requested the inclusion of bootchart in Maverick daily builds for some more optimisation work, again for boot time on the LiveCD itself; see bug 589629 for more information. bootchart should be removed from Maverick come Alpha 5 or Beta 1.

Hernando Torque (htorque) wrote :

Well, in that case I'm closing this bug. Thanks for the info!

Changed in pybootchartgui (Ubuntu):
status: New → Invalid
Morris Cavestro (fly82) on 2010-06-15
Changed in pybootchartgui (Ubuntu):
status: Invalid → Confirmed
tags: added: iso-testing
Brian Murray (brian-murray) wrote :

Setting back to Invalid as Morris provided no explanation as to why the bug report should be opened again. Additionally, pybootchartgui does not appear on the Oneiric Live CDs.

Changed in pybootchartgui (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments