Ubuntu

pybliographer doesn't support UTF-8

Reported by Erich Pawlik on 2006-04-08
10
Affects Status Importance Assigned to Milestone
Pybliographer
Unknown
Unknown
pybliographer (Ubuntu)
Wishlist
Unassigned

Bug Description

I am using UTF-8 on my machine. In my environment, there is

LANG=en_GB.UTF-8
LANGUAGE=en_GB:en

Default language in Gnome is English/United Kingdom.

I have edited bibtex files with kile (also on UTF-8). I have books in German, French and Portuguese in addition to English. In those languages there are characters such as Ä or á that are not being used in English. While tetex, gedit or a terminal window are showing them properly, the are shown correctly in pybliographer. é as an example is shown as é.

Regards

Erich

description: updated
Aanjhan Ranganathan (aanjhan) wrote :

Thanks for Reporting. Can you please attach a small sample German/French file that gives that error? I mean a file with those accents. It would be really helpful in confirming and further processing of the report. Also it would be nice if you could provide a neat step by step procedure to reproduce the bug.

Changed in pybliographer:
status: Unconfirmed → Needs Info

I have added a bibtex file in UTF8 containing bibliography entries about some mathematics textbooks. There are some German language titles containing umlauts such as ü, ö, ä. In addition, one author (Jean Dieudonné) is a frenchman those name is containing the letter é.

My locale settings are:

LANG=en_GB.UTF-8
LANGUAGE=en_GB:en

The file has been edited in Kile, a KDE-based latex editor using a UTF-8 as default encoding. It display correctly in the Gnome editor and in Firefox when selecting a UTF-8 encoding.

To reproduce the error is easy: Just open the attached file.

Please file free to contact me if you need additional information about my setup.

I have attached a screenshot taking when opening the file uploaded when opening the file uploaded in my previous post.

Thanks for uploading the file Eric. I could reproduce the bug. The file opens properly on gedit [accents are perfect] but pybliographer does not. Screen shot attached matches my output too.

Changed in pybliographer:
status: Needs Info → Confirmed
Aanjhan Ranganathan (aanjhan) wrote :

I also figured out that the Debian version is 1.2.8-1 but Ubuntu still holds 1.2.6.2.
May be the bug is solved in that stable release. What about an UVF exception?

William Grant (wgrant) wrote :

Still present in Feisty.

William Grant (wgrant) on 2007-04-03
Changed in pybliographer:
importance: Medium → Wishlist

Please check if this still happens in the current development release (hardy).
In that case it would be better to report the bug to the developers of the software in the bug tracker of http://sourceforge.net/projects/pybliographer/.

Aanjhan Ranganathan (aanjhan) wrote :

Comment from upstream bug tracker.
pybliographer expects standard LaTeX accented characters, like \'e for é.
Out of curiosity, what tool do you use to format your bibtex file?

Aanjhan Ranganathan (aanjhan) wrote :

it works. Modifying the bibtex file by replacing the umlauts in question with latex style replacements solves the issue.
Eg. use \"{u} for umlaut u.

Closing the bug. Feel free to re-open it if you have troubles still.

Changed in pybliographer:
status: Confirmed → Fix Released
Aanjhan Ranganathan (aanjhan) wrote :

Try this bib tex file and give feedback.

Kahn Jonas (kahn-jonas) wrote :

Well, it would seem it does not understand that pretty standard LateX either:

@ARTICLE{Guta&Kahn,
   AUTHOR = {Gu\c{t}\u{a}, M. and Kahn, J.},
   TITLE = {Local asymptotic normality for qubit states},
   JOURNAL = {Phys. Rev. A},
   VOLUME = {73},
   PAGES = {052108} ,
   YEAR = 2006,
   URL = {arXiv:quant-ph/0512075},
}

Here, the Romanian letters \c{t} and \u{a} are not understood.

I shall post the same message upstream.

I use "\usepackage[utf8]{inputenc}" in my LaTeX file. I have no problem to produce proper output with PDFLatex (using Kile) and I use "real" Umlauts etc in my Bibtex file. I think in the year 2008 it should be possible to use unicode instead of \"{a} etc. The latex accent characters should be possible as an alternative or for backwards compatibility.

Just think, Epiphany or Firefox would only display ä, when ä is used and ignore unicode.

I have the same problem described by Eric Pawlik. I have a bibtex file encoded in UTF-8 with some Spanish characteres, like á or ñ, but there are not correctly showed in Pybibliographer 1.2.12. Also, when I create a new entry the bibtex file is not coded using UTF-8. Instead, it use tex codes like \'a or \~n. I prefer the use of UTF-8 over tex codes. It is solved in the version 1.2.14? I'm using the version 1.2.12 only because it is shipped with Ubuntu 10.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.