HP3600 recommended driver fails to print some colours

Bug #228635 reported by Gareth Williams on 2008-05-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pxljr (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: foomatic-db

Heron LTS release(available updates to 8 May 2008 all loaded)

Installed HP3600 Color Laser over network
using the System / Administration / Printers dialogue (Appsocket/HP Jetdirect).
as hp:/net/HP_Color_Laserjet_3600?ip=102.168.1.114

Recommended printer driver (HP Color Laserjet 3600 Foomatic/pxljr [en])
fails to print 100% red,magenta and yellow (90% etc look fine).
Problem occurs on Printer Test Page and from Open Office Writer when printing Light Red, Light Magenta and Yellow ( where 'Red 4' colour - looks same as Light Red - prints OK ! )

The alternate printer driver prints the missing colours OK.
(HP Color Laserjet 3600 Foomatic/hpijs [en], 2.8.2).

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Can you scan or photograph your printout and post it here? My printout on this printer looks OK.

Changed in foomatic-db:
status: New → Incomplete
Revision history for this message
F.H. (fheinsen) wrote :

I can confirm this problem. Attached is a scan of a freshly printed test page.

Revision history for this message
F.H. (fheinsen) wrote :

Gareth -- I was able to solve the problem by switching from the recommended "pxljr" driver to the alternate "hpijs" driver. Go to System -> Administration -> Printing -> HP ColorLaserjet 3600, then click to change the make and model, choose HP -> Color LaserJet 3600, click on the "hpijs" driver, and accept the new postscript-printer-definition (PPD) file as is. That should solve the problem.

Revision history for this message
Aaron Albright (albrigha-deactivatedaccount) wrote :

Till,

Just curious--how come "pxljr" is the default ppd? Shouldn't it be hpijs?

A

Revision history for this message
Gareth Williams (gw-westdale) wrote :

I use the alternative driver.
I raised the bug so that (possibly) the alternative could be made the default.
Gareth

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

The hpijs driver does not print in the highest quality modes without a proprietary plug-in, whereas pxljr does all modes, as a completely free piece of software.

With which option settings did you obtain the problem?

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Now I could reporduce the bug. It occurs only in the draft and normal quality modes. I have high quality as default. So you can set your default to high quality as a workaround.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

I have switched to hpijs as default driver in the upstream Foomatic database now. With pxljr also the duplex did not work.

Changed in foomatic-db:
status: Incomplete → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package foomatic-db - 20080904-0ubuntu1

---------------
foomatic-db (20080904-0ubuntu1) intrepid; urgency=low

  * New upstream release
     o Fixed generic PostScript driver to get working with the PDF workflow.
       The driver got broken in the upstream release from August 21 and it
       had already problems before (LP: #259318).
     o Ricoh has fixed several problems reported by "cupstestppd" in their
       PPDs (Upstream bug #164).
     o Changed recommended driver for the HP Color LaserJet 35xx/36xx from
       "pxljr" to "hpijs". The former driver has problems with some colors
       (LP: #228635) and duplex does not work, too.
     o Added entries for Lexmark E120 and E120n (LP: #135489), the
       Dell 3100cn (LP: #90718), and the Okidata B4350 (LP: #203358).
     o Fixed typos in printer model names which made some listed PPDs
       not accessible: HP LaserJet 4345 MFP, HP Color LaserJet 9500 MFP,
       Brother HL-2060, HP DesignJet 750, Apple 12 640ps, Ricoh Aficio 5206
       (Red Hat bug #459847).
     o Changed recommended driver of Brother HL-2060 to "hpijs" (Upstream
       bug #166, Red Hat bug #292021).
     o Fixed PPDs for the "pbm2l7k" driver (Upstream bug #167).
     o Added IEEE 1284 device ID for Lexmark E120n (Red Hat bug #201318).
  * debian/rules: Replace the wrong "*1284DeviceId" by "*1284DeviceID" in
    the PPDs (Upstream bug #164).

 -- Till Kamppeter <email address hidden> Thu, 04 Sep 2008 16:38:03 +0200

Changed in foomatic-db:
status: In Progress → Fix Released
Revision history for this message
Ryan Rawdon (flieslikeabrick) wrote :

This problem is still present in Intrepid, foomatic-db version 20080918-0ubuntu2

I encountered the problem in Hardy with a clean install, suggested driver. Printing a test page resulted in the 100% red, magenta and yellow areas being white (with the black 100% text showing). I tried it again in a virtual machine with the same result. I upgraded the virtual machine to Intrepid and am having the same problem. The Hardy system had foomatic-db version 20080211-0ubuntu1

I am reopening this bug report as it is still impacting hardy, it is not fixed. Maybe it was fixed in the version that the Janitor mentions, but in that case there is a regression and the bug is present again.

Revision history for this message
Ryan Rawdon (flieslikeabrick) wrote :

See my previous comment, this bug is present in Intrepid's current foomatic-db version again, version 20080918-0ubuntu2.

My previous comment was based on a HP3600 (network), but it is clearly the same problem. My Ubuntu printer test page looks exactly like scan.png attached by Franz A. Heinsen

Changed in foomatic-db:
status: Fix Released → Confirmed
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

In the foomatic-db the recommended driver is switched to HPIJS, at least in Intrepid. The problem is a driver-internal problem of the pxljr driver. I am moving this bug to pxljr.

Note also that a simple upgrade from one Ubuntu release to another does not change printer drivers of existing print queues if the recommended driver in the foomatic-db changes.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Reported problem to the upstream author of the pxljr driver

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Got dix from upstream. Fixed Jaunty package is on its way.

Changed in pxljr:
status: Confirmed → In Progress
Changed in pxljr:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pxljr - 1.1-0ubuntu4

---------------
pxljr (1.1-0ubuntu4) jaunty; urgency=low

  * debian/patches/blank-color-squares.patch: Some solid colors got printed in
    white in "Normal" and "Draft" quality modes (Easily visible on Ubuntu test
    page, LP: #228635).

 -- Till Kamppeter <email address hidden> Tue, 11 Nov 2008 19:31:50 +0100

Changed in pxljr:
status: Fix Committed → Fix Released
Changed in pxljr (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments