Moving mouse messes up the desktop

Bug #1045491 reported by Carla Sella on 2012-09-03
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux-ti-omap4 (Ubuntu)
High
Ricardo Salveti
Quantal
High
Ricardo Salveti
pvr-omap4 (Ubuntu)
High
Ricardo Salveti
Quantal
High
Ricardo Salveti

Bug Description

After installing this image: http://cdimage.ubuntu.com/daily-live/20120903.4/quantal-desktop-armhf+omap4.img on a Panda board, after having logged on to my account, moving the mouse around creates lines on the desktop as you can see in the attached image.
I'ts very disturbing because as you move the mouse the desktop gets messed up.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xorg 1:7.7+1ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-209.15-omap4 3.5.2
Uname: Linux 3.5.0-209-omap4 armv7l
ApportVersion: 2.5.1-0ubuntu4
Architecture: armhf
Date: Mon Sep 3 22:03:34 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus:
 pvr-omap4, 1.9.0.5.1.1, 3.5.0-209-omap4, armhf: installed
 pvr-omap4, 1.9.0.5.1.1, 3.5.0-209-omap4, armv7l: installed
GraphicsCard:

InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha armhf+omap4 (20120903.4)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: ro quiet splash root=UUID=9cd16cf5-dce5-452e-a6ec-b7420f7bf194
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
version.compiz: compiz 1:0.9.8.0-0ubuntu1
version.libdrm2: libdrm2 2.4.38-0ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120821.c1114c61-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120821.c1114c61-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.12.99.905-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120713.6ef1ad6a-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1-4~ubuntu1

Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :

The Panda board is attached to a Samsung UE22D5003BV Television via HDMI.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1045491

tags: added: iso-testing
Oliver Grawert (ogra) on 2012-09-04
affects: xorg (Ubuntu Quantal) → pvr-omap4 (Ubuntu Quantal)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pvr-omap4 (Ubuntu):
status: New → Confirmed
Oliver Grawert (ogra) on 2012-09-04
Changed in pvr-omap4 (Ubuntu Quantal):
importance: Undecided → High
milestone: none → ubuntu-12.10-beta-2
assignee: nobody → Ricardo Salveti (rsalveti)
Oliver Grawert (ogra) wrote :

this is an issue with the kernel side of the 3D driver, i know that ricardo has a fix for this pending already.

Changed in linux-ti-omap4 (Ubuntu Quantal):
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Ricardo Salveti (rsalveti)
milestone: none → ubuntu-12.10-beta-2
Carla Sella (carla-sella) wrote :

With image: http://cdimage.ubuntu.com/daily-live/20120909/quantal-desktop-armhf+omap4.img during live desktop session, instead of getting a messed up desktop with orizontal lines when moving mouse aroung, the screen flickers when moving the mouse around.

Carla Sella (carla-sella) wrote :

With image: http://cdimage.ubuntu.com/daily-live/20120912/quantal-desktop-armhf+omap4.img moving the mouse around the desktop messes the desktop with grey/white/black lines, just like picture I attached when first reporting the bug.

description: updated
Oliver Grawert (ogra) wrote :

yes, the fix for this bug, while already tested, was still not uploaded...

http://people.canonical.com/~rsalveti/quantal/kernel/ has the test packages. in case you want to try them you can just wget all of them and run:

sudo dpkg -i *.deb; sudo dpkg-reconfigure pvr-omap4; sudo reboot

Ricardo Salveti (rsalveti) wrote :

Patches are available http://kernel.ubuntu.com/git?p=rsalveti/ubuntu-quantal.git;a=shortlog;h=refs/heads/omapdss-low-level-support, sent a pull-request to ppisati.

There's still an issue with DPMS, which can show a random color pattern instead of going black, but that doesn't happen all the time. As the flickering is gone with that kernel, it'd help if we could at least land these changes now.

Changed in pvr-omap4 (Ubuntu Quantal):
status: Confirmed → Invalid
Ricardo Salveti (rsalveti) wrote :

Marking it as Invalid at the pvr-omap4 side, as it's actually related with the kernel.

Carla Sella (carla-sella) wrote :

@ Oliver: I installed the test packages you suggested in comment #9 and everything after reboot works fine.
                 I can move windows and mouse around without any problem.
                Great!

Paolo Pisati (p-pisati) wrote :

fixed in 3.5.0-210-17

Changed in linux-ti-omap4 (Ubuntu Quantal):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers