puppetmaster-passenger fails to install with puppet 2.6.4-2ubuntu2.5

Bug #881361 reported by Blake Maltby on 2011-10-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
puppet (Ubuntu)
High
Marc Deslauriers
Lucid
High
Marc Deslauriers
Maverick
High
Marc Deslauriers
Natty
High
Marc Deslauriers
Oneiric
High
Marc Deslauriers
Precise
High
Marc Deslauriers

Bug Description

Description: Ubuntu 11.04
Release: 11.04
Running a clean image on amazon ec2 (or running locally) followed by

sudo apt-get update
sudo apt-get install puppetmaster-passenger

results in

--snip--
Setting up puppetmaster-common (2.6.4-2ubuntu2.5) ...
 * Starting puppet queue [ OK ]
Setting up puppetmaster-passenger (2.6.4-2ubuntu2.5) ...
/usr/lib/ruby/1.8/puppet/application/cert.rb:16:in `subcommand=': undefined method `to_sym' for nil:NilClass (NoMethodError)
 from /usr/lib/ruby/1.8/puppet/application/cert.rb:106:in `parse_options'
 from /usr/lib/ruby/1.8/puppet/application.rb:284:in `run'
 from /usr/lib/ruby/1.8/puppet/application.rb:393:in `exit_on_fail'
 from /usr/lib/ruby/1.8/puppet/application.rb:284:in `run'
 from /usr/sbin/puppetca:4
/usr/lib/ruby/1.8/puppet/application/cert.rb:16:in `subcommand=': undefined method `to_sym' for nil:NilClass (NoMethodError)
 from /usr/lib/ruby/1.8/puppet/application/cert.rb:106:in `parse_options'
 from /usr/lib/ruby/1.8/puppet/application.rb:284:in `run'
 from /usr/lib/ruby/1.8/puppet/application.rb:393:in `exit_on_fail'
 from /usr/lib/ruby/1.8/puppet/application.rb:284:in `run'
 from /usr/sbin/puppetca:4
notice: Signed certificate request for ca
notice: Rebuilding inventory file
You must provide hosts or :all when using generate
dpkg: error processing puppetmaster-passenger (--configure):
 subprocess installed post-installation script returned error exit status 24
Setting up ruby1.8-dev (1.8.7.302-2) ...
--snip--

This worked fine before the security patch released on the 24th October 2011.

CVE References

Dave Walker (davewalker) wrote :

I was able to reproduce this on a fresh natty install, with updates.

Changed in puppet (Ubuntu):
status: New → Confirmed
importance: Undecided → High
tags: added: regression-update
Changed in puppet (Ubuntu Natty):
status: New → Confirmed
importance: Undecided → High
Dave Walker (davewalker) on 2011-10-25
Changed in puppet (Ubuntu Lucid):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in puppet (Ubuntu Maverick):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in puppet (Ubuntu Natty):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in puppet (Ubuntu Oneiric):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in puppet (Ubuntu Precise):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in puppet (Ubuntu Oneiric):
importance: Undecided → High
Changed in puppet (Ubuntu Maverick):
importance: Undecided → High
Changed in puppet (Ubuntu Lucid):
importance: Undecided → High
Marc Deslauriers (mdeslaur) wrote :

This looks like it only affects Natty...

Changed in puppet (Ubuntu Lucid):
status: New → Invalid
Changed in puppet (Ubuntu Maverick):
status: New → Invalid
Changed in puppet (Ubuntu Oneiric):
status: New → Invalid
Changed in puppet (Ubuntu Precise):
status: Confirmed → Invalid
Dave Walker (davewalker) wrote :

Confirmed, only impacts Natty - and Lucid does not have this binary package.

Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package puppet - 2.6.4-2ubuntu2.6

---------------
puppet (2.6.4-2ubuntu2.6) natty-security; urgency=low

  * REGRESSION FIX (LP: #881361)
    - debian/patches/CVE-2011-3872.patch: updated to fix regression with
      "puppetca" command.
 -- Marc Deslauriers <email address hidden> Tue, 25 Oct 2011 13:16:29 -0400

Changed in puppet (Ubuntu Natty):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers