Puppet client is broken on Lucid Alpha 2

Bug #509625 reported by Paul Elliott
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
puppet (Ubuntu)
Fix Released
High
Unassigned

Bug Description

Binary package hint: puppet

Puppet 0.25.1-3ubuntu1 as part of Lucid Alpha 2 is broken, it fails to startup with the following error messages after a fresh install:

root@ubuntu2:/home/pre500# /etc/init.d/puppet start
 * Starting puppet configuration management tool /usr/lib/ruby/1.8/puppet/util/settings/file_setting.rb:20:in `group=': Internal error: The :group setting for must be 'service', not '$group' (Puppet::Util::Settings::FileSetting::SettingError)
 from /usr/lib/ruby/1.8/puppet/util/settings/setting.rb:44:in `send'
 from /usr/lib/ruby/1.8/puppet/util/settings/setting.rb:44:in `initialize'
 from /usr/lib/ruby/1.8/puppet/util/settings/setting.rb:38:in `each'
 from /usr/lib/ruby/1.8/puppet/util/settings/setting.rb:38:in `initialize'
 from /usr/lib/ruby/1.8/puppet/util/settings.rb:398:in `new'
 from /usr/lib/ruby/1.8/puppet/util/settings.rb:398:in `newsetting'
 from /usr/lib/ruby/1.8/puppet/util/settings.rb:533:in `setdefaults'
 from /usr/lib/ruby/1.8/puppet/util/settings.rb:518:in `each'
 from /usr/lib/ruby/1.8/puppet/util/settings.rb:518:in `setdefaults'
 from /usr/lib/ruby/1.8/puppet.rb:71:in `setdefaults'
 from /usr/lib/ruby/1.8/puppet/defaults.rb:51
 from /usr/lib/ruby/1.8/puppet.rb:110:in `require'
 from /usr/lib/ruby/1.8/puppet.rb:110
 from /usr/lib/ruby/1.8/puppet/application/puppetd.rb:1:in `require'
 from /usr/lib/ruby/1.8/puppet/application/puppetd.rb:1
 from /usr/sbin/puppetd:158:in `require'
 from /usr/sbin/puppetd:158

root@ubuntu2:/home/pre500# apt-cache policy puppet
puppet:
  Installed: 0.25.1-3ubuntu1
  Candidate: 0.25.1-3ubuntu1
  Version table:
 *** 0.25.1-3ubuntu1 0
        500 http://gb.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

Related branches

Jonathan Davies (jpds)
Changed in puppet (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package puppet - 0.25.1-3ubuntu2

---------------
puppet (0.25.1-3ubuntu2) lucid; urgency=low

  * lib/puppet/defaults.rb: Change owner/group to "service".
    (LP: #509625)
 -- Chuck Short <email address hidden> Tue, 26 Jan 2010 11:13:30 -0500

Changed in puppet (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers