Version 4.21.0-2 is blocking ruby-net-scp/3.0.0-1 migration

Bug #1885614 reported by Lucas Kanashiro on 2020-06-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
puppet-beaker (Ubuntu)
Undecided
Unassigned

Bug Description

puppet-beaker/4.21.0-2 is blocking ruby-net-scp/3.0.0-1 migration because it has a tight version constraints regarding dependency on net-scp (and also net-ssh 6.x which is already in the Groovy release pocket).

Upstream already patched its gemspec file to be compatible with net-ssh 5.x and 6.x (no changes needed):

https://github.com/puppetlabs/beaker/commit/582e72bd152271e53c53b86eebe5323a461c9965

And net-scp version constraint was already relaxed in Debian (from ~> 1.2 to ~> 2.0) and after updating it to ~> 3.0 tests are still passing. I also filed a bug upstream to update net-scp to version 3.0.0 here:

https://tickets.puppetlabs.com/browse/BKR-1675

Related branches

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package puppet-beaker - 4.21.0-2ubuntu1

---------------
puppet-beaker (4.21.0-2ubuntu1) groovy; urgency=medium

  * Relax version constraints of net-s{sh,cp} (LP: #1885614).

 -- Lucas Kanashiro <email address hidden> Mon, 29 Jun 2020 11:32:36 -0300

Changed in puppet-beaker (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers