Autopkgtest regression triggered by Ruby 2.7

Bug #1866881 reported by Lucas Kanashiro
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
puma (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

puma version 3.12.4-1 has a regression in all architectures triggered by ruby-defaults/1:2.7~0.

autopkgtest log on amd64 as an example:

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-focal/focal/amd64/p/puma/20200306_211725_c5a69@/log.gz

Revision history for this message
Lucas Kanashiro (lucaskanashiro) wrote :

The debdiff attached applies the previous delta we used to carry on which it is still needed. The regression is fixed with it:

autopkgtest [16:06:25]: @@@@@@@@@@@@@@@@@@@@ summary
gem2deb-test-runner PASS

Bryce Harrington (bryce)
summary: - Autopkgtest regression trigerred by Ruby 2.7
+ Autopkgtest regression triggered by Ruby 2.7
Revision history for this message
Bryce Harrington (bryce) wrote :

Can you identify if this is intended to be a temporary fix, or a normal fix?

If it's just temporary, to test out if disabling the test is ok, then +1 to land it.

However, if this is intended to be a semi-permanent fix to the problem, a couple suggestions:

* Explain in whatever detail is available, what you think is causing the test failure. So when someone restores the test some day, they'll have some idea on what to check.

* A link to a debian or upstream discussion/ticket about the issue would be a nice-to-have

Revision history for this message
Lucas Kanashiro (lucaskanashiro) wrote :

I am not quite sure but since we are needing to carry this patch along new upstream releases this might not be just temporary. According to the DEP-3 headers this is an issue with Ubuntu builders:

Description: This test is probably using an already taken port on Ubuntu builder farm,
 it doesn't fail in Debian, in Ubuntu with sbuild on DebOMatic and locally.
Author: Gianfranco Costamagna <email address hidden>

I didn't spend more time investigating this since I noticed that the sync was a mistake and the previous delta fixes the regression. If you think more info is needed we can ask Gianfranco to chime in, and tell us the rationale behind this patch but I think the description is self explanatory.

Revision history for this message
Bryce Harrington (bryce) wrote :

Yeah I think a bit more detail would be worth gathering. Might help identify a way to eventually eliminate the delta.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

meh, I did have a look when I firstly introduced the delta, it was somewhat related to some internal LP configuration (it tries to talk with some localhost service), and I decide to patch back on disco days, one year ago.

I sponsored this one, because it doesn't indeed regress what is in release currently, but some more investigation is welcome, because I failed to trace it down to a real cause.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package puma - 3.12.4-1ubuntu2

---------------
puma (3.12.4-1ubuntu2) focal; urgency=medium

  - Merge from Debian unstable. Remaining changes:
    - Disable a test that fails on Ubuntu builder farm, but not locally
      (LP: #1866881).

 -- Lucas Kanashiro <email address hidden> Tue, 10 Mar 2020 15:46:46 -0300

Changed in puma (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments