Show an input port for cards which have no ALSA volume control

Bug #978109 reported by Conor Curran
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
High
David Henningsson
Precise
High
David Henningsson

Bug Description

Because pulse in Ubuntu ignores card ports which do not have a volume valid inputs and outputs are not detected by the control center's sound settings.
By removing "required = volume" in analog-input.conf valid SPDIF and input ports on my behringer uca222 are now visible.

Related branches

Revision history for this message
Conor Curran (cjcurran) wrote :
Revision history for this message
Conor Curran (cjcurran) wrote :
Changed in pulseaudio (Ubuntu):
assignee: nobody → David Henningsson (diwic)
importance: Undecided → Medium
status: New → In Progress
status: In Progress → Triaged
Revision history for this message
Sebastien Bacher (seb128) wrote :

raising the importance and milestoning for precise since according to Conor that's responsive for quite some bugs in the new soundnua interface in precise

Changed in pulseaudio (Ubuntu):
importance: Medium → High
summary: - Expose ports which have no volume
+ Show an input port for cards which have no ALSA volume control
Revision history for this message
David Henningsson (diwic) wrote :

Ok, so I had a look and it does not look like commenting out "required = volume" in analog-input.conf would cause many false positives, so I believe it's worth a try - i e, it probably fixes more machines than it breaks, and the potential breakage is not too bad (it will just show an extra port).

So far I have only heard of this happening on the input side, so limiting this bug to target input ports. I guess the same could happen on the output side, but without any hardware to prove it I'm not happy about doing something similar there.

Changed in pulseaudio (Ubuntu Precise):
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:1.1-0ubuntu15

---------------
pulseaudio (1:1.1-0ubuntu15) precise; urgency=low

  * 0125-alsa-sink-source-Really-set-volumes-on-port-change.patch:
    Fix volume not being correctly set on port change. With this fixed
    we can also drop
    0017-Hack-around-a-bug-in-the-core-causing-volumes-not-to.patch.
  * 0022-allow-analog-input-path-for-no-volume.patch:
    Allow inputs with no volume controls to still have ports. The lack of
    ports caused a problem for the new sound settings UI (LP: #978109)
  * 0126-alsa-sink-source-Make-sure-volumes-are-synchronised-.patch:
    Fix volumes not synchronised in guest session (LP: #915035)
 -- David Henningsson <email address hidden> Thu, 12 Apr 2012 00:24:20 +0200

Changed in pulseaudio (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers