Ubuntu

[Dell Inspiron N411Z] Bluetooth Headset pairs but does not show up in Sound Settings profile

Reported by Benjamin Kerensa on 2012-04-03
220
This bug affects 45 people
Affects Status Importance Assigned to Milestone
PulseAudio
New
Undecided
Unassigned
bluez (Ubuntu)
Medium
Unassigned
linux (Ubuntu)
Medium
Unassigned
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Expected Result:

After pairing bluetooth headset the device should then show up in > Sound Settings and work like any other audio device

Actual Result:

Jabra Halo v2 Bluetooth Headset pairs fine but does not show up in sound settings therefore is unusable

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: pulseaudio 1:1.1-0ubuntu13
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bkerensa 2121 F.... pulseaudio
Date: Mon Apr 2 20:07:36 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120325)
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: pulseaudio
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/24/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 0VK06J
dmi.board.vendor: Dell Inc.
dmi.board.version: FAB1
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd06/24/2011:svnDellInc.:pnDellSystemInspironN411Z:pvr:rvnDellInc.:rn0VK06J:rvrFAB1:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System Inspiron N411Z
dmi.sys.vendor: Dell Inc.
---
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
DistroRelease: Ubuntu 12.04
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
InterestingModules: btusb rfcomm bnep bluetooth
MachineType: Dell Inc. Dell System Inspiron N411Z
Package: pulseaudio
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-29-generic root=UUID=281cfb17-fceb-4b60-b002-bbadb81bf79b ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Tags: precise running-unity
Uname: Linux 3.2.0-29-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 06/24/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 0VK06J
dmi.board.vendor: Dell Inc.
dmi.board.version: FAB1
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd06/24/2011:svnDellInc.:pnDellSystemInspironN411Z:pvr:rvnDellInc.:rn0VK06J:rvrFAB1:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System Inspiron N411Z
dmi.sys.vendor: Dell Inc.
hciconfig:
 hci0: Type: BR/EDR Bus: USB
  BD Address: AC:72:89:44:9D:8B ACL MTU: 310:10 SCO MTU: 64:8
  UP RUNNING PSCAN
  RX bytes:828 acl:0 sco:0 events:34 errors:0
  TX bytes:637 acl:0 sco:0 commands:33 errors:0

Benjamin Kerensa (bkerensa) wrote :

This could be a bluez issue. To make sure, could you get bluez debug logs?

You can do this easily:

sudo stop bluetooth
sudo /usr/sbin/bluetoothd -n -d

Then attach the output of bluetoothd, you should be able to see whether it tries to hand off the device to pulseaudio. If it does, then pulseaudio debug logs will be needed as well.

Changed in bluez (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
Benjamin Kerensa (bkerensa) wrote :

Attached find the output of bluetoothd and if you need pulseaudio debugged can you pass on the process of harvesting that info.

Well, yes, it will also need the pulseaudio logs. AFAICT, bluez is finding the device and initializing the audio server bluetooth service; let's see if pulseaudio says it gets it.

In the attached files currently it doesn't list the bluetooth device as an audio device, was it paired when you filed the bug?

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
Benjamin Kerensa (bkerensa) wrote :

Yeah it was paired and it shows in BT settings but not in Sound Settings.... Which is what is weird.

How can I grab pulseaudio logs?

Benjamin Kerensa (bkerensa) wrote :

Attached find the logs from pulseaudio

Seems like maybe bluez doesn't actually support the device all that well after all:

Apr 12 08:39:57 bkerensa bluetoothd[1043]: Discovery session 0x7fd800edf2c0 with :1.111 activated
Apr 12 08:40:05 bkerensa bluetoothd[1043]: Stopping discovery
Apr 12 08:40:11 bkerensa bluetoothd[1043]: Badly formated or unrecognized command: AT+BIA=0,0,0,1,1,1,0
Apr 12 08:40:12 bkerensa kernel: [ 5040.289440] input: 50:C9:71:26:51:3E as /devices/virtual/input/input19
Apr 12 08:40:13 bkerensa pulseaudio[2137]: [pulseaudio] card.c: Created 4 "bluez_card.50_C9_71_26_51_3E"
Apr 12 08:40:13 bkerensa bluetoothd[1043]: Operation not supported (95)
Apr 12 08:40:13 bkerensa pulseaudio[2137]: [pulseaudio] bluetooth-util.c: Failed to acquire transport fd: Input/output error
Apr 12 08:40:13 bkerensa pulseaudio[2137]: [pulseaudio] card.c: Freed 4 "bluez_card.50_C9_71_26_51_3E"
Apr 12 08:40:13 bkerensa pulseaudio[2137]: [pulseaudio] module.c: Failed to load module "module-bluetooth-device" (argument: "address="50:C9:71:26:51:3E" path="/org/bluez/1043/hci0/dev_50_C9_71_26_51_3E""): initialization failed.

I can't match that to bluez debug logs attached above. Any chance you could try that again? We should be seeing some "Transport XXXX: read lock acquired" messages, if things were working properly. Or it's just failing earlier than that point.

Regardless, we'll need to file this bug upstream with the bluez authors.

Benjamin Kerensa (bkerensa) wrote :

Here is the bluez log again... If you would like I can raise a bluez bug upstream

Richard (richarderiley) wrote :

I have exactly the same problem with a bluetooth Belkin Music Receiver. It worked fine in 11.10 and stopped working upon upgrade to 12.04 LTS last week.

Don't know if the attached pulseaudio log helps?

I'm also seeing this issue, with a Sennheiser MM100 headset. As for Richard, this worked fine on Ubuntu 11.10. It seems like there are enough attached logs to be getting on with, but let me know if that's not the case and what commands to run and I'll happily gather more :-)

Benjamin, Simon; could you please attach the output of lsusb for the bluetooth device you use? I'd like to know if we're talking about the same device in all three cases, which might explain a lot.

For instance, I use a Sennheiser MM200 daily; it pairs just fine on 12.04, just like it did in previous releases.

There indeed seems to be more than enough logs on this bug report -- Simon and Richard, just to be safe please file separate bug reports and also attach bluetooth debug logs (see comment #2), in case we're dealing with a different issue, on different hardware.

Benjamin Kerensa (bkerensa) wrote :

Bus 002 Device 010: ID 0b0e:090c GN Netcom

Mathieu will you need anything else from me or will that output and the above logs work?

Changed in bluez (Ubuntu):
status: Incomplete → Confirmed
Changed in pulseaudio (Ubuntu):
status: Incomplete → Confirmed
CuteChaps (sh-senthilkumar) wrote :

I am facing the same problem

spacemonkey (tj-tjstevens) wrote :

Same problem here using 12.04 with a Jawbone Jambox. Device pairs and appears in bluetooth settings but is not available as an input or output device in sound settings.

Same problem with MM100 in 12.04. Device pairs but doesn't show up as sound output. The problem is intermittent, though. If I restart bluetoothd it tends to work again.

Sorry Mathieu, I only just came back to check on the status of this bug! New to the way launchpad works, I'd assumed that I'd get e-mail notifications or some such.

Do you want the output of lsusb when I've attempted to pair the headphones or just generally? Or a before and after?

Restarting bluetoothd doesn't seem to do the trick for me, even though I have the same device as Jordan.

drink (martin-espinoza) wrote :

Same problem with Motorola H685 on Precise amd64.
I'd include pulseaudio logs if I knew how

Simon: it shouldn't matter. If it's not a bluetooth dongle when lsusb at any time is good. If it's a dongle, then it would be better if it was done while it's connected ;)

drink; please also attachthe output of lsusb.

Changed in bluez (Ubuntu):
status: Confirmed → Incomplete

Setting to Invalid for now for pulseaudio, because discussing with bkerensa it seems as though this might be a hardware specific problem with support in bluez.

Changed in pulseaudio (Ubuntu):
status: Confirmed → Invalid

My lsusb output is below. Can I ask what exactly "bluez" is? This is certainly a regression between different Ubuntu releases, so it's certainly a "confirmed" bug. I can believe that it's not in pulseaudio and needs to be punted off somewhere else though - I'm guessing that "bluez" is the bluetooth handler, or something to that effect?

Let me know if there's anything else I can get for you :-)

$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 04f2:b1d8 Chicony Electronics Co., Ltd
Bus 001 Device 003: ID 0cf2:6250 ENE Technology, Inc. SD card reader (UB6250)
Bus 003 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Benjamin Kerensa (bkerensa) wrote :

Mathieu: In letting slangasek have a look at the hardware and my laptop he felt this may be a Kernel bug

Changed in bluez (Ubuntu):
status: Incomplete → Confirmed

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 972063

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

ApportVersion: 2.0.1-0ubuntu11
Architecture: amd64
DistroRelease: Ubuntu 12.04
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
InterestingModules: rfcomm bnep bluetooth
MachineType: Acer AO533
NonfreeKernelModules: wl
Package: linux
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-27-generic root=UUID=6b15cc21-1016-49f2-ae13-7efacb682be8 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
Tags: precise running-unity
Uname: Linux 3.2.0-27-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 06/07/2010
dmi.bios.vendor: Acer
dmi.bios.version: V1.05
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: AO533
dmi.board.vendor: Acer
dmi.board.version: V1.05
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.05
dmi.modalias: dmi:bvnAcer:bvrV1.05:bd06/07/2010:svnAcer:pnAO533:pvrV1.05:rvnAcer:rnAO533:rvrV1.05:cvnAcer:ct10:cvrV1.05:
dmi.product.name: AO533
dmi.product.version: V1.05
dmi.sys.vendor: Acer
hciconfig:

syslog:

tags: added: apport-collected running-unity

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in pulseaudio (Ubuntu):
status: Invalid → Confirmed

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Benjamin Kerensa, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please plug in your USB bluetooth receiver into your computer, unplug all other USB devices, execute the following in a terminal, and report the results to this report:
lsusb

As well, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

Please let us know your results. Thank you for your understanding.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Medium
robert.vertesi (vertesi) wrote :

Same problem here.
Ubuntu 12.04LTS on Toshiba Satellite A300 + Sony CMTHX5BT -- works fine
Ubuntu 12.04LTS on Lenovo U300s + Sony CMTHX5BT -- Nothing to select after pairing

robert.vertesi, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette

When opening up the new report, please feel free to subscribe me to it. Thank you for your understanding.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

robert.vertesi (vertesi) wrote :

Dear Christopher,
Looks like my post was too early. Yesterday i tried to connect for the 1st time, I was struggling with it a lot, reboots etc. - without any use, today i tried and it just worked. I haven't downloaded updates or anything. I think there's no point in filing a report now. If I meet the error again, I will try to figure out how to reproduce and return to the issue.
Robert

Benjamin Kerensa (bkerensa) wrote :

Robert,

My Bluetooth device does not have a "USB Receiver" it is intended to connect strictly via a BT connection with my BT hardware on the laptop in question. However here is what I get when I connect USB charging cable and BT headset via USB:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 1bcf:2980 Sunplus Innovation Technology Inc.
Bus 002 Device 003: ID 8086:0189 Intel Corp.

Benjamin Kerensa (bkerensa) wrote :

Notably extensive testing of this hardware has already been conducted by myself and also various Canonical Engineers/Developers there seems to be a strong consensus that this is Kernel related.

Mainline does nothing to resolve the issues.

tags: added: kernel-bug-exists-upstream

Benjamin Kerensa, thank you for providing the lsusb output and testing the mainline kernel.

+ Just to clarify https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/972063/comments/12 :
Bus 002 Device 010: ID 0b0e:090c GN Netcom

This is also an example of a bluetooth device intended to connect strictly via a BT connection with your BT laptop?

+ Regarding https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/972063/comments/53 :
Bus 001 Device 003: ID 1bcf:2980 Sunplus Innovation Technology Inc.
Bus 002 Device 003: ID 8086:0189 Intel Corp.

Did both of these device IDs pop up when you plugged your BT in?

+ Regarding https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/972063/comments/54 :
>"Notably extensive testing of this hardware has already been conducted by myself and also various Canonical Engineers/Developers there seems to be a strong consensus that this is Kernel related."

We all knew this already, as it is documented in this report. As well, I strongly consense this is a kernel issue.

However, I am bound by Ubuntu Kernel Team and Ubuntu Bug Control policy to ensure the minimum requirement information is provided here, in order to mark this Triaged. Once marked, as per UKT/UBC policy, a report is in the official state where any Ubuntu Community/Kernel.org developer could begin working on this. :)

>"Mainline does nothing to resolve the issues."

Just to be clear, which mainline kernel did you test specifically?

Alan Weeks (aweeks1) wrote :

I apparently have similar problem.
Ubuntu 12.04 updated
Logitech BT Speaker Adapter.

Updated BT s/ware but problem remains.

Alan Weeks, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette

When opening up the new report, please feel free to subscribe me to it. Thank you for your understanding.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

Mark Williams (markuk73) wrote :

I also have this problem
Xubuntu 12.04
Thinkpad T42
Logitech Bluetooth Wireless Speaker Adaptor
Blueman pairs and connects to the audio sink, but no output appears in pulseaudio.

Mark Williams (markuk73) wrote :

Apologies, I don't have this bug.

installing pulseaudio-module-bluetooth solved the problem.

Sorry.

preetam (preetamsashankreddy) wrote :

I have tried with multiple bluetooth audio headsets. None of them are ever seen in the audio devices list. They just pair and stay there.
It appers that the A2DP protocol itself doesnt work. I am not too much into this stuff but here is my observation.
I have the following headsets:
1. Byte - DM-5710BT
2. Plantronics in ear bluetooth headphones with mic for calls.
3. Sony MW600 - A2DP with mic for calls.

I have not been able to get any of them detected by the pulseaudio. In case of the MW600, It doesnt even turn on. It connects in bluetooth for a short time and immediately disconnects on its own.

I have checked in synaptic package manager and the module pulseaudio-module-bluetooth is already present.

I have no idea of how to debug on this, but I would be happy to if someone can tell me somethng about this.

I had the same problem with the default bluetooth manager.
But once I set it up with blueman, it works also with the default manager.

Dmitry Kann (yktooo) wrote :

I have the same problem with Logitech Wireless Adapter for Bluetooth. Connected but never shows up as an output device (see screenshot).

Just a few months ago it worked fine.

Dmitry Kann (yktooo) wrote :

The solution described here helped all of a sudden: http://askubuntu.com/questions/175933/why-did-my-bluetooth-headset-disappear-from-sound-settings-and-how-can-i-get-it

All you need is to set card profile. First look up your device ID:

~$ pactl list cards short
0 alsa_card.pci-0000_01_00.1 module-alsa-card.c
1 alsa_card.usb-Generic_Turtle_Beach_USB_Headset_0000000001-00-Headset module-alsa-card.c
2 alsa_card.pci-0000_00_14.2 module-alsa-card.c
8 bluez_card.C8_84_47_04_21_6F module-bluetooth-device.c

Then you use the above ID to bind the profile to the card:
~$ pactl set-card-profile bluez_card.C8_84_47_04_21_6F a2dp

The device shows up in the list again.

Kim Marivoet (kim-marivoet) wrote :

None of the solutions described here work for me.

I get following error in the syslog:Oct 13 17:58:45 desktop bluetoothd[1073]: /org/bluez/1073/hci0/dev_48_C1_AC_08_FE_8F/fd0: fd(35) ready
Oct 13 17:58:45 desktop rtkit-daemon[1899]: Successfully made thread 3121 of process 1897 (n/a) owned by '1000' RT at priority 5.
Oct 13 17:58:45 desktop rtkit-daemon[1899]: Supervising 5 threads of 1 processes of 1 users.
Oct 13 17:58:45 desktop bluetoothd[1073]: Badly formated or unrecognized command: AT+XEVENT=USER-AGENT,COM.PLANTRONICS,PLT_VOYAGERPRO,0109,27.90,FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
Oct 13 17:58:46 desktop bluetoothd[1073]: Audio connection got disconnected

soreau (oreaus) wrote :

This bug affected me as well. The solution here worked for me and I didn't see it anywhere in this thread so I figured I'd mention it:

https://bugzilla.redhat.com/show_bug.cgi?id=827692#c3

Quote:

What I think fixed the issue for me was to create

/etc/bluetooth/audio.conf

and add

[General]
Enable=Source,Sink,Headset,Gateway,Control,Socket,Media

soreau (oreaus) wrote :

There should be an existing [General] section that you can use. After making this change, restart the bluetooth service and try again.

preetam / Richard Ulrich / Dmitry Kann / Kim Marivoet / soreau, please see https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/972063/comments/57 .

JaSauders (jasauders) wrote :

Same deal here. Plantronics BB903+ headset, Ubuntu 12.04 64 bit. No dice. Nothing listed in sound settings. Adjusting the /etc/bluetooth/audio.conf file did nothing at all.

Dutch Waldbauer (waldbaro) wrote :

Basics
Acer V5 171 purchased Sept 2012 (new model)
Ubuntu 12:10

I loaded 12:04 on my Acer immediately after purchase. Bluetooth adapter would not turn on under Ubuntu but functioned fine under Windoz 7.

Updated to 12:10 yesterday. Bluetooth radio turns on. I have paired with two Bluetooth headsets (Plantronics Voyager Pro + and Motorola H780) but cannot connect.

summary: - Bluetooth Headset pairs but does not show up in Sound Settings profile
+ [Dell Inspiron N411Z] Bluetooth Headset pairs but does not show up in
+ Sound Settings profile
zin (zdravko-nikolov) wrote :

This is a bluez bug, I can't believe it is still not fixed. All I had to do is to revert back to an older bluez

sudo dpkg -i bluez_4.84-0ubuntu1_i386.deb

and bluetooth headset (jawbone) and browsing my nokia N9 via bluetooth started working again.

zin, if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug bluez

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report may delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Not just Bluetooth!
I disable an input device (mic from webcam). It will never came back! ... funny?????

WTF???

Not a way to be productive. A review in this system is needed, maybe from gnome upstream.

Do not answer install package "apt-get install blahblah", I have no notice about "blahblah" anywhere. It is too much easy to get an interface out, and it is sooooo hard to have it back working.

I would to be more arrogant or something like that, really this is not usability.

Bug not related ... point out where.

I found a solution for bluetooth saying install "blahblah" in askubuntu. This is not a solution.

IMO Ubuntu should consider to switch default Desktop Environment if this is what gnome thinks usability. If this is what ubuntu think about usability .. well, I am arrogant, but this is NOT usability.

Daniele Cruciani, if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Kernel team article:
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports

the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report may delay your problem being addressed as quickly as possible.

Thank you for your understanding.

dum (dummyxl) wrote :

I have similar problem.

It always worked for me but after the modus setting "off" in the sound menu it never came back.

Ubuntu 12.04 updated
Logitech BT Speaker Adapter.

but post #63 did the trick.

dum, if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug sound

For more on this, please see the Ubuntu Audio Developer team article:
https://wiki.ubuntu.com/DebuggingSoundProblems

the Ubuntu Bug Control team and Ubuntu Bug Squad team article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report may delay your problem being addressed as quickly as possible.

Thank you for your understanding.

zin (zdravko-nikolov) wrote :

Ghristopher, there are numerous filings for both the headset connection not working and for the browsing issue. The fact that the problem is solved by reverting back to the older bluez package speaks for itself. Any package above bluez_4.84-0ubuntu1_i386.deb will break usability for me. I have spent enough time trying to pinpoint the problem. I use THINKPAD X41 (bluetooth chip v 1.2).

Mani Sabri (mani-sabri) wrote :

I can confirm that installing Blueman solved the problem for me too (not having the headset in sound settings)
HP Pavilion g series with USB bluetooth dongle

Neal McBurnett (nealmcb) wrote :

Comment #55 by penalvch seems to give some sense of how this bug is being tracked, as a Dell Inspiron N411Z issue, and other similar but different bluetooth bugs related to pulseaudio seem unwelcome here, for good reason. More clarity on exactly what this bug covers would be welcome.

I'll note though that the debugging ideas in here are very valuable for bluetooth and pulseaudio bugs, so it is worth reading, until that info is summarized somewhere else. Especially because bluetooth is way more complicated than the bug-reporting hints suggest. Keywords: lsusb, pactl, hciconfig, module-bluetooth-discover, module-bluetooth-device.

But I'm still puzzled at the current status of this bug. It has been described at various times as kernel-related, as bluez related, and as pulseaudio related. The current status is "confirmed" for both bluez and pulseaudio, and "incomplete" for linux (ubuntu). But my sense is that it is a kernel bug, not a bug in bluez or pulseaudio, Could someone clear that up?

I'll note in passing that I have a bug in precise 12.04 on a system76 lemu2, with a 0a12:0001 Cambridge Silicon Radio headset, which doesn't show up in pulseaudio after being paired properly. But it works fine in 14.04 beta1, and using blueman in 12.04 at least gets it working as A2DP headphones (but not HSP microphone input). And I guess I should report that as a separate bug....

Neal McBurnett:
>"...I should report that as a separate bug...."

That would be the best, given these issues are dealt with on a per hardware basis.

I've reinstalled Ubuntu 12.04 LTS64 bit and am no longer able to reproduce
the issue.
Not a lot of help in tracking down the root cause, but this may help others.

On 5 March 2014 10:05, Christopher M. Penalver <
<email address hidden>> wrote:

> Neal McBurnett:
> >"...I should report that as a separate bug...."
>
> That would be the best, given these issues are dealt with on a per
> hardware basis.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/972063
>
> Title:
> [Dell Inspiron N411Z] Bluetooth Headset pairs but does not show up in
> Sound Settings profile
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/972063/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.