pulseaudio crashed with SIGSEGV (parallel calls to dbus_bus_get_private)

Bug #937933 reported by Brian_Clem
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Medium
David Henningsson

Bug Description

Jack audio server. Low latency kernel. Using Ubuntu then Lubuntu via- wubi.exe

Lubuntu was not available through wubi.exe Only ubuntu. All other variations produced errors. I think needed audio packages for multitrack recording via-Ardour and Rosegarden create unstable system state.

Jack crashes pulse audio adapter ... rebooting seems to help sometimes.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: pulseaudio 1:1.1-0ubuntu9
ProcVersionSignature: Ubuntu 3.0.0-13.21ppa1~natty1-lowlatency 3.0.6
Uname: Linux 3.0.0-13-lowlatency x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.92-0ubuntu1
Architecture: amd64
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0520000 irq 49'
   Mixer name : 'Analog Devices AD1884A'
   Components : 'HDA:11d4184a,103c3034,00100200'
   Controls : 34
   Simple ctrls : 20
CrashCounter: 1
Date: Tue Feb 21 11:46:52 2012
ExecutablePath: /usr/bin/pulseaudio
ProcCmdline: /usr/bin/pulseaudio --start --log-target=syslog
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fc58dfd15ee: mov %rdx,0x8(%rax)
 PC (0x7fc58dfd15ee) ok
 source "%rdx" ok
 destination "0x8(%rax)" (0xc46c000000000008) not located in a known VMA region (needed writable region)!
 Stack memory exhausted (SP below stack segment)
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: pulseaudio
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
Title: pulseaudio crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 03/05/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 786G1 v01.16
dmi.board.asset.tag: 2UA92918QC
dmi.board.name: 3031h
dmi.board.vendor: Hewlett-Packard
dmi.chassis.asset.tag: 2UA92918QC
dmi.chassis.type: 4
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr786G1v01.16:bd03/05/2009:svnHewlett-Packard:pnHPCompaqdc7900SmallFormFactor:pvr:rvnHewlett-Packard:rn3031h:rvr:cvnHewlett-Packard:ct4:cvr:
dmi.product.name: HP Compaq dc7900 Small Form Factor
dmi.sys.vendor: Hewlett-Packard

Related branches

Revision history for this message
Brian_Clem (mrbrianclem-gmail) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 link_before (link=0xc46c18, before_this_link=0xc46c00, list=0x7fc5540009e0) at ../../dbus/dbus-list.c:122
 _dbus_list_prepend (list=0x7fc5540009e0, data=<optimized out>) at ../../dbus/dbus-list.c:278
 _dbus_list_append (list=0x7fc5540009e0, data=<optimized out>) at ../../dbus/dbus-list.c:250
 _dbus_watch_list_add_watch (watch_list=0x7fc5540009e0, watch=0x7fc554000ba0) at ../../dbus/dbus-watch.c:361
 socket_connection_set (transport=0x7fc554000a20) at ../../dbus/dbus-transport-socket.c:1010

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in pulseaudio (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Revision history for this message
David Henningsson (diwic) wrote : Re: pulseaudio crashed with SIGSEGV

This looks like a race in dbus caused by two threads trying to get a private connection simultaneously.

visibility: private → public
Changed in pulseaudio (Ubuntu):
status: New → Triaged
summary: - pulseaudio crashed with SIGSEGV
+ pulseaudio crashed with SIGSEGV (probably race in dbus library)
affects: pulseaudio (Ubuntu) → dbus (Ubuntu)
Revision history for this message
David Henningsson (diwic) wrote :

I have created a small test case and sent bug upstream: https://bugs.freedesktop.org/show_bug.cgi?id=47060

summary: - pulseaudio crashed with SIGSEGV (probably race in dbus library)
+ pulseaudio crashed with SIGSEGV (parallel calls to dbus_bus_get_private)
Revision history for this message
David Henningsson (diwic) wrote :

According to upstream, we have forgotten to call dbus_init_threads_default. Fixing.

affects: dbus (Ubuntu) → pulseaudio (Ubuntu)
Changed in pulseaudio (Ubuntu):
assignee: nobody → David Henningsson (diwic)
status: Triaged → In Progress
Changed in pulseaudio (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:1.1-0ubuntu13

---------------
pulseaudio (1:1.1-0ubuntu13) precise; urgency=low

  * 0020-daemon-Initialize-dbus-to-use-thread-safe-mode-by-de.patch:
    Make sure dbus is thread safe to avoid crashes in pa_make_realtime
    (LP: #937933)
  * 0111-protocol-native-Protect-against-clients-trying-to-se.patch:
    Don't crash if clients try to set a NULL port (LP: #951273)
  * 0021-Fix-input-device-for-M-audio-fasttrack-pro.patch:
    Probe two different input devices (LP: #569932)
  * 0112-module-loopback-Never-call-adjust_rates-after-teardo.patch:
    Don't crash on shutdown in module-loopback (LP: #946400)
  * 0619-module-switch-on-port-available-Do-not-switch-profil.patch:
    Prevent switching to HDMI profiles from analog profiles, as a result
    of discussion on the pulseaudio-discuss and ubuntu-audio-dev mailinglist.
 -- David Henningsson <email address hidden> Wed, 21 Mar 2012 10:47:33 +0100

Changed in pulseaudio (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.