noise during recording with high volume

Bug #927961 reported by Jhosman Lizarazo on 2012-02-06
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

I have had this unfortunate problem with the audio recording on my computer is an ASUS K42F that when I try to record with the internal microphone recording quality is very poor, I have to lower your levels of the microphone from the terminal with the command "alsamixer "low levels until there is much noise distortion but the problem is that the volume of the recording is very bad way too low, if you upload entire volume presents the noise is horrible that no one can understand the noise of which I speak is not the noise of the environment where I am.

My computer is Windows 7 dualboot and I have also run the same tests done recording under Windows works perfectly! the problem has been occurring since version Ubuntu 11.04 I have not tried previous versions, and I could not give solution to the problem.

Check the link below specifications

http://usa.asus.com/Notebooks/Versatile_Performance/K42F/#specifications

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: pulseaudio 1:1.1-0ubuntu5
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic-pae 3.2.2
Uname: Linux 3.2.0-12-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.91-0ubuntu1
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: anonymouse 1764 F.... pulseaudio
 /dev/snd/pcmC0D0p: anonymouse 1764 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7c00000 irq 44'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:10ec0269,10431313,00100100 HDA:80862804,80860101,00100000'
   Controls : 20
   Simple ctrls : 9
Date: Mon Feb 6 18:23:06 2012
ExecutablePath: /usr/bin/pulseaudio
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120129)
ProcEnviron:
 LANGUAGE=es_CO:es
 PATH=(custom, no user)
 LANG=es_CO.UTF-8
 SHELL=/bin/bash
SourcePackage: pulseaudio
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/26/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 500
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: K42F
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr500:bd01/26/2011:svnASUSTeKComputerInc.:pnK42F:pvr1.0:rvnASUSTeKComputerInc.:rnK42F:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: K42F
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Jhosman Lizarazo (jhosman) wrote :
Jhosman Lizarazo (jhosman) wrote :

Anyone know any possible solution to this problem?

Jhosman Lizarazo (jhosman) wrote :
Download full text (3.6 KiB)

I started to check it and think it's Launchpad same problem

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/580338

I download the file alsa-hda-intel-optiplex-dkms_1.0.23_all.deb

And I did the following to the console but do not succeed to install:

sudo dpkg -i alsa-intel-hda-optiplex-dkms_1.0.23_all.deb
Selecting previously unselected package alsa-intel-hda-optiplex-dkms.
(Leyendo la base de datos ... 221107 ficheros o directorios instalados actualmente.)
Desempaquetando alsa-intel-hda-optiplex-dkms (de alsa-intel-hda-optiplex-dkms_1.0.23_all.deb) ...
dpkg: problemas de dependencias impiden la configuración de alsa-intel-hda-optiplex-dkms:
 alsa-intel-hda-optiplex-dkms depende de dkms (>= 1.95); sin embargo:
  El paquete `dkms' no está instalado.
dpkg: error al procesar alsa-intel-hda-optiplex-dkms (--install):
 problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
 alsa-intel-hda-optiplex-dkms
anonymouse@anonymouse-K42F:~/Instaladores$ sudo apt-get install dkms
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  libx264-118 wine1.3 libhighgui2.1 libcvaux2.1 libaccess-bridge-java-jni
  libaccess-bridge-java libvpx0 wine1.3-gecko-i386 libcv2.1
  pulseaudio-module-zeroconf libgconfmm-2.6-1c2
Utilice «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes NUEVOS:
  dkms
0 actualizados, 1 se instalarán, 0 para eliminar y 0 no actualizados.
1 no instalados del todo o eliminados.
Necesito descargar 73,0 kB de archivos.
Se utilizarán 346 kB de espacio de disco adicional después de esta operación.
Des:1 http://archive.ubuntu.com/ubuntu/ precise/main dkms all 2.2.0.3-1 [73,0 kB]
Descargados 73,0 kB en 2seg. (31,8 kB/s)
Selecting previously unselected package dkms.
(Leyendo la base de datos ... 221137 ficheros o directorios instalados actualmente.)
Desempaquetando dkms (de .../dkms_2.2.0.3-1_all.deb) ...
Procesando disparadores para man-db ...
Configurando dkms (2.2.0.3-1) ...
Configurando alsa-intel-hda-optiplex-dkms (1.0.23) ...
Loading new alsa-intel-hda-optiplex-1.0.23 DKMS files...
First Installation: checking all kernels...
Building only for 3.2.0-16-generic-pae
Building for architecture i686
Building initial module for 3.2.0-16-generic-pae
Error! Bad return status for module build on kernel: 3.2.0-16-generic-pae (i686)
Consult /var/lib/dkms/alsa-intel-hda-optiplex/1.0.23/build/make.log for more information.
anonymouse@anonymouse-K42F:~/Instaladores$ sudo dpkg -i alsa-intel-hda-optiplex-dkms_1.0.23_all.deb
(Leyendo la base de datos ... 221184 ficheros o directorios instalados actualmente.)
Preparando para reemplazar alsa-intel-hda-optiplex-dkms 1.0.23 (usando alsa-intel-hda-optiplex-dkms_1.0.23_all.deb) ...

------------------------------
Deleting module version: 1.0.23
completely from the DKMS tree.
------------------------------
Done.
Desempaquetando el reemplazo de alsa-intel-hda-optiplex-dkms ...
Configurando alsa-intel-hda-optiplex-dkms (1.0.23) ...
Loading new alsa-intel-hda-optiplex-1.0.23 DKMS files...
First I...

Read more...

Jhosman Lizarazo (jhosman) wrote :

The problem it's Solved!

Run this:

Open /etc/modprobe.d/alsa-base with the following command:

sudo nano /etc/modprobe.d/alsa-base.conf

Add this line in the end file
#NUEVA LINEA
options snd-hda-intel model=asus

Now in the terminal!
wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.25.tar.bz2
wget ftp://ftp.alsa-project.org/pub/lib/alsa-lib-1.0.25.tar.bz2
wget ftp://ftp.alsa-project.org/pub/utils/alsa-utils-1.0.25.tar.bz2

Now!
sudo apt-get install libncursesw5-dev build-essential libncurses-dev gettext xmlto xmltoman linux-headers-`uname -r`

Now!

sudo mkdir -p /usr/src/alsa
cd /usr/src/alsa
sudo nautiluz

Go to> /home/usuario/Downloads/
Copy the files: "alsa-driver-1.0.25.tar.bz2", "alsa-lib-1.0.25.tar.bz2", "alsa-utils-1.0.25.tar.bz2"
Go to /usr/src/alsa
Paste the files!

Now!
sudo tar xjf alsa-driver*.bz2
sudo tar xjf alsa-lib*.tar.bz2
sudo tar xjf alsa-utils*.tar.bz2

Now!
cd alsa-driver*
sudo ./configure --with-cards=hda-intel --with-kernel=/usr/src/linux-headers-$(uname -r)
sudo make
sudo make install

Now!
cd ../alsa-lib*
sudo ./configure
sudo make
sudo make install

Now!
sudo ln -s libpanelw.so.5 /usr/lib/libpanelw.so
sudo ln -s libformw.so.5 /usr/lib/libformw.so
sudo ln -s libmenuw.so.5 /usr/lib/libmenuw.so
sudo ln -s libncursesw.so.5 /lib/libncursesw.so

Now!
cd ../alsa-utils*
sudo ./configure
sudo make
sudo make install

Reboot System!

Open a Terminal
Write: alsamixer
Press F6 key
Select 0 HDA Intel
The item "Capture" go to level 25
The item "Internal Mic Boost" go to Level 51
Press Scape Key

Done!

Changed in pulseaudio (Ubuntu):
status: New → Fix Released

Instead of compiling ALSA, it would probably e better to just use this PPA: https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+packages

Jhosman Lizarazo (jhosman) wrote :

@Dave Lentz Well, doing the steps indicated in # 3 has solved the problem or at least I can now record with optimum quality, now you tell me to install a. Deb but if you work it out so that I do it? Furthermore it can not conflict with compiling ALSA you make?

Jhosman Lizarazo (jhosman) wrote :

After having done all this process of ALSA, I had problems with Chrome and Chromium and was not reproduced sound ANY KIND ie youtube or record sounds like a twitcam, peek into for hours and this was the only solution that enconrre

1) Opened a new tab
2) Entered "chrome://plugins/"
3) Pressed the "+ Details" button
4) Search (ctrl+f) of flash plugin, disabled the plugin

Rullez =)

I have the same problem with Asus 1005PE --- it's really a nightmare each and every time you upgrade... I can't understand why it's marked "fix released" if the solution is hand-compiling the alsa drivers, which will break at next kernel upgrade.

Romano, that's why I suggested anyone else experiencing this bug use the PPA I linked to, which is easier to install and uses dkms to automatically rebuild the kernel module for new kernels.

Dave, it's still not "fixed" if it's not going in automatically in the following upgrade. Can you give some more help on how to use the PPA?

Dave, I added the alsa-daily ppa, and then installed alsa-hda-dkms.

I had no sound at all on reboot; I tried with the options snd-hda-intel model=asus line and without. Just the dummy driver in the sound settings menu.

I am trying to go back to the bad sound.

I really am quite sad at the fact that, since ubuntu 8.04, EVERY upgrade meant broken sound for a month at least. Really.

Romano, if the dkms package made it worse, then you should remove the package and reinstall the kernel package:

sudo apt-get purge alsa-hda-dkms
sudo apt-get install linux-image-`uname -r`

If you continue to experience issues, please file a new bug since you have different hardware (and probably a different audio codec) than the OP. Remember to remove any /etc/modprobe.d/alsa-base.conf customization before filing the bug.

Yes, I removed alsa-hda-dkms and the thing come back as before (I didn't reinstall the linux-image... shuld I?) .
I will report a new bug --- sorry for the harsh words of yesterday, but this thing is a bit of a stressing thing. It all worked so beautifully with oneiric and the alsa ppa... . What was the incantation to have apport add the information?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers