Mic only works when pulseaudio sound settings open with skype

Bug #865820 reported by iMac on 2011-10-04
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Basically I fire up current skype (2.2.0.35-0oneiric2) and start a video chat session. Video is fine. Audio settings are all to PulseAudio defaults.

In order for the other side to hear me, I have to open the Sound Settings and go to the Input tab, at which point my audio begins to register. I made no changes to device selection or muting. I just opened the dialogue box and voila. If I close it, audio stops working.

Not sure if it is skype or pulseaudio. Since messing with pulseaudio seems to fix it, i started here.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: pulseaudio 1:1.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: imac 2779 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xd2400000 irq 16'
   Mixer name : 'IDT 92HD71B7X'
   Components : 'HDA:111d76b2,103c30f2,00100302 HDA:11c11040,103c137e,00100200'
   Controls : 22
   Simple ctrls : 14
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xd2310000 irq 19'
   Mixer name : 'ATI RS690/780 HDMI'
   Components : 'HDA:1002791a,00791a00,00100000'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Mon Oct 3 21:03:18 2011
ProcEnviron:
 LANGUAGE=en
 LANG=en_US.utf8
 SHELL=/bin/bash
PulseSinks: Error: command ['pacmd', 'list-sinks'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
PulseSources: Error: command ['pacmd', 'list-sources'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
SourcePackage: pulseaudio
UpgradeStatus: Upgraded to oneiric on 2011-09-09 (25 days ago)
dmi.bios.date: 08/19/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.37
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 30F2
dmi.board.vendor: Quanta
dmi.board.version: 98.36
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.37:bd08/19/2009:svnHewlett-Packard:pnHPPaviliondv5NotebookPC:pvrRev1:rvnQuanta:rn30F2:rvr98.36:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv5 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard

iMac (imac-netstatz) wrote :
os (syriatalks) wrote :

I have the same problem in ubuntu 11.10 i386 + input volume reduced automatically .

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pulseaudio (Ubuntu):
status: New → Confirmed
Luke Yelavich (themuso) wrote :

This is a bug in pulseaudio, relating to how skype checks for the pulse library version. Upstream pulse accidentally changed things for 1.0 such that it has broken skype somewhat. A fix is upstream, however whether this goes through before final oneiric release, or as an SRU is up to the release team. Subscribing ubuntu-release for their thoughts.

Changed in pulseaudio (Ubuntu):
status: Confirmed → Triaged
Luke Yelavich (themuso) wrote :

The patch I referred to has already been uploaded, but did not fix this issue, based on feedback I received from someone else with the same issue. Setting back to confirmed.

Changed in pulseaudio (Ubuntu):
status: Triaged → Confirmed
iMac (imac-netstatz) wrote :

Is there a commit reference for the upstream patch to save a search. I'd like to give it a go myself.

If you install Oneiric's latest updates, you will have the patch in question.

Hi,

Taking a closer look at the latest diff of PulseAudio (1:1.0-0ubuntu2),
it seems there are two problems with it:

  1) The upstream patch was changed before applying, so only the
pa_get_headers_version macro was changed, not the pa_get_library_version
API function. This might have been enough for Phonon, but Skype being
closed source, it's very likely to use pa_get_library_version function,
instead of the macro. I e, Skype is not fixed/affected by the patch.

  2) The patch and release was not added to
lp:~ubuntu-audio-dev/pulseaudio/ubuntu.oneiric tree.

How do we best fix this up?

--
David Henningsson, Canonical Ltd.
http://launchpad.net/~diwic

On Oct 6, 2011 3:28 AM, "David Henningsson" <email address hidden>
wrote:
>
> 1) The upstream patch was changed before applying, so only the
pa_get_headers_version macro was changed, not the pa_get_library_version API
function. This might have been enough for Phonon, but Skype being closed
source, it's very likely to use pa_get_library_version function, instead of
the macro. I e, Skype is not fixed/affected by the patch.
>

We can update to use the entire patch.

> 2) The patch and release was not added to
lp:~ubuntu-audio-dev/pulseaudio/ubuntu.oneiric tree.

Please push after doing the above.

Also, we need to make the rest of the release team aware. It won't be in for
RC, but we could try for final or an SRU at worst.

David Henningsson (diwic) wrote :

On 10/06/2011 10:28 AM, Dan Chen wrote:
>
> On Oct 6, 2011 3:28 AM, "David Henningsson"
> <<email address hidden>
> <mailto:<email address hidden>>> wrote:
> >
> > 1) The upstream patch was changed before applying, so only the
> pa_get_headers_version macro was changed, not the pa_get_library_version
> API function. This might have been enough for Phonon, but Skype being
> closed source, it's very likely to use pa_get_library_version function,
> instead of the macro. I e, Skype is not fixed/affected by the patch.
> >
>
> We can update to use the entire patch.
>
> > 2) The patch and release was not added to
> lp:~ubuntu-audio-dev/pulseaudio/ubuntu.oneiric tree.
>
> Please push after doing the above.
>
> Also, we need to make the rest of the release team aware. It won't be in
> for RC, but we could try for final or an SRU at worst.
>

Thanks for the advice. With the help of Martin Pitt, this has now been
uploaded as well.

--
David Henningsson, Canonical Ltd.
http://launchpad.net/~diwic

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:1.0-0ubuntu3

---------------
pulseaudio (1:1.0-0ubuntu3) oneiric; urgency=low

  * debian/patches/0102-Always-return-a-three-part-version-number-in-API
    -cal.patch: Update to fix skype regression as well (LP: #865820)
 -- David Henningsson <email address hidden> Thu, 06 Oct 2011 10:39:49 +0200

Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
Krzysztof Janowicz (janowicz) wrote :

I also have this strange bug.

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

Gabriel_P (gabp) wrote :

I have this issue not only with Skype but apparently with any app that uses the mic.

Grzegorz G. (grzesiek1e5) wrote :

So it's not fixed? Perhaps you should report another bug?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers