Ubuntu

Selected USB device not saved until next session

Reported by Paul Hoell on 2011-09-07
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

I have following audio set up on my desktop pc:
A 4.1 system at the back connectors
A headset at the front connectors (mic muted via switch on the cable)
A Logitech C270 web cam which acts as an USB audio input device

For the most part, i want my input source to be the web cam and not the headset's mic at the front mic jack. So i select it in the audio configuration. It works fine until i reboot my machine.
At that point the selected input device is switched back to the Internal Audio with the front jack as source.

This is very annoying and inconsistent behavior, because the system should remember which device i selected and should keep it as default until i select another one or the selected one is not available any more.

If you need any furter information, i'm happy to provide anything you need.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: alsa-base 1.0.24+dfsg-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: paul 1707 F.... pulseaudio
 /dev/snd/controlC0: paul 1707 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xfe700000 irq 53'
   Mixer name : 'Realtek ALC892'
   Components : 'HDA:10ec0892,1043841b,00100302'
   Controls : 35
   Simple ctrls : 20
Card1.Amixer.info:
 Card hw:1 'U0x46d0x825'/'USB Device 0x46d:0x825 at usb-0000:00:1d.0-1.2.3, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0825'
   Controls : 2
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 6144
   Mono: Capture 2864 [47%] [17.18dB] [on]
Card2.Amixer.info:
 Card hw:2 'Generic'/'HD-Audio Generic at 0xfe640000 irq 54'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card2.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Wed Sep 7 13:11:46 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64+mac (20110901)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaRecordingTest: ALSA recording test through plughw:U0x46d0x825 failed
Symptom_Card: Juniper HDMI Audio [Radeon HD 5700 Series] - HD-Audio Generic
Symptom_Type: None of the above
Title: [USB-Audio - USB Device 0x46d:0x825, recording] Recording problem
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/08/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1011
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8P67 LE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0X
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1011:bd04/08/2011:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP8P67LE:rvrRevX.0X:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Paul Hoell (hoellp) wrote :
David Henningsson (diwic) wrote :

Hmm, I remember answering this one earlier, but now there is no comment? Maybe something went wrong...

Anyway, what I think is happening here is that PulseAudio starts up before the USB webcam is fully initialized. At that point, it detects the internal card only, and then that is set as default because someone asks what the default is.

Hopefully this will be fixed in 12.04 with Colin Guthrie's device priority lists, if he gets them done by then.

affects: alsa-driver (Ubuntu) → pulseaudio (Ubuntu)
David Henningsson (diwic) wrote :

Okay, I can actually reproduce that here, so I'm taking a deeper look at the problem.

summary: - Selected input device (mic) not saved until next session
+ Selected USB device not saved until next session
Changed in pulseaudio (Ubuntu):
status: New → Triaged
David Henningsson (diwic) wrote :

Sending patch to upstream for review

Changed in pulseaudio (Ubuntu):
status: Triaged → In Progress

The attachment "0001-Make-sure-module-dbus-protocol-is-loaded-after-modul.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.99.3-0ubuntu5

---------------
pulseaudio (1:0.99.3-0ubuntu5) oneiric; urgency=low

  [ David Henningsson ]
  * 0017-Avoid-crash-by-not-updating-volume-on-shutdown.patch:
    Fix typo in patch

  [ Luke Yelavich ]
  * Patch from David Henningssen to make sure module-dbus-protocol is loaded
    after module-device-restore (LP: #843780)
 -- Luke Yelavich <email address hidden> Thu, 15 Sep 2011 09:59:20 +1000

Changed in pulseaudio (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers