"Front" alsa control is turned off by PulseAudio for "Analog Headphones" profile

Bug #836921 reported by Petter Flensburg on 2011-08-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Medium
David Henningsson
Declined for Maverick by Chris Van Hoof
Declined for Natty by Chris Van Hoof
Oneiric
Medium
David Henningsson
Precise
Medium
David Henningsson

Bug Description

Hi everyone! Thank you for taking the time to help with this issue!

If I put headphones in the front, alsa sets the front output to 0(before I put in headphones, everything looks fine in alsa), and I can't raise the volume. If I restart pulseaudio(pulseaudio -k), sound comes back, and this also shows when opening alsa.

I do not know if this is related to the fact that I also have HDMI output on my graphics card. I do not remember if I had this issue before I put it in, and this was also while using 11.10 alpha. If it helps, I can test if the behavior persists if I take the graphics card out.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: alsa-base 1.0.24+dfsg-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: petter 2570 F.... pulseaudio
 /dev/snd/pcmC0D0p: petter 2570 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xfe024000 irq 23'
   Mixer name : 'Realtek ALC1200'
   Components : 'HDA:10ec0888,103c2a72,00100101'
   Controls : 31
   Simple ctrls : 19
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xfdcfc000 irq 44'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100100'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Mon Aug 29 20:41:54 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:NVidia successful
Symptom_Card: Internal Audio - HDA NVidia
Symptom_Jack: Green Headphone Out, Front
Symptom_PulsePlaybackTest: PulseAudio playback test successful
Symptom_Type: None of the above
Title: [HP Compaq dx2450 Microtower, Realtek ALC1200, Green Headphone Out, Front] Playback problem
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/20/2009
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 5.60
dmi.board.name: 2A72h
dmi.board.vendor: PEGATRON CORPORATION
dmi.board.version: 3.02
dmi.chassis.asset.tag: CZC9166YG4
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr5.60:bd02/20/2009:svnHewlett-Packard:pnHPCompaqdx2450Microtower:pvr:rvnPEGATRONCORPORATION:rn2A72h:rvr3.02:cvnHewlett-Packard:ct3:cvrChassisVersion:
dmi.product.name: HP Compaq dx2450 Microtower
dmi.sys.vendor: Hewlett-Packard

Petter Flensburg (petterf) wrote :
David Henningsson (diwic) wrote :

Hi Petter and thanks for reporting this bug!
The problem is inconsistent naming of volume controls - on some machines, such as yours, the "Front" volume control is part of what's controlling the headphone volume, but on most machines, it isn't. So PulseAudio can't know - based on the name - whether to use the "front" volume control or turn it off. Current behaviour is to turn it off, but I've been thinking about whether setting it to zero would be better.

In your case you actually have a "virtual" master control so you would get the same sound quality as if you were able to control "Front".

David Henningsson (diwic) wrote :

This will be applied the next time Pulseaudio is released into Oneiric. Meanwhile, you can try editing /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf and change

 [Element Front]
switch = off
volume = off

to

 [Element Front]
switch = mute
volume = zero

affects: alsa-driver (Ubuntu) → pulseaudio (Ubuntu)
Changed in pulseaudio (Ubuntu):
assignee: nobody → David Henningsson (diwic)
status: New → Fix Committed
summary: - Sound[HP Compaq dx2450 Microtower, Realtek ALC1200, Green Headphone Out,
- Front] Playback problem
+ "Front" alsa control is turned off by PulseAudio for "Analog Headphones"
+ profile
Launchpad Janitor (janitor) wrote :
Download full text (4.3 KiB)

This bug was fixed in the package pulseaudio - 1:0.99.3-0ubuntu1

---------------
pulseaudio (1:0.99.3-0ubuntu1) oneiric; urgency=low

  [ David Henningsson ]
  * 0018-alsa-mixer-Set-Front-control-to-0-dB-on-headphone-pa.patch:
    Set Front to 0 dB for Headphones (LP: #836921)

  [ Luke Yelavich ]
  * New upstream bugfix release
    - source: Remove the PA_SOURCE_PASSTHROUGH flag
    - alsa: Don't always suspend/unsuspend on sink-input removal
    - formats: Use correct API to check for passthrough streams
    - alsa: Open iec958 device with NONAUDIO bit set in passthrough mode
    - formats: Fix bad passsthrough check
    - alsa: Fix bad function name
    - daemon: Fix compiler warning about missing function prototype
    - passthrough: We must not plug in a resampler on stream move
    - sink-input: Ensure no volumes are applied for passthrough streams
    - source-output: Ensure no volumes are applied for passthrough streams
    - Revert "device-restore: Make bools not be bit fields"
    - sample-util: Fix off-by-one in error check
    - sink: Add PA_SINK_SET_FORMATS macro
    - build-sys: Fix some LDFLAGS vs. LDADD usage
    - echo-cancel: Add multiple include protection for header
    - echo-cancel: Use pa_streq instead of strcmp
    - echo-cancel: Move speex preprocessing out of the main module
    - passthrough: Fix what volume we set sinks/sources to
    - passthrough: Fix setting volume to unamplified again
    - echo-cancel: Make save_aec modarg a bool instead of an int
    - echo-cancel: Don't allow streams to attach while unloading
    - echo-cancel: Get rid of annoying compiler warnings
    - equalizer: Comment out unused function
    - def: Add a new enum to allow differntiation between sinks and sources.
    - dbus: Use pa_device_type_t rather than an internal equivalent
    - device-restore: Change the API to include type information (sink
      vs. source)
    - device-restore: Split device restore database into two parts.
    - device-restore: Restore volumes on port change.
    - build-sys: bump soname
    - alsa-mixer: Mute IEC958 optical raw for several Audigy models
    - alsa-mixer: Add "Line HP Swap" element
    - JACK: Load module-jackdbus-detect in default.pa
    - Remove offensive part of error message
    - switch-on-connect: Don't switch to a monitor source
    - Fix spelling sucess -> success
    - Set better priorities on input paths
    - introspect: fix typo in default sink/source docs
    - pacat: make pacat respond to cork/uncork events
    - Spelling fixes in public headers
    - More spelling fixes
    - gitignore: Add Orc autogenerated files
    - echo-cancel: Use stream index in debug message
    - Remove extra ; s where they are not allowed in strict C99
    - sndfile-util: Check return value of sf_command for errors
  * Pull some further fixes from upstream git master:
    - fb107fc (vala: Add has_type_id=false to all enums, structs and classes)
    - c7bba24 (module-switch-on-connect: Don't switch unlinked sink input and
               source outputs)
    - 9636991 (alsa-mixer: Set "Front" control to 0 dB on headphone path)
    - fc3ddfb (module-equalizer-sink: Use %z for printf of size_t variables)
...

Read more...

Changed in pulseaudio (Ubuntu):
status: Fix Committed → Fix Released
Chris Van Hoof (vanhoof) on 2012-04-11
Changed in pulseaudio (Ubuntu Oneiric):
status: New → Fix Released
assignee: nobody → David Henningsson (diwic)
importance: Undecided → Medium
Changed in pulseaudio (Ubuntu Precise):
importance: Undecided → Medium
tags: added: blocks-hwcert-enablement
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers