pulseaudio crashed with SIGABRT in pa_source_output_move_to()

Bug #831675 reported by Alexander Hunziker
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Medium
David Henningsson

Bug Description

I tried to make a call using SIP in the just uploaded empathy 3.1.5.1, then PA crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: pulseaudio 1:0.99.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-9.12-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: hunzikea 12162 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf2620000 irq 47'
   Mixer name : 'Conexant CX20585'
   Components : 'HDA:14f15069,17aa2132,00100300'
   Controls : 8
   Simple ctrls : 5
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 6HHT14WW-1.02'
   Mixer name : 'ThinkPad EC 6HHT14WW-1.02'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Tue Aug 23 00:43:53 2011
ExecutablePath: /usr/bin/pulseaudio
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcCmdline: /usr/bin/pulseaudio --start --log-target=syslog
ProcEnviron:
 LANGUAGE=en
 PATH=(custom, no user)
 LANG=en_DK.utf8
 SHELL=/bin/bash
Signal: 6
SourcePackage: pulseaudio
StacktraceTop:
 pa_source_output_move_to () from /usr/lib/libpulsecore-0.99.so
 ?? () from /usr/lib/pulse-0.99/modules/module-switch-on-connect.so
 pa_hook_fire () from /usr/lib/libpulsecore-0.99.so
 pa_sink_put () from /usr/lib/libpulsecore-0.99.so
 module_echo_cancel_LTX_pa__init () from /usr/lib/pulse-0.99/modules/module-echo-cancel.so
Title: pulseaudio crashed with SIGABRT in pa_source_output_move_to()
UpgradeStatus: Upgraded to oneiric on 2011-08-18 (4 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 03/14/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 6HET35WW (1.20 )
dmi.board.name: 28239KG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6HET35WW(1.20):bd03/14/2011:svnLENOVO:pn28239KG:pvrThinkPadT400s:rvnLENOVO:rn28239KG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 28239KG
dmi.product.version: ThinkPad T400s
dmi.sys.vendor: LENOVO

Revision history for this message
Alexander Hunziker (alex-hunziker) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 pa_source_output_move_to (o=0x1c156c0, dest=0x1c12cf0, save=false) at pulsecore/source-output.c:1471
 source_put_hook_callback (source=0x1c12cf0, c=<optimized out>, userdata=<optimized out>) at modules/module-switch-on-connect.c:273
 source_put_hook_callback (c=<optimized out>, source=0x1c12cf0, userdata=<optimized out>) at modules/module-switch-on-connect.c:235
 pa_hook_fire (hook=0x19efbe0, data=0x1c12cf0) at pulsecore/hook-list.c:106
 pa_sink_put (s=0x1c11350) at pulsecore/sink.c:626

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in pulseaudio (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Changed in pulseaudio (Ubuntu):
status: New → Confirmed
Revision history for this message
David Henningsson (diwic) wrote :

This is due to module-switch-on-connect switching stream to a monitoring source. This should not happen.

Changed in pulseaudio (Ubuntu):
assignee: nobody → David Henningsson (diwic)
status: Confirmed → In Progress
Revision history for this message
David Henningsson (diwic) wrote :
Changed in pulseaudio (Ubuntu):
status: In Progress → Fix Committed
visibility: private → public
Revision history for this message
David Henningsson (diwic) wrote :

Fixed in 0.99.3

Changed in pulseaudio (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers