FFe: multiarch support of alsa-plugins dependencies

Bug #825342 reported by Steve Langasek on 2011-08-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
flac (Debian)
Fix Released
Unknown
flac (Ubuntu)
Low
Unassigned
jack-audio-connection-kit (Ubuntu)
Low
Unassigned
json-c (Ubuntu)
Low
Unassigned
libasyncns (Ubuntu)
Low
Unassigned
libogg (Ubuntu)
Low
Unassigned
libsamplerate (Ubuntu)
Low
Unassigned
libsndfile (Ubuntu)
Low
Unassigned
libvorbis (Ubuntu)
Low
Unassigned
pulseaudio (Ubuntu)
Low
Unassigned
speex (Ubuntu)
Low
Unassigned
tcp-wrappers (Ubuntu)
Low
Unassigned

Bug Description

The alsa-lib and alsa-plugins packages were converted for multiarch earlier in the cycle, but the dependencies of alsa-plugins have not been, making it impossible in practice to use this in a multiarch context. The dependencies that need to be converted for multiarch to make alsa-plugins installable are:
  libjack0
  libpulse0
  libsamplerate0
  libspeexdsp1
  libsndfile1
  libwrap0
  libflac8
  libogg0
  libvorbis0a
  libvorbisenc2
  libasyncns0

None of these have plugin paths that require patching the library for backwards-compatibility; they're each a simple matter of fixing up the library to install to the correct path and tagging the library Multi-Arch: same. So the risk of regression is fairly small.

Steve Langasek (vorlon) wrote :

Note that the impact of not fixing this is that flashplugin is installable via multiarch, but can only output sound to alsa devices directly, not to pulseaudio.

Changed in pulseaudio (Ubuntu):
importance: Undecided → Low

How does this get tested to verify there's no regression?

Steve Langasek (vorlon) wrote :

On Fri, Aug 12, 2011 at 04:57:11PM -0000, Scott Kitterman wrote:
> How does this get tested to verify there's no regression?

Given that none of these libraries have plugins, regression testing should
be as simple as checking the output of ldd on all of
/usr/lib/$arch/alsa-lib/*.so to verify that the libraries are found, plus
verifying that packages which build-depend on each of these libraries can
still build. I'm converting the libraries in dependency order so already
testing the latter locally, and the 'ldd' check is trivial to run when it's
all done.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Steve Langasek (vorlon) on 2011-08-12
Changed in libvorbis (Ubuntu):
importance: Undecided → Low
Changed in libsndfile (Ubuntu):
importance: Undecided → Low
Changed in libogg (Ubuntu):
importance: Undecided → Low
Changed in flac (Ubuntu):
importance: Undecided → Low
Scott Kitterman (kitterman) wrote :

OK. FFe approved then. I'll let you do the LP magic if you feel so inspired.

Steve Langasek (vorlon) on 2011-08-12
Changed in libsamplerate (Ubuntu):
importance: Undecided → Low
Steve Langasek (vorlon) on 2011-08-12
Changed in speex (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libogg - 1.2.2~dfsg-1ubuntu1

---------------
libogg (1.2.2~dfsg-1ubuntu1) oneiric; urgency=low

  * Build for multiarch. LP: #825342.
 -- Steve Langasek <email address hidden> Fri, 12 Aug 2011 11:45:07 -0700

Changed in libogg (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libvorbis - 1.3.2-1ubuntu2

---------------
libvorbis (1.3.2-1ubuntu2) oneiric; urgency=low

  * Build for multiarch. LP: #825342.
 -- Steve Langasek <email address hidden> Fri, 12 Aug 2011 11:54:37 -0700

Changed in libvorbis (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package flac - 1.2.1-4ubuntu1

---------------
flac (1.2.1-4ubuntu1) oneiric; urgency=low

  * Build for multiarch. LP: #825342.
 -- Steve Langasek <email address hidden> Fri, 12 Aug 2011 12:19:08 -0700

Changed in flac (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) on 2011-08-12
Changed in jack-audio-connection-kit (Ubuntu):
importance: Undecided → Low
Changed in tcp-wrappers (Ubuntu):
importance: Undecided → Low
Steve Langasek (vorlon) on 2011-08-12
Changed in libasyncns (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsndfile - 1.0.24-1ubuntu2

---------------
libsndfile (1.0.24-1ubuntu2) oneiric; urgency=low

  * Build for multiarch. LP: #825342.
 -- Steve Langasek <email address hidden> Fri, 12 Aug 2011 12:39:20 -0700

Changed in libsndfile (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

tcp-wrappers has already been transitioned to multiarch in Debian; package synced.

Changed in tcp-wrappers (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsamplerate - 0.1.7-3ubuntu1

---------------
libsamplerate (0.1.7-3ubuntu1) oneiric; urgency=low

  * Build for multiarch. LP: #825342.
 -- Steve Langasek <email address hidden> Fri, 12 Aug 2011 11:32:43 -0700

Changed in libsamplerate (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jack-audio-connection-kit - 1:0.121.0+svn4469-2ubuntu2

---------------
jack-audio-connection-kit (1:0.121.0+svn4469-2ubuntu2) oneiric; urgency=low

  * Build for multiarch. LP: #825342.
  * Drop dh-buildinfo build-dependency; this creates conflicting
    per-architecture buildinfo.gz files that prevent multiarch
    co-installability, and all this information is already available in the
    build logs.
 -- Steve Langasek <email address hidden> Fri, 12 Aug 2011 13:01:12 -0700

Changed in jack-audio-connection-kit (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package speex - 1.2~rc1-1ubuntu2

---------------
speex (1.2~rc1-1ubuntu2) oneiric; urgency=low

  * Build for multiarch. LP: #825342.
 -- Steve Langasek <email address hidden> Fri, 12 Aug 2011 12:11:03 -0700

Changed in speex (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Missed one library earlier (because it wasn't a dependency of libpulse0 until just now), libjson0. This is another trivial library, no plugin paths, not even any reverse deps. Is it ok if I convert this one too?

Changed in json-c (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libasyncns - 0.8-2ubuntu1

---------------
libasyncns (0.8-2ubuntu1) oneiric; urgency=low

  * Build for multiarch. LP: #825342
 -- Steve Langasek <email address hidden> Fri, 12 Aug 2011 15:11:52 -0700

Changed in libasyncns (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.99.1-0ubuntu2

---------------
pulseaudio (1:0.99.1-0ubuntu2) oneiric; urgency=low

  * Build for multiarch:
    - libpulse{,-mainloop-glib}0{,-dbg} and libpulse-dev are Multi-Arch: same.
    - pulseaudio itself should be Multi-Arch: foreign, since it's a daemon.
    - drop dh-buildinfo build-dependency, incompatible with multiarch and not
      relevant in Ubuntu where we have build logs for all builds.
    - LP: #825342.
 -- Steve Langasek <email address hidden> Sat, 13 Aug 2011 02:22:42 +0000

Changed in pulseaudio (Ubuntu):
status: New → Fix Released
Scott Kitterman (kitterman) wrote :

Ack. Go ahead with json-c.

Changed in json-c (Ubuntu):
status: Incomplete → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package json-c - 0.9-1ubuntu1

---------------
json-c (0.9-1ubuntu1) oneiric; urgency=low

  * Build for multiarch. LP: #825342.
 -- Steve Langasek <email address hidden> Fri, 12 Aug 2011 23:03:30 -0700

Changed in json-c (Ubuntu):
status: Confirmed → Fix Released
Changed in flac (Debian):
status: Unknown → Fix Committed
Changed in flac (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.