pulseaudio distorts VLC audio

Bug #751265 reported by DemocritusJr on 2011-04-05
296
This bug affects 64 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

Audio quality full of hiss (similar to what it might sound like if you pulled your headphone/speaker plug out halfway). The hiss distortion is constant and affects all VLC 1.1.8 audio. True for all audio sources: internet stream, mp3, cd, flv, etc.
Problem occurred on a clean install of Ubuntu 11.04 beta (32-bit) using only the included repositories, and updated as of today's date. Pulseaudio version: 1:0.9.22+stable-queue-24-g67d18-0ubuntu2
Disabling pulseaudio allows VLC to play cleanly. Have not observed audio distortion with other players using pulseaudio.
Would like to see VLC operate properly with pulseaudio. I had no issues on same machine using Ubuntu 10.10 and VLC 1.1.4.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: pulseaudio 1:0.9.22+stable-queue-24-g67d18-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC0D0p: blaine 2039 F...m vlc
Card0.Amixer.info:
 Card hw:0 'Audigy2'/'SB Audigy 2 [SB0350b] (rev.4, serial:0x20061102) at 0xcc80, irq 19'
   Mixer name : 'SigmaTel STAC9750,51'
   Components : 'AC97a:83847650'
   Controls : 211
   Simple ctrls : 46
Card1.Amixer.info:
 Card hw:1 'U0x46d0x8ca'/'USB Device 0x46d:0x8ca at usb-0000:00:1d.7-6, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:08ca'
   Controls : 2
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 3072
   Mono: Capture 0 [0%] [18.00dB] [off]
Card2.Amixer.info:
 Card hw:2 'Generic'/'HD-Audio Generic at 0xefddc000 irq 43'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card2.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Tue Apr 5 06:32:13 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: pulseaudio
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/08/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 0HJ054
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 6
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd01/08/2007:svnDellInc.:pnDellDM051:pvr:rvnDellInc.:rn0HJ054:rvr:cvnDellInc.:ct6:cvr:
dmi.product.name: Dell DM051
dmi.sys.vendor: Dell Inc.

DemocritusJr (disponibel) wrote :
David Henningsson (diwic) wrote :

Hi Blaine and thanks for your bug report. I tried vlc here but could not reproduce it, and I'm not sure what could be causing it. If you feel like investigating further, here are some possible ideas:

1) Construct a PulseAudio log and see if it says anything about it: https://wiki.ubuntu.com/PulseAudio/Log
2) Do the same thing but add PULSE_NO_SIMD=1 on the command line in front of the command that starts pulseaudio, and see if that helps
3) Try to create an audio sample by capturing the monitoring stream and see if the hiss is present there, if so, attach the resulting wave file here.

Changed in pulseaudio (Ubuntu):
status: New → Incomplete

David, thanks for your quick response. I think I can shed some light on
this issue. I solved the problem by going into VLC > Tools > Preferences
 > Audio. I changed the Output module from the default (Pulseaudio, I
assume) to ALSA and the distortion went away. While playing VLC, this
change shows in the taskbar sound manager in Preferences > Applications.
Instead of saying "VLC media player", it now says "ALSA plug-in [vlc]".
VLC doesn't seem to like Pulseaudio on my machine with my card at least,
and, of course, the VLC folks recommend disabling Pulseaudio. Not sure
where you want to go fromhere, especially if it isn't affecting a lot of
people.
Thanks, Blaine
Incidentally, I did not have to do this with VLC 1.1.4 in Maverick. Not
sure why it became necessary.

On 04/05/2011 07:29 AM, David Henningsson wrote:
> Hi Blaine and thanks for your bug report. I tried vlc here but could not
> reproduce it, and I'm not sure what could be causing it. If you feel
> like investigating further, here are some possible ideas:
>
> 1) Construct a PulseAudio log and see if it says anything about it: https://wiki.ubuntu.com/PulseAudio/Log
> 2) Do the same thing but add PULSE_NO_SIMD=1 on the command line in front of the command that starts pulseaudio, and see if that helps
> 3) Try to create an audio sample by capturing the monitoring stream and see if the hiss is present there, if so, attach the resulting wave file here.
>

David Henningsson (diwic) wrote :

Thanks. Sounds almost like a bug in the PulseAudio driver for VLC, but I don't know for sure. If more people show up that are having this problem, perhaps that will add some more information to the problem and help us figure out what's causing it. As you seem to have solved the problem, I'll leave it at that for the time being.

Gotisch (gotisch) wrote :

Attached you find the PulseAudio Log for the setup described in https://wiki.ubuntu.com/PulseAudio/Log and the one with the added pulse_no_simd=1 setting. Both times sound is as described by first reporter of bug.

also attached is a audiosample captured by the default mixer via audacity.

Gotisch (gotisch) wrote :
Gotisch (gotisch) wrote :

Also here is relevant vlc log

Marko Palojärvi (jososs) wrote :

Here is another case. I have same problem mentioned in recorded audio sample (#7).
Problem comes out with other applications also: rhytmbox, totem, xine, flashplugin ...

Ubuntu 11.04 (fresh installation)

Linux 2.6.38-8-generic x86_64 GNU/Linux

Pulseaudio: 1:0.9.22+stable-queue-24-g67d18-0ubuntu3
vlc: 1.1.9-1ubuntu1

Old installation of Ubuntu10.04 has no this kind of problems with audio quality.

Command pulseaudio -k helps in most cases. Sometime new starting distortion "fade away" during playback after few seconds.

Other problem with pulseaudio -k is sound levels. After restart of my computer Uubuntu sound theme after login is absolute too loud. Now it is not possible to know what is normal audio level because there is variations of sound levels after pulseaudio restart.

Changed in pulseaudio (Ubuntu):
status: Incomplete → Triaged
David Henningsson (diwic) wrote :

Thanks. A quick test here does not expose the actual problem (I can play back an ogg file through vlc -> pulseaudio just fine), so I guess we need to figure out a way to force this bug to appear. I have seen similar things being reported here lately (pool full errors) so this might be something to have a closer look at when I get home (hopefully...)

Jochen Fahrner (jofa) wrote :

I'm experiencing the same problems since upgrade to Natty. On my MacBook VLC starts playing with distortions, but they go away after a few seconds. On my Dell Inspiron 22 the distortions don't go away. The above mentioned workaround does not work here. Totem and other players work fine, VLC is the only player having this problem.

NVR_UBUNTU (misc-narendra) wrote :

Yeh, I have same problem too with my upgrade from 10.10 to 11.04. I don't know any technical matters about it. I have a D101GGC board with P4 3 GHz and 768 RAM and Radeon X200 series sound card. I have VLC 1.1.9 and TOTEM 2.32.0 and others where no prob with TOTEM and others but only with VLC 1.1.9

Ryan Padilla (allidap623) wrote :

I have this same problem when using pulse audio with vlc. The sound starts out okay, but then gets garbled and stays that way until I reboot the machine. My sound also has a 2 second delay that is present when using vlc and skype. The delay might be a separate issue. If I use "vlc -vvv" to start vlc and select ALSA with the default settings, the delay is gone and after about 10 seconds the audio dies completely and vlc outputs

"[0x7f19f00048e0] main audio output debug: audio output is starving (21337), playing silence
[0x7f19f00048e0] main audio output warning: output date isn't PTS date, requesting resampling (48071)
[0x7f19f00048e0] main audio output warning: buffer is 48071 late, triggering upsampling"

then I get a repeating string of errors like this:

"[0x7f19f00048e0] main audio output warning: output date isn't PTS date, requesting resampling (75778)
[0x7f19f00048e0] main audio output warning: audio drift is too big (178071), dropping buffer"

If I use AlSA and select the (hw 1:3) I bypass pulse audio and the everything works fine.

The sound use to be of poor quality in skype until last night when it magically cleared up, but the 2 second delay is still present.

I am using a fresh install of 11.04. I didn't have any of these problems on 10.10 with the same hardware.

aplay -l gives:

card 0: SB [HDA ATI SB], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I am currently using the HDMI for sound, the problem is also present using Analog sound.

....I was just playing with the sound and the poor sound quality in skype in back. Apparently after running vlc with pulse, the sound has stayed at a poor quality for both vlc and skype while totem works fine.

I'm going to continue to test it and see if there is anything else I can find.

Ryan Padilla (allidap623) wrote :

As I continued to test things I eventually decided to delete the ~/.pulse directory and the /tmp/pulse-* directories ( though I'm not sure deleting the /tmp directories was necessary. I rebooted the system and the sound comes through clear. Apparently something just got messed up with the local configuration.

Unfortunately for me, there is still a 1.5-2 second delay when using VLC and skype through the Pulse Audio server. If I use ALSA through pulse audio on vlc, the I still the get the same error as before ( audio drift too big) after about 10 seconds of playing a file.

So, delete ~/.pulse and the sound is clear. My other issues seem to be a separate problem.

Ryan Padilla (allidap623) wrote :

After continuing to play with things, it appears that when I use the analog output, rather than the hdmi, for the sound there is no delay, but there is a crackling sound that accompanies normal output on both vlc and skype. Digital output gives me a delay, but clear sound and analog output has no delay, but a crackling sound on top of normal output. Why can't it just work?

Hans Bronk (h-c-bronk) wrote :

I also have this problem, after a clean 11.04 install. VLC was not installed on my system when i noticed a distorted sound in Skype, like the one in the above file, and an echo. My mic was shut off using a hardware switch, so looping sound did not cause this. The microphone also does not work in Skype, but can be looped back to the speakers, using ALSA. I guess thats a different issue

The next day I installed VLC and it also has distorted sound output (again, like the uploaded file). Switching to ALSA ouput in preferences > audio did the trick. Though this way I can't use the surround sound on my Creative X-fi Extreme Gamer card. Skype still has issues.

Hans Bronk (h-c-bronk) wrote :

I forgot to add I'm running the 64bit version and there is also a thread on the Skype forum about something similar: http://forum.skype.com/index.php?showtopic=815999&st=0&gopid=3395627&#entry3395627

Hans Bronk (h-c-bronk) wrote :

Installing pavucontrol, and fiddling with it's settings seems to have resolved the VLC problem for me. Skype sound is also much much better, though still annoying. I have good hopes for that too.

KernelPanic (jfrusciante) wrote :

Same problem with Skype + pulseaudio, fresh Ubuntu 11.04 (Natty) x86_64 install. Skype seems to be the only application suffering of this problem. Details at:

http://forum.skype.com/index.php?showtopic=815999

I tried tens of configuration with no success. Had to purge pulseaudio; now I'm using pure ALSA (and sometimes Jack, experiencing slightly different problems).

The noise I hear (same for recording) is a bit different than the one from Gotisch. Sound is just noisy, sometimes stops, sometimes a big sample (~half second) is repeated some seconds later. However, I was not able to grab any sample: even when recording from audio mix (or recording skype calls) samples are perfectly clear. It's just in reproducing.

Hardware: sony vaio VPCS11E7E, module snd-hda-intel, codec Realtek ALC275.
lspci: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)

Jochen Fahrner (jofa) wrote :

I can confirm that removing .pulse directory made the problem with VLC go away.

Confirmed: rm ~/.pulse -rf solves the problem.

munbi (gabriele) wrote :

I can confirm that removing .pulse directory does *not* solves the problem for me :-(
But I found an empirical solution that is perfectly reproducible for me and maybe can shed some light on the problem:

1. start playing an mp3 with VLC -> sound is distorted/crackling
2. while VLC is playing, kill pulseaudio with 'pulseaudio -k'
3. obviously VLC is not happy and crashes
4. restart VLC and... voilà.. the sound is perfectly clear from now on, even after suspend/resume cycle !!!

Note that simply killing pulseaudio withouth VLC playing does not work (at least for me).

This trick also solves the similar audio crackling problem with Skype new version which was unusable for me before!
Maybe there is a problem of pulseaudio initialization for some applications?
Or could this be related to DMA/Buffer issues of the specific soundcard/codec (like position_fix or irq workarounds you see int the attached dmesg) ?

lspci | grep -i audio:
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)

cat /proc/asound/card0/codec#0 | grep -i codec:
Codec: SigmaTel STAC9200

dmesg | grep -i hda:
[ 25.363052] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
[ 25.363057] hda_intel: position_fix set to 1 for device 1028:01cc
[ 25.363123] HDA Intel 0000:00:1b.0: irq 46 for MSI/MSI-X
[ 25.363157] HDA Intel 0000:00:1b.0: setting latency timer to 64
[ 25.479947] input: HDA Intel Mic at Ext Left Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8
[ 25.480224] input: HDA Intel HP Out at Ext Left Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9
[ 32.464729] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

munbi (gabriele) wrote :

After posting the above information to a corresponding bug in Skype, another user posted back a solution that definitely solved the problem for me for both VLC and Skype (and I suppose every other source in PC with intel-hda chipsets):
https://jira.skype.com/browse/SCL-726?focusedCommentId=47858&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#action_47858

You have to modify the following line in /etc/pulse/default.pa

load-module module-udev-detect

with :

load-module module-udev-detect tsched=0

After further researches, I've found this is the suggested workaround for broken alsa sound drivers in regards to "glitch-free" PA. See following links for informations:

http://pulseaudio.org/wiki/BrokenSoundDrivers
https://wiki.archlinux.org/index.php/PulseAudio

Jochen Fahrner (jofa) wrote :

I have to correct myself. The workaround by removing ~/.pulse directory was only temporary. Some time later the distortions begun again on my MacBook.
Yesterday I got a new Acer Aspire One 521 Netbook and did a fresh install of Natty. This fresh installation has the same problems with audio in VLC, and only in VLC! Totem and mplayer work without distortions.

Gotisch (gotisch) wrote :

I can confirm that solution #23 solved the problem for me.

Jochen Fahrner (jofa) wrote :

With workaround #23you disable time scheduled mode and switch back to old interupt driven mode. The new time scheduled mode should save cpu usage. The question here ist: why did the time scheduled mode work in Maverick and not in Natty? And why is only vlc affected and none of the other players? Is it a bug in vlc? Is it a bug in Nattys pulseaudio?

Dmitriy Larchenko (neokril) wrote :

> And why is only vlc affected and none of the other players?

I had the same problem with skype too... Maybe it's a common issue of
QT-based applications?

2011/5/28, Jochen Fahrner <email address hidden>:
> With workaround #23you disable time scheduled mode and switch back to
> old interupt driven mode. The new time scheduled mode should save cpu
> usage. The question here ist: why did the time scheduled mode work in
> Maverick and not in Natty? And why is only vlc affected and none of the
> other players? Is it a bug in vlc? Is it a bug in Nattys pulseaudio?
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/751265
>
> Title:
> pulseaudio distorts VLC audio
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/751265/+subscribe
>

janusz (sunmake) wrote :

Solution #23 solved sound problem with Skype 2.2.0.25 - Ubuntu 10.04 64bit, kernel 2.6.32-32 sound VT1708/A[Azalia HDAC] (VIA High Definition Audio Controller),module snd-hda-intel.Previous Skype version 2.1.0.81 works properly without any workaround,

LittleHorror (littlehorror) wrote :

Solution #23 worked for both Skype 2.2.0.25 and VLC 1.1.9 in my case. Card: Creative Labs SB Live!

David Henningsson (diwic) wrote :

If solution #23 works, we're looking at a hardware specific problem rather than a general VLC problem. And so individual bugs should be filed for each card that needs the #23 solution.

Gray (b-web) wrote :

I must say that I wasn't expecting the #23 solution to work but it just did. Brilliant - Thanks!

#23 worked for me as well, guess someone should look what the real problem is - Thanks for the fish ;)

Hardware:

00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383] (rev 40)
03:00.1 Audio device [0403]: ATI Technologies Inc Device [1002:aa80] <-- thats my video device, seems to use the same audio driver as the onboard sound card

Codec:

VIA VT2020

Jorge Gustavo (jgr) wrote :

#23 worked for me as well.

2.6.38-11-generic x86_64
pulseaudio 0.9.22-24-g67d18

 Manufacturer: Sony Corporation
 Product Name: VPCF13Z1E
 Version: C606F071
 Family: VAIO

             description: Audio device
             product: 5 Series/3400 Series Chipset High Definition Audio
             vendor: Intel Corporation
             physical id: 1b
             bus info: pci@0000:00:1b.0
             version: 05
             width: 64 bits
             clock: 33MHz
             capabilities: pm msi pciexpress bus_master cap_list
             configuration: driver=snd_hda_intel latency=0
             resources: irq:47 memory:ea200000-ea203fff

Jorge Gustavo (jgr) wrote :

I must add that #23 solution solved the audio output problem. I still have recordings full of hiss. Removing ~/.pulse didn't worked.

Primo (nsclumo) wrote :

I experienced this problem using VLC 1.1.12 under Lubuntu 11.10 x86_64. Deleting the ~/.pulse folder fixed this issue on my system.

Primo (nsclumo) wrote :

Just to clarify the "~/.pulse folder fix" is temporary until the next boot up.

rpr nospam (rpr-nospam) wrote :

I can confirm this problem on Ubuntu 11.10 with:
- Linux 3.0.0-14-generic #23-Ubuntu SMP Mon Nov 21 20:28:43 UTC 2011 x86_64
- VLC 1.1.12-2
- pulseaudio 1:1.0-0ubuntu3

"lspci -vvv" says:
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
        Subsystem: Giga-byte Technology Device a102
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 32, Cache Line Size: 4 bytes
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at fe024000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

Solution #23 was helpful (after reboot).

-- rpr.

I can also confirm on Lucid Lynx. Removing ./pulse solves until reboot, adding tsched=0 fixes only vlc not skype. For my system removing "rtkit" package solves vlc, skype and intermediate bootup freezes. Canonical leave Unity aside who needs it. We need sound on out PCs. Cheers!

Jani Uusitalo (uusijani) wrote :

@David: I have this bug but only with HDMI output from my gfx adapter. #23 works here, so as per your #30 I'm about to file a separate bug, but would the driver at fault in this case be for the underlying (Intel) sound card or for the (Radeon) display adapter? Audio coming through analog (headphones) never crackles.

David Henningsson (diwic) wrote :

@Jani, "ubuntu-bug audio" will do fine. (Note that the Radeon driver does not support HDMI audio anymore.) Thanks!

zibeltbg (zibeltbg) wrote :

Solved!!! The same problem in Kubuntu-10.10-need to compile Luggage 1.1.5 -http://mafayyaz.wordpress.com/2010/07/02/hello-world/ and the sound is bettherq and no crash

Shiba (shiba89) wrote :

For me boot tsched=0 (#23) and removing rtkit (#38) seemed to solve this for vlc and skype.

Jani Uusitalo (uusijani) wrote :

Note to others here suffering from this with Radeon HDMI only as I am: as per @David's comments, I've just filed Bug #927323 about this.

David Henningsson (diwic) wrote :

Hi,
Is there anyone testing 12.04 these days that can tell if this is still a problem?
If so, try the workarounds suggested here: https://wiki.ubuntu.com/Audio/PositionReporting - if this resolves your problem, it is hardware specific, and thus it needs a separate bug report.

Changed in pulseaudio (Ubuntu):
status: Triaged → Incomplete
LittleHorror (littlehorror) wrote :

To David Henningsson (diwic): Should new, card specific, bug reports (in case if solution 23 works) be submitted as pulseaudios or other packages bugs?

Also, can users of distributions, based on Ubuntu (Mint, etc), report bugs here at all? (Switched some time after my previous comment was posted.)

David Henningsson (diwic) wrote :

> Should new, card specific, bug reports (in case if solution 23 works) be submitted as pulseaudios or other packages bugs?

For this case, file the bug against the alsa-base package.

> Also, can users of distributions, based on Ubuntu (Mint, etc), report bugs here at all?

I don't know if there is an official/generic answer to that, but my personal preference would be that you could try it on a clean Ubuntu installation first, and only if the bug still exists there, to file a bug in Ubuntu.

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

Murz (murznn) wrote :

Solution from #23 solves the problem for me, thanks.

Colin Law (colin-law) wrote :

David Henningsson: I am still seeing seeing the problem on 12.04. I tried the tests in https://wiki.ubuntu.com/Audio/PositionReporting, the position fixes did not work, but the module-udev-detect tsched=0 fix did work. Submitted a bug as requested there. bug #1024702.

Rocko (rockorequin) wrote :

I am also seeing this in 12.04 with pulseaudio 1:1.1-0ubuntu15.1 and vlc 2.0.3-0ubuntu0.12.04.1. The solution in #23 fixes it. Also changing vlc's Tools / Preferences / Audio to use ALSA instead of pulseaudio will fix it.

Colin Law (colin-law) on 2012-08-18
Changed in pulseaudio (Ubuntu):
status: Incomplete → Confirmed
ShinobiTeno (lct-mail) wrote :

Long time I have used this account. This problem happened in LinuxMint Debian Edition - the core files are from debian. This is not Ubuntu related, and upstream "trouble".

How I recieved this "crispy, fuzzy" sound:
- I have edited /etc/pulse/daemon.conf and increased fragment amount and msec. This should reduce delays in slower apps (wine).
- next, I killed pulse audio (ps aux|grep pulse; kill -15 xxx)

Immediate result is this crispy, fuzzy audio in VLC, but even in OpenArena 0.8.8.
In VLC it disappears if I increase/decrease volume, but reappears if I restart VLC, change different media or navigate.
In Openarena it disappears after 10 seconds.

This looks like a problem with buffers to me.

The solution #21
"rm -r ~/.pulse"
solved the issue.

ShinobiTeno (lct-mail) wrote :

Ok, after restart the problem was back.. Even after I set the daemon.conf back to default.

The solution in #23 helped however, thank you!

So, I will then create a report for this chip, this is Ax00 AMD chip Intel HDA on AMD 785G, kernel 3.2.

Turbo (axelhc) wrote :

My five cents:

I just upgraded to Kubuntu 12.10 beta 2 AMD64 with full updates and the awful cracking/echoing noise is still present in both VLC 2.0.3 and Skype 4.0.0.8 x64. My system is AMD based with 785G chipset.

* The ¨rm ~/.pulse -rf¨ worked only for seconds until I closed and reopened VLC; no changes in Skype.

* The solution at #23 solved inmediatly the cracking for both apps.

On any case I'm still scared of how OLD this problem is. Come on, we are in 2012 and this thing is still chasing us five years later. I'm sure there is someone we can write an email or something to fix it FOREVER....

Regards.

PD: If I find some change will post back. ;-)

Ex Qwztis (xqwztis) wrote :

I'm using Ubuntu 12.04 and have hissing after the playback is initiated or continued after a pause in VLC 2.0.3 and Exaile 0.3.2.2. I'm using Creative's Audigy 2. Workaround #23 doesn't work.

Can you be of any help with this?

Ex Qwztis (xqwztis) wrote :

Plus it seems that moving the mouse seems to stop this annoying sound.

giffel (xgiffel) wrote :

I upgraded to Xubuntu 12.10 with VLC 2.0.4 and this issue arise. My configuration is SB Live! with EMU10k1 on AMD 890GX motherboard. I discover when I change sound card profile in Volume control window (Configuration tab) to any "Analog surround*" profile, issue disappear.

FriedChicken (domlyons) wrote :

Thanks for answer #23, it solved my problem.

The problem occured only by VLC itself and the KDE Phonon VLC module. So I suspect that VLC is doing something a little bit different than most other audio backends. Maybe the chunk size VLC uses or the timing of VLC.

Also I followed https://wiki.archlinux.org/index.php/PulseAudio#Choppy.2C_overdriven_sound (set samplerate to 48000 Hz) and https://wiki.archlinux.org/index.php/PulseAudio#Setting_the_default_fragment_number_and_buffer_size_in_Pulseaudio (Set correct buffer and fragment size for 48000 Hz). This alone without answer #23 was not enough, but I guess they are worthwhile anyway.

$ lspci | grep -i audio
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)
01:05.1 Audio device: Advanced Micro Devices [AMD] nee ATI RS880 HDMI Audio [Radeon HD 4200 Series]

Thanks also for #23 that solved my solution for skype and vlc
pg@pipoTower: ~$ lspci|grep -i audio
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)
01:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev a1)

Angelo Pantano (ghilteras) wrote :

had this issue on 12.04 but after some sec it went away on vlc by let it play the movie.

then on upgrade to 12.10 it became worse, it was always present and although after a while disappeared any jump back (shift + left arrow) made it come back.

fixed it by removing rtkit and restarting pulse, my audio is:

00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)

astro (bernard-godard) wrote :

Did not have the issue in 12.04, but I have the issue now on 12.10.
However the issue is not present if the program pavucontrol is running at the time I start VLC and I leave it running.

Also if I request VLC to ouput via ALSA, the issue is no present but I get another weird bug (I don't know if they are related): when I pause the video and I play it again, I don't get audio from VLC anymore. The only way to get audio back is to move the cursor position manually.

Rémi Denis-Courmont (rdenis) wrote :

It's all very confusing with many people experiencing similar symptoms. But the original logs look like a simple case of PulseAudio selecting a far too short latency:

I: protocol-native.c: Final latency 201.00 ms = 0.50 ms + 2*100.00 ms + 0.50 ms
D: alsa-sink.c: Cutting sleep time for the initial iterations by half.
D: alsa-sink.c: Latency set to 0.50ms

And indeed, VLC version 1.1.8 requested tlength=200ms and minreq=100ms. A similar problem affects more recent VLC versions with tlength=40ms and minreq=-1 (overriden by PA to 20ms). It seems that when tlength is exactly twice minreq, PulseAudio settles on an insanely small latency. That causes frequent underrun in hardware buffers, accounting for the distorsion.

Turbo (joel-avery) wrote :

I have this issue on a fresh install of 12.10 AMD 64. Sound was bad from VLC launch.

Like others, this choppiness would eventually go away on it own (see #59) and come back some time later. I could also fix the problem with a pause and then unpause. Moving the mouse (#55) also "seemed" to fix the problem quite often.

I moved VLC from default audio to ALSA and this got rid of the static / echo / choppiness. There was much rejoicing.

However, I then picked up problem #60. This is a somewhat acceptable solution - I usually just use the menu "playback" -> "jump backwards" to fix the problem as this gives a more precise amount of replay and I never encounter the bad audio.

I tried the famous fix #23 and it made things worse. VLC would start with no sound for about 20 seconds. Moving the slider to a new point resulted in the same no audio problem. I backed that out right away.

Agree with #62.

I tried everything and I still have glitches with 12.10 64bits

I had the same issue with the following hardware:

00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)
        Subsystem: ASUSTeK Computer Inc. Device 8436
        Flags: bus master, slow devsel, latency 32, IRQ 16
        Memory at fe600000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd-hda-intel

Ubuntu 12.10.

#23 fixed it. I get garbled sound all the time if I play a video with Totem, then with VLC.

Edward Liaw (chrono2200) wrote :

Having a similar issue on Linux Mint Debian like #51. Haven't tested it yet with VLC, but making calls through Google Mail/Voice is crackling ferociously.

$ lspci | grep -i audio
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)
06:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Cayman/Antilles HDMI Audio [Radeon HD 6900 Series]

#23 fixed it.

Binoy Babu (royale1223) on 2013-04-27
affects: pulseaudio (Ubuntu) → vlc (Ubuntu)
affects: vlc (Ubuntu) → pulseaudio (Ubuntu)
Binoy Babu (royale1223) wrote :

I can confirm that this bug is on Ubuntu 13.04. Loud crackling when playing audio streams on vlc. I'm using the following card.

03:01.0 Multimedia audio controller: Yamaha Corporation YMF-744B [DS-1S Audio Controller] (rev 02)
 Subsystem: Yamaha Corporation DS-XG PCI Audio CODEC
 Flags: bus master, medium devsel, latency 64, IRQ 16
 Memory at febf8000 (32-bit, non-prefetchable) [size=32K]
 I/O ports at ec00 [size=64]
 I/O ports at e880 [size=4]
 Capabilities: <access denied>
 Kernel driver in use: snd_ymfpci

A workaround I found was to change audio output module in audio preferences of vlc.

Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu.

Ubuntu 11.04 (natty) reached end-of-life on October 28, 2012.
Ubuntu 12.10 (quantal) reached end-of-life on May 16, 2014.
Ubuntu 13.04 (raring) reached end-of-life on January 27, 2014.
Ubuntu 12.04 (precise) reached end-of-life on April 28, 2017.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We appreciate that this bug may be old and you might not be interested in discussing it any more. But if you are then please upgrade to the latest Ubuntu version and re-test.

Changed in pulseaudio (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for pulseaudio (Ubuntu) because there has been no activity for 60 days.]

Changed in pulseaudio (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.