OSS no longer works as a standalone sound driver for WINE.

Bug #662472 reported by Darin Miller on 2010-10-18
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

In Maverik, open winecfg, select the Audio tab, uncheck all drivers except OSS and click apply and CLOSE winecfg.

Re-open winecfg, select the Audio tab and click the Test Sound button. With only the OSS driver, the Test Audio button produces "Audio Test failed.".

The same behavior occurs with wine 1.2, wine 1.3, and the version of wine that installs with Picasa only with Ubuntu 10.10.

All versions of Ubuntu from 7.10 through 10.04 have worked perfectly with the wine OSS driver across many version of wine (0.9.42 to 1.3.5).

As long as the ALSA and OSS driver options are checked, sound works but ALSA seems to take priority over the OSS driver. Some legacy games, such as Starcraft, work best with only OSS checked (stuttering and/or clipping and eventual total loss of sound occur with the ALSA driver).

Running winecfg via the command line does not provide any additional information regarding the "Audio Test failed." error.

I am unsure if pulseaudio is at fault as 10.04's version of PA which worked fine matches 10.10's (0.9.21-63-gd3efa-dirty).

I am at a loss as to what to test next.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: pulseaudio 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu21.1
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: darin 22940 F.... pulseaudio
 /dev/snd/pcmC0D0p: darin 22940 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6ffc000 irq 46'
   Mixer name : 'SigmaTel STAC9228'
   Components : 'HDA:83847616,1028022e,00100201'
   Controls : 28
   Simple ctrls : 19
Date: Sun Oct 17 19:41:27 2010
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: pulseaudio
dmi.bios.date: 11/19/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A12
dmi.board.name: 0D501F
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA12:bd11/19/2008:svnDellInc.:pnXPSM1530:pvr:rvnDellInc.:rn0D501F:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1530
dmi.sys.vendor: Dell Inc.
mtime.conffile..etc.pulse.daemon.conf: 2010-08-18T20:59:41.997069

Darin Miller (darinmiller) wrote :
markofealing (mark-ferns16) wrote :

Makes no difference whether ALSA and OSS are ticked, it still fails. This is a right pain as Spotify no longer works.

I agree that this was not a problem prior to 10.10.

Julian Murgia (straton) wrote :

I confirm this bug in Ubuntu 10.10. It is present with wine 1.1.1, but whatever version is identical. Problem causes no sound in the game (here Startopia).

This bug happened after upgrading Ubuntu to 10.10.

Attachment : capture of winecfg / Audio tab : both alsa and oss are checked.

Raymond (superquad-vortex2) wrote :

it is not wine bug because they drop OSS emulation in ubuntu 10.10

you cannot

cat any.wav > /dev/dsp

cat /dev/dsp > any.wav

markofealing (mark-ferns16) wrote :

Raymond, you're right!

Removing OSS emulation has upset a hell of a lot of Ubuntu users if you look at bug 579300 https://bugs.launchpad.net/ubuntu/+source/linux/+bug/579300

Whilst I appreciate the need to progress, progress should not be at any cost!

markofealing (mark-ferns16) wrote :

Good News, at least if you use Spotify in Linux under Wine.

When I upgraded to Ubuntu 10.10, Spotify broke as Ubuntu 10.10 runs Wine 1.2.

Following the instructions at http://www.winehq.org/download/deb and upgrading to Wine 1.3 Beta has fixed audio playback in Spotify.

Whilst I'm unsure if it fixes other applications having audio playback problems under Wine, applying Wine 1.3 Beta is definitely worth a try.

Raymond (superquad-vortex2) wrote :

If they have removed oss emulation, they should also remove the option to select OSS Driver in winecfg to avoid confusion

Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu.
Ubuntu 10.10 (maverick) reached end-of-life on April 10, 2012.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

Please upgrade to the latest version and re-test.

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for pulseaudio (Ubuntu) because there has been no activity for 60 days.]

Changed in pulseaudio (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers