[Maverick] Sound is always muted on startup; unmuting makes the volume at lowest level

Bug #592016 reported by nobody on 2010-06-10
306
This bug affects 59 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
High
Luke Yelavich
Maverick
High
Luke Yelavich

Bug Description

This hasn't happened before this week, or with Lucid, by the way.

tags: added: maverick
Doug McMahon (mc3man) wrote :

Can confirm same here - always boots to muted sound

As a temp workaround in /etc/pulse/default.pa find this line and comment it out (seems counter-intuitive,, but works

load-module module-device-restore

Changed in ubuntu:
status: New → Confirmed
affects: ubuntu → pulseaudio (Ubuntu)
liamdawe (liamdawe) wrote :

On every boot up i also seem to be muted on my eeepc.

Yep, same here on a MacBook

Doug McMahon (mc3man) wrote :

Actually I like it the way pulse is now - hopefully it won't get messed up if this is fixed.

With that line commented out pulse will not change the pcm level on boot if lowered in alsamixer from the inexplicable default of 100.
(there is no reason to use a pcm or any other level of 100 with desktop speaker systems - it produces distorted and clipped sound

Additionally on a 5.1 desktop system it leaves the output device device at surround 5.1

(previously in karmic, lucid, setting pulse not to reset pcm to 100 resulted in the output device being set to stereo, at least here.

So I'm all for just commenting that line out and leaving things be...

Doug McMahon (mc3man) wrote :

This appears to be a continuing issue for many - whether the volume is actually muted or just set to 0 at boot.
Commenting the mentioned line does resolve for most ...

( The pcm levels I mentioned in previous post (5.1 output), were the actual pcm's that affected the various channel levels - not the "pcm" level which affects nothing. (in a 5.1 setup

I can also confirm this issue both on a desktop with a quad core, and a MacBook Pro 4,1 with a Core2 Duo CPU.

Could everybody with this issue try the following for me:

1. If you have the above line commented, please uncomment it.
2. In your logins ession, set up the volume to your satisfaction.
3. Log out of your session, don't restart or shut down, log out.
4. Restart your system.
5. Log back into your session.

If you still have sound volumes set correctly, then this confirms what I am seeing, where pulse seems to get messed up on restart, but if you log out of your session and then restart from the login screen, things seem to be ok.

If you can confirm the above, please follow the procedure outlined here, https://wiki.ubuntu.com/PulseAudio/Log and leave pulseaudio running in a terminal. Restart your system from within your session, and confirm that your audio is muted on next login. Attach the log to this bug, so we can see whether everyone gets the same behavior from pulse when you restart.

Thanks for your help in debugging this.

Luke

Doug McMahon (mc3man) wrote :

On a laptop with stereo output installed from 1 day pre alpha 3 this is no longer an issue other than an occasional boot to MUTED sound

On a desktop with 5.1 analog output, installed alpha 1, commenting the line and a log out/login produces no change, ie. sound levels stay the same.
However a re-start will produce sound level set to 0 ( note that the sound is not muted, just set to 0
Attached log as requested from the desktop

Doug McMahon (mc3man) wrote :

Line 3 above should read
..... uncommenting the line

Doug McMahon (mc3man) wrote :

What has come up is that this may be related to alsa-utils

On machines where alsa-utils is installed, but alsamixer never run then sound on boot is fine (not muted and or set to 0
Once alsamixer has been run once, then on reboot sound is either muted @level 0 or just set to level 0

maybe in question is this line? line 385
mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1

(removing the line or setting the 1 to 0 and sound is always fine on boot, even is alsamixer has been used

Jake LeMaster (ssoundasleep) wrote :

I can confirm Luke's observations.

Doug, I've never fiddled with alsamixer and still have the bug.

Could you check whether it is still present? Recent updated fixed it for me.

Yep, fixed for me. Marking as fix-released

Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
Jake LeMaster (ssoundasleep) wrote :

This isn't completely fixed. It's still here in a strange way.

For my account, the issue is gone. But for the second user account on my machine, the bug still exists. Here are peculiar things I can easily reproduce:

Consider user A my account - sound always works fine. User B is the account where sound will still start muted.

1. Log into user B first after booting the computer.
2. Sound is muted.
3. Switch to user A.
4. Sound works. (Login theme plays and everything.)
5. Switch back to user B - sound is no longer muted and is working.
6. Switch to user A and log out.
7. Switch to user B and log out.
8. Log back into user B.
9. Sound is muted again.
10. Repeat steps 3-9 as many times as you want.

It's like Pulse isn't "working" for user B unless user A logged in at some point during user B's session. I wouldn't know what's really going on, but I can reproduce it trivially everytime with those steps. It doesn't require rebooting or anything. Any idea?

Changed in pulseaudio (Ubuntu):
status: Fix Released → Confirmed
Luke Yelavich (themuso) wrote :

Jake, could you clear out all .pulse related files from the user with the problem, and try again? The easiest way to do this is to log out, go t a text console, make sure you don't have any pulseaudio processes for that user running, and rm -rf .pulse* in your home directory.

Thanks.

Jake LeMaster (ssoundasleep) wrote :

Hi Luke, I tried your suggestion and it didn't help. I actually did it for both accounts, and now the one that was working is back to having the muted problem again too. :/

If you yourself try what you suggested, does it make the problem come back? Or for anyone else?

Is there anything else I should try?

And just for the record, I am indeed running a fully up-to-date standard Maverick.

Thanks.

Brice (brice-boucard) wrote :

Same problem here on an Alpha 3 fresh install and fully upgraded.

Still present as of pulseaudio 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu17. No behavioural changes whatsoever.

(BTW, this version is listed in changelog with date 2010-07-21 -- I wonder which "recent updated" posting #11 refers to?)

Jorge Suárez de Lis (ys) wrote :

Same here. Upgraded after alpha 3 release.

I tried creating a new user and rebooting directly into his account and no dice.

Doug McMahon workaround [1] fixed this for me.

[1] https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/592016/comments/1

Colin Mills (cm006a5077) wrote :

I installed Ubuntu 10.10 Beta (64 bit) and encountered the bug, the sound was muted and when unmuted the sound was set to minimum.

The workaround suggested by Doug McMahon and Jorge Suárez de Lis (https:/ /bugs.launchpad .net/ubuntu/ +source/ pulseaudio/ +bug/592016/ comments/ 1) fixed the problem for me as well.

David Henningsson (diwic) wrote :

Isn't this a race between pulseaudio quitting, and alsa-utils muting the output to prepare for shutdown? Can we fix this by changing /etc/init/alsa-mixer-save.conf

from

start on starting rc RUNLEVEL=[06]

to something like:

start on (starting rc RUNLEVEL=[06]) and (there is no pulseaudio process left)

...however you write that in upstart, if it's even possible?

I e, start when both conditions are fulfilled. Optionally keep it as it is, then wait for pulseaudio to be killed before continuing.

Mark Shuttleworth (sabdfl) wrote :

I've noticed this with a USB headset. If we're going to have a default level in Ubuntu it should be 65% please, but the best is to reset to the former level of the same device.

Changed in pulseaudio (Ubuntu):
importance: Undecided → High
Daniel T Chen (crimsun) wrote :

David: sounds reasonable, go for it!

Regarding Mark's comments, there are actually a couple pieces here. Firstly, we're incorrectly using alsactl via the udev script; the fix for that is in maverick's alsa-utils bzr branch. Secondly, percentage isn't precise for "default" levels given the inordinate number of hardware quirks, particularly with usb audio devices. Most of those devices behave wildly differently at 65%, and dB information isn't precise for a nontrivial number of them.

David Henningsson (diwic) wrote :

Okay, so just to test, I hacked "/sbin/alsa-utils stop" a little to wait for pulseaudio to quit, but I had a timeout of 15 seconds and after that time, pulseaudio was still alive. So something should tell pulseaudio to shutdown, but it doesn't.

Changed in pulseaudio (Ubuntu Maverick):
status: Confirmed → Triaged
Mark Shuttleworth (sabdfl) wrote :

OK, I'm reassured you're on the case of the underlying bug :)

With regard to the 65%, I do understand that there are outliers. But I
feel strongly that we should pick a reasonable level, and fix the
outliers. Turning the computer on and having "no sound" always feels
like a problem. The chances of setting some level like 65% causing
deafness are so remote that I think it's better for us to give the new
user a straightforward starting position.

Mark

David Henningsson (diwic) wrote :

@Mark, IIRC, PulseAudio does not mess with the controls unless the volume control is actually moved, so the current "factory default" levels (e g, what you get if you boot a Live-CD) are what you see in /sbin/alsa-utils (function sanify_levels_on_card()). Most of them (front, pcm, master) are set to 80%.

David Henningsson (diwic) wrote :

So getting to this seems pretty hard. I think we're going to need a startup/shutdown expert to fix this the right way.

Here is what *should* happen, in that order:

#1) PulseAudio plays the log-out sound, if any
#2) All applications accessing PA should quit
#3) PA should store current volume, then quit
#4) alsa-utils should mute the card to prepare for shutdown

#1 and #2 can go in parallel.

What we know so far is that #4 happens before #3 and probably before #2 as well, and #1 does not happen at all ( see bug #214370 ). We should probably try to delay #4 rather than killing PA earlier, to prevent us from making it harder to fix #1.
Perhaps we should also prevent PA from autospawning if the runlevel is 0 or 6.

Mark Shuttleworth (sabdfl) wrote :

Subscribing Scott, as a world expert on startup / shutdown :-)

Scott, do you think David's outline in https://bugs.edge.launchpad.net/ubuntu/+source/pulseaudio/+bug/592016/comments/26 is achievable?

Johannes Schmitz (jsemail) wrote :

I can confirm the always mute problem in beta.

eZFlow (breakdevize) wrote :

It doesn't happen on my main system with a sb audigy 2 but it does happen on an older pc with sb live!

luk1don (luk1don) wrote :

I can confirm too, but now sound is muted for the some time.

angel orna (angelorna) wrote :

it is working fine for me (ubuntu 10.10 beta)

Jake LeMaster (ssoundasleep) wrote :

This is now fixed for me after the latest update to alsa-utils this morning.

* debian/init: Restore change from 1.0.21-1ubuntu2 lost during merge
    that skips muting and zeroing levels prior to shutdown/reboot,
    which was a hack for broken drivers. This change closes LP: #21804,
    LP: #208920, #227505, #360108, #432660, #449783, #553132, #564472,
    LP: #584609, #592016, #596360, #613054, #617516, #622487, #632019.

Thanks.

Jake LeMaster (ssoundasleep) wrote :

Perhaps I spoke a little too soon. It does indeed appear to be *mostly* fixed (sound isn't muted now upon boot), but I just logged out of one user and into another, and the second user had muted sound. The levels weren't zeroed, but it was indeed muted when it shouldn't have been. (No login sound or anything.) Blah.

Daniel T Chen (crimsun) wrote :

Jake, was the second user an existing one or a new one? Note that for existing users, it isn't an alsa issue but what pulseaudio has stored for that user. You should try and reproduce the issue with a brand new user.

Note also that the graphical greeter has a corresponding user. :-)

Raymond (superquad-vortex2) wrote :

>> so the current "factory default" levels (e g, what you get if you boot a Live-CD)

The controls are muted by default by the driver to prevent accidental damage of the speaker ,

The volume of Live-CD is the result of "alsactl init"

If you use "alsactl store -f original.txt" before you logout/reboot

After you login/boot and the pulseaudio restore the volume

 "alsactl store -f current.txt"

and compare with the controls in current.txt and original.txt

Giorgi Maghlakelidze (dracid) wrote :

I think it got fixed after yesterday's(?) update... Everything's fine on my HP Pavilion, x32 Maverick Beta with latest updates... :)

luk1don (luk1don) wrote :

Yes, for me too.

It's working mostly for me again (Maverick 32 with all updates), but I now find that if I use fast user switching and log in as, say, the guest user, the wrong audio device is selected and the volume is again muted and at 0%.

Brice (brice-boucard) wrote :

On a single user machine, the latest updates solve the issue for me too. If I find enough time, I'll try to create a new user and make some tests.

very (very-concerned-person) wrote :

A week ago I fixed this issue - temporarily - by commenting the line "load-module module-device-restore" in the file /etc/pulse/default.pa , as someone else recommended.

But since the last 2 updates (one this morning and one a few days ago) no matter if that line is commented or not I stil have no audio since the audio after I restart is always muted.

Also, now, when I try to open my Audio/Sound Preferences to raise the volume it takes more than 5-10 minutes to open if it opens at all, because right now I'm just getting a window with a message that says something in the line: "Watiting for the audio/sound system to respond" (my system is not in English) and I just have to press "Cancel".

Thanks.

Jake LeMaster (ssoundasleep) wrote :

Daniel, but how would I fix the problem for an existing user? I've already tried stopping pulse and deleting .pulse* from the home directory.

I'm glad that when I start my computer and login to my username, my sound isn't muted upon entering my session anymore. But I'm still troubled by the fact this isn't guaranteed for other user sessions that may start during (like with fast user switching) or after that initial session. They still get muted sound upon login.

Alberto (alberto-torricelli) wrote :

What happens to me is the following:
1. I can here sometimes the login sound (once/twice out ten);
2. I never hear the logout sound
3. I sometimes hear the system sounds (but not loud...)

David Henningsson (diwic) wrote :

@Jake, it should be as simple to just change the volume to your preferred one, then either reboot or log out, and it should store the latest value, then restore it when you log in again. Repeat this procedure for every user.

Jake LeMaster (ssoundasleep) wrote :

I've done that multiple times and it doesn't work, unfortunately.

Changed in pulseaudio (Ubuntu Maverick):
assignee: nobody → Luke Yelavich (themuso)

There was an update to alsa-utils today. Everybody please update their systems, completely delete ~/.pulse/ and restart your system to check that all is working again..

For the record, I am no longer able to reproduce this issue on a few machines here, and haven't been able to do so for several weeks.

Jake LeMaster (ssoundasleep) wrote :

I've updated today and done as you said, but no luck.

Omer Akram (om26er) wrote :

Yes, I had the problem in two different machines and now everything is fine for me.

very (very-concerned-person) wrote :

@Luke I followed your instructions as you said in post #45 and now everything works fine. Thank you very much!

Mark Shuttleworth (sabdfl) wrote :

 On 24/09/10 00:17, Luke Yelavich wrote:
> There was an update to alsa-utils today. Everybody please update their
> systems, completely delete ~/.pulse/ and restart your system to check
> that all is working again..

If this fix does work, how are we going to handle updates? Can we reset
the contents of .pulse programatically on first-login-after-upgrade?

Mark

Luke Yelavich (themuso) wrote :

On Sat, Sep 25, 2010 at 11:50:36PM EST, Mark Shuttleworth wrote:
> On 24/09/10 00:17, Luke Yelavich wrote:
> > There was an update to alsa-utils today. Everybody please update their
> > systems, completely delete ~/.pulse/ and restart your system to check
> > that all is working again..
>
> If this fix does work, how are we going to handle updates? Can we reset
> the contents of .pulse programatically on first-login-after-upgrade?

No, and as far as I am aware, packages are not allowed to touch files in a user's home directory. I was only suggesting this as a quick way of making sure pulseaudio is set back to default volume levels. All being well, when users upgarde from lucid, this bug will not surface, and their pulseaudio preferences, however simple or complex they may be, will be kept.

Dave North (north) wrote :

Initially I was going to comment that the bug showed up on my beta, but even better I can add that after updating today, it went away. Hope that proves useful.

LeDucDuBleuet (eleduc) wrote :

Same here, latest update solves the problem! Yeah! Thx all!

Andrea Amoroso (heiko81) wrote :

I still have the problem..it happens randomly, maybe when switching from Unity to Ubuntu..at start I find the audio off..and if I try to reenable audio and turn up the volume, tha audio still doesn't work..I managed to make it work changing the connector 3 times or so in the output tab of the audio preferences..when I select again Analog Speakers, that I had previously, it works again..hope you find the solution soon..thanks..

Andrea Amoroso (heiko81) wrote :

and yes, when unmuting the volume is at the lowest level, but not working at all..

David Henningsson (diwic) wrote :

Confirming that it is fixed. If it still appears for you, you're probably affected by another bug.

Changed in pulseaudio (Ubuntu Maverick):
status: Triaged → Fix Released

I've tried #45 but nothing works on my end (Running on a model 5 Pangolin Performance from System76).

I'm also plagued by
1.) No startup sounds
2.) No log out sounds

Jim Hunziker (landtuna) wrote :

I still had the problem after the fix, and one more thing fixed it for me:

sudo apt-get remove --purge alsa-utils
sudo apt-get install ubuntu-desktop

owenspa (peter-nanks) wrote :

I'm running KDE 4.5.4. Fully uptodate. On every reboot audio was muted with volume level at 44%.
I've tried all the solutions I could find in this list.

What worked for me was.

Set audio unmuted and at the required volume level using kmix.
(not sure if this is essential)

sudo apt-get purge pulseaudio

reboot.

(am I having deja vu - vague memories of 8.04 experiences)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers