No Sound Through USB Headset

Bug #566449 reported by Ryan Williams on 2010-04-19
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

Ubuntu 10.04
64-bit

When using a standard USB headset, sound will not play through the headphones. Both input (microphone) and output are detected, but only the microphone works. When switching to use the headphones, no audio seems to play. It previously worked in 9.10 and intermittently after first installing 10.04.

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ryan 7099 F.... pulseaudio
 /dev/snd/controlC0: ryan 7099 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'VT82xx'/'HDA VIA VT82xx at 0xfbffc000 irq 17'
   Mixer name : 'Realtek ALC662 rev1'
   Components : 'HDA:10ec0662,10438290,00100101'
   Controls : 36
   Simple ctrls : 19
Card1.Amixer.info:
 Card hw:1 'default'/'C-Media USB Headphone Set at usb-0000:00:10.2-2, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB0d8c:000c'
   Controls : 7
   Simple ctrls : 3
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406.1)
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
PackageArchitecture: all
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Tags: lucid
Uname: Linux 2.6.32-21-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 11/15/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0503
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5VD2-VM SE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev x.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0503:bd11/15/2007:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5VD2-VMSE:rvrRevx.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Ryan Williams (theamazingjanet) wrote :
description: updated

Could you please ensure your headset is connected, and run "apport-collect -p alsa-base 566449", so we can get some information about your sound hardware?

Could you also please follow the procedure at https://wiki.ubuntu.com/PulseAudio/Log, so we can get a log of what pulseaudi ois doing while you try and use the headphones/microphone of your headset?

Thanks.

 affects ubuntu/pulseaudio
 status incomplete

Changed in pulseaudio (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Here's the pulse log you requested. Apport info already added.

Daniel T Chen (crimsun) wrote :

PulseAudio definitely detects the output. Are you sure you didn't choose a profile for the usb headset that doesn't have analog output?

Yes, I've tried most combinations of profiles and the analog output/analog speakers setting in the output tab. Profile for headset is analog stereo output + analog mono input, setting for normal speakers/sound hardware is stereo analog output.

Other settings listed are digital stereo duplex (IEC958) and the same + analog input for both the headset and hardware, IEC958 output + digital stereo input (IEC958) for hardware only. None of these appear to make a difference.

Devin Davis (rd-kryten) wrote :

I'm seeing similar results with my Creative Arena USB headset. Device is selected and mixer shows activity, but no sound. It did work for me in Karmic until recently, but I'm not sure when the issue began.

David Burrows (snadge) wrote :

I am also seeing this with a: ID 1395:3556 Sennheiser Communications USB Headset

You'll notice from Ryan's Card1.Amixer.values.txt attachment that the speaker playback volume is set to 0%. If you run alsamixer, and select the USB device, and turn the volume up the device works correctly. The gnome-volume-control utility appears to have no control over the actual volume level for this device. Perhaps it is controlling an ineffectual pcm mixer channel instead of master volume, or vice versa?

This problem is new to me in lucid and worked as expected when I was running karmic.

David Burrows (snadge) on 2010-05-24
Changed in pulseaudio (Ubuntu):
status: Incomplete → Confirmed

Thank you, this solved the issue. Sound now works perfectly!

Stephen Gornick (sgornick) wrote :

with Ubuntu 10.04 x86-64, by using gnome-volume-control and selecting the "Analog Output" connector will cause this assignment of volume 0 to occur. Changing back to "Analog Speakers" and adjusting the volume will have no effect on the volume for the USB device. The only way to resolve this, as far as I know is to adjust the value using alsamixer and selecting (F6) the USB audio playback device.

Would anyone running 10.10 be able to confirm that this behavior persists with 10.10?

Lars Karlsson (mintlars) wrote :

I can confirm this behaviour on Kubuntu 10.10. I guess it's applicable to Ubuntu 10.10 as well then.

andypiper (andypiperuk) wrote :

Also an issue on Ubuntu 11.04 with a Microsoft Lifechat USB headset. It worked for a while and then "suddenly" stopped. I can only get audio through the headset if I run alsamixer at the cmdline and change the volume there.

Artur Krysiak (ventharin) wrote :

It also has a side effect. I've launched VLC and changed the audio device on VLC to plantronics C420 ... and managed to have the sound in my headphones. Sadly, when I did it, the buttons located below trackpoint stopped to work at all. When I plugged out the headphones from usb port, then all returns to normal.

Raymond (superquad-vortex2) wrote :

Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 151
  Mono:
  Front Left: Playback 0 [0%] [-28.37dB] [on]
  Front Right: Playback 0 [0%] [-28.37dB] [on]

it was bug of pulseaudio since usb audio really has playback volume

I: alsa-sink.c: Using 2.0 fragments of size 176400 bytes (1000.00ms), buffer size is 352800 bytes (2000.00ms)
I: alsa-sink.c: Time scheduling watermark is 20.00ms
D: alsa-sink.c: hwbuf_unused=0
D: alsa-sink.c: setting avail_min=87319
D: alsa-mixer.c: Activating path analog-output
D: alsa-mixer.c: Path analog-output (Analog Output), direction=1, priority=99, probed=yes, supported=yes, has_mute=yes, has_volume=no, has_dB=no, min_volume=0, max_volume=0, min_dB=0, max_dB=0
D: alsa-mixer.c: Element Speaker, direction=1, switch=1, volume=2, enumeration=0, required=0, required_absent=0, mask=0xbfaeb851eb851ebe, n_channels=2, override_map=no
I: alsa-sink.c: Driver does not support hardware volume control, falling back to software volume control.
I: alsa-sink.c: Using hardware mute control.

Raymond (superquad-vortex2) wrote :

the workaround is to change the name of the playback volume control

https://git.kernel.org/cgit/linux/kernel/git/tiwai/sound.git/commit/sound/usb/mixer.c?id=9b4ef97757953c6071563b7cbfc689e3dd771603

you need to open another bug report if your case are not as same as reporter

Raymond (superquad-vortex2) wrote :

https://bugs.freedesktop.org/show_bug.cgi?id=46236

Front Left: Playback 0 [0%] [-28.37dB] [on]
   Front Right: Playback 0 [0%] [-28.37dB]

the dB min -28.37 dBat 0% of your USB headset is much higher than pulseaudio expect -∞ dB

Daniel van Vugt (vanvugt) wrote :

Ryan,

Thank you for reporting this bug to Ubuntu.
Ubuntu 10.04 (lucid) reached end-of-life on May 9, 2013.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

Please upgrade to the latest version and re-test.

Raymond: Please log a new bug if you continue to experience problems.

Changed in pulseaudio (Ubuntu):
status: Confirmed → Incomplete
Daniel van Vugt (vanvugt) wrote :

Closed due to no response.

Changed in pulseaudio (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.