Ubuntu

Add rtkit Conflicts to force removal of rtkit for release testing

Reported by Tony Espy on 2009-10-15
86
This bug affects 4 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

The last pulseaudio upload to Karmic ( 1:0.9.19-0ubuntu2 ) removed the rtkit Recommends from the debian/control file due to the fact that the Karmic kernel was never patched to support rtkit. This was necessary as rtkit was added to main and by default, its daemon process is started, causing "Invalid Parameter" log messages to be written to the daemon.log, and wasting CPU cycles.

This removal works, however since we won't be releasing any more development releases of Karmic, a user needs to manually remove the rtkit package in order to fully test pulseaudio in the manner with which it will actually be released.

In order to get more test coverage between now and Karmic final, I propose that we add a Conflicts for rtkit in order to force removal of the rtkit package between now and final. This was discussed today on #ubuntu-desktop today with pitti and dtchen.

See bug #406702 for more details.

Tony Espy (awe) on 2009-10-15
Changed in pulseaudio (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.19-0ubuntu3

---------------
pulseaudio (1:0.9.19-0ubuntu3) karmic; urgency=low

  [ Tony Espy ]
  * debian/control: Add a Conflicts for rtkit so we force removal, and
    hence get more testing coverage between now and Karmic final (LP: #452458).

  [ Daniel T Chen ]
  * debian/patches/0056-ignore-sound-class-modem.patch:
    + Apply patch from Whoopie to fix initialization of devices with
      modem subdevices (LP: #394500, #450222)

 -- Tony Espy <email address hidden> Thu, 15 Oct 2009 15:33:02 -0400

Changed in pulseaudio (Ubuntu Karmic):
status: Confirmed → Fix Released
Dylan McCall (dylanmccall) wrote :

Please make sure this conflict is removed BEFORE the final disks are built, or we'll have a real mess. Is there a second bug report to keep track of that requirement?

The conflict will stay, because there is no patches in the kernel that allow rtkit to do its thing, and the conflict is there to make sure rtkit is removed from users' systems to ensure CPU cycles are not wasted, and syslog is not flooded.

James Henstridge (jamesh) wrote :

Might it not be better to add the conflict to the kernel package then? After all, it is the kernel that needs updating to resolve the conflict.

Javier Cabezas (javier-cabezas) wrote :

It seems that it is easily fixable. Only a tiny kernel patch (used in the past releases of Fedora) is required:

http://0pointer.de/blog/projects/pa-in-ubuntu.html

Can this be fixed in time for Karmic?

I'm surprised he hasn't commented on this himself, but you guys should probably read this blog entry by Lennart Poettering: http://0pointer.de/blog/projects/pa-in-ubuntu.html

Tobias Wolf (towolf) wrote :

I agree with Lennart on two counts. It’s disappointing that flatvol was disabled. And too bad that PA can’t run as real-time now.

You guys need to collaborate more.

Alex Wauck (awauck) wrote :

I really think the kernel patch should be applied and rtkit should be re-added. I looked through the patch, and it shouldn't have any effect on any application that does not use SCHED_RESET_ON_FORK. I doubt any non-free kernel modules use task_struct, so the patch should not have any effect on those, either.

Is there a real rationale for not applying the patch?

RK (kubuntu-rk) wrote :

> Only a tiny kernel patch (used in the past releases of Fedora) is required:
> http://0pointer.de/blog/projects/pa-in-ubuntu.html

I might be blind... but where in that rant did you find a kernel patch? Because I, for sure, can't find any there.

Gabriel Bauman (gabrielbauman) wrote :

@RK:

http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Ftorvalds%2Flinux-2.6.git&a=search&h=HEAD&st=commit&s=SCHED_RESET_ON_FORK

Also, easy on Lennart. He has reason to be frustrated.

Hope to see rtkit properly integrated in Karmic.

Paul Sladen (sladen) wrote :

Filed bug #455978 "merge SCHED_RESET_ON_FORK (for rtkit/pulseaudio)".

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers