[Karmic] slmodemd blocks pulseaudio to detect sound hardware with module-udev-detect

Bug #450222 reported by Jens Georg on 2009-10-13
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

With module-udev-detect enabled I only have a dummy output device. Disabling module-udev-detect and enabling module-detect, sound is working fine.

It seems that slmodemd is preventing pulseaudio from detecting the soundcard properly when module-udev-detect is used.

ProblemType: Bug
.etc.asound.conf: ##__RDE_AVS_NGL
Architecture: i386
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/dsp', '/dev/snd/pcmC0D6p', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/hwC0D1', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/pcmC0D6c', '/dev/snd/seq', '/dev/snd/timer', '/dev/sequencer', '/dev/sequencer2'] failed with exit code 1:
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xb0000000 irq 16'
   Mixer name : 'Realtek ALC260'
   Components : 'HDA:10ec0260,10cf0000,00100400 HDA:11c13026,11c13026,00100600'
   Controls : 23
   Simple ctrls : 15
Date: Tue Oct 13 11:53:29 2009
DistroRelease: Ubuntu 9.10
Package: pulseaudio 1:0.9.19-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.44-generic
SourcePackage: pulseaudio
Uname: Linux 2.6.31-13-generic i686

Jens Georg (yg-jensge) wrote :
Jens Georg (yg-jensge) wrote :
Jens Georg (yg-jensge) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.19-0ubuntu3

---------------
pulseaudio (1:0.9.19-0ubuntu3) karmic; urgency=low

  [ Tony Espy ]
  * debian/control: Add a Conflicts for rtkit so we force removal, and
    hence get more testing coverage between now and Karmic final (LP: #452458).

  [ Daniel T Chen ]
  * debian/patches/0056-ignore-sound-class-modem.patch:
    + Apply patch from Whoopie to fix initialization of devices with
      modem subdevices (LP: #394500, #450222)

 -- Tony Espy <email address hidden> Thu, 15 Oct 2009 15:33:02 -0400

Changed in pulseaudio (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers