Ubuntu

USB creative xmod XFI Output does not work

Reported by taiebot65 on 2009-09-14
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

My USB creative xmod XFI is not recognise as an Input/output audio system but only as an input. It was recognise in Jaunty.

ProblemType: Bug
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: taiebot 2951 F.... pulseaudio
 /dev/snd/controlC0: taiebot 2951 F.... pulseaudio
 /dev/snd/pcmC0D0p: taiebot 2951 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd4240000 irq 22'
   Mixer name : 'SigmaTel STAC9250'
   Components : 'HDA:83847634,107b0366,00100101 HDA:10573057,00010001,00100100'
   Controls : 9
   Simple ctrls : 7
Card1.Amixer.info:
 Card hw:1 'Xmod'/'Creative Technology Ltd Creative Xmod at usb-0000:00:1d.0-2, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB041e:30d0'
   Controls : 7
   Simple ctrls : 5
Date: Mon Sep 14 21:41:16 2009
DistroRelease: Ubuntu 9.10
Package: pulseaudio 1:0.9.17-0ubuntu1
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.32-generic
SourcePackage: pulseaudio
Uname: Linux 2.6.31-10-generic i686

taiebot65 (taiebot65) wrote :
taiebot65 (taiebot65) on 2009-09-27
tags: added: alsa-usb karmic pulseaudio
Øyvind Stegard (oyvinst) wrote :

I have a Creative Xmod, and it behaves somewhat strangely with Pulseaudio in Karmic. First of all, the default audio profile chosen for this card is "Analog stereo input", but you can select a different profile at the bottom of the audio properties for the device (right click mixer icon, selects prefs, go to the Hardware tab). The problem is that only surround-profiles are available, and a simple "Analog stereo output" is not there. I don't understand why. But selecting "Analog surround 5.1 .." actually works with stereo output, just as long as you stay away from the channel left/right balance slider or volume control. That will mess up the sound (makes it scratchy/thin). So this is an unacceptable workaround.

It would be good if a simple "Analog stereo output" could be made available for this card, and that it should be the profile with the highest priority, so it gets automatically selected. It's probably possible if you mess around with ALSA config (or Pulseaudio-config), but it should be there by default.

Øyvind Stegard (oyvinst) wrote :

And btw, I confirm the bug described by the reporter. The Creative Xmod USB sound card is not properly set up in Ubuntu Karmic. It worked better in Jaunty.

Øyvind Stegard (oyvinst) wrote :

It seems ALSA does not expose the Xmod with only two channels/stereo ? At least, I am unable to play a stereo WAV using aplay with the "front" PCM device of the Xmod ("Channels count not available" ..). I'm guessing that's why Pulseaudio does not make stereo output available for this card.

To work around that problem, I added the following to /usr/share/pulseaudio/alsa-mixer/profile-sets/default.conf:
; Special stereo-out for Creative Xmod card
[Mapping xmod-stereo-out]
device-strings = surround51:%f
description = Analog Stereo Creative Xmod
channel-map = front-left,front-right
paths-output = analog-output
direction = output
priority = 10

That is, I selected the ALSA "surround51"-PCM, BUT I only set front-left and front-right in the channel mapping. Restarting Pulseaudio and selecting this profile for the Xmod makes volume control work properly for stereo output. Left/right balance and volume adjustment of the PCM-control behaves OK, and it sounds normal. Observing alsamixer when adjusting the volume through Pulseaudio shows me that it's doing the right thing (i.e. adjusts volume like ALSA does natively for the Xmod).

If it turns out the Creative Xmod actually needs special handling, or this is a problem for generic USB audio card class, I don't know. But instead of modifying default.conf directly, it would probably better to add a udev-rule with a custom Pulseaudio mixer profile configured through PULSE_PROFILE_SET, e.g. a udev-rule with .. ENV{PULSE_PROFILE_SET}="xmod.conf" or similar.

dilnix (dilnix) wrote :

In default.conf I found existing "[Mapping analog-stereo]"... But in it's string "device-strings" was only "front:%f hw:%f" for internal audio card... so I put "surround41:%f" to end of this string so that this mapping now looks so:
--------------
[Mapping analog-stereo]
device-strings = front:%f hw:%f surround41:%f
channel-map = left,right
paths-output = analog-output analog-output-headphones analog-output-mono analog-output-lfe-on-mono
paths-input = analog-input analog-input-mic analog-input-linein analog-input-aux analog-input-video analog-input-tvtuner analog-input-fm analog-input-mic-line
priority = 10
--------------
& after saving that I just restarted my PulseAudio with command "pulseaudio -k && pulseauido -D"...
as result now I have "Analog Stereo Output" profile for my Creative X-mod in PulseAudio Volume Control and have clear sound without any scratchy/thin. Shorter, no more dirty sound forever in stereo playing =)

My system is Fedora 12 (but I don't think that is problem for others)

PS: I'm sorry for my russian jargon =)

Termo (termopeten) wrote :

I did as suggested of both dilnix and Øyvind - and the sound works with out any of the miss sounds as I had earlier - BUT!

The volume knob, the gnome volume control and the volume in the sound preferences all control the left of the two speaker outputs I have in alsamixer.

1. Why are there 2 "Speaker" outputs in alsamixer?

2. Why does the left Speaker channel in alsamixer have no affect at all - BUT mute the channel and sound mutes?!?

3. right Speaker channel controls both sound and mutes perfect, but I can not control that one from gnome??

I tried change the front-left/right in Øyvind's mod to rear-left/right... but no change in how I control or how the alsamixer channels work on my sound.

Benjamin Vedder (vedder87) wrote :

I can confirm the exact same behaviour Termo described. There are two speaker outputs for creative xmod in alsamixer, and pulse is controlling the wrong one. I have also added

; Special stereo-out for Creative Xmod card
[Mapping xmod-stereo-out]
device-strings = surround51:%f
description = Analog Stereo Creative Xmod
channel-map = front-left,front-right
paths-output = analog-output
direction = output
priority = 10

to /usr/share/pulseaudio/alsa-mixer/profile-sets/default.conf as Øyvind suggested, and that fixed the crackly sound issues.

Also, i can confirm the bug described by the reporter. It is like this:

If my computer is already running and i plug in the xmod for the first time, there is only analog stereo input available in the mixer, any output cannot be selected from the profile menu. To fix this i have to use "pulseaudio -k" and "pulseaudio -D" which makes the other profiles appear. If i boot the computer with my xmod plugged in all profiles are available from the beginning and it is possible to get sound output, however, i had to use the fix mentioned above in order to a stereo profile with get clear sound.

taiebot65 (taiebot65) on 2010-01-24
Changed in pulseaudio (Ubuntu):
status: New → Confirmed
Laurent Raufaste (analogue) wrote :

I tested my Xmod under lucid beta1 and I encounter the same problem: stereo input detected but no output detected

taiebot65 (taiebot65) on 2010-03-22
tags: added: lucid
Termo (termopeten) wrote :

I have updated my alsamixer and pulseaudio with the Ubuntu Audio Dev team PPA, currently I have:

pulseaudio 0.9.21-32-g8478
AlsaMixer v1.0.20

Now the volume knob works (weirdly enough there is now no volume in alsamixer that is controlled by the knob, and only one output volume [Speaker] ?!?)

The problem with not recognizing Xmod when plugged in after the system is running still exist.

Øyvind Stegard (oyvinst) wrote :

Confirming problem is still there in Ubuntu 10.04. Work-around for getting a normal stereo output mixer profile still applies.

Laurent Raufaste (analogue) wrote :

In a stock 10.04 install, I have this:

 1 [Xmod ]: USB-Audio - Creative Xmod
                      Creative Technology Ltd Creative Xmod at usb-0000:00:0b.0-6, full speed

And it works out of the box.

Fixed for me.

Toutanc (toutanc) wrote :

I did a fresh install of 10.04 and can confirm that the knob works fine. The sound is no longer cracking but is lower than normal. Theanalog stereo output is still not available unless we use the workaround provided by dilnix. With that, the output profile is available and the volume is much better.

Toutanc (toutanc) wrote :

This bug is still present in Maverick with metallic sound and low volume. The afore-mentionned fix still works.

Øyvind Stegard (oyvinst) wrote :

Same problem on Maverick ..

Øyvind Stegard (oyvinst) wrote :

I guess for this bug to go anywhere, it needs to be reported upstream to either Pulseaudio or ALSA project. My guess is that Pulseaudio is at fault here, or, put in other words, lacks support for proper channel mapping for the Creative Xmod USB audio card. I'll see about getting it reported upstream.

taiebot65 (taiebot65) wrote :

maverick tags added.

Thank you for the updates on this bug. Could we not create a patch and send it to the ubuntu-sound team?

description: updated
tags: added: maverick
Øyvind Stegard (oyvinst) wrote :

This bug might be related to another bug which has been fixed:

“Highpitched rattling like sound with 5.1 surround configuration”
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/445849

The fix has also been backported to Lucid.

Dmitry Kann (yktooo) wrote :

I confirm this one. Interestingly, for me the bug only appeared in 13.04 Raring, before that the system recognised my Xmod fine.
The proposed workaround worked out perfectly.

taiebot65 (taiebot65) wrote :

Raring tag added. Thanks for the update.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers