since introduction of module-udev-detect: volumes not restored, everything muted

Bug #409723 reported by Martin-Éric Racine on 2009-08-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Low
Luke Yelavich

Bug Description

Binary package hint: pulseaudio

Since the introduction of PA 0.9.16~test into Karmic, volumes do not get restored at daemon start.

Instead, most of the channels have the volume at zero and the MUTE button on mute, while the MASTER volume control is at full but muted as well.

Fixing this requires manually re-adjusting each volume control and un-muting each channel, every time the daemon restarts. On audio hardware with many features, going through all channels manually like this can take several minutes.

ProblemType: Bug
Architecture: i386
Date: Thu Aug 6 10:14:07 2009
DistroRelease: Ubuntu 9.10
Package: pulseaudio 1:0.9.16~test4-0ubuntu1
ProcEnviron:
 LANGUAGE=fi_FI:fi:en_GB:en
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-14.47-generic
SourcePackage: pulseaudio
Uname: Linux 2.6.28-14-generic i586

Martin-Éric Racine (q-funk) wrote :
Martin-Éric Racine (q-funk) wrote :

I forgot to mention, this happened when Karmic went from 1:0.9.15-4ubuntu3 to 1:0.9.16~test4-0ubuntu1, last evening.

Mingming Ren (portis25) on 2009-08-06
Changed in pulseaudio (Ubuntu):
status: New → Confirmed
Rocko (rockorequin) wrote :

I can confirm part of this behaviour: my headphone channel is always muted when I reboot Karmic (and since it's chained to the PCM, I get no output from the speakers or headphones).

But I think the volume levels are usually maintained between reboots. totem does always reduce volume (sometimes to zero) at start and end of playback, though, which sometimes makes it appear that the volume has been reset.

My PC has a Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02) chip.

Is this behaviour reproducible in the version of pulseaudio in the
~ubuntu-audio-dev PPA?

On Aug 15, 2009 12:10 AM, "Rocko" <email address hidden> wrote:

I can confirm part of this behaviour: my headphone channel is always
muted when I reboot Karmic (and since it's chained to the PCM, I get no
output from the speakers or headphones).

But I think the volume levels are usually maintained between reboots.
totem does always reduce volume (sometimes to zero) at start and end of
playback, though, which sometimes makes it appear that the volume has
been reset.

My PC has a Intel Corporation 82801H (ICH8 Family) HD Audio Controller
(rev 02) chip.

-- since introduction of module-udev-detect: volumes not restored,
everything muted https://bugs.l...

Rocko (rockorequin) wrote :

I just rebooted into Karmic and the volumes were NOT muted this time. It's now running pulseaudio 1:0.9.16~test4-0ubuntu6.

Martin-Éric Racine (q-funk) wrote :

Also using 1:0.9.16~test4-0ubuntu6 and this is not fixed for me.

Martin-Éric Racine (q-funk) wrote :

1:0.9.16~test4-0ubuntu7~ppa3 restores a few more controls, but not all. Still no sound at reboot.

Martin-Éric Racine (q-funk) wrote :

Please note that this is still not fixed.

Just wondering: why is pulseaudio trying to reinvent the wheel, rather than letting alsa-utils restore the volume for us?

On Tue, Sep 01, 2009 at 01:46:16PM EST, Martin-Éric Racine wrote:
> Please note that this is still not fixed.
>
> Just wondering: why is pulseaudio trying to reinvent the wheel, rather
> than letting alsa-utils restore the volume for us?

I must admit I don't know, probably to offer users a seemless way to control volume without being confused by the many options available from other appets etc.

Have you tried the latest ubuntu-audio-dev PPA packages?

On Tue, Sep 1, 2009 at 7:45 AM, Luke Yelavich wrote:
> On Tue, Sep 01, 2009 at 01:46:16PM EST, Martin-Éric Racine wrote:
>> Please note that this is still not fixed.
>>
>> Just wondering:  why is pulseaudio trying to reinvent the wheel, rather
>> than letting alsa-utils restore the volume for us?
>
> I must admit I don't know, probably to offer users a seemless way to
> control volume without being confused by the many options available from
> other appets etc.
>
> Have you tried the latest ubuntu-audio-dev PPA packages?

Yes, I have. It's even worse than what's currently in Karmic.

Daniel T Chen (crimsun) wrote :

2009/9/1 Martin-Éric Racine <email address hidden>:
> Yes, I have. It's even worse than what's currently in Karmic.

The crashers are known and being investigated.

Martin-Éric Racine (q-funk) wrote :

Actually, 0.9.17 is somewhat usable, except that it insists upon launching sessions with the Master Volume set on Mute and its slider position at a ridiculously low level.

Changed in pulseaudio (Ubuntu):
importance: Undecided → Low
assignee: nobody → Luke Yelavich (themuso)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers