Audio hangs in ugly loop for 1 sec at S3 suspend

Bug #404986 reported by Janne Hyötylä on 2009-07-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: pulseaudio

When suspending to RAM, and at the same time playing any audio file (e.g. music in Rhythmbox), the audio will hang in an ugly-sounding loop for ~ 1 sec before shutting off.

If this cannot be fixed in pulseaudio or similar itself, maybe mute the sound when suspending and unmute at resume?

ProblemType: Bug
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/dsp', '/dev/snd/pcmC0D0c', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/pcmC0D1p', '/dev/snd/pcmC0D0p', '/dev/snd/seq', '/dev/snd/timer', '/dev/sequencer2', '/dev/sequencer'] failed with exit code 1:
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe9fc000 irq 21'
   Mixer name : 'SigmaTel STAC9205'
   Components : 'HDA:838476a0,102801f9,00100204 HDA:14f12c06,14f1000f,00100000'
   Controls : 25
   Simple ctrls : 16
Date: Sun Jul 26 18:44:34 2009
DistroRelease: Ubuntu 9.10
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Alpha i386 (20090726)
Package: pulseaudio 1:0.9.15-4ubuntu2
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-3.19-generic
SourcePackage: pulseaudio
Uname: Linux 2.6.31-3-generic i686

Janne Hyötylä (janne-hyotyla) wrote :
Daniel T Chen (crimsun) on 2009-07-26
Changed in pulseaudio (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Daniel T Chen (crimsun) on 2009-07-27
Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Committed
Janne Hyötylä (janne-hyotyla) wrote :

Thanks, that was fast.

I looked quickly at the code and have one question:
Could there be a problem with a device being unmuted on resume which the user has muted earlier on purpose?

Daniel T Chen (crimsun) wrote :

Yes, there's that potential. Maintaining state across suspends/resumes for sinks (i.e., conditional unmute upon resume) seems ugly, however...

Changed in pulseaudio (Ubuntu):
status: Fix Committed → In Progress
Janne Hyötylä (janne-hyotyla) wrote :

Is there any kind of "global" mute switch which would leave the states of individual sinks alone?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.15-4ubuntu3

---------------
pulseaudio (1:0.9.15-4ubuntu3) karmic; urgency=low

  * debian/01PulseAudio: Mute sinks and sources prior to
    suspend; unmute sinks and sources after resume (LP: #404986)
  * debian/patches/series: Reenable glitch-free.

 -- Daniel T Chen <email address hidden> Mon, 27 Jul 2009 22:06:34 -0400

Changed in pulseaudio (Ubuntu):
status: In Progress → Fix Released
Daniel T Chen (crimsun) wrote :

Reopening due to changes made to fix bug 483900

Changed in pulseaudio (Ubuntu):
status: Fix Released → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.21-0ubuntu1

---------------
pulseaudio (1:0.9.21-0ubuntu1) lucid; urgency=low

  [ Daniel T Chen ]
  * New upstream bugfix release
  * debian/control: pulseaudio-module-raop must Depends
    pulseaudio-module-zeroconf (LP: #484870). Thanks, Dominic Evans!
  * Bump for 0.9.21:
    + debian/libpulse0.shlibs
    + debian/pulseaudio.shlibs
    + debian/rules
  * debian/pulseaudio.install:
    debian/copyright: Amend for addition of:
    + module-device-manager.so
  * debian/README.Debian: Update for Ubuntu 9.04+.
  * 0002-Fix-makefiles-to-include-all-alsa-path-files-on-inst.patch:
    Drop, fixed upstream.
  * 0051-fix-sigfpe-mcalign.patch: Drop, needs fixing in alsa-kernel
    and alsa-lib.

  [ Chow Loong Jin ]
  * debian/01PulseAudio: Add/modify functions to (re)store sink/source
    state for (resume/)suspend (LP: #404986, #483900)

  [ Luke Yelavich ]
  * Remove wrapper scripts and accessibility special case, to help with the
    desktop startup time. The accessibility case should be solved in
    speech-dispatcher by the time lucid ships.
    - debian/patches/0006-a11y-special-case-disable.patch: Removed
    - debian/70pulseaudio: Removed
    - debian/pulse-session: Removed
    - debian/pulseaudio.install: Re-add the xdg autostart desktop file
    - debian/pulseaudio.preinst: Instead of removing the xdg autostart desktop
      file on upgrade, remove the 70pulseaudio X Session script on upgrade
 -- Daniel T Chen <email address hidden> Wed, 25 Nov 2009 16:34:54 -0500

Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers