Ubuntu

Muting at shutdown causes sound at next boot to dissapear

Reported by David Stansby on 2009-06-05
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
pulseaudio (Debian)
Fix Released
Undecided
Unassigned
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

Steps to reproduce:

1. Mute system volume
2. Restart
3. Login
4. Try and play sound

What happens:
Sound won't play, from whatever source. Trying to raise the volume using the volume applet doesn't work either

What should happen:
Sound should play

Workaround:
Run 'sudo killall pulseaudio' to restart pulseaudio and this problem disappears

ProblemType: Bug
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: david 4086 f.... mixer_applet2
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfdff8000 irq 16'
   Mixer name : 'Realtek ALC888'
   Components : 'HDA:10ec0888,103c2a50,00100001'
   Controls : 40
   Simple ctrls : 22
Date: Fri Jun 5 18:28:43 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: pulseaudio 1:0.9.15-2ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-8.9-generic
SourcePackage: pulseaudio
Uname: Linux 2.6.30-8-generic i686

David Stansby (dstansby) wrote :
Conn O Griofa (psyke83) wrote :

I can confirm this issue as well. Muting and unmuting the PulseAudio Master mixer can also restore sound as well.

This appears to be the problem (and it's fixed upstream): https://tango.0pointer.de/pipermail/pulseaudio-discuss/2009-June/004129.html

David Stansby (dstansby) on 2009-06-08
Changed in pulseaudio (Ubuntu):
status: New → Fix Committed
Changed in pulseaudio (Debian):
status: Unknown → New
David Stansby (dstansby) wrote :

Setting to fix released because I don't have this problem any more.

Changed in pulseaudio (Ubuntu):
status: Fix Committed → Fix Released
David Stansby (dstansby) on 2009-07-21
Changed in pulseaudio (Debian):
importance: Unknown → Undecided
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.