skype stops recording/playing sound after a few seconds

Bug #348979 reported by hmw93 on 2009-03-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: pulseaudio

Maybe this is interesting to you: Sound prolems were much worse under Intrepid; I couldnt watch a movie or listen to music:
When using the mouse while playing a video, especially, when (as I _guess_) some mouseover stuff happened (like pointing onto or moving over the system monitor panel applet), the sound stopped. Often within 0.5 seconds, sometimes only after 3 seconds or so.
It stopped without moving the mouse, too, but in many cases, i could listen for some minutes before the error occured. I saw some "POLLERR" in the logs. In many situations, restarting the app helped getting sound again, sometimes i needed to restart X. Rotating the compiz cube with the mouse via the key bound to "Initiate" in Rotate Cube seemed NOT to have had the same bad effects to the sound, as moving the mouse over the screen normally.

Ubuntu 9.04 (the os, with which I created the report): Video playback works fine, also playing 2 vids and/or music at the same time works good. The problem seems to happen with Skype only now: When selecting pulse audio in Skype, i get it basically working, but I hear stuttering sound and my call partner only gets scrambled sounds or noise. When selecting ALSA i have good sound for a few seconds. In the last case, my call partner stopped hearing the noise completely after roughtly 10 seconds, and sound playback stopped for me another 10 seconds or so later, too.

I am currently testing recording sound with the "Sound Recorder" appliction, while simultaneously playing 2 videos. So far, it seems to work properly, 3 minutes recorded successfully.

Skype version: 2.0.0.72-1_i386 (should be the most current version.) installed from the .deb file downloaded from skype's web site several weeks ago.

As advised by someone in #ubuntu+1, I installed the kernel from http://kernel.ubuntu.com/~dtchen/ but it didn't make any difference.

As this is my first bug report, I want to apologize, if I left out anything important. Hopefully apport did include all you want to know.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: pulseaudio 0.9.14-0ubuntu14
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
SourcePackage: pulseaudio
Uname: Linux 2.6.28-11-generic i686

hmw93 (harald-wirth) wrote :
hmw93 (harald-wirth) wrote :

As I don't see my hardware listed anywhere, and I suspect you would like to know, what sound card I use, I provide the following:

hmw@cursor:~ $ lspci
00:00.0 Host bridge: ATI Technologies Inc Radeon 9100 IGP Host Bridge (rev 02)
00:01.0 PCI bridge: ATI Technologies Inc Radeon 9100 IGP AGP Bridge
00:13.0 USB Controller: ATI Technologies Inc OHCI USB Controller #1 (rev 01)
00:13.1 USB Controller: ATI Technologies Inc OHCI USB Controller #2 (rev 01)
00:13.2 USB Controller: ATI Technologies Inc EHCI USB Controller (rev 01)
00:14.0 SMBus: ATI Technologies Inc SMBus (rev 18)
00:14.1 IDE interface: ATI Technologies Inc Dual Channel Bus Master PCI IDE Controller
00:14.3 ISA bridge: ATI Technologies Inc Device 434c
00:14.4 PCI bridge: ATI Technologies Inc IXP200 3COM 3C920B Ethernet Controller
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97 Audio Controller
00:14.6 Modem: ATI Technologies Inc IXP AC'97 Modem (rev 01)
01:05.0 VGA compatible controller: ATI Technologies Inc RS300M AGP [Radeon Mobility 9100IGP]
02:04.0 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus Controller (rev 01)
02:04.1 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus Controller (rev 01)
02:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

hmw93 (harald-wirth) wrote :

Even more info:

hmw@cursor:~ $ apt-cache policy alsa-utils
alsa-utils:
  Installed: 1.0.18-1ubuntu10
  Candidate: 1.0.18-1ubuntu10
  Version table:
 *** 1.0.18-1ubuntu10 0
        500 http://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

hmw@cursor:~ $ apt-cache policy pulseaudio
pulseaudio:
  Installed: 0.9.14-0ubuntu14
  Candidate: 0.9.14-0ubuntu14
  Version table:
 *** 0.9.14-0ubuntu14 0
        500 http://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

and

http://www.alsa-project.org/db/?f=1f8c0c39aea462f6f542895fb4c2bcec281d8bcd

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release the Karmic Koala. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
sqlpython (sqlpython) wrote :

I have a new 9.04 amd64 install kernel 2.6.28-11-generic
Running the static Skype kype_static-2.1.0.47
I see this has been a problem since Jan 09 tracing back many internet posts......
Seems neither Ubuntu nor Skype is addressing the issue ..or at least has not fixed it in 11 months..Yikes.
I have a plugin camera
Bus 001 Device 002: ID 046d:09c1 Logitech, Inc. QuickCam Deluxe for Notebooks
and the only way I could get this to work is with an assignment like such to run skype
PULSE_SERVER=192.167.4.105 /home/sqlpython/skype/skype
.........
 The only problem would be is that with my roving laptop I would have to continually modify the ip address depending on WiFi hookup or Cat etho direct connect...
So I wrote a Bash to identify the IPaddress and run the Skype command based on the existing connection and inserting correct IPaddress as a variable..........
 Here is the Script but it does Not fix the Fact the I can not Play back any sound While Skype is connected VOIP to any other Person....
Please Fix it!!!!!
  This does not happen in my 8.04 install I get Sound Play Back with 8.04 while Skype Connected.

..

#!/bin/bash

ifconfig wlan0 | grep "inet addr" | cut -d: -f2 | cut -d" " -f1 $1
ifconfig eth0 | grep "inet addr" | cut -d: -f2 | cut -d" " -f1 $2
if [ $1 -gt $2 ]
  then
echo $1
PULSE_SERVER=$1 /home/sqlpython/skype/skype
fi
if [ $2 -gt $1 ]
  then
echo $2
PULSE_SERVER=$2 /home/sqlpython/skype/skype
fi

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers