pulseaudio doesn't care about default device

Bug #346753 reported by LCID Fire on 2009-03-22
2
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: pulseaudio

I have 3 sound devices on my laptop running Ubuntu Studio Jaunty.
/proc/asound/pcm:
00-00: Intel ICH : Intel 82801DB-ICH4 : playback 1 : capture 1
00-01: Intel ICH - MIC ADC : Intel 82801DB-ICH4 - MIC ADC : capture 1
00-02: Intel ICH - MIC2 ADC : Intel 82801DB-ICH4 - MIC2 ADC : capture 1
00-03: Intel ICH - ADC2 : Intel 82801DB-ICH4 - ADC2 : capture 1
00-04: Intel ICH - IEC958 : Intel 82801DB-ICH4 - IEC958 : playback 1
01-00: USB Audio : USB Audio : playback 1 : capture 1
01-01: USB Audio : USB Audio #1 : playback 1 : capture 1
01-02: USB Audio : USB Audio #2 : capture 1
02-00: Intel ICH - Modem : Intel 82801DB-ICH4 Modem - Modem : playback 1 : capture 1

In alsa and in the gnome preferences I have the second (USB) device set as the default but pulseaudio just outputs to the first device and I haven't seen any dialog to change the pulseaudio default device. Nevertheless it should use either the alsa or gnome default.

Changed in pulseaudio (Ubuntu):
status: New → Confirmed
Daniel T Chen (crimsun) wrote :

This is being addressed in gnome-media for the next GNOME release. In the meanwhile, you should use pavucontrol.

Changed in pulseaudio (Ubuntu):
importance: Undecided → Wishlist
LCID Fire (lcid-fire) wrote :

What's the procedure to change the default pulseaudio output?
Using pavucontrol I changed the default to the usb card and it still outputs via the onboard one.
Then I did "killall pulseaudio" and restarted pulseaudio and it still outputs via the onboard one *angry sigh*.

David Henningsson (diwic) wrote :

I'm not really sure what the officially recommended procedure is, but here's what works for me (Intrepid):

For pulseaudio; edit /etc/pulse/default.pa and add a line
set-default-sink nameofyoursoundcard
(where nameofyoursoundcard is something like "alsa_output.pci_1412_1724_sound_card_0_alsa_playback_0", you can find it if you use the command "pactl list").

After you have done that, delete the files under ~/.pulse , then logout and login again.

Mark Falcey (mfalcey) wrote :

All you need to do is move the streams to the correct sink the next time you start them. Pulseaudio defaults to the first device and directs applications to that as they are opened. It also remembers which device and the volume settings for each application for the next time the application is used which overrides the default setting. So, if you have an application playing in the wrong device you must move it the next time it plays so pulse will remember. You can change the default device in pavucontrol but that will only affect new applications.

There is intermittent discussion about changing this behavior at the pulseaudio mailing list and patches have been proposed but Lennart seems a little resistant though he admits that "default" is not really default.

Daniel T Chen (crimsun) wrote :

Is this still reproducible in a current daily-live of Lucid?

Changed in pulseaudio (Ubuntu):
status: Confirmed → Incomplete
LCID Fire (lcid-fire) wrote :

It's fixed in Lucid :)

Changed in pulseaudio (Ubuntu):
status: Incomplete → Fix Released

Somehow this is still an issue in Ubuntu 19.10

Oops, sorry, wrong thread, I actually meant another bug (1631161)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers