Ubuntu

static noise, no audio in pulseaudio 0.9.14-0ubuntu11

Reported by Richard Jonsson on 2009-03-10
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: pulseaudio

After upgrading jaunty today, pulse (0.9.14-0ubuntu11) broke for me.
When watching a video with mplayer it usually works ok at first, but pausing and resuming sometimes trigger this bug. Rhythmbox has this same problem too. I can not reliably trigger the bug.
When the bug triggers, pulseaudio process consumes >60% cpu and fastforwards playback, while outputting a static noise. (Think analog television badly out of tune). I've had to kill the process to recover.
I have not seen this with previous versions, and I update 3-5 times per week and use sound every day.

Daniel T Chen (crimsun) wrote :

Are you using modified /etc/pulse/* ?

Changed in pulseaudio:
status: New → Incomplete

No, I have previously experimented with resampling-method, but that setting got restored with the latest update. I should mention now that after killing the pulse process I have not triggered the bug again.

Ok, I just got this again. Starting a flash video clip in firefox:
pulse process at 60% and also noticed that syslogd process was at a constant 39%. Then checked /var/log/syslog and it's hammered with messages like these:

Mar 10 17:08:07 richie-laptop pulseaudio[4564]: alsa-util.c: snd_pcm_avail_update() returned a value that is exceptionally large: 16140901064420282444 bytes (384306774581 ms) Most likely this is a Linux bug. Please report this issue to the ALSA developers.
Mar 10 17:08:07 richie-laptop pulseaudio[4564]: alsa-util.c: snd_pcm_avail_update() returned a value that is exceptionally large: 16140901064420267084 bytes (384306774501 ms) Most likely this is a Linux bug. Please report this issue to the ALSA developers.
Mar 10 17:08:07 richie-laptop pulseaudio[4564]: alsa-util.c: snd_pcm_avail_update() returned a value that is exceptionally large: 16140901064420251724 bytes (384306774421 ms) Most likely this is a Linux bug. Please report this issue to the ALSA developers.

I had watched a few clips before this occured. When killing the pulse process firefox sprung away to 100%, but for that I blame abobe flash.

To add to my last comment, I had previously set resample-method to ffmpeg, and it now is at the default src-linear, which is a setting I had briefly tested before.

Test case 1:
1. Watch clip on youtube
2. repeat step 1, about 30% of the time it will err, and pulseaudio process needs to be killed. Firefox will be fine if you manage to close the youtube tab.

Test case 2:
1. Watch video with mplayer cli
2. Pause mplayer for a minute or so.
3. Possibly there needs to be notification sounds playing here.
4. Resume mplayer, just about every time when waiting a few moments pulse will err and needs to be killed, mplayer will also need to be killed when this happens.

This bug is ultra-annoying, if I can help in other ways just tell me what to do!

I notice the bug is marked as "incomplete", what piece is missing?

Changed in pulseaudio:
status: Incomplete → New
unggnu (unggnu) wrote :

I can confirm this but only for Rhythmbox so far. In most cases it happens after first start of the music player. It doesn't help to change the song, the noise stays. After closing Rhythmbox, running vlc shortly and then restart it music always works fine.

unggnu (unggnu) wrote :

Btw. freshly installed, up to date Jaunty. No changes to configuration which might be relevant to this issue. No problem with Intrepid.

Martin Vysny (vyzivus) wrote :

Exactly the same here. Only Rhythmbox does this so far. Closing and restarting Rhythmbox several times fixes the problem.

I simply purged pulseaudio and the problem went away, software sound mixing still works. No more a/v sync problems with video either. My biased opinion is that my laptop runs cooler too, but can't confirm. YMMV.

The command I used was "sudo apt-get purge pulseaudio".

Note that this doesn't fix the bug, only that the faulting app is removed.

unggnu (unggnu) wrote :

Is it possible that this is fixed? I hadn't had the problem for quite some time and it appears regularly before

unggnu (unggnu) wrote :

This seems to be fixed in current Jaunty so marking as such. Feel free to reopen if it still happens with Jaunty final release.

Changed in pulseaudio (Ubuntu):
status: New → Fix Released
Alberto Bertogli (albertito) wrote :

This has been happening to me since upgrading to 9.04 from 8.10.

I reproduce it the following way:

1. start pulseaudio (after making sure it's not running)
2. mplayer something
3. pause for about 30 seconds (does NOT seem to reproduce if the pause is shorter)
4. resume playing, it breaks as described below
5. (only sometimes) mplayer something again, fails the same way
6. mplayer something again, it works but the line counting how far it goes
    gets frozen, and if it's a video, there is no video output
7. goto step 2 (you can reproduce it again)

At any moment you can kill pulseaudio and it go back to step 1.

When it breaks in step 4, I hear only static and it plays too fast, as if it was
skipping samples, and then pulseaudio uses 100% CPU for about 10 seconds,
then goes back to the usual ~0%. There is no output when this happens.

When I start pulseaudio, I see the following:

$ pulseaudio
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
W: alsa-util.c: Device hw:1 doesn't support 44100 Hz, changed to 48000 Hz.
W: alsa-util.c: Cannot find fallback mixer control "Mic" or mixer control is no combination of switch/volume.

There is no output beyond that in all of my tests, and there is nothing related
in the kernel logs.

My sound card is an on-board Intel, lspci says:
  Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

My motherboard is an Intel DG36EC. I'm using a 2.6.29.1 (unpatched) kernel.

I'm up to date with packages, the currently installed pulseaudio version is
0.9.14-0ubuntu20.

If you need anything else, please let me know.

Thanks a lot,
    Alberto

Changed in pulseaudio (Ubuntu):
status: Fix Released → New
Johan Sköld (johan-skold) wrote :

Affects me too. Sometimes when I start playback in Muine, sometimes in SMPlayer, sometimes when attempting to watch flash, and even sometimes when I start my computer it's already bugged. Note that it only seems to happen when starting playback, never if playback already has started.

I cannot seem to replicate it, not even by any way already reported, and dmesg says nothing. I do however have the exact same symptoms. I'm using the mainline 2.6.29 kernel due to bug #346691.

$ uname -a
Linux stormen 2.6.29-020629-generic #020629 SMP Tue Mar 24 11:23:53 UTC 2009 x86_64 GNU/Linux

$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

$ dpkg -s pulseaudio | grep Version
Version: 1:0.9.14-0ubuntu20.2

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release the Karmic Koala. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in pulseaudio (Ubuntu):
status: Incomplete → Invalid
Ray Perry (urththeprophet) wrote :

I can trigger the error 90% of the time.

There are two MP3's on my computer: "Tunnels.mp3" and "IWant....mp3".
Both of these files when played, will do one of two things:

1) It will immediately start playing a static noise instead of the song.
2) It will play correctly, but if you try to change the song or pause the song, it will CONTINUE playing and then the static noise will start.

I can attach these files if necessary.

And I am running Ubuntu 10.10 on a HP Pavilion dv4-2164US.

Changed in pulseaudio (Ubuntu):
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers