pulseaudio: snd_pcm_avail_update() returned a value that is exceptionally large

Bug #323976 reported by Anand Kumria on 2009-02-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

Jan 26 08:02:37 eve pulseaudio[24162]: alsa-util.c: snd_pcm_avail_update() returned a value that is exceptionally large: 205324 bytes (1163 ms) Most likely this is an ALSA driver bug. Please report this issue to the PulseAudio developers.

This is possibly:

http://www.pulseaudio.org/ticket/396

or:

https://bugzilla.redhat.com/show_bug.cgi?id=462200

anand@eve[~]% lspci
00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
00:00.1 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
00:00.3 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 03)
02:01.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
02:04.0 CardBus bridge: Texas Instruments PCI7420 CardBus Controller
02:04.1 CardBus bridge: Texas Instruments PCI7420 CardBus Controller
02:04.2 FireWire (IEEE 1394): Texas Instruments PCI7x20 1394a-2000 OHCI Two-Port PHY/Link-Layer Controller
02:04.3 Mass storage controller: Texas Instruments PCI7420/7620 Combo CardBus, 1394a-2000 OHCI and SD/MS-Pro Controller
02:05.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
anand@eve[~]% lsmod | grep snd
snd_atiixp_modem 20360 0
snd_via82xx_modem 19336 0
snd_intel8x0m 22028 5
snd_intel8x0 37532 3
snd_ac97_codec 112292 4 snd_atiixp_modem,snd_via82xx_modem,snd_intel8x0m,snd_intel8x0
ac97_bus 9856 1 snd_ac97_codec
snd_pcm 82820 7 snd_atiixp_modem,snd_via82xx_modem,snd_intel8x0m,snd_intel8x0,snd_ac97_codec
snd_seq 56880 0
snd_timer 29704 2 snd_pcm,snd_seq
snd_seq_device 14988 1 snd_seq
snd 62628 23 snd_atiixp_modem,snd_via82xx_modem,snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_seq,snd_timer,snd_seq_device
soundcore 15200 1 snd
snd_page_alloc 16904 5 snd_atiixp_modem,snd_via82xx_modem,snd_intel8x0m,snd_intel8x0,snd_pcm
anand@eve[~]%

However I have the latest version of pulseaudio, which includes:

http://git.0pointer.de/?p=pulseaudio.git;a=commitdiff;h=b712e7b13dd6aed3e56eaee423ff071d6f0ce2c2

So this kind of error should not really be occuring from my brief glance at things.

Thanks,
Anand

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: pulseaudio 0.9.14-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=C
 SHELL=/usr/bin/zsh
SourcePackage: pulseaudio
Uname: Linux 2.6.28-6-generic i686

Anand Kumria (wildfire) wrote :
Daniel T Chen (crimsun) wrote :

Worked around by falling back to interrupt-based buffer semantics

Changed in pulseaudio:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 0.9.14-0ubuntu6

---------------
pulseaudio (0.9.14-0ubuntu6) jaunty; urgency=low

  * 0004_disable_autospawn.patch: Disable this patch. Doing so
    allows the daemon to spawn if not already running, which
    works around LP: #191027, #204272
  * 0012_clarify_driver_error_redirect_to_alsa_devs.patch:
    - Only log POLL* being set if tsched is used so that syslog
      isn't filled with innocuous messages when we set tsched=0
      (see 0030 below) (LP: #323712),
    - Hint 'linux' source package instead of 'alsa-driver' for
      Launchpad bug reports,
    - The debug-specific portion is only applicable to 0.9.14;
      0.9.15 enables a rate limiting module by default to work
      around this (and other) issues
  * 0029_fix_suspend_on_idle_null_race.patch: Handle sink case,
    too
  * 0030_set_tsched0.patch: Work around a shedload of (driver)
    bugs by falling back to interrupt-based buffer semantics
    (LP: #190754, #292880, #295519, #298494, #301755, #302964,
     LP: #319118, #323976, #324103, #326205, #326864)
  * Backport fixes from git HEAD:
    - 0031_fix_6chan_map.patch,
    - 0032_reinit_proplist.patch,
    - 0033_fix_pa-gcc-packedmalloc.patch,
    - 0034_bt_fixes.patch
  * Make invoking the stop target in the initscript not fail an
    upgrade (LP: #317921)
  * Previous upload (0.9.14-0ubuntu3) fixed LP: #321357
  * 01PulseAudio: use sudo -H to ensure that $HOME is, in fact,
    the user's when invoking pacmd for suspend/resume

 -- Daniel T Chen <email address hidden> Sun, 15 Feb 2009 02:35:26 -0500

Changed in pulseaudio:
status: Fix Committed → Fix Released
Martin Emrich (emme) wrote :

I have pulseaudio 1:0.9.14-0ubuntu20.1 installed, and I still experience PA problems. Whenever there is high CPU load (compiling something, ...), My music stops, I hear only crackling noises and I see these messages:

D: alsa-util.c: snd_pcm_avail_update() returned a value that is exceptionally large: 4611686018037680368 bytes (139430435728 ms) Most likely this is a Linux bug. Please report this issue to the ALSA developers.
D: alsa-util.c: snd_pcm_avail_update() returned a value that is exceptionally large: 4611686018037637360 bytes (139430435646 ms) Most likely this is a Linux bug. Please report this issue to the ALSA developers.

My soundcard:
00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383]
 Subsystem: Giga-byte Technology Device [1458:a022]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 32, Cache Line Size: 4 bytes
 Interrupt: pin ? routed to IRQ 16
 Region 0: Memory at fe024000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

On Fri, May 1, 2009 at 10:54 AM, Martin Emrich <email address hidden> wrote:
> I have pulseaudio 1:0.9.14-0ubuntu20.1  installed, and I still
> experience PA problems. Whenever there is high CPU load (compiling
> something, ...), My music stops, I hear only crackling noises and I see
> these messages:
>
> D: alsa-util.c: snd_pcm_avail_update() returned a value that is exceptionally large: 4611686018037680368 bytes (139430435728 ms) Most likely this is a Linux bug. Please report this issue to the ALSA developers.
> D: alsa-util.c: snd_pcm_avail_update() returned a value that is exceptionally large: 4611686018037637360 bytes (139430435646 ms) Most likely this is a Linux bug. Please report this issue to the ALSA developers.
>
> My soundcard:
> 00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383]
>        Subsystem: Giga-byte Technology Device [1458:a022]

The snd_pcm_avail_update() messages are actually caused by mid-layer
ALSA pcm-lib bugs. Are you also using the kernel from jaunty-proposed
(2.6.28-12.43-generic)?

Also, note that there is a *separate* bug affecting cpu limit
behaviour in pulseaudio.

Martin Emrich (emme) wrote :

No, I have 2.6.28-11.42 installed (jaunty-proposed is enabled, but there is no newer version available).

Could you point me to the specific bug you mean? There are lots of bugs regarding pulseaudio and cpu usage...

Martin Emrich (emme) wrote :

Today, 2.6.28-12.43-generic appeared in jaunty, and I installed it.

This time, it took considerably longer until the music crashed (hours instead of minutes), but finally the crackling noise was back and "pulseaudio -vv" printed tons of these messages again:

D: alsa-util.c: snd_pcm_avail_update() returned a value that is exceptionally large: 4611686018107775812 bytes (139430568183 ms) Most likely this is a Linux bug. Please report this issue to the ALSA developers.
D: alsa-util.c: snd_pcm_avail_update() returned a value that is exceptionally large: 4611686018107732804 bytes (139430568102 ms) Most likely this is a Linux bug. Please report this issue to the ALSA developers.
D: alsa-util.c: snd_pcm_avail_update() returned a value that is exceptionally large: 4611686018107689796 bytes (139430568021 ms) Most likely this is a Linux bug. Please report this issue to the ALSA developers.
D: alsa-util.c: snd_pcm_avail_update() returned a value that is exceptionally large: 4611686018107646788 bytes (139430567939 ms) Most likely this is a Linux bug. Please report this issue to the ALSA developers.

Ciao

Martin

Martin Emrich (emme) wrote :

It still happens frequently, it apparently was only coincidence that it held out for hours after the new kernel was installed.

I also tried with and without "tsched=0", it makes no difference.

Ciao

Martin

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers