[jaunty regression] Pulse Audio finds no card for output

Bug #322374 reported by Paulo Albuquerque on 2009-01-28
170
This bug affects 14 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
High
Luke Yelavich
Nominated for Jaunty by Jeffrey Baker

Bug Description

== WORKAROUND ==
Run "pulseaudio -k ; start-pulseaudio-x11" without the quotes from a terminal (Applications -> Accessories -> Terminal)

Binary package hint: pulseaudio

Description: Ubuntu jaunty (development branch)
Release: 9.04
pulseaudio:
  Installed: 0.9.14-0ubuntu2
  Candidate: 0.9.14-0ubuntu2
  Version table:
 *** 0.9.14-0ubuntu2 0
        500 http://pt.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

I installed Jaunty Alpha 3 64 bit on a test machine a while ago, I've been doing all the updates. With the last update to the HAL and/or PulseAudio sound output was broken. Upon boot and login the system plays a sound as expected, but with a started session there is no sound output. Volume control displays a strange thing, my sound card is detected as an input source, but not as an output.

I have checked with alsamixer and I have no muted channels, and my sound card is correctly detected and configured. Output of "cat /proc/asound/cards" follows:
 0 [CK804 ]: NFORCE - NVidia CK804
                      NVidia CK804 with ALC850 at irq 22

I tried playing playing a sound from the terminal, I get no error but I don't hear anything:
pmfa@sardinha:~$ aplay /usr/share/sounds/alsa/Noise.wav
Playing WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono

Trying the same command from a text console yields the following error:
pmfa@sardinha:~$ aplay /usr/share/sounds/alsa/Noise.wav
Playing WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
ALSA lib pcm_pulse.c:626:(pulse_prepare) PulseAudio: Unable to create stream: Invalid argument

aplay: set_params:1022: Unable to install hw params:
ACCESS: RW_INTERLEAVED
FORMAT: S16_LE
SUBFORMAT: STD
SAMPLE_BITS: 16
FRAME_BITS: 16
CHANNELS: 1
RATE: 48000
PERIOD_TIME: 125000
PERIOD_SIZE: 6000
PERIOD_BYTES: 12000
PERIODS: 4
BUFFER_TIME: 500000
BUFFER_SIZE: 24000
BUFFER_BYTES: 48000
TICK_TIME: [0 0]

Related branches

Niclas Lockner (niclasl) wrote :

Same thing for me. I just installed alpha 3 and downloaded all the updates. Before the update I had sound, but not now.
Sound card: Intel 82801G (ICH7 Family( High Definition Audio Controller (rev 02)
pulseaudio: 0.9.14-0ubuntu2

Changed in pulseaudio:
status: New → Confirmed

I have attached the output of "pactl list" and "pactl stat".

Niclas Lockner (niclasl) wrote :

For those who really want sound I have found a way to get it working (until you log out).
Log in, and then start a guest session. Go to System->Settings>Sound and check if there exist an output device.
Then log out from the guest session and back into your user. You should now have the device under output.
For me, the device was unselected. If it is, just select it and you should have audio.

Confirming, its a race condition yet again between the playing of the login sound and the starting of pulseaudio.

 affects ubuntu/pulseaudio
 status confirmed
 assignee themuso

Changed in pulseaudio:
assignee: nobody → themuso
Luke Yelavich (themuso) wrote :

Another way to work around it is to load a terminal, run pulseaudio -k, then run start-pulseaudio-x11.

The same issue. Another workaround: killall pulseaudio; pulseaudio

marmuta (marmuta) wrote :

Confirming the race condition. With login sounds I'm getting

pulseaudio[4938]: alsa-util.c: Error opening PCM device autovol: Device or resource busy

and pa fails to start with the session.

Setting the sound theme to 'No Sound' stops the login sound from playing and pulseaudio starts normally.

Jeffrey Baker (jwbaker) wrote :

Another workaround would be to remove pulseaudio from the distribution ...

Confirmed yet again on Intel HDA with SiI1392 codec. Jaunty/x86-64

Gina (ginalinux) wrote :

I also confirm that setting sound theme to NoSound stops the sound immediately after login and enables sound in applications.

André Gondim (andregondim) wrote :

$ pulseaudio -k ; start-pulseaudio-x11

This is a workaround...

the work around doesnt seem to be working for me.
any debug i can provide ?

Kai Mast (kai-mast) wrote :

Yeah i can confirm this bug and the workaround

habtool (clive-wagenaar) wrote :

I can also confirm this bug and the workaround

Romeo A. Cioaba (romeo-cioaba) wrote :

I can also confirm this bug and the workaround.

jerrylamos (jerrylamos) wrote :

sudo killall pulseaudio works great.
I also removed pulseaudio from System Preferences Sessions and
added ausdio settings management to System Administration Sessions.

I'll try pulseaudio from time to time.

Jerry

Noel J. Bergman (noeljb) wrote :

Workaround does not work for me. No audio at all with Jaunty since the mid-week updates.

Noel J. Bergman (noeljb) wrote :

And I do have Intel HDA listed as the output device, so it probably isn't this bug but a related one.

Noel J. Bergman (noeljb) wrote :

OK, for me it was Bug 315971.

Hope this can help.
I updated the alsa-base and my sound stopped working on my laptop again, pasting a solution I tried from Suse and wrote in a forum about a week ago:
----------------------------------
"I've bought a Compaq Presario CQ45 102TU, and I installed Kubuntu 9.04 Jaunty Alpha 2 on it. I had no sound and the speaker button was red. The fix that people had for Intrepid
adding "options snd-hda-intel enable_msi=1"
at the end didn't work here, because it seems like the Ubuntu team already added it... I looked around and found an undocumented solution on a suse forum.
In the: "/etc/modprobe.d/alsa-base"
I added: "options snd-hda-intel model=hp-m4"
before "options snd-hda-intel enable_msi=1", and now everything works.
As they said on that forum, that "hp-m4" was nowhere to be found in the Alsa documentation though, there was a "dell-m4" which I tried earlier, it made the speaker symbol lighten up but there was no sound."
----------------------------------
This time I tried hp-m6 first which they also mentioned on the suse forum but with no luck, so I added "options snd-hda-intel model=hp-m4" again and rebooted and the sound worked.

I'm a noob so I don't know if the order the input in the file is so I just paste the end of my alsa-base file here:
-------------------------
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Added By Jorgen
options snd-hda-intel model=hp-m4
# End Added
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
-------------------------
Here's what the laptop says about the sound card:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Codec: IDT 92HD71B7X
Codec: LSI ID 1040
Codec: Generic 8086 ID 2802

==> /proc/asound/card0/codec#0 <==
Codec: IDT 92HD71B7X

==> /proc/asound/card0/codec#1 <==
Codec: LSI ID 1040

==> /proc/asound/card0/codec#2 <==
Codec: Generic 8086 ID 2802

Computer information:
Compaq Presario CQ45
FN440PA#AKC
Bios F.11c

Hew McLachlan (hew) on 2009-02-01
Changed in pulseaudio:
importance: Undecided → High
kingttx (kingttx-tomslinux) wrote :

Can confirm the workaround works and also had to make sure analog loopbacks are muted on alsamixer -c 0.

Michael Rooney (mrooney) on 2009-02-02
description: updated

I need to correct my previous statment: the workaround works, only when i do it twice. the first time it fails.

also the volume is now VERY VERY low! I also tried with previous kernel (-5) and its the same

Hello
If tou try to install the gnome alsa mixed you maybi van adjust the
volume to anorher level

Sendt fra min iPhone

Den 2. feb.. 2009 kl. 11.47 skrev BUGabundo <email address hidden>:

> I need to correct my previous statment: the workaround works, only
> when
> i do it twice. the first time it fails.
>
> also the volume is now VERY VERY low! I also tried with previous
> kernel
> (-5) and its the same
>
> --
> [jaunty regression] Pulse Audio finds no card for output
> https://bugs.launchpad.net/bugs/322374
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 0.9.14-0ubuntu3

---------------
pulseaudio (0.9.14-0ubuntu3) jaunty; urgency=low

  [ Daniel T Chen ]
  * Add fixes from git HEAD:
    - 0014_fix_avail-min_calc.patch,
    - 0015_no_pa-asyncq-push_fail.patch,
    - 0016_dont_rely_pa-sink-running-idle_for_optim.patch,
    - 0017_fix_hsp_rate_chan.patch,
    - 0018_dont_restore_mute_vol_when_already_set.patch,
    - 0019_fix_mem_leak_in_pa-alsa-open-by-device-string.patch,
    - 0020_ask_for_same_frag_set_when_resuming_oss_dev.patch,
    - 0021_add_missing_const.patch,
    - 0022_dont_hit_assert_in_esound-sink_when_latency_queried.patch

  [ Luke Yelavich ]
  * Re-instate /etc/X11/Xsession.d/70pulseaudio, to again load pulseaudio
    earlier in the X session, to aleviate a pulse/login-sound race condition
    (LP: #322374)

 -- Luke Yelavich <email address hidden> Mon, 02 Feb 2009 15:27:55 +0100

Changed in pulseaudio:
status: Confirmed → Fix Released

Håkon I already tried alsamixer -c 0 and alsamixergui without any results! lets see if this update changes anything.

--
Hi, I'm BUGabundo, and I am Ubuntu (whyubuntu.com)
(``-_-´´) http://LinuxNoDEI.BUGabundo.net && Ubuntu LoCoTeam Portugal http://ubuntu-pt.org
Linux user #443786 GPG key 1024D/A1784EBB

Seems the latest update fix the issue. But damn, return back horizontal
slider and double-click applet behaviour!

2009/2/2 BUGabundo <email address hidden>

> Håkon I already tried alsamixer -c 0 and alsamixergui without any
> results! lets see if this update changes anything.
>
> --
> Hi, I'm BUGabundo, and I am Ubuntu (whyubuntu.com)
> (``-_-´´) http://LinuxNoDEI.BUGabundo.net && Ubuntu LoCoTeam
> Portugal http://ubuntu-pt.org
> Linux user #443786 GPG key 1024D/A1784EBB
>
> --
> [jaunty regression] Pulse Audio finds no card for output
> https://bugs.launchpad.net/bugs/322374
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

I updated to pulseaudio 0.9.14-0ubuntu3 and sound is back, however some problems remain:
 * the login sound is garbled, when it's playing I hear a lot of noise
 * i get too volume control applets in the panel (the old style and the new one, see screenshot)

Noel J. Bergman (noeljb) wrote :

> i get too[sic] volume control applets in the panel (the old style and the new one, see screenshot)

I confirm that I now see two volume control applets, just as shown in his screen capture.

They don't seem quite identical. Right now, the old one shows "Master: 79%" when I hover over it, and a full context menu. The new one has only "Mute" and "Sound Preferences" as menu items, and shows "Output :80% -9.00 dB HDA Intel - AD198x Analog" when hovering.

Please check whether /etc/xdg/autostart/pulseaudio.desktop exists. If it does, please remove it, and I'll try and make sure it gets removed in future pulseaudio package revisions.

I don't have /etc/xdg/autostart/pulseaudio.desktop, and I have two volume
control applets.

On Tue, Feb 3, 2009 at 9:35 AM, Luke Yelavich
<email address hidden>wrote:

> Please check whether /etc/xdg/autostart/pulseaudio.desktop exists. If it
> does, please remove it, and I'll try and make sure it gets removed in
> future pulseaudio package revisions.
>
> --
> [jaunty regression] Pulse Audio finds no card for output
> https://bugs.launchpad.net/bugs/322374
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Noel J. Bergman (noeljb) wrote :

I do not have /etc/xdg/autostart/pulseaudio.desktop:

# ls -l /etc/xdg/autostart/
total 60
-rw-r--r-- 1 root root 2741 2008-10-07 16:19 bluetooth-applet.desktop
-rw-r--r-- 1 root root 289 2008-10-27 05:58 evolution-alarm-notify.desktop
-rw-r--r-- 1 root root 6423 2009-01-06 12:24 gnome-at-session.desktop
-rw-r--r-- 1 root root 6282 2008-11-20 13:30 gnome-power-manager.desktop
-rw-r--r-- 1 root root 2083 2008-12-02 10:10 gnome-settings-daemon.desktop
-rw-r--r-- 1 root root 2714 2009-01-29 11:51 jockey-gtk.desktop
-rw-r--r-- 1 root root 649 2009-01-14 05:41 nm-applet.desktop
-rw-r--r-- 1 root root 5491 2009-01-25 17:20 print-applet.desktop
-rw-r--r-- 1 root root 2204 2008-11-13 16:20 tracker-applet.desktop
-rw-r--r-- 1 root root 1791 2008-11-13 16:20 trackerd.desktop
-rw-r--r-- 1 root root 247 2008-11-25 15:40 update-notifier.desktop
-rw-r--r-- 1 root root 4081 2008-09-25 13:58 user-dirs-update-gtk.desktop

and I have two volume controls. One is in the normal place, the other appears in the notification area. Please note what I just said: *the second appears in the notification area*.

I don't have /etc/xdg/autostart/pulseaudio.desktop. As matter of fact I did a "find / -iname 'pulseaudio.desktop'" and nothing came up.

$ ls /etc/xdg/autostart/pulseaudio.desktop
-rw-r--r-- 1 root root 197 2008-09-12 09:57 /etc/xdg/autostart/pulseaudio.desktop

I have it but i only have one sound applet!
Luke should I remove it?

What version of pulseaudio do you have installed? If you have 0.9.14-0ubuntu3 then yes, remove it, and I'll ahve to investiate why it wasn't removed. If you don't have that version, please upgrade.

On Tuesday 03 February 2009 16:53:36 Luke Yelavich wrote:
> What version of pulseaudio do you have installed? If you have
> 0.9.14-0ubuntu3 then yes, remove it, and I'll ahve to investiate why it
> wasn't removed. If you don't have that version, please upgrade.

it was removed after upgrade.

--
Hi, I'm BUGabundo, and I am Ubuntu (whyubuntu.com)
(``-_-´´) http://LinuxNoDEI.BUGabundo.net && Ubuntu LoCoTeam Portugal http://ubuntu-pt.org
Linux user #443786 GPG key 1024D/A1784EBB

None of the above helpt me fix my audio. My user was not in the audio group.
sudo adduser <username> audio, worked for me.

None of the above helps me either... not even adding myself back to the audio group.

Hmmm, after running asoundconf set-pulseaudio yesterday it worked again but there were updates meanwhile and same situation. No sound through pulseaudio - this means especially no flash soudn.

Steven (vtstevenvt) wrote :

I have an Asus Xonar DX card. Audio was working, then stopped working. I tried many things, but it seems that removing pulseaudio and rebooting, fixed the problem.

Radu Cristescu (radu.c) wrote :

Something like this just crept into Karmic, except the workaround doesn't fix it. Just noticed it tonight.

Daniel T Chen (crimsun) wrote :

Radu C, please file a new bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers