pulseaudio error 1 upgrading pulseaudio_0.9.13-2ubuntu6_i386.deb

Bug #317921 reported by marcobra (Marco Braida) on 2009-01-16
52
This bug affects 4 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Daniel T Chen

Bug Description

Binary package hint: pulseaudio

On regular update/upgrade of:

Description: Ubuntu jaunty (development branch)
Release: 9.04

Pulseaudio is running:

sudo /etc/init.d/pulseaudio start
 * Starting system PulseAudio Daemon /usr/bin/pulseaudio already running.
ubuntu@ubu-vendita:~$ sudo /etc/init.d/pulseaudio start

But on upgrade....

Mi preparo a sostituire pulseaudio 0.9.13-2ubuntu5 (con .../pulseaudio_0.9.13-2ubuntu6_i386.deb) ...
 * Stopping system PulseAudio Daemon invoke-rc.d: initscript pulseaudio, action "stop" failed.
dpkg: attenzione - il vecchio script di pre-removal ha restituito un codice di errore 1
dpkg - provo quindi lo script dal nuovo pacchetto ...
 * Stopping system PulseAudio Daemon No process in pidfile `/var/run/pulse/pid' found running; none killed.
 * PulseAudio Daemon is not running
                                                                         [fail]
invoke-rc.d: initscript pulseaudio, action "stop" failed.
dpkg: errore processando /var/cache/apt/archives/pulseaudio_0.9.13-2ubuntu6_i386.deb (--unpack):
 il sottoprocesso nuovo script di pre-removal ha restituito un codice di errore 1
 * Starting system PulseAudio Daemon [ OK ]
Sono occorsi degli errori processando:
 /var/cache/apt/archives/pulseaudio_0.9.13-2ubuntu6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Thank you

description: updated
Daniel T Chen (crimsun) wrote :

After the system daemon instance is running, what are the permissions on /var/run/pulse, and what are the contents of /var/run/pulse/pid?

Changed in pulseaudio:
status: New → Confirmed

ls -la /var/run/
...
drwxr-xr-x 2 pulse pulse 80 2009-01-22 05:11 pulse
...

And there are no pulse pid...

 ls -la /var/run/pulse/
totale 8
drwxr-xr-x 2 pulse pulse 80 2009-01-22 05:11 .
drwxr-xr-x 23 root root 860 2009-01-22 05:11 ..
-rw-r----- 1 pulse pulse-access 16 2009-01-22 04:47 .esd_auth
-rw-r----- 1 pulse pulse-access 256 2009-01-22 04:47 .pulse-cookie

sudo /etc/init.d/pulseaudio restart

[sudo] password for ubuntu:

 * Stopping system PulseAudio Daemon No process in pidfile `/var/run/pulse/pid' found running; none killed.
 * PulseAudio Daemon is not running [fail]

sudo /etc/init.d/pulseaudio start
 * Starting system PulseAudio Daemon [ OK ]

sudo /etc/init.d/pulseaudio restart
 * Stopping system PulseAudio Daemon

sudo /etc/init.d/pulseaudio restart
 * Stopping system PulseAudio Daemon No process in pidfile `/var/run/pulse/pid' found running; none killed.
 * PulseAudio Daemon is not running [fail]

Starting pulseaudio i don't see a valid pulse pid into /var/run/pulse/

Temporary i try this:

sudo chmod 777 /var/run/pulse

sudo /etc/init.d/pulseaudio restart
 * Stopping system PulseAudio Daemon No process in pidfile `/var/run/pulse/pid' found running; none killed.
 * PulseAudio Daemon is not running [fail]

But it still fail

Thank you

If i do only a start...

sudo /etc/init.d/pulseaudio start
 * Starting system PulseAudio Daemon [ OK ]

and the content of

ls -la /var/run/pulse/pid
-rw------- 1 pulse pulse 6 2009-01-22 05:23 /var/run/pulse/pid

is

sudo cat /var/run/pulse/pid
18586

ls -la /etc/init.d/pulseaudio
-rwxr-xr-x 1 root root 2045 2009-01-09 07:14 /etc/init.d/pulseaudio

The
md5sum /etc/init.d/pulseaudio
3c182b6871ffd3ce47375ccae5225f39 /etc/init.d/pulseaudio

if is different by your i send the content of /etc/init.d/pulseaudio

Hope this helps

In short seems restarting pulseaudio from /etc/init.d/pulseaudio fail to restart pulseaudio

sudo cat /var/run/pulse/pid -> 21357

sudo /etc/init.d/pulseaudio stop * Stopping system PulseAudio Daemon
sudo /etc/init.d/pulseaudio start * Starting system PulseAudio Daemon

cat /var/run/pulse/pid → 21874

sudo /etc/init.d/pulseaudio restart * Stopping system PulseAudio Daemon

sudo cat /var/run/pulse/pid
cat: /var/run/pulse/pid: Nessun file o directory

In attach my /etc/init.d/pulseaudio script file.

Hope this helps

Carl Johnstone (carljohnstone) wrote :

Me too - not that I've upgraded the last couple of times by hacking the scripts and stopping pulseaudio myself.

Preparing to replace pulseaudio 0.9.14-0ubuntu1 (using .../pulseaudio_0.9.14-0ubuntu2_i386.deb) ...
 * Stopping system PulseAudio Daemon
invoke-rc.d: initscript pulseaudio, action "stop" failed.
dpkg: warning - old pre-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
 * Stopping system PulseAudio Daemon
No process in pidfile `/var/run/pulse/pid' found running; none killed.
 * PulseAudio Daemon is not running
   ...fail!
invoke-rc.d: initscript pulseaudio, action "stop" failed.
dpkg: error processing /var/cache/apt/archives/pulseaudio_0.9.14-0ubuntu2_i386.deb (--unpack):
 subprocess new pre-removal script returned error exit status 1
 * Starting system PulseAudio Daemon
   ...done.

Arenlor (arenlor) wrote :

I figured out that it's because you're using pulseaudio in daemon mode. If you edit the config file and disable daemon temporarily it'll upgrade for you.

Daniel T Chen (crimsun) on 2009-02-14
Changed in pulseaudio:
status: Confirmed → Fix Committed

Yes stopping pulseaudio the upgrade process run fine...

But why this bug was closed and set as fixed, not fixed, is pulseaudio daemon is running

Thank you

Sorry for my previous message still issue here, pulseaudio don't update itself

sudo /etc/init.d/pulseaudio stop
[sudo] password for ubuntu:
 * Stopping system PulseAudio Daemon

ubuntu@ubu-vendita:~$ sudo apt-get upgrade
I seguenti pacchetti saranno aggiornati:
  pulseaudio
1 aggiornati, 0 installati, 0 da rimuovere e 1 non aggiornati.
È necessario prendere 0B/405kB di archivi.
Dopo quest'operazione, verranno occupati 12,3kB di spazio su disco.
Continuare [S/n]?
(Lettura del database ... 243484 file e directory attualmente installati.)
Mi preparo a sostituire pulseaudio 0.9.13-2ubuntu5 (con .../pulseaudio_0.9.14-0ubuntu5_i386.deb) ...
 * Stopping system PulseAudio Daemon No process in pidfile `/var/run/pulse/pid' found running; none killed.
 * PulseAudio Daemon is not running
                                                                         [fail]
invoke-rc.d: initscript pulseaudio, action "stop" failed.
dpkg: attenzione - il vecchio script di pre-removal ha restituito un codice di errore 1
dpkg - provo quindi lo script dal nuovo pacchetto ...
 * Stopping system PulseAudio Daemon No process in pidfile `/var/run/pulse/pid' found running; none killed.
 * PulseAudio Daemon is not running
                                                                         [fail]
invoke-rc.d: initscript pulseaudio, action "stop" failed.
dpkg: errore processando /var/cache/apt/archives/pulseaudio_0.9.14-0ubuntu5_i386.deb (--unpack):
 il sottoprocesso nuovo script di pre-removal ha restituito un codice di errore 1
 * Starting system PulseAudio Daemon [ OK ]
Sono occorsi degli errori processando:
 /var/cache/apt/archives/pulseaudio_0.9.14-0ubuntu5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I can't also remove pulseaudio package even if pulseaudio daemon is running or not.

sudo /etc/init.d/pulseaudio start
 * Starting system PulseAudio Daemon [ OK ]

pre-removal always return error code 1

Thank you

I reopen this bug still not fixed for me... without any workaround founded.

Changed in pulseaudio:
status: Fix Committed → New
Arenlor (arenlor) wrote :

Edit /etc/default/pulseaudio and change start in daemon mode to 0 then update and change it back to 1.

Thank Arenlor i changed the files putting

PULSEAUDIO_SYSTEM_START=1

to

PULSEAUDIO_SYSTEM_START=0

and after reboot the pc the upgrade was fine but i still thinking this bug is not solved.

Best regards

Arenlor (arenlor) wrote :

there have been many upgrades that have failed to fix this so far, but the work around is simple enough.

Daniel T Chen (crimsun) wrote :

I've already fixed this bug in my bzr branch.

Changed in pulseaudio:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 0.9.14-0ubuntu6

---------------
pulseaudio (0.9.14-0ubuntu6) jaunty; urgency=low

  * 0004_disable_autospawn.patch: Disable this patch. Doing so
    allows the daemon to spawn if not already running, which
    works around LP: #191027, #204272
  * 0012_clarify_driver_error_redirect_to_alsa_devs.patch:
    - Only log POLL* being set if tsched is used so that syslog
      isn't filled with innocuous messages when we set tsched=0
      (see 0030 below) (LP: #323712),
    - Hint 'linux' source package instead of 'alsa-driver' for
      Launchpad bug reports,
    - The debug-specific portion is only applicable to 0.9.14;
      0.9.15 enables a rate limiting module by default to work
      around this (and other) issues
  * 0029_fix_suspend_on_idle_null_race.patch: Handle sink case,
    too
  * 0030_set_tsched0.patch: Work around a shedload of (driver)
    bugs by falling back to interrupt-based buffer semantics
    (LP: #190754, #292880, #295519, #298494, #301755, #302964,
     LP: #319118, #323976, #324103, #326205, #326864)
  * Backport fixes from git HEAD:
    - 0031_fix_6chan_map.patch,
    - 0032_reinit_proplist.patch,
    - 0033_fix_pa-gcc-packedmalloc.patch,
    - 0034_bt_fixes.patch
  * Make invoking the stop target in the initscript not fail an
    upgrade (LP: #317921)
  * Previous upload (0.9.14-0ubuntu3) fixed LP: #321357
  * 01PulseAudio: use sudo -H to ensure that $HOME is, in fact,
    the user's when invoking pacmd for suspend/resume

 -- Daniel T Chen <email address hidden> Sun, 15 Feb 2009 02:35:26 -0500

Changed in pulseaudio:
status: Fix Committed → Fix Released
Teunis Peters (teunis) wrote :

not fixed yet.

this is the bad section in pulseaudio.postinst:
# Automatically added by dh_installinit
if [ -x "/etc/init.d/pulseaudio" ]; then
        update-rc.d pulseaudio start 50 2 3 4 5 . stop 15 1 . >/dev/null
        if [ -x "`which invoke-rc.d 2>/dev/null`" ]; then
                invoke-rc.d pulseaudio start || exit $?
        else
                /etc/init.d/pulseaudio start || exit $?
        fi
fi
# End automatically added section

comment it out and everything works fine. It's either that or fix the ruddy init script to recognize if it's session-started or not. I WANTED a system-wide one but the system keeps overriding my settings.

Daniel T Chen (crimsun) on 2009-03-17
Changed in pulseaudio (Ubuntu):
assignee: nobody → crimsun
status: Fix Released → Confirmed
Jeremy Wilkins (wjeremy) wrote :

Confirmed it is still not fixed even after beta release and latest pulseaudio.

Jeff (jeffmart) wrote :

The workaround of "undaemonize" with PULSEAUDIO_SYSTEM_START=0 worked for me, and I could upgrade to 0.9.14

I can also confirm that it works to edit /etc/default/pulseaudio to set PULSEAUDIO_SYSTEM_START to 0. After that, it asked me about this very file (updated version of config file in package, current version modified locally). I told it to use the version of the file from the new package, which also contains PULSEAUDIO_SYSTEM_START=0. I then read the comment in the file and figured that since this is the recommended way to use it, I'll just follow. So it is still zero. I'll report back if there are any problems in the future.

Ken Tanzer (ktanzer) wrote :

My update failed today because of this problem. I also run in daemon mode. I'm sure the workaround would work, but I'll wait a bit and see if this bug gets fixed first.

Daniel T Chen (crimsun) on 2010-03-05
Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
zEn (der-eremit) wrote :

I can still confirm this bug on two headless servers with with maverick-rc
...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments