pcm muted every session

Bug #298301 reported by Shirish Agarwal on 2008-11-15
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: pulseaudio

PCM gets muted each session. Whether I'm into GNOME or XFCE doesn't matter. I have to unmute PCM and then can listen to music.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: pulseaudio 0.9.10-2ubuntu9
ProcEnviron:
 SHELL=/bin/bash
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_IN
SourcePackage: pulseaudio
Uname: Linux 2.6.27-7-generic i686

Shirish Agarwal (shirishag75) wrote :
Daniel T Chen (crimsun) wrote :

Why is your pulseaudio version so old? I've applied a fix that's present in the current jaunty version that should alleviate this symptom. Please report back.

Changed in pulseaudio:
importance: Undecided → Low
status: New → Incomplete
Daniel T Chen (crimsun) on 2009-01-09
Changed in pulseaudio:
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 0.9.13-2ubuntu5

---------------
pulseaudio (0.9.13-2ubuntu5) jaunty; urgency=low

  [ Daniel T Chen ]
  * Add fixes from git:
    - 0015_use_fionread.patch,
    - 0016_add_pa-source-message-get-latency.patch,
    - 0017_allow_dev_dsp_w-ok.patch,
    - 0018_fix_return_val_pa-frame-aligned.patch,
    - 0019_fix_macro_pa-unlikely.patch,
    - 0020_catch_driver_errors.patch (LP: #312373),
    - 0021_convert_to_pa-bool-t.patch,
    - 0022_fix_return_val_dump-resample-methods.patch,
    - 0023_use_gdbm-nolock.patch,
    - 0024_dont_mix_front-center_into_rear.patch,
    - 0025_drop_cap-nice_properly.patch,
    - 0027_handle_multicast_sdp_with_same_ip_ttl_as_rtp.patch,
    - 0028_prefer_mixer_controls_with_vols.patch (LP: #281605),
    - 0029_add_minor_fixes.patch
  * Forward-port workaround from hardy branch for source/sink and
    suspend-on-idle race (LP: #203654):
    - 0026_work_around_suspend-on-idle_source_sink_race.patch
  * debian/control: Drop padevchooser(Recommends) and pavucontrol
    (Suggests) completely - functionality has been subsumed by
    jaunty's gnome-volume-control.
  * debian/pulseaudio.init:
    - Make initscript more informative in the default case of per-user
      sessions (LP: #259522),
    - Make initscript retry (until three-second timeout) if stopping
      fails when restarting (LP: #244414),
    - LSB {Required-*,Should-*} should specify hal instead of dbus,
      since hal is required (and already requires dbus) (LP: #244679)
  * Previous upload contains patches to close:
    LP: #193491, #268891, #295164, #298301

  [ Luke Yelavich ]
  * 0008_regen_autotools.patch: Pull some libtool 2.2 updates from git,
    and regenerate autotools glue.
  * debian/rules: Add --enable-static to force creation of libpulse.a,
    a side-effect of messing with the autotools files. This shouldn't
    be needed for the 0.9.14 release.

 -- Luke Yelavich <email address hidden> Fri, 09 Jan 2009 17:05:38 +1100

Changed in pulseaudio:
status: Fix Committed → Fix Released
Uwe Schilling (uschilling) wrote :

Problem present on my machine

Changed in pulseaudio (Ubuntu):
status: Fix Released → Confirmed
Uwe Schilling (uschilling) wrote :

package version is 0.9.14-0, bug exactly as described above

Raps (tdebo) wrote :

It seems that I have the same problem.
Starting a session the volume indicator is muted.

Architecture: i386
DistroRelease: Xubuntu 9.04
Package: pulseaudio 1.0.9.14-0ubuntu20.2
Uname -rsm: Linux 2.6.28-15-generic i686

Sorry if it is not the same issue. I found very few related problem on the web.

Jim in Chicago (jbcady) wrote :

Same here, I have 1:0.9.14-0ubuntu20.2 installed and it has my PCM at 0 volume and muted every startup.
I have found out this, though. If I have to kill my system (NOT go through the normal shutdown) the pcm volume is ok when the system comes back up. So, I must infer that whatever is doing this is doing it during shutdown.

Cruncher (ubuntu-wkresse) wrote :

This looks very much like a duplicate of bug #378470 and/or #432660. Please check that bug and mark this one as a duplicate if that is the case. (it would probably help to keep #378740 the "original" bug, since it already contains information about an (although unregarded) upstream bug)

Also, I found elsewhere that there were some other muting related problems fixed in pulseaudio 0.9.15, but from my understanding they describe a different bug. But you might want to try to recreate your bug with a newer version.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers