Ubuntu

ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)

Reported by Dimitrios Symeonidis on 2008-10-18
80
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Medibuntu
Undecided
Unassigned
bluez (Ubuntu)
Undecided
Unassigned
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

In skype, trying to make a phone call. I get this message 6 times:
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
and the call fails immediately with "problem with audio playback"...

This is on a laptop, with bluetooth enabled, but i'm not trying to use a bluetooth headset or anything...

skype is 2.0.0.72-0medibuntu3
alsa-base is 1.0.17.dfsg-2ubuntu1
all this on intrepid 32-bit with latest updates

tell me if you need more info...

description: updated
Dimitrios Symeonidis (azimout) wrote :

remark: why do i find skype in the list of packages, but when trying to assign to it, i get "package skype not published in ubuntu"?

voodoodaddy (m-handerek) wrote :

same problem on ubuntu 8.10 amd64, anybody have a solution/ workaround for this bug?

Dimitrios Symeonidis (azimout) wrote :

in fact, updating to skype 2.0.0.72-0medibuntu4 has fixed the problem

Changed in alsa-lib:
status: New → Fix Released
Dimitrios Symeonidis (azimout) wrote :

i added medibuntu in the related packages, since this is with the medibuntu version of skype...

voodoodaddy, which version of skype are you running?

Changed in medibuntu:
status: New → Fix Released
Changed in alsa-lib:
status: Fix Released → Invalid
voodoodaddy (m-handerek) wrote :

First i've tried to download the i386 deb from skype.com, install by forcing the architecture and fixing the dependencies with getlibs. But without success. Starting skype in terminal throws

ALSA lib ../../../src/pcm/pcm.c:2156:(snd_pcm_open_conf) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_bluetooth.so

So i located this file via apt-file in bluez-alsa package and copied it from the i386 package to the required location (also tried to symlink this to /usr/lib64/alsa-lib/libasound_module_pcm_bluetooth.so). Launching skype causes

ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)

and calling the skype test center still throws 'Problem with Audio Playback'.
Also a installation from the medibuntu repositories don't change anything.

All of my attempts based on Skype 2.0.0.72

Stefan Seidel (seidler2547) wrote :

Contrary to Dimitrios, I am trying to use a bluetooth stereo headset, and get this error. It seems that pcm_bluetooth is broken in intrepid, because this was working fine in hardy! My .asoundrc reads:

pcm.!default {
  type bluetooth
  device "00:11:67:7F:FF:13"
  profile “hifi”
}

but it doesn't work.

voodoodaddy (m-handerek) wrote :

is there any way to disable bt support in skype, in order to use it the conventional way?

acimmarusti (andrescimmarusti) wrote :

Hello,

When running either skype_2.0.0.72-0medibuntu4 or skype-
static_2.0.0.72-0medibuntu4 from the terminal I get the following
statements.

ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)

The sound doesn't work at all in skype. I cannot make calls. I don't
understand what's happening, as I'm not trying to use a bluetooth.
Although this has happened to me (without the bluetooth issue) while
running skype on hardy heron 8.04, it didn't happen all the time. My
real problems with skype began when I installed a fresh copy of Intrepid
Ibex (8.10).

I tried skype-static-oss 2.0.0.72-0medibuntu4 and the sound works, but
my usb microphone doesn't seem to be supported (usb microphone embedded
in a logitech quickcam pro for Notebooks).

When I got everything to work while running skype on hardy heron 8.04,
even then If I used the microphone in conjunction with the video, the
mic would screw up the video image. I had to use a separate mic or not
use the cam at all!

I've checked that I have all the apparent fixes and I have everything up to date, but my problem is not solved!

samuraigui (samuraigui) wrote :

Hi, I had the same problem in my computer and now it's ok!
try this:

sudo killall -9 pulseaudio

In my computer it works!! I found in one website, in a language that I have no idea what they write there... lol

voodoodaddy (m-handerek) wrote :

Killing pulseaudio works for me too. Now i am able to do calls, without 'Problem with Audio Playback' error.
But starting Skype in terminal, still throws errors like mentioned in my 2nd post.

acimmarusti (andrescimmarusti) wrote :

Thanks for the workaround, but do I have to kill pulseaudio everytime I log in into my computer and want to use skype?...
I'm a newbie with ubuntu, so I'm going to ask a beginner's question: what does pulseaudio really do? Do I really need it? or could I get rid of it? could I disable it somehow?

samuraigui (samuraigui) wrote :

I'm a newbie too! It's just something to help us until we find something to repair this bug...

voodoodaddy (m-handerek) wrote :

You can disable it permanently under System > Preferences > Session
Pulseaudio is a network sound server. I'm not sure, but i think you don't realy use it, may by some applications like Skype. More details here: http://www.pulseaudio.org/wiki/AboutPulseAudio

Motin (motin) wrote :

As it works when PulseAudio is not running I am assuming that the "Problem with audio playback" problem is described in #288269

This bug report then is about ALSA not being able to query BT_GETCAPABILITIES. Now, if this has any implications for users that are not using bluetooth headsets, I don't know, meanwhile marking the bug as New again.

Changed in alsa-lib:
status: Invalid → New
Dimitrios Symeonidis (azimout) wrote :

i was wrong earlier when i marked it as fix released. i got the message again today while adding a contact. note that it does not cause any obvious problems, and i see it only if running skype from a terminal...

Changed in medibuntu:
status: Fix Released → New
Stefan Seidel (seidler2547) wrote :

Well then, why don't all those having problem with Skype hang on to the bug Motin mentioned and we treat this bug here according to its title - as a pcm_bluetooth BUG which exists and should be fixed for those who wish to use their bluetooth headsets.

zeusOne (vaudano) wrote :

Hi, I use Kubuntu 8.10 and I have the same problem also without Pulse Audio.

With the command:

aplay -D bt_audio audio.wav

I received this result:

ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : Input/output error(5)
aplay: main:583: audio open error: Input/output error

Robie Basak (racb) wrote :

I got this after upgrading from Hardy to Intrepid (not Medibuntu). pulseaudio also produces the error when trying to use bluetooth to send audio too (0.9.13 - I backported from jaunty).

Therefore, I think this is a problem in bluez, not in alsa or pulseaudio.

Additionally, the "Bluetooth device setup wizard" fails to find any devices, but "hcitool scan" does - I don't know if that's related.

Robie Basak (racb) wrote :

Further debugging: it looks like pulseaudio is connecting to the socket using bt_audio_service_open(), but then fails after that. netstat shows that there is a socket @/org/bluez/audio listening.

I had similar issues setting up my S9 BT headphones today in 8.10 -- workaround:

1. In /etc/init.d/bluetooth disable HID2HCI by changing HID2HCI_ENABLED=1 to:
HID2HCI_ENABLED=0

Now I could pair my headphones in the GUI.

2. Then in ~/.asoundrc insert:
pcm.bluetooth {
 type plug
 slave {
  pcm "bluetooth_hw"
 }
}

pcm.bluetooth_hw {
 type bluetooth
 device 00:00:00:00:00:00 # Get your headphone's mac address from 'hcitool scan' and put it here.
 profile "hifi"
}

3. Make visiable to pulseaudio: ( You have to do this everytime you login / enable phones. )

pactl load-module module-alsa-sink device=bluetooth
pactl load-module module-alsa-source device=bluetooth

4. Open up pulseaudio volume control and you can set phones as your default or per application like any other sound card.

-- Hope this work around helps some of you guys with new xmas phones. :D

Leonardo Gaudino (gaudino110) wrote :

Workaround from Mongoose does work for me, but without type plug section in .asoundrc (with that doesn't).
Modify /etc/init.d/bluetooth not necessary.
Furthermore I did modify /etc/bluetooth/audio.conf (attachment):

Autostart=true
SCORouting=HCI
HFP=true

I'm not really a geek, nor a programmer, but I "feel" the problem is in bluez. The device works almost always with:

mplayer -ao alsa:device=headset
aplay -D headset

and work with skype also, but only for the first call. It seems that, under certain circumstances (not only with skype), the headset keep connection alive, or keep connecting and disconnecting (in that cases I ear the corresponding beeps in the headset). In such cases, if I /etc/init.d/bluetooth restart, the headset does "beep" like disconnecting, so anything return to "normality" and works fine, since the problem reappear.
With skype the problem appear always, but in only one case I could do 2 calls, whatsoever it does mean...

Ubuntu 8.10
bluez 4.12-0ubuntu5
libasound2 1.0.17a-0ubuntu4

Marc Horowitz (marc-mit) wrote :

I was having the same problem as zeusOne. After a bunch of investigation, it became clear that bluetoothd didn't have all the necessary dbus devices set up internally. Forcing it to do service discovery on my headphones (Plantronics 590A, in a2dp mode) made it all work:

dbus-send --system --dest=org.bluez --print-reply /org/bluez/hci0/dev_00_19_7F_38_F6_FF org.bluez.Device.DiscoverServices string:

I'm not sure why this should be necessary, or what should be doing it, but hopefully this will help someone else.

Marc Horowitz (marc-mit) wrote :

I can't seem to edit my previous comment, so I'll make another: make sure when you issue the above command, you replace the hex in the dbus path with your own device's address. You can find this from "hcitool scan" if its discoverable.

Daniel T Chen (crimsun) wrote :

This problem should be fixed in current jaunty; please report.

Changed in alsa-lib:
status: New → Incomplete
Igor Gomes (igorgomes) wrote :

I've solved my problem (bluetooth headset) by adding the following repository and upgrading all bluez-related (bluez*, bluetooth, libbluetooth3). It will upgrade the bluez 4.27. Now works discover, pairing (using bluetooth-applet)... Etc.

So, step by step:

1) Add the repositories

deb http://philip.magicalforest.se/ intrepid extra
deb-src http://philip.magicalforest.se/ intrepid extra

2) Add the repo's GPG sig

wget http://philip.magicalforest.se/Philip5.gpg | sudo apt-key add key.asc

3) Update the repository using Synaptic or apt-get update

4) Mark the upgrades to bluez*, bluetooth, libbluetooth3

5) Apply

Afterwards, just restart the service (sudo /etc/init.d/bluetooth restart) and everything working again. You can test by using the following command:

aplay -D bluetooth /usr/share/sounds/question.wav

Cheers,

Igor Gomes

kai-w (kai-w1986) wrote :

Daniel T Chen,
using the Jaunty daily release as of 2009-01-26 the bug does not seem to be fixed for me. Though it is much robuster now. I tested this with Skype using my BT-headset. I did approx. 20 calls without any problems. I tried again after I had not been touching the computer for four houres and I received this from Skype:

ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL bluetooth
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL bluetooth
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL bluetooth
ALSA lib pcm_bluetooth.c:1561:(audioservice_expect) BT_SET_CONFIGURATION failed : Input/output error(5)

The "Invalid CTL bluetooth" messages appeared right at the beginning of my Skype session, and these were the only ones. I attach my dmesg output.

Dimitrios Symeonidis (azimout) wrote :

bluez 4.12 (the version available in Intrepid) was released on 06.10.2008
jaunty currently includes 4.25
the latest versoin is 4.27, released 16.01.2009

any chance of upgrading the intrepid version?

Robie Basak (racb) wrote :

Daniel,

Problem fixed for me using latest jaunty bluez package built on Intrepid - thanks.

Incidentally, in addition to this I had to build pulseaudio from latest jaunty too, though ALSA seemed to work fine. I gather there's been an API change in bluez.

Daniel T Chen (crimsun) on 2009-02-04
Changed in bluez:
status: New → Fix Released
Changed in pulseaudio:
status: Incomplete → Fix Released
Jackflap (deriziotis) wrote :

I tried absolutely everything above and nothing worked.

In the end, the only thing that did work for me was to downgrade the bluetooth packages to Hardy's version. Here's a HOWTO I put together:

http://jackflapb.wordpress.com/2009/03/23/howto-downgrading-intrepids-bluetooth-packages-to-hardys/

Alex

Bruno Girin (brunogirin) wrote :

The problem still exists with skype 2.0.0.72-0medibuntu4 on latest Jaunty:

ALSA lib pcm.c:2205:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2205:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm_bluetooth.c:1569:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib pcm_bluetooth.c:1569:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib pcm.c:2205:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2205:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm_bluetooth.c:1569:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib pcm_bluetooth.c:1569:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib pcm.c:2205:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2205:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm_bluetooth.c:1569:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)
ALSA lib pcm_bluetooth.c:1569:(audioservice_expect) BT_GET_CAPABILITIES failed : Input/output error(5)

Note that I am not using a bluetooth headset, I just have bluetooth enabled on the laptop. Also note that this appears to be independent of the conflict with pulseaudio because I have this output whether pulseaudio is running or not; therefore, I will open a new bug for the pulseaudio problem.

Changed in medibuntu:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers