Recording does not work with internal microphone on Dell Vostro 1500 laptop

Bug #277532 reported by Srix on 2008-10-03
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Ubuntu Audio Team

Bug Description

Sound Recorder, Ekiga, Empathy are not able to record from the internal (or external, for that matter) microphone. Audacity works, but the input device in the application is set to OSS:/dev/dsp.

In gnome-volume-control, device selected was "HDA Intel (Alsa mixer)". In the "Recording" tab, "Capture", "Digital" and "Mux" all have a little red cross on the mic. icons (tooltip reads "Toggle audio recording from..."). Toggling these does not help - the next time the window is opened the red crosses are back.

Both (internal and external) microphone inputs were working fine under Hardy, but stopped working after a dist-upgrade to Intrepid Alpha 6 (and even after further updates from Beta).

alsa-info.sh output is at:
http://www.alsa-project.org/db/?f=357c6d201cac124e0a2233839ec3dbf0568cac40

Harvey Muller (hlmuller) wrote :

Changing package from linux to pulseaudio, and assigning to Ubuntu Audio Team

Changed in linux:
assignee: nobody → ubuntu-audio
status: New → Confirmed
Harvey Muller (hlmuller) wrote :

I've confirmed this bug on a Dell Inspiron 1420 with onboard Intel HD Audio Controller (ICH8 family).

My results are similar to the original reporter. I isolated pulseaudio as the culprit by killing it, adjusting volume controls, and then running Sound Recorder.

It is possible to record sound with pulseaudio running. Sound capture has to be set to Pulseaudio Sound Server in Sound Preferences. But the recorded input is too faint, even at highest levels.

_blue (blue) wrote :

I'm also running into this bug, in Intrepid on a Dell 1420. If I switch to alsa sound, I can get capture to work, but at uselessly low levels.

lspci | grep Audio:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Capture was working fine in Hardy.

Rocko (rockorequin) wrote :

I have the same audio controller on a Dell XPS M1530.

Like blue, my digital microphone does work, but its sensitivity is set very low and unlike Srix, I don't even have the digital microphone sensitivity control any more (which is a regression from Hardy).

I've opened Bug #290505 for the missing digital sensitivity control because I think it's different from this bug, which is that the mike doesn't work at all.

on my dell xps m1530 i have a digital microphone sensitivity control but even if i turn it all the way up the signal still is very faint. every time i open gnome-volume-control i see the same red cross effect Srix described.

Daniel T Chen (crimsun) wrote :

@Srix Can you confirm that your symptoms match bug 282316?

Changed in pulseaudio:
status: Confirmed → Incomplete
Srix (srix) wrote :

Interestingly enough, recording now works for me, with "HDA Intel (Alsa mixer)" selected in the Volume Control properties. This is after regular system updates up until yesterday.
Volume is a little low, but audible. However, the red crosses on the mic icons in the Recording tab in the Volume Control dialog are still there and never seem to go away.

I did face the funny time display problems with Sound Recorder when the recording was not working, but it seems to be OK now, so I'm unable to reproduce bug 282316.

has anyone found a way to get the microphone sensitivity to a usable level?

Id2ndR (id2ndr) wrote :

Is this still the case with Karmic beta ?

Jase (jase-king) wrote :

I've had the same issue on 9.04 with my 1500 Vostro. I worked round it by disabling the HAL detect module in PulseAudio (default.pa) and only enabling an ALSA sink. ie. I didn't let PA 'know' about my built in mic.

Also updated to the latest ALSA drivers, utils, libs, plugins and tools by downloading the code from the ALSA site make/make install/etc.

The newer ALSA code fixed an issue with the mic not working well at all, stopping PA knowing about the built in mic fixed the low mic volume/recording problem.

Just to re-iterate;

1) I had a driver problem fixed but updating ALSA to >= 1.0.19 (currently got 1.0.21(a) installed). This for my mic working
2) I stopped PA finding my internal Mic, this fixed the low recording volume problem while leaving PA in place to do good stuff with sinks, etc.

Jase (jase-king) wrote :

"1) I had a driver problem fixed but updating ALSA to >= 1.0.19 (currently got 1.0.21(a) installed). This for my mic working"

should read

1) I had a driver problem fixed by updating ALSA to >= 1.0.19 (currently got 1.0.21(a) installed). This got my mic working outside PA.

Jase (jase-king) wrote :

I've just tested on a Karmic beta live CD and the volume on the mic is low but can easily be turned up in padevchooser. Once the mic volume was turned up it seems to work fine, I could record from the mic using the sound recorder, playback worked out of the box.

Can probably leave this issue for Jaunty, fixed in Karmic(?)

omvsj (omvsj) wrote :

On a HP tx1220us, Karmic, you can't access important settings through Volume Control GUI (like ATAPI MIC). Instead you need to use alsamixer from a command line terminal:

% alsamixer -V all

Hope it helps...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: Incomplete → Fix Released

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments