Sound output from PulseAudio replaced with static after update

Bug #275392 reported by covox on 2008-09-28
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

After a recent update, PulseAudio no longer outputs sound, but instead a series of popping noises.

Applications that attempt to use raw OSS (aside from having no hardware mixing) produce perfect sound.

Version: Intrepid
Kernel: 2.6.27-4-generic (problem also happens with 2.6.27-3-generic)
PA version: 0.9.10-2ubuntu6 (tried upgrading/downgrading from Luke's PPA 0.9.12 release, no change)
Driver: snd-hda-intel (Realtek ALC861 chipset, Toshiba Satellite A100)

Luke Yelavich (themuso) wrote :

How are you trying to play audio? Are you using applications that use pulseaudio directly, or are you using applications that use alsa, whicih then goes via pulseaudio? What applications are you using to play audio?

have you changed any settings in the files located in /etc/pulseaudio? Is the login sound also crackling/making odd noises?

Thanks

Luke Yelavich (themuso) wrote :

 affects ubuntu/pulseaudio
 duplicate no

covox (covox) wrote :

The applications I've used to test the audio were using a native PulseAudio backend (Exaile, which uses gstreamer, and Audacious which uses an output plugin). The login sound was also making crackling noises, however I've now turned the Gnome sound events off.

The only config file I changed was /etc/pulse/daemon.conf, to change the default sampling rate from 44100 to 48000 (there was an error message in syslog complaining that 44100 wasn't valid, changing this got rid of the error but didn't affect the static problem). At one stage I tried copying the contents of /etc/pulse/ from the recent beta LiveCD (which does have a working install of Pulse) without any success.

Have you tried running alsa applications without pulseaudio running? If so, what results do you get?

covox (covox) wrote :

Just to clarify, this is when running "pulseaudio -k" after booting with a clean /etc/asound.conf that doesn't use the "pulse" device? I'll try that.

covox (covox) wrote :

Okay, tried replacing my pulse /etc/asound.conf with my old dmix one. Killing PulseAudio then running Audacious with the ALSA backend gives perfect sound.

OMGsplosion (omgsplosion) wrote :

I don't think this is a dupe of 274124 because I've tried all the most of the fixes for that. I am also experiencing the same problem, Apps like flash player always make a crackling noise. If I set the output in sounds to OSS then things like Totem and Rhythmbox work, but if I set them to Pulseaudio sound server it doesn't work. Does the Gnome GDM use pulseaudio directly? Because I can't hear the GDM login or any of the other event sounds either.

covox (covox) wrote :

Just to clarify, I got sick of having no sound after a month and migrated to a fresh Intrepid install. PulseAudio is working now. If you have a backup HDD then that could be an easy way out, just check first if the Intrepid LiveCD can play sound. I still haven't a clue what the issue was.

pyjamashark (pyjamashark) wrote :

I have exactly the same problem, static instead of sound when trying to use pulseaudio but apps that use oss produce perfect sound (if i change to oss using system>preferences>sound). With a fresh install of intrepid this fixed the problem but a recent update has brought the bug back.
I really have no idea what is going on! Please help.
Cheers,
Joe

pyjamashark (pyjamashark) wrote :

Just to clarify in system>preferences>sound - if I put all options on autodetect and press 'test sound' I hear a crackling/static sort of noise, the same if I change sound playback to ALSA or pulseaudio. However if sound playback is changed to OSS I hear a perfect test tone.

I have tried the methods described here: HOWTO: PulseAudio Fixes (distilled) - *Updated, Call For Testing!* - http://ubuntuforums.org/showthread.php?t=866965 which it seems Luke you're involved with. Alas this has not helped at all.

Anyone please help? Especially Luke, you seem to know what you're doing. I'm currently using a dell inspiron 1525 - the ones dell ship with ubuntu preinstalled so I imagine this could potentially effect quite a few ubuntu users!

Thanks,
Joe

Hakana Snow (aaron-ash428) wrote :

Okay, I've had this exact same problem sprout up seemingly randomly. Pulseaudio was working fine for everything, even able to divert streams to a bluetooth headset until suddenly everything was just this static like, crackly sound. Even the system sounds at startup.

Anyway, I found buried deep in a thread this very simple fix:

{ Originally Posted by psyke83
EDIT: My apologies. I thought I was replying to the Hardy thread.

It seems a lot of users are having problems with the PCM mixer erroneously being set to 0 or muted.

Check the volume levels:

In terminal: $ alsamixer -Dhw
}

Anyway, that was the case for me. PCM was set to 0. I set it up to 100 and then pressed esc. After that all audio is working again without a hitch.

ggonzar (ggonzar) wrote :

I have tried several configuration, reinstall software, etc... and I found a problem with gdm sound player (/usr/lib/gdmplay). This script plays the GDM login prompt sounds

When I configure the GDM to play sounds on startup, the default player (/usr/bin/aplay) play de .wav file but not the .ogg file (noise).

Then, I change the default player to /usr/bin/play (SoX package)... This plays the .wav and .ogg sounds correctly but my Rhythmbox hangs (don't play anything). Its something like this /usr/bin/play or the GDM don't free the device. Then I kill pulseaudio (pkill pulseaudio) and restart (pulseaudio -vv ... to see what happens) and my Rhythmbox plays everything, my mixer works correctly.

So, to fix this, I disable the GDM sounds on Startup and everything works ok. Maybe the bug is in GDM integration with the pluseaudio...

Why /usr/lib/gdmplay works correctly in Hardy?

Version: Intrepid amd64 (Upgrade from Hardy)
Kernel: 2.6.27-10-generic
Driver: snd-hda-intel (Realtek ALC861 chipset, Toshiba Satellite A100)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pulseaudio (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers