Race condition in pulseaudio loading for GNOME session

Bug #274124 reported by hudnix on 2008-09-24
164
This bug affects 14 people
Affects Status Importance Assigned to Milestone
alsa-plugins (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned
pulseaudio (Ubuntu)
High
Unassigned
Intrepid
High
Unassigned

Bug Description

Sound card is onboard VIA 8237. Sound no longer works after latest Intrepid kernel upgrade. The card is recognized, the kernel module loads, just no sound. Tried using PulseAudio, ALSA, and OSS. Output of alsa-info.sh script is at http://www.alsa-project.org/db/?f=297f0693e2211aa72e929d66ba2c526fa9e31075.

hudnix (hudnix-gmail) wrote :

Forgot to add: running pulseaudio in a terminal gives the following:

chris@monarch:~$ pulseaudio
W: ltdl-bind-now.c: Failed to find original dlopen loader.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0

Adam Guthrie (ispiked) wrote :

The upgrade broke me as well. Here's the output of my alsa-info.sh script: http://www.alsa-project.org/db/?f=9f2b389b4571507ddefb8f383690ffe380b66177.

I also get the same message when running the `pulseaudio' command.

Adam Guthrie (ispiked) wrote :

I'm pretty sure this was caused by this change to the pulseaudio package on 2008-09-24:

* debian/pulse.conf, debian/pulse-alsa.conf. Asoundrc configuration files
    to allow the use of pulseaudio as the default output for applications

I fixed the problem by choosing "PulseAudio Sound Server" for all the options except the "Default Mixer Track" in System > Preferences > Sound (gnome-sound-properties). I haven't checked if things will remain fixed after a restart yet, however.

Can you please test the package for your architecture found here: http://www.themuso.id.au/ubuntu/alsa-plugins.

The problem is nothing to do with the kernel, but the pulseaudio plugin for alsa. Other people have experienced similar symptoms, and I believe I have tracked it down. If you could plesae test this package and report back, that would be much appreciated.

Thanks.

Tried it. The patch doesn't seem to help. I've rebooted, and tried
pretty much every possible combination of alsa/pulseaudio/oss sound
settings. Still no sound.

--
Many are stubborn in pursuit of the path they have chosen, few in
pursuit of the goal. - Nietzsche
To the man who only has a hammer in the toolkit, every problem looks
like a nail. -Maslow
Strategy without tactics is the slowest route to victory. Tactics
without strategy is the noise before defeat. - Sun Tzu

I've got the same issue, and the libasound2-plugins update didn't solve the issue.

Changed in pulseaudio:
importance: Undecided → High
status: New → Confirmed
Emilio Pozuelo Monfort (pochu) wrote :

...but downgrading to libasound-plugins 1.0.17-0ubuntu2 fixed it.

DataPath (compenguy) wrote :

Could you post some steps for how to do that downgrade? Or at the very least, someplace that has the deb for it? Googling didn't turn up that deb file anywhere.

ginnyh532 (ginnyh532) wrote :

I'm having the same problem. When I ran the command pulseaudio in terminal, I got
ginny@ginny-desktop:~$ pulseaudio
W: ltdl-bind-now.c: Failed to find original dlopen loader.
E: pid.c: Daemon already running.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
E: socket-server.c: bind(): Address already in use
E: module.c: Failed to load module "module-esound-protocol-unix" (argument: ""): initialization failed.
E: main.c: Module load failed.
E: main.c: Failed to initialize daemon.
E: pid.c: PID file '/tmp/pulse-ginny/pid' not mine!

I'm using an Intel onboard sound card, 82081G(ICH7 Family)

Ewan Dunbar (ewan-dunbar) wrote :

Hi Luke -
This patch works fine for me.

For those of you who have tried the test package and found that things still don't work, please try the following:

1. SHut down/kill pulseaudio. This can be done either by running "killall pulseaudio" or "pulseaudio -k", the latter probably being more full-proof.
2. Delete all .pulse related files from your home directory, "cd ; rm -r .pulse*" should do the trick.
3. YOu can either log out and back in, reboot, or restart pulseaudio with "pulseaudio -D --log-target=syslog"

Then try playing audio as you have previously and let me know the results.

Thanks.

After I installed the update and followed your directions, I got the following in my syslog:

Sep 28 19:12:41 ginny-desktop pulseaudio[19323]: ltdl-bind-now.c: Failed to find original dlopen loader.
Sep 28 19:12:41 ginny-desktop pulseaudio[19325]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Sep 28 19:12:41 ginny-desktop pulseaudio[19325]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted

I still have no sound. I hope this helps.

On Mon, Sep 29, 2008 at 11:22:09AM EST, ginnyh532 wrote:
> After I installed the update and followed your directions, I got the
> following in my syslog:
>
> Sep 28 19:12:41 ginny-desktop pulseaudio[19323]: ltdl-bind-now.c: Failed to find original dlopen loader.
> Sep 28 19:12:41 ginny-desktop pulseaudio[19325]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
> Sep 28 19:12:41 ginny-desktop pulseaudio[19325]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted

This is not anything to worry about.

> I still have no sound. I hope this helps.

What did you do to attempt to play sound, and what errors if any, did you get?

Could you try going to System, Preferences, and choose sound, and attempt to test the sound output options there, when they are set to either PulseAudio or ALSA?

Thanks.

Luke

I checked the sound by starting up the game Gweled. The last time I had problems - with the system sounds - it worked even though the logout and other system sounds didn't. Now none of my games have sound.

I also checked system > preferences > sound again, like you asked. I don't get sound even if I put the settings to pulseaudio or alsa. I don't get any errors - I just don't get any sound. (My volume control is set to its normal level, so I get a bit of crackling.)

Thank you -

Ginny

On Mon, Sep 29, 2008 at 12:25:45PM EST, ginnyh532 wrote:
> I checked the sound by starting up the game Gweled. The last time I had
> problems - with the system sounds - it worked even though the logout and
> other system sounds didn't. Now none of my games have sound.
>
> I also checked system > preferences > sound again, like you asked. I
> don't get sound even if I put the settings to pulseaudio or alsa. I
> don't get any errors - I just don't get any sound. (My volume control
> is set to its normal level, so I get a bit of crackling.)

If you have the pavucontrol package installed, I suggest you run pavucontrol and see what output pulseaudio is using by default. If you could also give me the contents
of your /proc/asound/cards that would also be much appreciated. I suspect your system has more than one sound device, and the sound card you want to use is not set as
the default.

Thanks

Luke

The output I got from /proc/asound/cards is:
ginny@ginny-desktop:~$ cat /proc/asound/cards
 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xcfe3c000 irq 16

When I ran pavucontrol, I got a volume control for one output device: ALSA PCM on front:- (ALC888 Analog) via DMA with no input devices listed.

I made sure the tab for all output devices was selected.

Ginny

Do you have any .asoundrc files in your home directory? If so, try moving them away, or if you don't want them any more, delete them.

This is interesting, as if you get no error then the package I linked to worked, but you still don't get any sound. Could you check syslog at the time you play a file say with rhythmbox or totem, and tell me if you see anything?

Thanks.

There was no .asoundrc file in my home directory.

Here is my syslog output for when I tried to play a song using rhythmbox.

Sep 28 22:41:00 ginny-desktop pulseaudio[26159]: ltdl-bind-now.c: Failed to find original dlopen loader.
Sep 28 22:41:00 ginny-desktop pulseaudio[26161]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Sep 28 22:41:00 ginny-desktop pulseaudio[26161]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted

I hope this helps.

On Mon, Sep 29, 2008 at 02:49:23PM EST, ginnyh532 wrote:
> Sep 28 22:41:00 ginny-desktop pulseaudio[26159]: ltdl-bind-now.c: Failed to find original dlopen loader.
> Sep 28 22:41:00 ginny-desktop pulseaudio[26161]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
> Sep 28 22:41:00 ginny-desktop pulseaudio[26161]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted

Does this happen every single time you try and play something through pulseaudio? If so, there is something else on your system that is not set correctly. With the package I linked to above, on a fresh install, I can use rhythmbox through pulseaudio or alsa without any issues.

Thanks for helping to troubleshoot this further.

Luke.

Luke Yelavich wrote:
> For those of you who have tried the test package and found that things
> still don't work, please try the following:
>
> 1. SHut down/kill pulseaudio. This can be done either by running "killall pulseaudio" or "pulseaudio -k", the latter probably being more full-proof.
> 2. Delete all .pulse related files from your home directory, "cd ; rm -r .pulse*" should do the trick.
> 3. YOu can either log out and back in, reboot, or restart pulseaudio with "pulseaudio -D --log-target=syslog"

This made the trick for me. I guess it was ~/.pulse*, as the other time I tried
it I did the other steps, but not the 2.

Thanks!

Well, it didn't work for me.

I had opened a bug report, this one:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/275166

It was tagged as a duplicate of this one, but I'm not sure it is.

In my case, the sound IS working. It only works through the speakers, NOT through the USB headphones !

It's as the headphones were detached. But they're there ! The USB microphone IS working, and that's a set headphones/mike it's ONE peripheral only !

Thanks for any help
Catonano

cato (catonano) wrote :

Sorry, I didn't test the libasound package indicated by Luke, so the removing of the .pulse* files from the home dir is not supposed to produce effects.

Sorry again.

Still, is the libasound package supposed to heal my headset issue ?

Thanks
Catonano

cato (catonano) wrote :

Well, I tried to install the libasound plugins for my architecture and the resukt is that libasound2 is NOT installed on the machine and the plugins package depends on that so it can not be installed.

But I swear the headphone were working until september 25

Thanks
Bye
Catonano

hudnix (hudnix-gmail) wrote :

Deleting ~/.pulse* didn't help. I even created a new user account to test, with the same results.

The device listed in Sound Preferences and pavucontrol is: Alsa PCM on front:0 (VIA 8237) via DMA
I think this business with front:0 has something to do with it. I do not recall ever seeing that in my sound configuration before this round of updates.

Luke, if it would help. I would be happy to provide ssh access to the box.

Various Outputs (note invalid ctl front:0):

chris@monarch:~$ cat /proc/asound/cards
 0 [V8237 ]: VIA8237 - VIA 8237
                      VIA 8237 with ALC658D at 0xe400, irq 22

chris@monarch:~$ pulseaudio -k
W: ltdl-bind-now.c: Failed to find original dlopen loader.
chris@monarch:~$ pulseaudio
W: ltdl-bind-now.c: Failed to find original dlopen loader.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0

ginnyh532 (ginnyh532) wrote :

I have now gotten my sound to work. I had to:
1) do a clean re-install.
2) install the test file linked to above.
3) rm -r .pulse*
4) kill pulseaudio (pulseaudio -k).
5) restart pulseaudio.

2 - 5 I'm sure you recognize.

Thank you.

 affects ubuntu/pulseaudio
 status invalid

 affects ubuntu/alsa-plugins
 status inprogress

Changed in pulseaudio:
status: Confirmed → Invalid

This bug was fixed in the package alsa-plugins - 1.0.17-0ubuntu4

---------------
alsa-plugins (1.0.17-0ubuntu4) intrepid; urgency=low

  * Revert commit b05f0176d1427586e411a91cda02a8877c5c8c0d from alsa-plugins
    git. This commit enabled the pulseaudio alsa plugin to use 32-bit sample
    lengths via PulseAudio, however PulseAudio 0.9.10 in Intrepid doesn't
    support these sample lenths in its API. This resulted in gstreamer
    applications failing to play audio with an error, when attempting to use
    pulseaudio output via the alsa pulseaudio plugin. It was also breaking
    SDL applications/games that were using SDL's ALSA output. (LP: #274124)

 -- Luke Yelavich <email address hidden> Tue, 30 Sep 2008 13:44:03 +1000

Changed in alsa-plugins:
status: In Progress → Fix Released
Emilio Pozuelo Monfort (pochu) wrote :

I keep having problems after every reboot, with libasound2-plugins 1.0.17-0ubuntu4.

If, after boot, I do:
$ pulseaudo -k
$ rm -r ~/.pulse*

Then sound works fine.

Note that the login sound works fine after boot, but others (GStreamer apps) don't. Perhaps it's not pulseaudio's fault but GStreamer, or perhaps pulseaudio broke compatibility...

Iain Lane (laney) wrote :

I see the same symptoms as pochu (except that I don't need to remove .pulse* to make things work), and additionally I can never multiplex flash audio with other apps. I don't know much about the audio stack to provide any further insights.

Playing flash audio always seems to require me to kill PA to get PA apps to work again, and while they're running flash will be silent, but when none of them are open flash will work again. Wow, that was a difficult sentence. Example:

1. Boot computer, hear GDM jingle
2. Log in, get login sound
3. Play song in Banshee, no audio
4. Restart PA, restart Banshee, audio
5. Play flash video, no audio
6. Close Banshee, play flash video, audio
7. Start banshee, back at #3

Note that if I decide to play a flash video first, the above will jump to #6 after #2, but otherwise will be the same.

Is this part of the same bug?

Iain Lane wrote:
> I see the same symptoms as pochu (except that I don't need to remove
> .pulse* to make things work)

I haven't tried just killing pulseaudio, I'll try next time.

The released package hasn't fixed the problem for me. Even after running "pulseaudio -k ; rm -rf ~/.pulse* ; pulseaudio -D --log-target=syslog", the sound output is still nothing but static. Rhythmbox, the Sound Preferences test, the GDM login sound, everything.

太和 (tayhe) wrote :

i can confirm this problem:
when i input pulseaudio and press enter button in the console, something like this emerged:
ping@ping-desktop:~$ pulseaudio &
[1] 7159
ping@ping-desktop:~$ W: ltdl-bind-now.c: Failed to find original dlopen loader.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM front:0
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM surround40:0
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM surround41:0
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM surround50:0
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM surround51:0
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM surround71:0
ALSA lib pcm_hw.c:1429:(_snd_pcm_hw_open) Invalid value for card
E: alsa-util.c: Error opening PCM device hw:0: No such file or directory
E: module.c: Failed to load module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_8086_27d8_alsa_playback_0"): initialization failed.
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM front:0
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM surround40:0
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM surround41:0
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM surround50:0
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM surround51:0
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM surround71:0
ALSA lib pcm_hw.c:1429:(_snd_pcm_hw_open) Invalid value for card
E: alsa-util.c: Error opening PCM device hw:0: No such file or directory
E: module.c: Failed to load module "module-alsa-source" (argument: "device_id=0 source_name=alsa_input.pci_8086_27d8_alsa_capture_0"): initialization failed.

nwm (noah-mcilraith) wrote :

I have been experiencing a similar if not the same problem.

It seems as though pulseaudio isn't using the soundcard as a sink (where audio goes into), its also worth noting that it still detects my microphone and uses that as a source, which works fine.

Load up paman and take a look at anything related to Sinks. Perhaps this has something to do with the problem.

While frigging around with getting it to work something managed to mute alot of volume controls, so check that occasionally.

ktp420 (ktp420) wrote :

For all the people whose sound is not working, are you on 64-bit or 32-bit?

32

2008/10/5 ktp420 <email address hidden>

> For all the people whose sound is not working, are you on 64-bit or
> 32-bit?
>
> --
> Sound no longer working after kernel upgrade to 2.6.27-4
> https://bugs.launchpad.net/bugs/274124
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in "alsa-plugins" source package in Ubuntu: Fix Released
> Status in "pulseaudio" source package in Ubuntu: Invalid
>
> Bug description:
> Sound card is onboard VIA 8237. Sound no longer works after latest Intrepid
> kernel upgrade. The card is recognized, the kernel module loads, just no
> sound. Tried using PulseAudio, ALSA, and OSS. Output of alsa-info.sh script
> is at
> http://www.alsa-project.org/db/?f=297f0693e2211aa72e929d66ba2c526fa9e31075
> .
>

--
La difesa più sicura contro il male è l'estremo individualismo,
l'originalità di pensiero, la stravaganza, perfino, se volete,
l'eccentricità… Il male va matto per la solidarietà.

Less than one di Joseph Brodsky

ktp420 wrote:
> For all the people whose sound is not working, are you on 64-bit or
> 32-bit?
>

32

Mine is 32 bit. Sound is working for me intermittently with pulseaudio.
1. While playing a movie with totem every now and then the movie becomes very slow with no sound for 2-3 seconds. Then it comes to normal speed.
2. While playing songs with rhythmbox some frames are dropped and I can clear know that song got cut.

And the problem of pulseaudio dying is also present after which I have to kill totem or rhythmbox and kill pulseaudio with -k. Sound card chipset is VIA 8237.
Could this be some problem related to buffer overruns?

covox (covox) wrote :

32-bit here. There's only one sound device in /proc/asound/cards , one soundcard sink (alsa_output.pci_8086_27d8_alsa_playback_0), all the volume sliders and mute buttons are set in pavucontrol, and generally it appears as if PulseAudio was running without any speakers plugged in. Except OSS works, so clearly there's something amiss.

Actually, when running pavucontrol from the command line, playing with the volume sliders generates a whole pile of the following error:
** (pavucontrol:7129): DEBUG: blah: alsa_output.pci_8086_27d8_alsa_playback_0
** (pavucontrol:7129): DEBUG: -5 = No such driver

Could everybody please drop the attached file into /usr/bin, making sure its name esdcompat stays the same. This will overwrite an existing file there.

The change i've made is to prevent pulseaudio from playing whil the login sound is also playing.

Please let me know if this works for you.

Luke

No change alas. There's still weird static in the place of the login sound, and no music playback.

Maddeningly, the new beta LiveCD has working PulseAudio. Since purging and installing every package with "pulse" in the name didn't work, I'm tempted to write off this installation as "cursed" and reinstall Ubuntu again.

I got it working! I deleted just about every dot file in my home directory
:). I think getting rid of the .dbus directory was what finally did it. I
still have no idea why logging into a newly created account results in no
sound...

Using the patched esdcompat script seemed to do the trick- thanks! I can now play audio through SDL (which I couldn't before).

FWIW - i'm using the automatic login feature of GDM so if that patch was working around a race condition (as it looks) then that might help explain things.

$ lspci | grep audio
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)

Relevant lines of syslog:

Oct 7 22:15:53 piano pulseaudio[7647]: ltdl-bind-now.c: Failed to find original dlopen loader.
Oct 7 22:15:53 piano pulseaudio[7647]: pid.c: Stale PID file, overwriting.
Oct 7 22:15:53 piano pulseaudio[7647]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Oct 7 22:15:53 piano pulseaudio[7647]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
Oct 7 22:15:54 piano pulseaudio[7647]: alsa-util.c: Error opening PCM device hw:0: Device or resource busy
Oct 7 22:15:54 piano pulseaudio[7647]: module.c: Failed to load module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_8086_266e_sound_card_0_alsa_playback_0"): initialization failed.

Daniel T Chen (crimsun) on 2008-10-07
Changed in pulseaudio:
status: Invalid → In Progress

Ok. Can everybody please run the following command? It disables the event sounds, as I want to see if audio problems still remain if there is no login sound:
$ gconftool-2 -s -t bool /desktop/gnome/sound/event_sounds false

Please try the above and report back.

Adam Collard (adam-collard) wrote :

Reverting to standard esdcompat script and disabling event sounds also works

Hi. Could people please put the attached file into /etc/xdg/autostart. Its a desktop file to launch pulseaudio. With this addition, you need not worry about the file I attached previsouly, as that has already proved to not be helpful for some people.

So please try the attached file and let me know whether thigns are still broken for you.

Luke

Yes, as I forgot to attach it.

Here it is.

Yes, that's working. I put it in /etc/xdg/autostart and tested it with a reboot.
Perfect! Thanks, Luke!

On Wed, Oct 08, 2008 at 07:17:47PM EST, Markus Ortel wrote:
> Yes, that's working. I put it in /etc/xdg/autostart and tested it with a reboot.
> Perfect! Thanks, Luke!

Is that with sound events enabled/you hear the login sound play? if so, thats wonderful.

If others could please try the above and get back to me, I can get a fix uploaded much sooner.

Am Mittwoch, den 08.10.2008, 15:34 +0000 schrieb Luke Yelavich:
> On Wed, Oct 08, 2008 at 07:17:47PM EST, Markus Ortel wrote:
> > Yes, that's working. I put it in /etc/xdg/autostart and tested it with a reboot.
> > Perfect! Thanks, Luke!
>
> Is that with sound events enabled/you hear the login sound play? if so,
> thats wonderful.
>
> If others could please try the above and get back to me, I can get a fix
> uploaded much sooner.
>

Yes, Luke. Login Sound plus sounds in Totem, flash movies and streaming
in Rhythbox.

:-)

Confirmed that the .desktop file does the trick here too. Event sounds, Rhythmbox and SDL all making the noises they should be!

sam tygier (samtygier) wrote :

the desktop file in /etc/xdg/autostart solves the issue for me. login sound and totem works now.
i am amd64
sam@oberon-test:~$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 631xESB/632xESB High Definition Audio Controller (rev 09)
08:00.1 Audio device: ATI Technologies Inc RV635 Audio device [Radeon HD 3600 Series]
sam@oberon-test:~$ cat /proc/asound/cards
 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xd0600000 irq 16
 1 [HDMI ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xd0210000 irq 17

Autodetecting sound does not work, but can manually change to OSS... however, the sound is cracked and bad!

Oleksij Rempel (olerem) wrote :

/etc/xdg/autostart worked around my problem too. ThinkPad T43
cat /proc/asound/cards
 0 [ICH6 ]: ICH4 - Intel ICH6
                      Intel ICH6 with AD1981B at irq 22
 1 [U0x46d0x991 ]: USB-Audio - USB Device 0x46d:0x991
                      USB Device 0x46d:0x991 at usb-0000:00:1d.7-3.1, high speed

covox (covox) wrote :

No change after adding pulseaudio.desktop to /etc/xdg/autostart for me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 0.9.10-2ubuntu8

---------------
pulseaudio (0.9.10-2ubuntu8) intrepid; urgency=low

  * debian/pulseaudio.desktop: Use a slightly modified version of the
    pulseaudio desktop file from more recent versions, and place it in
    /etc/xdg/autostart, to start pulseaudio earlier in the GNOME desktop
    initialization. This should avoid a race condition between the login
    sound being played, and pulseaudio being loaded. (LP: #274124)

 -- Luke Yelavich <email address hidden> Fri, 10 Oct 2008 15:22:51 +1100

Changed in pulseaudio:
status: In Progress → Fix Released
Iain Lane (laney) wrote :

I still had to killall pulseaudio to get Banshee to work with this update :(

Onkar Shinde (onkarshinde) wrote :

This update does not fix problem with me. Totem still slows down or freezes up. Same problem with rhythmbox. Everything works fine with ALSA output.

Onkar Shinde schrieb:
> This update does not fix problem with me. Totem still slows down or
> freezes up. Same problem with rhythmbox. Everything works fine with ALSA
> output.
>

I made fresh install on one of my systems and get same proble like you
describe: 1. no sound 2. video playslowdown.
Strange is that you can play alsa.. my alsa didn't worked. Package was
uptodate. This was not this bug.

Solutution was really simple: add user to the audio group

$sudo addgroup `whoami` audio

Now every think working just fine.

At least three of us are still seeing this symptom in current 8.10.

Changed in pulseaudio:
status: Fix Released → Confirmed

On Sat, Oct 11, 2008 at 06:47:16AM EST, Iain Lane wrote:
> I still had to killall pulseaudio to get Banshee to work with this
> update :(

Is it just banshee that exhibits this problem, or do other audio applications also fail to function correctly?

Iain Lane (laney) wrote :

It's not unique to Banshee, just that that's the media player I use so it's where the bug crops up for me.

Ok, those of you still experiencing this race condition, please do the following:

1. Move /etc/xdg/autostart/pulseaudio.desktop out of the way, i.e so it doesn't exist in that directory.
2. Place the attached 70pulseaudio file in /etc/X11/Xsession.d.
3. Place the attached pulse-session file into /usr/bin, and chmod it 755.

Then log in again, and let me know the results.

With the above steps, I am attempting to move the pulseaudio startup even further back in the X login procedure, to give it more time to settle before the startup sound plays, and so pulse is more or less ready when GNOME's sound support from gnome-settings-daemon is loaded.

Please get back to me ASAP, so I can get an upload in before release freeze.

Thanks

Luke

 affects ubuntu/pulseaudio
 status incomplete

Changed in pulseaudio:
status: Confirmed → Incomplete
Steve Langasek (vorlon) wrote :

Luke, from that description it sounds like you haven't addressed the race condition itself (that pulseaudio fails miserably if something else has the sound device open when it starts up), you've only reduced the risk of hitting the race?

Steve Langasek (vorlon) wrote :

I've tested starting pulseaudio via X11/Xsession.d instead of via xdg startup dirs, and it did fix the problem for me at least on this round - but I'm not convinced it's a robust fix for the problem.

Daniel T Chen (crimsun) wrote :

Forgot to mention yesterday that I also tested the most recent proposed workaround, and I haven't been able to trigger the race yet.

I need to mention that in my case, the only times when I could trigger the race were due to the login sound (via canberra-gtk-play) grabbing the sound device during session login prior to pulseaudio having attempted to load module-alsa-sink/source. Because intrepid's pulseaudio daemon (0.9.10) does not actually fail catastrophically in that case, the workaround listed above by various people (pulseaudio -k ; pulseaudio -D) rectifies the problem. However, it is clearly manual and therefore suboptimal.

I'm willing to poke at this for an 8.10.1 milestone or later (but not for 9.04, since that will go directly to pulseaudio 0.9.13, which has a different workaround), but properly resolving the race for 0.9.10 involves having the daemon queue the data upon failure (really, PA_STREAM_FAILED), retry/poke the sink/source after some time, reset the stream state, and process the data. Adding such a fix is pretty invasive this close to release, so I propose we just add Luke's most recent workaround for 8.10.

Iain Lane (laney) wrote :

I'm away from my home machine and therefore unable to test the proposed fix. Based on Daniel's experience, I suggest that it be uploaded anyway. It seems that the chance of regressions being introduced is slim. If I find that the issue is still present (which I strongly hope I do not), I wonder if it'd be worth putting in the release notes.

I shall be able to test tomorrow or Saturday anyway.

Steve Langasek (vorlon) on 2008-10-17
Changed in pulseaudio:
milestone: none → ubuntu-8.10
status: Incomplete → Confirmed
Iain Lane (laney) wrote :

Looks good. Please upload :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 0.9.10-2ubuntu9

---------------
pulseaudio (0.9.10-2ubuntu9) intrepid; urgency=low

  * debian/70pulseaudio && debian/pulse-session: Use a wrapper script
    to start pulseaudio at the Xsession.d phase of the login process.
    The wrapper script is necessary to execute processes that need to
    be loaded after pulseaudio, such as the X session manager. This
    works around a race condition involving pulseaudio and canberra-gtk-play
    and the GNOME login sound. (LP: #274124)
  * debian/pulseaudio.preinst: Remove /etc/xdg/autostart/pulseaudio.desktop
    if it exists. We don't want pulseaudio started more than once.

 -- Luke Yelavich <email address hidden> Mon, 20 Oct 2008 13:26:28 +1100

Changed in pulseaudio:
status: Confirmed → Fix Released
Sergio Schneider (spsf) wrote :

Still does not work :(
Only the drumroll and login sound, none of "Alerts an Sound Effects" (window minimize/maximize, button clicked, etc...) wont work at all
Please fix this before the RC/Final

ktp420 (ktp420) wrote :

my Alerts an Sound Effects/Windows and Buttons section in System/Preferences/Sound is not enabled. It seems this is a different issue than this.

Sergio Schneider (spsf) wrote :

I give up....
I reported this logout sound and "Alerts an Sound Effects" not working everywhere, in IRC (#ubuntu+1), in the forums (http://ubuntuforums.org/showthread.php?t=949777&page=3) and here (https://bugs.launchpad.net/ubuntu/+bug/285549 - this post was merged here as duplicated to this on, however I dont think it is)
Nobody, I mean the developers, seems to care or give right attention to sounds...
If Ubuntu claims to be a desktop oriented OS they should care for this bug, unfortunately that's not the case...
Hope someone else engages in this quest for decent sounds, as I observed, it has been a problem since hardy, what a shame...
If you want to see/hear how Gnome 2.24 should behave, check all the sounds WORKING in Mandriva 2009.
Regards

Sergio Schneider (spsf) wrote :

Well, I found a solution myself, at least for "Alerts and Sound Effects"
I found this page: https://launchpad.net/~gkulyk/+archive with the latest libcanberra 0.10 (the one used in intrepid is outdated 0.6).
I included the line: "deb http://ppa.launchpad.net/gkulyk/ubuntu intrepid main" in synaptic and reloaded. Immediately the new 0.10 showed up as an upgrade, marked all upgrades, and rebooted.
WOW!! All the "Alerts and Sound Effects" working 100%!! Clicks, Buttons, Errors, etc...
Just had to manually select some windows minimize/maximize sounds and everything is ok now!
Just one minor problem, the logout sound still not working :(
Hope it helps!
Regards

Jeremy (jdforsythe) wrote :

Using 0.9.10-2ubuntu9 and still having problems.

Playing youtube videos has started locking up randomly so that I have to kill firefox and remove it's .lock and .parentlock files from ~/.mozilla/firefox/xxx.default to get firefox to open again. Once this happens firefox refuses to load my bookmarks and I have twice had to copy my profile folder to a different location and point ~/.mozilla/firefox/profiles.ini to the new location, then it loads correctly. Renaming the folder didn't fix it, I had to copy it... I believe this is related to the pulseaudio problem because when that happens the audio breaks again. If I killall pulseaudio and restart it, the sound works fine again until the flash video locks up.

If I kill X and login again pulseaudio isn't broken like it used to be with prior versions. Only after the problem with flash do i have to kill it and restart. This leads me to believe that the login sounds aren't the only thing having a problem with pulseaudio.

I'm using VIA onboard sound with up-to-date Intrepid. I'm not sure how to capture the error when flash is locking up so if someone can point me to the right command I'll get that info. When the audio is broken, totem gives the following error on the command-line:

** Message: Error: Failed to connect stream: Invalid argument
pulsesink.c(634): gst_pulsesink_prepare (): /GstPlayBin:play/GstBin:abin/GstBin:audiosinkbin/GstGConfAudioSink:audio-sink/GstBin:bin4/GstAutoAudioSink:autoaudiosink1/GstPulseSink:autoaudiosink1-actual-sink-pulse

When I kill pulseaudio and restart this is the output:

jdf@jdf-desktop:~$ sudo killall pulseaudio
jdf@jdf-desktop:~$ pulseaudio
W: ltdl-bind-now.c: Failed to find original dlopen loader.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
W: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0

When the audio locks up, I will click play on the video and it will play 2 seconds of video (both times it has been 2 seconds) without audio, then it freezes and I have to kill firefox.

I hope this helps.

Savvas Radevic (medigeek) wrote :

Hm.. to all OSS users, (Realtek etc) - and to all those who just don't know, but want to try and make it work, try execute this command:

sudo apt-get install --reinstall oss-preserve psemu-sound-oss oss-compat alsa-oss alsa-tools alsa-firmware-loaders alsa-base alsa-utils
sudo adduser $USER audio
sudo adduser $USER pulse
sudo adduser $USER pulse-access
sudo adduser $USER pulse-rt

(One of the above packages made it work for me, I don't know which one or ones)
- When it's done installing/reinstalling, log out and log back in
- Go to System > Preferences > Sound, you should see new "ALSA ... Analog (OSS)" in the drop down lists - choose the last analog (oss) item mentioned in each list.
- For "Device:" choose the "Alsa mixer"

Now press Close and reboot your machine (yes, restart!).

Log in again, and execute this command to open the volume control:
gnome-volume-control

Choose in the device "Alsa mixer"
If you see a PCM section in the volume control, raise its volume.
If you don't see it, click "Preferences" and make sure "PCM" is checked there.

This should hopefully enable you to listen to flash movies audio and local audio until pulseaudio is fixed :)

Despite the solution for the bug, still remains a interesting problem when the volume of PCM is muted, returning the cracking sound when audio is used. I think its not a new bug, so no creating a new thread for it.

Changed in pulseaudio:
status: Fix Released → In Progress
Steve Langasek (vorlon) wrote :

francisofabian,

"cracking sounds" are not a symptom of this bug. Please open a separate bug report for your unrelated issue.

Changed in pulseaudio:
status: In Progress → Fix Released

Just to record another observation: the replacement esdcompat is important, even if it doesn't fix the problem. I left it out because users reported that is doesn't solve the problem and went on with the other proposed solutions. That didn't help. So I installed the esdcompat replacement and after a reboot I got sound working.

matt s (matt-smalley) wrote :

Started with Hardy x64, then upgraded to Intrepid. Audio has always worked fine. Then I installed kde and upon logging in would get an error to the effect of "your intel alc888 audio device doesn't work; falling back to default". Got it working by following the instructions here:

http://forumubuntusoftware.info/viewtopic.php?f=43&t=1640&sid=c2f2b5d973e8b2248d0793a4ffaede1c

but some of the package names have changed so there was some fiddling involved. Also sometimes when starting up pulse I had to go in to the volume controls and unmute the device. I haven't gotten 5.1 working yet though; when I tried setting default-sample-channels = 6 rhythmbox just locks up when I try to play a song. Not sure that I ever had 6-channel in gnome, though.

Vladimir Hidalgo (vlad88sv) wrote :

I can't get my V8237 working :(

I've tried every suggested solution and it still does not work :\

Running Intrepid/2.6.27-11-generic on a Biostar U8668-D Motherboard.

Joel Aelwyn (fenton) wrote :

On my system:

1) The login sound doesn't play either.

2a) It started only *after* an upgrade of pulseaudio (currently 0.9.10-2ubuntu9.3).

2b) As far as I can tell, it didn't start *right* after that upgrade, so the upgrade may or may not have had anything to do with triggering the situation.

3) It is, so far, consistent about not playing sounds (not "sometimes login" or "sometimes works fine"; it stopped working, and hasn't worked since).

So I'm not entirely certain that it is the same bug, but I haven't made any other changes to the audio subsystem recently, only kept up to date on standard intrepid packages. But something recent has triggered either this, or a very similar problem.

I'll work on obtaining more details, but since it is my work laptop, the priority of getting sound working isn't terribly high (or at least, difficult to excuse making high).

Vladimir Hidalgo (vlad88sv) wrote :

I tried an old disk of Kubuntu 7.10 that I had around there, I tried it live but there was not sound.

Luke Yelavich (themuso) wrote :

Vladimir, your issue doesn't appear to be the same as what this bug is about, could you please file another bug about your issues with sound in Kubuntu?

Thanks.

Vladimir Hidalgo (vlad88sv) wrote :

Oh, but my problem is exactly as described in the first post and I'm using Intrepid. I was just commenting that I tried too with a Kubuntu 7.10 CD to see if sound was functional at that version.

So, my soundcard is a V8237, it's detected and appears in the "aplay -l" list. Everything _seems_ fine but there's not sound. I think is the same issue, but if you still think that I should open a new bug ticket then please let me know.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers