Ubuntu

Dell XPS 1330 microphone not sensitive enough

Reported by mike hancock on 2008-08-25
70
This bug affects 11 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by alexsimps

Bug Description

I am running a dell xps 1330 (pre-installed ubuntu) with Hardy. When using both the internal or the external microphone the recording is 'too soft'. in the sound mixer app, there is not option to set "Mic Boost(+200 db)" like there normally is when one has a microphone. If you need any more information please let me know

Mario Limonciello (superm1) wrote :

Use the digital mic instead. Be sure to turn up the digital mixer if you are having troubles (it's hidden by default, but can be turned up)

Changed in dell:
status: New → Won't Fix
mike hancock (javaiscoolmike) wrote :

the digital mic option is turned up all the way. but it it still not sensitive enough. it does 'work'. but I have to yell use it with ekiga. why is this set to won't fix?!

Changed in dell:
status: Won't Fix → Incomplete
mike hancock (javaiscoolmike) wrote :

if you need more information about my system please let me know. I really want this to get fixed.
thanks

Treris (treris) wrote :

I can subscribe to this, digital is all the way, I've been fiddling with a lot of settings and I can get the microphone to work, but it's just too soft, even if I scream it barely moves the pulseaudio volume meter (capture). I could really use that 20db boost here somehow.

mike hancock (javaiscoolmike) wrote :

I am now using intrepid beta and this is still a problem with the internal mic. but the external mic(analog input i think??) now works correctly. in hardy _both_ were not sensitive enough

Treris (treris) wrote :

I was kinda hoping that intrepid would fix this problem, but apparently not, a real shame.

mike hancock (javaiscoolmike) wrote :

it's a real shame that this was even a bug in the first place! I bought the dell-ubuntu laptop expecting there to be almost no hardware issues, and I have had quiet a few. my wife says "I like the old laptop better." nows thats a shame! I wanted to show her how user friendly Ubuntu could be. We have had issues with wifi, suspend/resume, the microphone, the brightness buttons,etc. It is hard to believe that this is a Ubuntu-preinstalled laptop with all these issues! All that said things are getting _much_ better for me in Intrepid beta :) ; this is one of the few issues(hardware issues that is) i still have.

Treris (treris) wrote :

I must admit this is just about the only hardware issue I'm having with this laptop, but I did choose to go with the intel graphics and the intel wireless card (the 4965AGN) as they are generally compatible with linux. I've been able to solve my problem by using an external mic under Hardy, but still. I suspect some of the problems with the low volume of the mic to be coming from pulseaudio because before I had skype using pulseaudio the volume, for some reason, was higer, but I couldn't use Skype alongside for instance a media player which isn't real handy either.
My guess would be that somewhere in the code pulseaudio decreases the sensitivity of the mic. If it were a driver problem I'd think that the mic would not be working at all, instead of being too soft.
I must admit that I'm still not convinced that pulseaudio was a step forward for ubuntu.

mabawsa (mabawsa) wrote :

I can confirm this bug on my M1330.

mabawsa (mabawsa) wrote :
Rocko (rockorequin) wrote :

I also have this bug (ie microphone volume is low with the digital sensitivity set to high) in Hardy on my XPS M1530, and there's no 20db boost, but I assumed that was because the audio chip doesn't support it.

The audio output is also low - I have to set master, PCM, and front to max to hear anything.

I have this audio controller:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

280534 is a slightly different issue - the digital sensitivity control doesn't even appear in Intrepid.

I am running intrepid and digital control is there if I run:

alsamixer -Dhw

On Wed, Oct 22, 2008 at 8:47 AM, Rocko <email address hidden> wrote:

> I also have this bug (ie microphone volume is low with the digital
> sensitivity set to high) in Hardy on my XPS M1530, and there's no 20db
> boost, but I assumed that was because the audio chip doesn't support it.
>
> The audio output is also low - I have to set master, PCM, and front to
> max to hear anything.
>
> I have this audio controller:
>
> 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio
> Controller (rev 02)
>
>
> 280534 is a slightly different issue - the digital sensitivity control
> doesn't even appear in Intrepid.
>
> --
> Dell XPS 1330 microphone not sensitive enough
> https://bugs.launchpad.net/bugs/261018
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Dell Project: Incomplete
> Status in Ubuntu: Incomplete
>
> Bug description:
> I am running a dell xps 1330 (pre-installed ubuntu) with Hardy. When using
> both the internal or the external microphone the recording is 'too soft'.
> in the sound mixer app, there is not option to set "Mic Boost(+200 db)"
> like there normally is when one has a microphone. If you need any more
> information please let me know
>

mabawsa (mabawsa) wrote :

OK looked into it a bit and I disabled the pulseaudio system in Intrepid doing the following:
$sudo gedit /etc/X11/Xsession.d/70pulseaudio

# out everything as per Bug #280534 message from Erik Reuter
# If we are loading a GNOME session, load pulseaudio.

#if [ "$BASESTARTUP" = gnome-session -o \
# \( "$BASESTARTUP" = x-session-manager -a \
# "`readlink /etc/alternatives/x-session-manager`" = \
# /usr/bin/gnome-session \) ]; then
# STARTUP="/usr/bin/pulse-session $STARTUP"
#fi

NEXT: System > Preference > Sessions
disable all pulse related stuff

NEXT remove all pulse home directory stuff:
$cd ~
$rm pulse*

NEXT set the sound card to Intel:
$asoundconf set-default-card Intel

NEXT:
$alsamixer
Max everything and enable the digital microphone.

Yay! My microphone is now loud and clear.
Remember to set things like Skype, etc back to the defaults.

This method keeps all the pulse stuff on the computer so once its updated you can reverse the method and try pulse again. I read its also possible to remove pulse using apt-get or synaptics, but when I broke the sound completely. It should also work for hardy but I haven't tried.

Changed in dell:
importance: Undecided → Wishlist
status: Incomplete → Triaged
Jack Deslippe (jdeslip) wrote :

I can confirm this bug on the internal mic on my 1420n laptop after upgrading to intrepid. The recording is extremeley low! I have maxed out just about every setting in alsamixer.

Same thing for me on XPS 1330.

When using alsa only (disabling pulseaudio) the mic works fine (after selecting digital input source = digital mic 1 and maxing the "digital" recording level). With pulseaudio recording works but volume is too low.

Something interesting I noticed is that, when recording through pulseaudio, the volume is not affected by the "digital" level in alsamixer. You can turn digital to 0 and still record with the same (low) volume. I find this strange (for example lowering the master playback level in alsamixer lowers the volume also in pulseaudio). Maybe pulseaudio gets it's input from somewhere else and not from digital? (I'm not an alsa/pulseaudio expert though so I might be missing something)

Jack Deslippe (jdeslip) wrote :

Why is this bug been assigned a priority of "wishlist"? Not being able to use the internal mic on your laptop seems to be more important than the wishlist...

Mario Limonciello (superm1) wrote :

It's set Wishlist on the Dell project because the laptop ships with Ubuntu 8.04 not 8.10. it's fine in 8.04. pulseaudio triagers haven't touched it however.

Treris (treris) wrote :

I'm afraid it's anything but fine in hardy. I first experienced this problem in hardy and it continues on in intrepid, without any fix whatsoever. I'm going to have to agree with jdeslip here and request a higer priority than 'wishlist'

Jack Deslippe (jdeslip) wrote :

Recording worked for me in skype in Hardy at least because skype was not using the pulseaudio alsa plugin (i.e. libasound2-plugins was broken). Recording seems to work fine for me when pulseaudio is not present. Intrepid seems to have fixed libasound2-plugins - so skype output now recognizes pulse, but input has gone to extremeley low volumes. This problem exists even with the latest libasound2-plugins package in proposed repo.

mike hancock (javaiscoolmike) wrote :

I first reported this bug from a fresh dell xps laptop with hardy that had been preinstalled and undated. I don't think this is fine in 8.04. It never worked for me, and i just recently upgraded to intrepid.

can any one confirm that this still does not work in hardy??

why does "dell project" not cover dell bugs in intrepid?!!!!

why is this not clearly stated some where what bugs should go to dell project?? If you want good bug reports make it clear what we should report!

talent03 (talent03) wrote :

I confirm this bug on the m1330. The internal mic and line using pulse audio record at unusable low levels. In Intrepid the internal mic continues recording at low levels, but now the line works perfectly as analog input. If I use only alsa, then everything works as expected. I hope for Intrepid the dell packages fix this bug and not treat it merely as a wishlist, but as a bug that needs to get fixed.

bryanp (bryanp) wrote :

I confirm this bug too. I bought a Dell xps 1330, because of the Dell offers it with ubuntu. Hoping bugs like this will get better priority than wishlist. very low recording volume.

Flavio Tordini (zarlino) wrote :

I can confirm too. Come on Dell guys! Are you going to fix this before my laptop becomes obsolete?

Tom Haddon (mthaddon) wrote :

Also affecting me on a Inspiron 1420N after upgrade to Intrepid.

mike hancock (javaiscoolmike) wrote :

The problem occurs in "Ubuntu 8.04" un-like what Mario Limonciello had said before! Is it rude to just change that priority since it was set based on false claims?

hell the bug was originally reported from "Ubuntu 8.04"(a fresh install/update at that).

I am _really_ surprised/disappointed that more is not done to support the "dell ubuntu" computers.

Binoy (mailbinoyv) wrote :

There is a fix/workaround for this bug. Its mentioned here
http://www.naysaying.com/blog/2008/10/fixing-low-microphone-volume-problem.html

------------------------
   1. Open Application -> Sound & Video -> PulseAudio Device Chooser
   2. Click on the "PulseAudio Applet" on the system tray and open "Manager".
   3. Click on the "Devices" tab, select "alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0.monitor" which is the "Monitor Source of ALSA..."
   4. Click properties and set the volume to maximum (480% on my computer)
--------------------------

Poleh (spam-swaziboy) wrote :

followed the advice in the previous post and it had no effect. See the screenshots but I have two devices listed in teh Devices Tab for sources and only one of them registers any sound when clicking on "Show volume meter". (screenshot2)

The second device (non Monitor one) is the one which shows input volume and detection of sound, but when I try to increase the volume slider it won't go beyond 100% (screenshot1) whereas if I follow the advice on the previous post it can go as high as 400%.

After following the previous post if I have my face right up against the monitor mic and talk quite loudly I can record at a level where I can hear it playing back.

Any further suggestions welcome.

Poleh (spam-swaziboy) wrote :

second screenshot, don't know how to add more than one per post.

Dear All,
I found a workaround for this - it's a hack but it works. Assuming you are running pulseaudio (do 'ps -e | grep pulse', if you get a response then you are running pulseaudio) you can use 'pacmd' to set the level. 'man pulseaudio' is also a useful source of information.

So,, type 'pacmd'. Once inside, 'help' is useful. 'list-sources' will give you info in the sources, and you probably want to do 'set-source-volume 1 150000' to turn up the volume on the built-in microphone. Although I failed to find a configuration file to make this permanent, the setting is retained when the computer re-boots. The only thing to avoid is using the pulseaudio volume control as that will set you back where you started.

An alternative as suggested above is to remove pulse audio, and the gentle method suggested above seems sensible. I took the brutal route of using synaptic to remove everything pulse related, and so far it seems OK. The downside is that you are then faced with a plethora of options and they have to be right! The gnome-volume-control seems to me a bit faulty - the text alamixer is strange but more dependable. If you set the levels on 'capture' and 'digital' to max, and 'digital input source' to 'digital mic', you will probably be in business.

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

Changed in somerville:
importance: Undecided → Wishlist
status: New → Triaged
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305681

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers