Ubuntu

pulseaudio hangs

Reported by ghamar on 2008-05-30
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
PulseAudio
Fix Released
Unknown
linux (Ubuntu)
Low
Daniel T Chen
pulseaudio (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: pulseaudio

I am using a completely updated Hardy Heron. Sometimes (after a few hours use) applications hang, for example (pidgin, firefox). When this happend I tried to restart them. I killed the running firefox and started it again. A new process appeared in the process list but the firefox window didn't showed. I also tried some other programs like terminal and the same happened.

I logged out and started to kill all of the processes that was still running. I realized that pulseaudio can be terminated only with the kill signal. Next time when my applications started to freeze I've just killed pulseaudio and everything started to run.

Glyph Lefkowitz (glyph) wrote :

This happens for me as well.

It is definitely exacerbated by the presence of ALSA applications (in my case: skype, the flash 9 debug player which doesn't work with libflashsupport, the AIR debug runtime).

I have 4 hardy machines I use regularly, one of which was a fresh install and three which were upgraded from gutsy. The ones upgraded from gutsy have all exhibited this problem. However, the one with the fresh install appears not to. It may just be that I haven't tickled the bug there, though.

The wedged applications are always frozen in a "read()" system call on the pulseaudio socket.

Killing the pulseaudio daemon itself (it only responds to -KILL) seems to unfreeze all the wedged applications by allowing those calls to complete. I have not managed to get any useful strace output from pulseaudio itself yet, but this is due to some mistakes on my part, next time it happens I should be able to.

Stibbons (gaetan-xeberon) wrote :

I do have the same issue with hardy and ibex beta. After a few hours of use, the pulseaudio server don't seem able to anwser to request (mplayer hangs on request to open ao_pulse for instance).

A simple 'killall -9 pulseaudio && pulseaudio' works, but this is annoying. I'll post a complete log as soon as I can reproduce it.

Brad Langhorst (brad-langhorst) wrote :

I'm hearing an infinite repeating stutter at about 180Hz, pulseaudio

here's a backtrace
(gdb) bt
#0 0xb7fe5430 in __kernel_vsyscall ()
#1 0xb7c00405 in sem_wait@@GLIBC_2.1 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb7f9ca38 in pa_semaphore_wait () from /usr/lib/libpulsecore.so.5
#3 0xb7f93f6d in pa_asyncmsgq_send () from /usr/lib/libpulsecore.so.5
#4 0xb659d722 in ?? () from /usr/lib/pulse-0.9/modules/libprotocol-native.so
#5 0xb65b3a99 in pa_pdispatch_run ()
   from /usr/lib/pulse-0.9/modules/libpdispatch.so
#6 0xb65971b2 in ?? () from /usr/lib/pulse-0.9/modules/libprotocol-native.so
#7 0xb65bd02b in ?? () from /usr/lib/pulse-0.9/modules/libpstream.so
#8 0xb65c9488 in ?? () from /usr/lib/pulse-0.9/modules/libiochannel.so
#9 0xb7f49d49 in pa_mainloop_dispatch () from /usr/lib/libpulsecore.so.5
#10 0xb7f4a0a1 in pa_mainloop_iterate () from /usr/lib/libpulsecore.so.5
#11 0xb7f4a164 in pa_mainloop_run () from /usr/lib/libpulsecore.so.5
#12 0x0805118d in main ()

and what's happening
Process 6361 attached - interrupt to quit
futex(0x8871150, 0x80 /* FUTEX_??? */, 0^C <unfinished ...>
Process 6361 detached

maybe this is a deadlock?

Brad Langhorst (brad-langhorst) wrote :

I'm pretty sure this is the same bug I'm seeing.

Changed in pulseaudio:
status: New → Confirmed
Changed in pulseaudio:
status: Unknown → New
Lee Johnson (jleejj) wrote :

Another vote for the randomly observed hangs of pulseaudio. I had no trouble with this until the last few days. No major software changes that I can think of either ...

Tim Perry (pimterry) wrote :

Having the same issue. Rhythmbox reaches a new song and stops dead, a couple of hours in, and locks the whole app. Only cure is killing pulseaudio (-KILL) and restarting it.

This is a up to date ibex (x86) installed clean a few days ago.

Michael Axiak (mike-axiak) wrote :

This happened to me as well. I'm using dual core AMD 64-bit running i686 version of 8.10.
lspci outputs: 00:14.2 Audio device: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller (rev 01)

Thanks for looking into this! This is a real bummer :-\

A list of duplicates:
#288861
#288652
#288093
#288039
#286966
#286430
#285965
#235990

And I'm sure there are more that I'm missing ... since this is affecting a lot of people.

Dan McGuirk (incandenza) wrote :

Happens to me as well, however for me it only seemed to start happening when I upgraded to Intrepid. pulseaudio hangs every 12-24 hours or so.

Hardware is a Dell e1405 notebook. Sound devices:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Dan McGuirk (incandenza) wrote :

I might have a small extra clue here. I just watched pulseaudio hang in the middle of playback (leaving it looping a few milliseconds of sound over and over). In the syslog I caught this message:

Dec 15 10:04:48 inspiron pulseaudio[6157]: protocol-native.c: Failed to push data into queue
Dec 15 10:04:53 inspiron last message repeated 8443 times

I looked through my old syslogs, and this has happened 3 other times over the past week. So it looks like I'm getting this message every time I'm experiencing the hang.

Dan McGuirk (incandenza) wrote :

Bug 288093 (already mentioned as a possible dup above) may be the same thing with more detail.

Changed in pulseaudio:
importance: Undecided → High
Daniel T Chen (crimsun) wrote :

Workaround: stop the audio application, resume the audio application.

Changed in pulseaudio:
importance: High → Medium
status: Confirmed → Triaged
Daniel T Chen (crimsun) wrote :

See also bug 330814, which is the culprit in jaunty.

Daniel T Chen (crimsun) on 2009-03-04
Changed in linux:
assignee: nobody → ubuntu-audio
importance: Undecided → Low
status: New → Confirmed
Changed in pulseaudio:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 0.9.14-0ubuntu11

---------------
pulseaudio (0.9.14-0ubuntu11) jaunty; urgency=low

  [ Daniel T Chen ]
  * Reenable 0030_set_tsched0.patch, which re-disables glitch-free;
    too many users are reporting regressions and audio aberrations.
  * Adjust 0003_change_resample_and_buffering.patch to use linear
    resampler to work better with lack of PREEMPT in jaunty's
    -generic kernel config (LP: #207135, #322250, #332761, #335955,
    LP: #336965).
  * Last upload, specifically 0091_workaround_alsa_horkage, fixes:
    LP: #235990, #237443, #279847, #317997, #323185, #330814,
    LP: #334874.
  * sudo -H change in ubuntu6 fixed LP: #312505.
  * Closing old bugs fixed in 0.9.11+: LP: #187963, #193520, #211052.
  * Refresh 0006_regen-autotools.patch.
  * Add 0043_load_sample_dir_lazy.patch to cache
    /usr/share/sounds/ubuntu/stereo/* in default.pa.
  * debian/:
    - control: Build against libcap2-dev (LP: #339448);
    - copyright: Update copyright from Debian's 0.9.14-2;
    - rules: Add DEB_OPT_FLAG = -O3 as per recommendation from
      pulseaudio-discuss/2007-December/001017.html.
  * Refresh fixes from git HEAD:
    - 0038_handle_errno_properly.patch,
    - 0091_workaround_alsa_horkage.patch,
    - 0092_fix_null_pointer_access.patch.

  [ Luke Yelavich ]
  * Add a special case to prevent Pulseaudio from being started when the
    blindness accessibility profile has been enabled from the Ubuntu live CD,
    and for an accessibility install. Unfortunately Pulseaudio and speech do
    not currently work very well with each other, and its too late in
    the cycle to solve this problem any other way.

 -- Luke Yelavich <email address hidden> Tue, 10 Mar 2009 09:00:40 +1100

Changed in pulseaudio:
status: Fix Committed → Fix Released
Daniel T Chen (crimsun) wrote :

released in jaunty's -11.38

Changed in linux (Ubuntu):
assignee: ubuntu-audio → crimsun
status: Confirmed → Fix Released
Changed in pulseaudio:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.