package update-manager 1:0.87.24 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1)

Bug #224421 reported by jdackle on 2008-04-29
2
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: update-manager

Similarly to an apparently "invalid" bug report ( #176629 ), my installation too was aborted.
Please also see my bug report #224415 (occured during the same upgrade process and possibly related).

ProblemType: Package
Architecture: i386
Date: Tue Apr 29 17:04:37 2008
DistroRelease: Ubuntu 8.04
ErrorMessage: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1)

Package: update-manager 1:0.87.24
PackageArchitecture: all
SourcePackage: update-manager
Title: package update-manager 1:0.87.24 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1)
Uname: Linux 2.6.22-14-generic i686

jdackle (jdalinux) wrote :
jdackle (jdalinux) wrote :

The list of the packages that could NOT be updated (for one reason or the other), til the upgrade process was aborted, is:

- gnome-power-manager
- gnome-session (I'm using lxp-icewm)
- hal
- network-manager (which I never used anyhow)
- policykit
- policykit-gnome
- pulseaudio
- ubuntu-desktop
- update-manager

Synaptic shows NO broken packages! (though some of the above allegedly failed due to broken dependencies)

Should I try to RE-install them? (Synaptic shows them as installed and up to date!)

I mean, the system's got a few glitches right now but it's more or less usable (just very slow)

jdackle (jdalinux) wrote :

Added my current /etc/apt/sources.list

jdackle (jdalinux) wrote :

My above question about wheter I should try to reinstall the packages or not is not really appropriate for a bug report so I've asked that in the forum instead. If you can help with that, pleas go here:
http://ubuntuforums.org/showthread.php?p=4838286#post4838286

I hope the rest of the informations are useful to the developers.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Please attach the files in /var/log/dist-upgrade to this bugreport.

The bugreport you mention (#176629) is most likely unreleated to the error you get, but I will verify once the logs are avaialble.

 Thanks Michael

Changed in update-manager:
importance: Undecided → High
status: New → Incomplete
jdackle (jdalinux) wrote :

Thanks for the answer, Michael.

Requested directory attached in tarball.

Ralph Janke (txwikinger) on 2008-06-10
Changed in update-manager:
status: Incomplete → Triaged
Jean-Baptiste Lallement (jibel) wrote :

The cause a the failure is
=====
A instalar pulseaudio (0.9.10-1ubuntu1) ...

A sua conta de utilizador expirou; por favor contacte o seu administrador de sistema

chfn: A autenticação PAM falhou

adduser: `/usr/bin/chfn -f PulseAudio daemon pulse' retornou o erro de código 1. Saindo.

dpkg: erro ao processar pulseaudio (--configure):

 subprocesso post-installation script retornou erro do status de saída 1

=====

This is a known issue reported in bug 238755

Don't hesitate to submit any new bug

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers