Logout/Shutdown Sound Not Working

Bug #214370 reported by Anthony M on 2008-04-09
360
This bug affects 70 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
gnome-session
New
Medium
Nominated for Main by Samuel Chase
Fedora
Won't Fix
Unknown
gnome-session (Ubuntu)
Low
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher
pulseaudio (Ubuntu)
Medium
Luke Yelavich
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

In Hardy heron beta my system does not play any logoff or shutdown sound.

All other sounds works and in System>Preferences>Sound, I can play all sounds successfully, including logoff.

Junior (juniorperes) wrote :

The same is happening with me in my two instalations of Hardy Heron Beta. The sound is playing pretty fine with the only problem of end session sound.

lizardmenke (lizardmenke) wrote :

Same here but now in the final release. All the sound seems to work fine, but no log off sound.
attached my lshw.txt

Isaac Joseph (isaacj87) wrote :

I can confirm this here. I too also have an Acer Laptop (Acer Aspire 1642 WLMi) like the user above me.

Same behavior, all sounds work fine except for the logout sound.

Prinknash (colin-colinandjenny) wrote :

I have 3 systems here, all different Dell models, running Hardy final release (2 upgraded from Gutsy, 1 a new install) and I don't get the shutdown sound with any of them. All other sounds work and I had no problem getting the shutdown sound with Gutsy.

Jason (jasonxh) wrote :

I second this bug. Seems like the sound server is shut down too early.

darkshado (darksoldier1) wrote :

Same problem! No logout sound de others one work fine! My motherboard asus deluxe a7n8x

Stormdragon (stormdragon2976) wrote :

I have the same problem. Using 2 computers, one a Gateway laptop, the other a Compaq c500 laptop. Had 8.04 on a Compaq desktop with same problem. The strange thing is, it worked in the last Alpha release but not the beta or final release.

BandD (swords-into-plowshares) wrote :

Same problem here. I suspect that the system is shutting down the sound deamon too fast. It seems that every once in a while it tries to play something for a split second and then gets cut off JUST before Gnome disappears.

lizardmenke (lizardmenke) wrote :

Is there a way to postpone the shutting down of the sound server so I could test the theory that the sound server is shut down too early?

Sotito (sotito) wrote :

Same is happening in a Dell XPS-M1210

Nico Veenkamp (nico) wrote :

I have the same problem on my HP530 running Ubuntu 8.04

Same here on several pc's, not only mine, but all my friends and costumers !

dark_harmonics (jyost) wrote :

Same problem on all 5 of my computers including a macbook pro, HP nc6000, PowerBook G4, HP nc610c and a mutt desktop.

Aitor gara (aitorgara) wrote :

I detected the problem on both hardy and gutsy with several computers (pc's and laptops) with intel sound cards. I'm almost sure that the problem is that the alsa driver switches off too fast.

David Clayton (dcstar) wrote :

In Gutsy installing the esound package used to fix this, I tried this once in Hardy (early beta) and it basically killed my system - so I live with it at the moment.

ENigma885 (enigma-pentagram) wrote :

I WORKED OUT THE PROBLEM

It's all about the PulseAudio, the new sound server in 8.04 Hardy,. Instead of that every application has its way to access the sound card, PulseAudio becomes a common (gate) to access ur sound card. The problem is that not all applications can deal with the new sound server. But it's getting better.

Apparently System Sounds have also a problem dealing with PulseAudio to get over it i installed "PulseAudio ESD compatibility layer" u can install it by :

[Code] sudo apt-get install pulseaudio-esound-compat[/Code]

One last thing:
-Make sure that PulseAudio is configured the primary sound device (System>>Preferences>>Sound) and in the Device tab select PulseAudio Sound Server, sometimes it will require a system restart to work properly,
-Make sure that Software Sound Mixing is enabled from the Sounds tab in Sound Preferences check "Enable Software Sounds Mixing ESD"

I posted the same issue here and i figured out the solution later http://ubuntuforums.org/showthread.php?t=789280
Also be sure that u will face other problems with PulseAudio this thread is really helpful http://ubuntuforums.org/showthread.php?p=4725430

It's totally true as David Clayton said above installing esound only in Gusty 7.10 fixes the issue BUT in Hardy 8.04 it freezes my whole system directly on start up.
And about the logout sound i do agree on the fast PulseAudio shutdown theory but i'm optimistic concerning PulseAudio in general. No one could disagree that's better than the previous sound mess in former Ubuntus.

Kane (kane-station) wrote :

I have a similar problem, I followed the instructions on th other thread, everything on it works fine except the customized sounds don,t work (downloaded .wav's) on the login sound selection, when I click "test" on a custom login sound it dosent work, and it prevents all the sounds on "test" button to work until I close the whole option menu and start it again, this happens each time I try to test a custom login sound.'

note: This ONLY happens on the "login" sounds.

Kane (kane-station) wrote :

Sorry for double posting, but. I found something else, my problem ONLY happens when I use the Borealis sound theme with the files; startup1_1.wav Startup 1_2.wav Startup 1_3.wav and Startup1_4.wav.

Changed in pulseaudio (Ubuntu):
assignee: nobody → Ubuntu Foundations Team (ubuntu-foundations)
importance: Undecided → Medium
Michael Terry (mterry) on 2009-06-01
summary: - Logout/Shutdown Sound Not Working In Hardy beta
+ Logout/Shutdown Sound Not Working
Changed in gnome-session:
status: Unknown → New
Changed in fedora:
status: Unknown → In Progress
Michael Terry (mterry) wrote :

This is not a pulseaudio bug. The underlying issue is that gnome-session does not run the shutdown scripts in /usr/share/gnome/shutdown. gnome-session-canberra puts a script in that directory that plays the logout sound. It just never gets run.

I've filed a patch in the linked GNOME bug to fix this. Will put up a debdiff here if they like it.

Changed in gnome-session (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
status: New → Confirmed
Changed in pulseaudio (Ubuntu):
status: Confirmed → Invalid
ShawnJGoff (shawn-goff) wrote :

This is not a paper cut because it is not a general usability issue, but rather a bug affecting a relatively small user population.

Changed in hundredpapercuts:
status: New → Invalid

This is a paper cut. By default, Ubuntu specifies a sound to be played at shutdown. Most users shutdown their computers, so most users are affecting by this (potentially) trivially fixable usability bug.

Changed in hundredpapercuts:
status: Invalid → Confirmed

On Wed, 2009-06-17 at 22:40 +0000, David Siegel wrote:

> This is a paper cut. By default, Ubuntu specifies a sound to be played
> at shutdown. Most users shutdown their computers, so most users are
> affecting by this (potentially) trivially fixable usability bug.
>
Though it's worth thinking about whether or not we _want_ a shutdown
sound.

If the sound is playing in the background during shutdown, it'll get cut
short because we save the mixer settings of the card and mute on the way
down.

If the sound is playing in the foreground, it'll make the shutdown take
longer because we're waiting for the sound to finish playing.

Scott
--
Scott James Remnant
<email address hidden>

2009/6/18 Scott James Remnant <email address hidden>:
> Though it's worth thinking about whether or not we _want_ a shutdown
> sound.
>
> If the sound is playing in the background during shutdown, it'll get cut
> short because we save the mixer settings of the card and mute on the way
> down.
>
> If the sound is playing in the foreground, it'll make the shutdown take
> longer because we're waiting for the sound to finish playing.

It can be user configured or disabled, what is a bug is that the user
wants it and he gets no sound.
--
Francisco Vila. Badajoz (Spain)
www.paconet.org

ricardisimo (ricardisimo) wrote :

> If the sound is playing in the background during shutdown, it'll get cut
> short because we save the mixer settings of the card and mute on the way
> down.
>
> If the sound is playing in the foreground, it'll make the shutdown take
> longer because we're waiting for the sound to finish playing.

I can tell you how it used to be, three releases ago: the sound would get cut short if it took too long (shutdown was the priority, correctly so, I think). There was a bit of art and skill involved in crafting a custom sound which would last just long enough to avoid this cruel fate. Personally, I'd like things back to this.

And yes, the bug is precisely that... It is listed as an option but doesn't function at all. Worst-case scenario is to remove the option; best-case is to make it work.

Changed in pulseaudio (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Canonical Desktop Team (canonical-desktop-team)
Changed in gnome-session (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Canonical Desktop Team (canonical-desktop-team)
Dylan McCall (dylanmccall) wrote :

I think it should play a jingle with the system beep, to satisfy bug #77010 :P

Otherwise, the issue here is that the shutdown sound can be customized. Sure, the default may be nice and short, but what happens if the user sets their own custom sound and finds that it only plays for about half a second then crumbles into nothingness?
So I don't recommend that solution, however appealing it may be.

David Clayton (dcstar) wrote :

Either it plays the *whole* sound the user anticipates or the feature is removed - having something as basic as this not working correctly for so long is amateurish.

wpshooter (joverstreet1) wrote :

I second that !!!

Changed in hundredpapercuts:
milestone: none → round-7
milestone: round-7 → round-8

Luke - can you confirm that this is an issue in Karmic.

Changed in pulseaudio (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Luke Yelavich (themuso)
Changed in gnome-session (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Luke Yelavich (themuso)
importance: Undecided → Low
wpshooter (joverstreet1) wrote :

It appears to me that in Karmic daily build as of July 26th, 2009, you can NOT even assign any sounds to various events/functions in the sound section of the O/S.

Hernan Rodriguez (h01) on 2009-08-20
description: updated
komputes (komputes) wrote :

Since we are paying attention to login/logout sounds during karmic development it may be worthwhile to test/correct the issues outlined in Bug #360147.

ricardisimo (ricardisimo) wrote :

By the way, has anyone else noticed that the sound issue is getting worse in Jaunty? Logout is not working at all, which we knew already, but now the custom login is breaking up, or getting cut short. On my work computer I think it even somehow switched itself back to the default login instead of custom. Neither machine is brand new, but certainly my home computer is new enough that hardware shouldn't be the problem.

komputes (komputes) wrote :

@ricardisimo Totally. Besides the startup/shutdown sounds, many session-specific sound effects do not work.

This is explained in the following bug:
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/360147

I was told this gnome issue is not a priority and that contributors are welcome to fix the bug. I agree this isn't a major bug that will crash your system, but it's nice to have sounds that work as expected.

I don't mean to sound hash, but I find the new "Sound theme" concept/interface to be buggy, confusing and incomplete.
It would be nice if sound effects could get some love before karmic rolls out.

Andrew (and471) wrote :

Redirecting focus to the actual bug filed here:

There is a file called 'libcanberra-logout-sound.sh' in /usr/share/gnome/shutdown that is meant to be run on shutdown. The reason the file is not played is that the piece of code that is meant to be in gnome-session to run all files in the /usr/share/gnome/shutdown directory is not there (it was forgot).

Upstream is a patch someone made to fix it and the nautilus developers suggested some changes to the patch. This bug needs someone to modify the patch as required.

wpshooter (joverstreet1) wrote :

Why is it that when installing Karmic, the sound is MUTED by default ?

Seems sort of strange !!!

Thanks.

Maxim Levitsky (maximlevitsky) wrote :

Maybe we should just remove logout sound?

With all due apologies, Maxim, but that seems like an almost insulting fix to this bug. Not only would this be a slap in the face of every user who has noted that this bug affects them, as well as those who have filed duplicate bugs because it is a real annoyance to them but they didn't see this bug first, it also strikes me as being a case of "we don't care how you guys (and girls) feel about this issue, and we're just going to ignore it completely." That is precisely the type of response that has ticked off so many Firefox 3 users and I'd really hope the Ubuntu and upstream devs aren't so heartless.

That said, I look forward to the possibility of the possible good news upstream that Andrew reported in comment #34. I'd be willing to test it if someone makes a deb available in a PPA or something.

Maxim Levitsky (maximlevitsky) wrote :

@J.M. "Peng" Hardin.

Sorry if I offended somebody!

My idea was that today anyway sounds are played through pulseaudio, and it has to shutdown as well on logout.
Thus to make sound play normally one had to make gnome session and friends to wait for logout sound.

Thus just making it play isn't enough,

Anyway, sorry!

Thanks for the clarification, Maxim. Now if only we can get it to work.

Claudio Viano (claudio-viano) wrote :

Proposals of just removing the logout sound pop up regularly here and there, but the point is that any other OS out there has a working logout sound, and you don't need to look too far either: KDE has it. Also to see how popular this feature is just check how many how-to one can find, with a quick search, to hack it into gnome with some work-around solution.

Night Train (nighttrain) wrote :

hi guys

i have the same problem with karmic 9.10 64 bit, new installation: no sound logout/shutdown

thanks

ginalfa (ginalfa) wrote :

Same issue with jaunty and now with karmic 32 bit

Changed in hundredpapercuts:
milestone: round-8 → none
Changed in fedora:
status: In Progress → Won't Fix

Great :-(

Andrew (and471) wrote :

Everyone, unless you have a comment relevent to the fixing of the problem as described below, please stop commenting so that the bug report remains clear. If you are simply saying it affects you, please use the 'This bug affects 18 people. Does this bug affect you?' link at the top.

Redirecting focus to the actual bug filed here:

There is a file called 'libcanberra-logout-sound.sh' in /usr/share/gnome/shutdown that is meant to be run on shutdown. The reason the file is not played is that the piece of code that is meant to be in gnome-session to run all files in the /usr/share/gnome/shutdown directory is not there (it was forgot).

Upstream is a patch someone made to fix it and the nautilus developers suggested some changes to the patch. This bug needs someone to modify the patch as required.

David Clayton (dcstar) wrote :

This works on my Ubuntu 9.04 system (tested with multiple user accounts).

Edit the following file:

/etc/gdm/PostSession/Default

And add this in before the "exit 0":

/usr/share/gnome/shutdown/libcanberra-logout-sound.sh

Now your logout of a Gnome session should play whatever logout sound you have specified (do I get a lollipop for this?).

Andrew (and471) wrote :

Woohoo! Thanks David!!

Although this is a workaround, there is no problem with it, it does the desired behavior (i.e. plays the shutdown/logout sound on logout and shutdown) and conforms with all the necessary configuration (i.e. if in Preferences > Sound you have sounds disabled, it will not play).

I shall create a debdiff with a patch, in the mean time, will people try it out and comment if the workaround doesn't work for them (make sure in Sound > Preferences, you have the Ubuntu theme selected and the alert volume is loud enough).

Andrew (and471) wrote :

Hi Guys,

I have realised I am not a shell script wizard and so I shall pass this onto someone who is, I have this working in bash, but ideally it needs to be working in /bin/sh. Also I have just realised we would be patching GDM instead of gnome-session which the bug is actually in.... I wish someone could just cleanup the patch upstream...

David Clayton (dcstar) wrote :

And to add a new level of bogosity to this bug, I have discovered that the actual Logout sound played depends on the particular behaviour of Pulseaudio at the time of initiating a Shutdown/Reboot (Logoffs seem 100% ok). Sometimes my correct sound is played, other times the cached default sound theme shutdown sound is played on my system.

It seems entirely user based, I can create new user accounts that seem to work 100% correctly all of the time, but my main account has this variability. I have now spent hours trying to pinpoint the cause on my system, but I am about to admit defeat.......

wpshooter (joverstreet1) wrote :

Let's see, I think this bug has been in existence for what, about a year to 2 years now !!!

Hmmmmmmmmmmm.

Vish (vish) wrote :

Logout/Shutdown works on Lucid.

To test: Create a new user account. And when you logout of the new account the sound does play.

However , the logout sound doesnt play in my old user account. Maybe something in my /home is blocking this. Will report back if i find something.

Changed in hundredpapercuts:
status: Confirmed → Fix Released
David Henningsson (diwic) wrote :

For me, it is still not working at all. What is it that actually should call /usr/share/gnome/shutdown/libcanberra-logout-sound.sh (on a default, unmodified system), so I can figure out why it isn't called on my system?

Claudio Viano (claudio-viano) wrote :

It doesn't work for me, also with a new user. The bug upstream is also still open and with no activity since a long time.

David Clayton (dcstar) wrote :

10.04 still does not have config file change as per post 45, when these changes are made Theme Logout sound playes as expected.

I find it astounding that the default GDM install in Lucid still does not have this fixed.

That Bum (jzachariou) wrote :

Indeed, in Lucid Beta 2 it is still a problem...I think it has to do something with Pulseaudio being killed too soon. Very annoying that this bug has been in Jaunty, Karmic, and now Lucid!

David Clayton (dcstar) wrote :

In 10.04 it seems to be that the Shutdown/reboot procedure just cuts off the GDM session and sound system at the knees, whereas the normal "Logout" allows GDM to execute the PostSession commands as you would anticipate.

I tried to find out what (if any) scripts were run when the Gnome Shutdown/Restart items were selected but I had no luck, does anyone know what is called in these circumstances?

ricardisimo (ricardisimo) wrote :

I have a quick question: Where has the custom sound selection window gone?

I'm on Karmic, and my login sound still plays (the very welcoming and soothing first ten-fifteen seconds of David Bowie's "Right"), but it has clearly just been "grandfathered" in from Jaunty or Hardy. There are no customization options any longer that I can see.

No logout still, of course.

David Clayton (dcstar) wrote :

"I have a quick question: Where has the custom sound selection window gone?"

That was last in 9.04 and the newer Gnome versions have not had any GUI tools developed as yet to do this sort of thing.

In 9.10 onwards the sounds are in Theme groups and the simplest way to change things is to replace the original .ogg files in the Ubuntu theme (/usr/share/sounds/ubuntu/stereo).

Rod Davis (ahylianhuman) wrote :

I believe this is definitely something to do with the sound server being shut off too quickly; I tried using the "play" command from the sox package, and it still doesn't work (even on logout).

Here's my current /etc/gdm/PostSession/Default

#!/bin/sh
play /usr/share/sounds/ubuntu/stereo/desktop-logout.ogg
sleep 5s
exit 0

I added the sleep 5s to see if that would help, but it did not.

Claudio Viano (claudio-viano) wrote :

This is marked as fix released in one hundred paper cuts, very misleading. There is a proposed patch in the upstream gnome bug, can't some good soul at Canonical finish it?

I run a restaurant, I can cook a dish of pasta but cannot code, but I'd be very willing to donate for this. I'm serious, tell me if I can do a per bug donation and I do it tomorrow, but please write that code already for crying out loud.

Vish (vish) wrote :

Well , this is weird. A few months ago this bug was fixed in Lucid and i could hear the logout sounds as per the earlier comment #52.
Now it doesnt work again.

Reverting status to confirmed.

Changed in hundredpapercuts:
status: Fix Released → Confirmed
Claudio Viano (claudio-viano) wrote :

This is not properly a bug but rather an unimplemented feature, as explained in the upstream gnome bug #528812. The code to execute the scripts at logout has been submitted to that bug by someone but nobody is finishing it up.

That's the status, no point adding entries in /etc/gdm/PostSession/Default, because nothing will read it, or hoping for a bugfix; someone has to implement the feature.

Tars (tars-ac) wrote :

I realize that this is a small issue, but from a usability standpoint, it's something that people expect. A nice sound experience is essential to a good user experience. Someone owns the broken code - we just need to prioritize this. Claudio - you may say it's not a bug, but since every other desktop OS since at least Windows 3.1 has done this in my personal experience, and I distinctly remember the option in previous versions of Ubuntu, that makes it a bug in my book. It used to work.

Claudio Viano (claudio-viano) wrote :

Tars, don't get me wrong, I said it's not a bug because it is worse still, it's an unimplemented feature, that nobody bothered to write when gdm/gnome session/whatever were rewritten. See my comment #61.

Jose Luis (josedelsud) wrote :

Since PulseAudio was added to Ubuntu this problem is happening to all versions, now we have Lucid Lynx and the sound problem is still a "problem", Shutdown sound does not work, Im not a programmer neither a nerd, just a simple user that love Ubuntu, it would be really nice to see this fixed as soon as possible and see the developers (ad honorem or not) not to say things like "this is irrelevant or unimportant" thats not a good response. Anyway thanks for the job.

Qugar (yezumg) wrote :

No se puede crear un script, parecido a login, pero para logout y que reproduzca el sonido?
Nadie consigue un fix para esto?

Changed in hundredpapercuts:
status: Confirmed → Invalid
status: Invalid → Confirmed
Qugar (yezumg) wrote :

Can not create a script, similar to login, but logout and reproducing sound?
Nobody gets a fix for this?

Nelux (manolollr) wrote :

This works for me: (you need sox installed. $sudo aptitude install sox)

To sound when you logout, put this code in /etc/gdm/PostSession/Default:

#!/bin/sh
sleep 1
nohup play /usr/share/sounds/ubuntu/stereo/desktop-logout.ogg &
exit 0

It doesn't work without sleep 1, because the session closes too fast.

To sound when you shutdown or reboot:

- In /etc/init.d create a file called, for example, logout-sound. Assign it execution permission and put in it this content:

#!/bin/sh
play /usr/share/sounds/ubuntu/stereo/desktop-logout.ogg
exit 0

- In /etc/rc0.d create a symbolic link to logout-sound /etc/rc0.d$sudo ln -s ../init.d/logout-sound S05logout-sound
- Do the same for /etc/rc6.d

And that's all. The sound first plays, and then the system closes, so please, don't play the 14 minutes song in a gadda da vida by Iron Butterfly :-)

Claudio Viano (claudio-viano) wrote :

Nelux

it works but it's not the optimal solution, it doesn't allow you to change the logout sound or the sound theme unless you manually modify your scripts or name your new sound theme "ubuntu" and move or erase the original one.

The clean way would be to execute /usr/share/gnome/shutdown/libcanberra-logout-sound.sh, but when the scripts in PostSession or init.d are executed everything Gnome is already killed, including canberra.

There is no way in Gnome to execute a script BEFORE Gnome itself logs out and kills everything, that is the problem, the code does not exist (it does exist and work in KDE though). The script for the logout sound is already there, it's the one I mentioned above, but nothing calls it. That is a long standing upstream bug but nobody can be bothered to write the code.

Incidentally, for the same reason, you cannot execute anything upon logout in Ubuntu, only AFTER logout, and probably only as root.

Bilal Akhtar (bilalakhtar) wrote :

If we all are really facing this issue, why not mark it "Triaged" in paper cuts ?

Changed in hundredpapercuts:
importance: Undecided → Medium
Changed in gnome-session (Ubuntu):
assignee: Luke Yelavich (themuso) → nobody
status: Confirmed → Triaged
Changed in gnome-session:
importance: Unknown → Medium
ricardisimo (ricardisimo) wrote :

On my computer at work, I have always simply upgraded to the newer version of Ubuntu. Therefore, my login sound at least, still works. What files or folders dictate this? Can I just copy and paste some folder from this computer to my home comp to get some sound options?

Is it a pipedream to think that we might get some of these options back some day? Is the "GNOME way" simply not going to give us back options once they've been taken away? Does Kubuntu have custom sounds?

Chris Wilson (notgary) wrote :

Quoting Andrew in comment 34,

"Redirecting focus to the actual bug filed here:

There is a file called 'libcanberra-logout-sound.sh' in /usr/share/gnome/shutdown that is meant to be run on shutdown. The reason the file is not played is that the piece of code that is meant to be in gnome-session to run all files in the /usr/share/gnome/shutdown directory is not there (it was forgot).

Upstream is a patch someone made to fix it and the nautilus developers suggested some changes to the patch. This bug needs someone to modify the patch as required."

What's happening with this patch? I've checked the upstream bug report in Gnome (https://bugzilla.gnome.org/show_bug.cgi?id=528812) and there hasn't been any activity since 2009. There was talk of 'cleaning the patch up', but there hasn't been a resubmission.

Changed in hundredpapercuts:
status: Confirmed → Triaged
David Clayton (dcstar) wrote :

While this issue is personally annoying to me, I find it has an implication way above the "hundred paper cuts" level in that Windows users considering moving to Linux hit something like this and come away with an attitude like "If they can't get something as simple and basic as playing a shutdown sound working, how can I trust Linux to work correctly in other more important areas?"

Quite frankly, despite all the valid reasons for the essential lack of priority in fixing this feature, I can't disagree with that conclusion.

Myroslav (mgalan) wrote :

My sentiments as well.

On 11-01-19 05:01 PM, David Clayton wrote:
> While this issue is personally annoying to me, I find it has an
> implication way above the "hundred paper cuts" level in that Windows
> users considering moving to Linux hit something like this and come away
> with an attitude like "If they can't get something as simple and basic
> as playing a shutdown sound working, how can I trust Linux to work
> correctly in other more important areas?"
>
> Quite frankly, despite all the valid reasons for the essential lack of
> priority in fixing this feature, I can't disagree with that conclusion.
>

Tobin Davis (gruemaster) wrote :

Interesting to see these comments. Quite honestly, if upstream Gnome developers haven't fixed this issue, I am not sure why Ubuntu should be at fault. I assume that this bug exists on other Gnome based distros as well (Fedora, Suse, Gentoo)?

But I hardly think this will be a show stopper for Windows converts. I think the faster boot/shutdown times will be more motivational than the system making a noise on shutdown.

wpshooter (joverstreet1) wrote :

Unfortunately, I have to agree with Myroslav's statement.

It can take only something as minor in overall importance as this to put off a lot of potential users from considering Linux/Ubuntu. I know that in the grand scheme of things that the playing of this sound is really not all that important BUT Myroslav is exactly correct in saying that a goodly number of potential users are going to wonder if something like this can not be fixed, then what more serious things might be going undone, that they have no knowledge of.

Not having these very trivial but very visible things like this go unfixed for an inordinate amount of time, is definitely not good advertising for Ubuntu !!!

Thanks.

Changed in hundredpapercuts:
assignee: nobody → Lee Williams (lee-willy1977-williams)
status: Triaged → In Progress
Ingo Gerth (igerth) wrote :

Lee, any progress?

Nothing to add as yet, apart from reproduced (which is evident of course ;) )

aaron (aaron-zareason) wrote :

This does seem to be more gnome-based, as kde and such have sounds just fine.

I agree with Comment #77. This is a bug report because it seems like something is wrong with the system when it can't play system sounds, and every other OS (you know, those other 2...) does. Yes. Micro$oft's and Appl€ 's OS's play shutdown sounds. And startup sounds. And why shouldn't the worlds most configurable operating system (that's linux, btw) allow us to configure audible notifications?

kyleabaker (kyleabaker) wrote :

First off, I subscribed to this bug ages ago and its still not fixed.

Secondly, I agree with aaron that this is a bug because its expected behavior.

Lastly, why has this bug gone on for so long? This should be embarrassing! Such a great operating system can't even focus enough effort to fix a bug such as this. It's all open source, can't someone fix this? I've seen plenty of patches in the forums for this that simply edit a file or two, so why can't that be implemented? Even if it fixes the issue for a minority, its better than no one having appropriate system sound effects!

I predict that IF/WHEN this bug if finally fixed, Ubuntu's focus on a new sound theme will become a higher priority.

At this point it is just becoming embarrassing for everyone.

Myroslav (mgalan) wrote :

I agree that this issue is ridiculous. Ubuntu developers have two
options if they respect loyal users.
1. They can fix the problem. It appears they are not willing to do this.
Or,
2. They can have the courtesy to provide reasons for not fixing the
problem. They may have good reasons. Ignoring customer complaints
never results in a good end.

On 5/28/2011 1:44 AM, kyleabaker wrote:
> First off, I subscribed to this bug ages ago and its still not fixed.
>
> Secondly, I agree with aaron that this is a bug because its expected
> behavior.
>
> Lastly, why has this bug gone on for so long? This should be
> embarrassing! Such a great operating system can't even focus enough
> effort to fix a bug such as this. It's all open source, can't someone
> fix this? I've seen plenty of patches in the forums for this that simply
> edit a file or two, so why can't that be implemented? Even if it fixes
> the issue for a minority, its better than no one having appropriate
> system sound effects!
>
> I predict that IF/WHEN this bug if finally fixed, Ubuntu's focus on a
> new sound theme will become a higher priority.
>
> At this point it is just becoming embarrassing for everyone.
>

Changed in hundredpapercuts:
status: In Progress → Confirmed
ricardisimo (ricardisimo) wrote :

Kyle, you say it's still a bug, but the bug was that an option was offered that didn't work. That option has now been removed, and with it the bug, no?

Don't get me wrong, I can't believe that this problem hasn't been fixed by anyone as of yet, and I'd love to have these sorts of options restored, as they seem to be steadily disappearing from Ubuntu (maybe Kubuntu is in our futures?). But removing the option does indeed remove the "bug".

Let's remove Ubuntu and every bug will be removed as well :-)

Tobin Davis (gruemaster) wrote :

Closing this as this option was removed by gnome upstream.

Changed in gnome-session (Ubuntu):
status: Triaged → Won't Fix
Maxim Levitsky (maximlevitsky) wrote :

Awesome to see this bug fixed!

I don't use Gnome anymore because they removed too many options.
KDE is nice, but its too buggy, so I installed Windows7 and its just awesome.
Its much better that Vista, and so huge thanks to Gnome developers for making me try to do that step.
(btw I was a kernel developer)

David Clayton (dcstar) wrote :

Perhaps there needs to be a new category for developers to put these sort of things in:

"Too hard to resolve, and we are busy playing with new stuff to be bothered with this"?

BTW, if Gnome is going to keep evolving into a touchscreen interface, is there going to be a new "politically correct" name for it as something like "Touch-Gnome" seems a bit too creepy to me?

Chris Wilson (notgary) wrote :

Closing papercut task based on comment #85.

Changed in hundredpapercuts:
status: Confirmed → Invalid
assignee: Lee Williams (lee-willy1977-williams) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.