totem-gstreamer crashed with SIGSEGV in pa_stream_update_timing_info()

Bug #198414 reported by Sascha Grossenbacher on 2008-03-04
416
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: totem-gstreamer

While inserting a DVD, i got a apport message that totem-gstreamer has crashed.

ProblemType: Crash
Architecture: amd64
Date: Tue Mar 4 17:17:03 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/totem-gstreamer
NonfreeKernelModules: nvidia
Package: totem-gstreamer 2.21.95-0ubuntu1
PackageArchitecture: amd64
ProcCmdline: totem file:///media/cdrom0
ProcEnviron:
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_CH.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: totem
StacktraceTop:
 ?? () from /usr/lib/libpulse.so.0
 ?? () from /usr/lib/libpulse.so.0
 pa_stream_update_timing_info () from /usr/lib/libpulse.so.0
 ?? () from /usr/lib/libpulse.so.0
 ?? () from /usr/lib/libpulse.so.0
Title: totem-gstreamer crashed with SIGSEGV in pa_stream_update_timing_info()
Uname: Linux 2.6.24-11-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video

Sascha Grossenbacher (berdir) wrote :
description: updated

StacktraceTop:pa_flist_pop (l=0xf915c0) at ./pulsecore/atomic.h:86
pa_operation_new (c=0x743f10, s=0xe76c10, cb=0, userdata=0x0) at pulse/operation.c:41
pa_stream_update_timing_info (s=0xe76c10, cb=0x1, userdata=0x0) at pulse/stream.c:1157
request_auto_timing_update (s=0x2, force=<value optimized out>) at pulse/stream.c:452
auto_timing_update_callback (m=<value optimized out>, e=<value optimized out>,

Changed in totem:
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

confirming due to the duplicates

Changed in pulseaudio:
importance: Medium → High
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

bug #204272 seems similar and has lot of duplicate too, should be a 8.04.1 bug

Brian Murray (brian-murray) wrote :

Assigning milestone based on seb's last comment.

Changed in pulseaudio:
milestone: none → ubuntu-8.04.2
Leu (mail2leu) wrote :

Got this bug-message in Ubuntu 8.10 Ibex today. All updates have been installed.
The crash-message appeared after playing an .avi-file in totem video-player. It appeared after the file has been completely played and I don't recognize any problems after the crash. Sound is working properly and any .avi-file could be played again and again.

Leu (mail2leu) wrote :

Did a new bug report as it affects ubuntu 8.10. This bug report is about 8.04. -> Bug #287282

Daniel T Chen (crimsun) wrote :

fixed in git head; adding to jaunty

Changed in pulseaudio:
status: Confirmed → Fix Committed
Daniel T Chen (crimsun) wrote :

Fixed in karmic

Changed in pulseaudio (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.