[SRU] pulseaudio: let a single alsa mixer support up to 8 channels (focal only)

Bug #1929817 reported by Hui Wang
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Fix Released
High
Hui Wang
Focal
Fix Released
High
Unassigned

Bug Description

[Impact]
Many Lenovo laptops have up to 4 microphones (microphone array), before the linux kernel 5.11, the alsa mixer for digital microphone is 2 channels, and the PA in the focal also supports up to 2 chanels for a single alsa mixer, so the PA in the focal works well with linux kernel 5.10 and lower on those Lenovo laptops. But we are going to install hirsute kernel (5.11) to the focal, the PA in the focal can't handle 4 channels of the digital mic, it will use pure software volume for digital mic, user can't adjust hardware volume of the digital mic anymore.

[Fix]
Backport 2 patches from PA-14.2, the PA in the hirsute (21.04) already have these 2 patches, so this SRU is for focal only. After applying these 2 patches, the PA could handle up to 8 channels for a single alsa mixer.

[Test]
Install patched PA on Lenovo laptops with 4 digital microphone, I could change the hardware input volume of digital mic through pulseaudio. I also installed patched PA to some old lenovo and Dell machines, all output and input devices worked as well as before, there is no regression observed.

[Where problems could occur]
This could introduce a regression on the output/input volume control, for example, the output or input volume only supports software volume in the PA, users can't adjust the hardware volume through pulseaudio anymore. But this regression possibility is very low, first the hirsute already has these 2 patches, second I already tested these 2 patches on different machines, all worked as well as before.

Hui Wang (hui.wang)
Changed in pulseaudio (Ubuntu):
importance: Undecided → High
status: New → In Progress
Changed in pulseaudio (Ubuntu Focal):
importance: Undecided → High
status: New → In Progress
Revision history for this message
Hui Wang (hui.wang) wrote :

This is the debdiff for focal. Thx.

Hui Wang (hui.wang)
description: updated
tags: added: focal
Hui Wang (hui.wang)
summary: - [SRU] pulseaudio: let a signle alsa mixer support up to 8 channels
+ [SRU] pulseaudio: let a single alsa mixer support up to 8 channels
+ (focal only)
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks for the work, there is already a SRU in the queue
https://launchpad.net/ubuntu/focal/+queue?queue_state=1&queue_text=pulseaudio

Do you want to include your changes and do another upload since it hasn't been accepted yet or should we wait for the other SRU to clear out first?

Revision history for this message
Sebastien Bacher (seb128) wrote :

Oh, I see now that you comment on the other bug, already I will merge the changes

Changed in pulseaudio (Ubuntu Focal):
status: In Progress → Fix Committed
Changed in pulseaudio (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

The focal SRU has been reuploaded merging the fixes

Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Hui, or anyone else affected,

Accepted pulseaudio into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pulseaudio/1:13.99.1-1ubuntu3.11 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-focal
Revision history for this message
Hui Wang (hui.wang) wrote :

Installed the pulseaudio-1:13.99.1-1ubuntu3.11 on two different machines, one of them have 4 digital mic and after installed the proposed pulseaudio, we could adjust 4 channel input volume through gnome or pulseaudio, the other machine has 2 digital mics, and the proposed pulseaudio worked as well as before.

verified done on focal.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:13.99.1-1ubuntu3.11

---------------
pulseaudio (1:13.99.1-1ubuntu3.11) focal; urgency=medium

  * d/p/0016-check_off_profile_when_switching_profile.patch
  * d/p/0017-add_dynamic_priority_bonus_base_for_alsa_profiles.patch
    Fix a "Rear Mic" always showing on input list when using dual codec.
    (LP: #1929371)

   [ Hui Wang ]
  * d/p/0704-alsa-mixer-use-safe-dB-range-values-when-the-overrid.patch
  * d/p/0705-alsa-mixer-add-support-up-8-mixer-channels.patch
    - The linux kernel 5.11 starts supporting more than 2 channels for
      the digital mic, we need to add the support of 8 channels for a
      single alsa mixer, otherwise the PA can't change the hardware input
      volume of the digital mic.
      (LP: #1929817)

 -- Jeremy Szu <email address hidden> Tue, 25 May 2021 16:04:07 +0000

Changed in pulseaudio (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for pulseaudio has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers