Activity log for bug #192888

Date Who What changed Old value New value Message
2008-02-18 11:23:48 LGB [Gábor Lénárt] bug added bug
2008-02-22 22:20:45 TerryG firefox: status New Incomplete
2008-04-03 21:17:05 Rafael C. Brandão pulseaudio: status Incomplete Confirmed
2008-04-06 15:27:58 Michael B. Trausch bug assigned to libflashsupport (Ubuntu)
2008-04-06 21:34:06 LGB [Gábor Lénárt] libflashsupport: status New Confirmed
2008-04-07 00:03:18 Jeff Fortin Tam bug added attachment 'unnamed' (unnamed)
2008-04-10 17:16:29 John Vivirito firefox: status New Invalid
2008-04-10 17:16:29 John Vivirito firefox: assignee mozilla-bugs
2008-04-15 20:04:11 Conn O Griofa bug added attachment 'nspluginwrapper_0.9.91.5-2ubuntu2_i386.deb' (nspluginwrapper_0.9.91.5-2ubuntu2_i386.deb)
2008-04-15 22:49:24 Alexander Sack bug assigned to flashplugin-nonfree (Ubuntu)
2008-04-15 22:50:32 Alexander Sack flashplugin-nonfree: importance Undecided High
2008-04-15 22:50:32 Alexander Sack flashplugin-nonfree: status New Triaged
2008-04-15 22:51:26 Alexander Sack pulseaudio: status Confirmed Invalid
2008-04-15 22:52:52 Alexander Sack libflashsupport: importance Undecided High
2008-04-15 22:54:10 Alexander Sack bug added attachment 'flashplugin_nolibflashsupport.debdiff' (make libflashsupport optional by moving it from Depends: to Suggests:)
2008-04-15 22:56:56 Alexander Sack flashplugin-nonfree: status Triaged Fix Committed
2008-04-15 23:00:16 Alexander Sack description Tested on two machines both with gutsy and hardy (on 32 bit x86): flash content very often crashes firefox (both of firefox-3.0 in hardy and older versions). I've just tried with other browsers, epiphany-browser crashes as well, and even konqueror from KDE (though it's not crashing at a whole, since it may run flash and other plugins as another user or something similar - I think at least - but it reports the crash of flash). I don't know exactly the package I should report this against, but as far as I can remember this issue presents since I started to play with pulseaudio: there is a wrapper lib to allow flash to play sound via PA right, so it CAN BE caused by this single issue instead of problem of the browser or the flash plugin itself? Testcase: use pulseaudio and libflashsupport together with flashplugin-nonfree in firefox. 1. navigate to youtube video 2. wait till sound plays 3. hit back button 4. hit forward 5. goto 2 if not yet crashed. the crash sometimes after 2 iterations. and i can't remember that i ever made 10 :) ... ================= Tested on two machines both with gutsy and hardy (on 32 bit x86): flash content very often crashes firefox (both of firefox-3.0 in hardy and older versions). I've just tried with other browsers, epiphany-browser crashes as well, and even konqueror from KDE (though it's not crashing at a whole, since it may run flash and other plugins as another user or something similar - I think at least - but it reports the crash of flash). I don't know exactly the package I should report this against, but as far as I can remember this issue presents since I started to play with pulseaudio: there is a wrapper lib to allow flash to play sound via PA right, so it CAN BE caused by this single issue instead of problem of the browser or the flash plugin itself?
2008-04-15 23:00:39 Alexander Sack description Testcase: use pulseaudio and libflashsupport together with flashplugin-nonfree in firefox. 1. navigate to youtube video 2. wait till sound plays 3. hit back button 4. hit forward 5. goto 2 if not yet crashed. the crash sometimes after 2 iterations. and i can't remember that i ever made 10 :) ... ================= Tested on two machines both with gutsy and hardy (on 32 bit x86): flash content very often crashes firefox (both of firefox-3.0 in hardy and older versions). I've just tried with other browsers, epiphany-browser crashes as well, and even konqueror from KDE (though it's not crashing at a whole, since it may run flash and other plugins as another user or something similar - I think at least - but it reports the crash of flash). I don't know exactly the package I should report this against, but as far as I can remember this issue presents since I started to play with pulseaudio: there is a wrapper lib to allow flash to play sound via PA right, so it CAN BE caused by this single issue instead of problem of the browser or the flash plugin itself? Testcase: use pulseaudio and libflashsupport together with flashplugin-nonfree in firefox. 1. navigate to youtube video 2. wait till sound plays 3. hit back button 4. hit forward 5. goto 2 if not yet crashed. the crash sometimes happens after 2 iterations ... and i can't remember that i ever made 10 :) ... ================= Tested on two machines both with gutsy and hardy (on 32 bit x86): flash content very often crashes firefox (both of firefox-3.0 in hardy and older versions). I've just tried with other browsers, epiphany-browser crashes as well, and even konqueror from KDE (though it's not crashing at a whole, since it may run flash and other plugins as another user or something similar - I think at least - but it reports the crash of flash). I don't know exactly the package I should report this against, but as far as I can remember this issue presents since I started to play with pulseaudio: there is a wrapper lib to allow flash to play sound via PA right, so it CAN BE caused by this single issue instead of problem of the browser or the flash plugin itself?
2008-04-16 12:50:00 Martin Pitt bug added subscriber MOTU Release Team
2008-04-17 08:57:24 Launchpad Janitor flashplugin-nonfree: status Fix Committed Fix Released
2008-04-19 11:34:38 Alexander Sack bug added attachment 'lp192888_pa.patch' (PA patch from comment 75 (crimsun))
2008-04-19 15:05:13 Daniel T Chen bug added attachment 'consider_2.diff' (more robust patch for default pulseaudio configuration)
2008-04-20 03:51:59 Conn O Griofa bug added attachment 'pulseaudio.log' (PulseAudio log (failed to initialize))
2008-04-20 03:52:41 Conn O Griofa bug added attachment 'pulseaudio.log' (PulseAudio log (failed to initialize))
2008-04-20 03:55:07 Conn O Griofa bug added attachment 'pulseaudio2.log' (PulseAudio log (successfully initializes))
2008-04-21 13:09:32 Conn O Griofa bug added attachment 'pulseaudio.log' (PulseAudio log (revision 23 config))
2008-04-21 13:41:21 Alexander Sack pulseaudio: importance Undecided High
2008-04-21 13:41:21 Alexander Sack pulseaudio: status Invalid Confirmed
2008-04-21 13:41:21 Alexander Sack pulseaudio: milestone ubuntu-8.04.1
2008-04-21 13:46:56 Daniel T Chen pulseaudio: status Confirmed In Progress
2008-04-21 15:32:56 Conn O Griofa bug added attachment 'pulseaudio-desktop.log' (PulseAudio log (desktop, rev23 patch))
2008-04-21 21:41:27 Michael Onnen bug added attachment 'pulseaudio-23-server.log' (pulseaudio-23-server.log)
2008-04-22 23:42:12 Jeremy LaCroix bug added attachment 'unnamed' (unnamed)
2008-04-23 02:57:09 Jeremy LaCroix bug added attachment 'unnamed' (unnamed)
2008-04-24 13:15:46 Conn O Griofa bug added attachment 'pulseaudio-flash.log' (pulseaudio-flash.log)
2008-04-24 13:16:29 Conn O Griofa bug added attachment 'pulseaudio-skype.log' (pulseaudio-skype.log)
2008-04-25 03:12:08 The Wind Blows bug added attachment 'systeminfo.txt' (systeminfo.txt)
2008-04-25 04:59:24 Brian Murray description Testcase: use pulseaudio and libflashsupport together with flashplugin-nonfree in firefox. 1. navigate to youtube video 2. wait till sound plays 3. hit back button 4. hit forward 5. goto 2 if not yet crashed. the crash sometimes happens after 2 iterations ... and i can't remember that i ever made 10 :) ... ================= Tested on two machines both with gutsy and hardy (on 32 bit x86): flash content very often crashes firefox (both of firefox-3.0 in hardy and older versions). I've just tried with other browsers, epiphany-browser crashes as well, and even konqueror from KDE (though it's not crashing at a whole, since it may run flash and other plugins as another user or something similar - I think at least - but it reports the crash of flash). I don't know exactly the package I should report this against, but as far as I can remember this issue presents since I started to play with pulseaudio: there is a wrapper lib to allow flash to play sound via PA right, so it CAN BE caused by this single issue instead of problem of the browser or the flash plugin itself? Testcase: use pulseaudio and libflashsupport together with flashplugin-nonfree in firefox. 1. navigate to youtube video 2. wait till sound plays 3. hit back button 4. hit forward 5. goto 2 if not yet crashed. the crash sometimes happens after 2 iterations ... and i can't remember that i ever made 10 :) ... ================= Tested on two machines both with gutsy and hardy (on 32 bit x86): flash content very often crashes firefox (both of firefox-3.0 in hardy and older versions). I've just tried with other browsers, epiphany-browser crashes as well, and even konqueror from KDE (though it's not crashing at a whole, since it may run flash and other plugins as another user or something similar - I think at least - but it reports the crash of flash). I don't know exactly the package I should report this against, but as far as I can remember this issue presents since I started to play with pulseaudio: there is a wrapper lib to allow flash to play sound via PA right, so it CAN BE caused by this single issue instead of problem of the browser or the flash plugin itself? ================= Workaround for early Hardy adopters: Manually uninstall the libflashsupport via 'apt-get remove libflashsupport' or synaptic. This is necessary because libflashsupport would not automatically be removed by update-manager when it was changed from a dependent package to a recommended package during the Hardy development cycle.
2008-04-25 04:59:24 Brian Murray title firefox crashes on flash contents firefox crashes on flash contents when using libflashsupport
2008-05-16 19:45:19 Alexander Jones bug added attachment 'unnamed' (unnamed)
2008-05-20 15:54:15 Alexander Jones bug added attachment 'unnamed' (unnamed)
2008-05-20 19:48:13 Alexander Jones bug added attachment 'unnamed' (unnamed)
2008-05-20 21:03:49 Daniel T Chen flashplugin-nonfree: status Fix Released In Progress
2008-05-20 21:03:49 Daniel T Chen flashplugin-nonfree: assignee crimsun
2008-05-20 21:04:12 Daniel T Chen pulseaudio: status In Progress Invalid
2008-05-20 21:04:28 Daniel T Chen pulseaudio: status In Progress Invalid
2008-05-20 21:04:47 Daniel T Chen pulseaudio: milestone ubuntu-8.04.1
2008-05-20 21:05:04 Daniel T Chen pulseaudio: milestone ubuntu-8.04.1
2008-05-20 21:05:21 Daniel T Chen linux: status New Invalid
2008-05-20 21:05:39 Daniel T Chen linux: status New Invalid
2008-05-20 21:06:13 Daniel T Chen libflashsupport: status Confirmed In Progress
2008-05-20 21:06:13 Daniel T Chen libflashsupport: assignee crimsun
2008-05-20 21:25:06 Launchpad Janitor libflashsupport: status In Progress Fix Released
2008-05-20 21:25:24 Launchpad Janitor flashplugin-nonfree: status In Progress Fix Released
2008-05-21 06:19:04 Alexander Jones bug assigned to ia32-libs (Ubuntu)
2008-05-23 11:06:14 Alexander Jones bug added attachment 'unnamed' (unnamed)
2008-05-29 17:18:10 Mantas Kriaučiūnas bug assigned to libflashsupport (Baltix)
2008-06-01 17:58:08 Phil bug added attachment 'konqueror.kcrash' (konqueror.kcrash)
2008-06-02 06:42:43 Arthur firefox: status Invalid Incomplete
2008-06-14 15:03:18 Cristian T. Moecke bug added attachment 'unnamed' (unnamed)
2008-06-16 17:42:44 Benjamin W. Smith bug added attachment 'firefox_crash.txt' (Debug output.)
2008-07-03 12:38:15 Vincent Tschanz libflashsupport: status Fix Released Confirmed
2008-07-11 09:03:17 Launchpad Janitor libflashsupport: status Confirmed Fix Released
2008-07-18 01:01:26 Conn O Griofa bug added attachment 'nspluginwrapper_1.1.0-0conn1_i386.deb' (nspluginwrapper (1.1.0) i386 package)
2008-07-18 12:57:34 Conn O Griofa bug added attachment 'nspluginwrapper_1.1.0-0conn2_i386.deb' (nspluginwrapper (1.1.0) Hardy i386 package)
2008-07-19 20:39:15 Jeremy LaCroix bug added attachment 'nspluginwrapper_1.1.0-0conn3_amd64.deb' (nspluginwrapper_1.1.0-0conn3_amd64.deb)
2008-08-13 04:16:29 Conn O Griofa description Testcase: use pulseaudio and libflashsupport together with flashplugin-nonfree in firefox. 1. navigate to youtube video 2. wait till sound plays 3. hit back button 4. hit forward 5. goto 2 if not yet crashed. the crash sometimes happens after 2 iterations ... and i can't remember that i ever made 10 :) ... ================= Tested on two machines both with gutsy and hardy (on 32 bit x86): flash content very often crashes firefox (both of firefox-3.0 in hardy and older versions). I've just tried with other browsers, epiphany-browser crashes as well, and even konqueror from KDE (though it's not crashing at a whole, since it may run flash and other plugins as another user or something similar - I think at least - but it reports the crash of flash). I don't know exactly the package I should report this against, but as far as I can remember this issue presents since I started to play with pulseaudio: there is a wrapper lib to allow flash to play sound via PA right, so it CAN BE caused by this single issue instead of problem of the browser or the flash plugin itself? ================= Workaround for early Hardy adopters: Manually uninstall the libflashsupport via 'apt-get remove libflashsupport' or synaptic. This is necessary because libflashsupport would not automatically be removed by update-manager when it was changed from a dependent package to a recommended package during the Hardy development cycle. Testcase: use pulseaudio and libflashsupport together with flashplugin-nonfree in firefox. 1. navigate to youtube video 2. wait till sound plays 3. hit back button 4. hit forward 5. goto 2 if not yet crashed. the crash sometimes happens after 2 iterations ... and i can't remember that i ever made 10 :) ... ================= Tested on two machines both with gutsy and hardy (on 32 bit x86): flash content very often crashes firefox (both of firefox-3.0 in hardy and older versions). I've just tried with other browsers, epiphany-browser crashes as well, and even konqueror from KDE (though it's not crashing at a whole, since it may run flash and other plugins as another user or something similar - I think at least - but it reports the crash of flash). I don't know exactly the package I should report this against, but as far as I can remember this issue presents since I started to play with pulseaudio: there is a wrapper lib to allow flash to play sound via PA right, so it CAN BE caused by this single issue instead of problem of the browser or the flash plugin itself? ================= Workaround for early Hardy adopters: Manually uninstall the libflashsupport via 'apt-get remove libflashsupport' or synaptic. This is necessary because libflashsupport would not automatically be removed by update-manager when it was changed from a dependent package to a recommended package during the Hardy development cycle. ================= Update 13/8/08: Hopefully this summary can help clarify the situation and help get this bug fixed! Since the release of Flash 9, ALSA is the only audio output method supported by Flash (as opposed to earlier releases which had OSS and ESD support built-in). However, to aid with backwards-compatibility, Adobe have provided a simple API to support other audio (and secure transaction) schemes, which can be exposed by using the "libflashsupport" code. You can view the original implementation on Adobe's wiki page, which extends OSS and ESD output to Flash 9: http://labs.adobe.com/wiki/index.php/Flash_Player:Additional_Interface_Support_for_Linux The version of libflashsupport used in Ubuntu (and most recent distributions that use PulseAudio) is different to the above, as it has been extended to support PulseAudio. You can see the relevant upstream wiki, with a description and link to the git repository: http://www.pulseaudio.org/wiki/FlashPlayer9Solution The problem that users are experiencing in this bug is that Flash becomes unstable when the libflashsupport API is used; both the original OSS/ESD implementation provided by Adobe and the version adapted for PulseAudio exhibit this instability. The source of the problem is within Flash itself and it is not due to a bug in the modified libflashsupport code. See this PulseAudio bug report: http://www.pulseaudio.org/ticket/267 So what can we do? We can drop libflashsupport entirely and use a better method to enable PulseAudio support in Flash (and all ALSA applications, in fact). PulseAudio provides ALSA plugins that enable most ALSA applications to have PulseAudio support. Unfortunately, Ubuntu is one of the few distributions that did not configure PulseAudio completely and thus ALSA applications completely bypass PulseAudio, causing mixing conflicts. This issue is reported on bug #198453 and you can read the FAQ at the following link for a summary of the problem here: http://ubuntuforums.org/showthread.php?t=866965 If we remove libflashsupport and fix bug #198453, there's "good news" and "bad news" with regards to Flash: The bad news: Flash 9 still won't work (due to Flash 9's erroneous reliance on snd_async_add_pcm_handler() which causes problems with the PulseAudio ALSA plugin). See the PulseAudio developer's comment on Flash 9 here: https://tango.0pointer.de/pipermail/pulseaudio-discuss/2008-May/001796.html The good news: the snd_async_add_pcm_handler() issue is fixed in Flash 10 (since beta 1). Essentially, Flash 10 is 100% PulseAudio compatible when using the proper configuration of bug #198453. In summary, the solution to this bug: 1. Upgrade to Flash 10 (at release candidate status as of 13/8) 2. Drop libflashsupport completely (it causes instability in Flash 9 and 10) 3. Fix bug #198453 This bug is a trivial fix for Intrepid (and should have been fixed a long time ago, to give PulseAudio time for testing). It is also possible to fix in Hardy, as long as the prerequisites of bug #198453 can be fulfilled whilst keeping the SRU policy for an LTS release in mind. Either way, *something needs to be done*.
2008-09-17 14:46:29 Alexander Sack ia32-libs: status New Triaged
2008-09-17 14:46:29 Alexander Sack ia32-libs: assignee shermann
2008-09-17 14:46:29 Alexander Sack ia32-libs: importance Undecided High
2008-09-17 14:46:29 Alexander Sack ia32-libs: statusexplanation \sh, can you remove libflashsupport.so from ia32-libs too? (probably just missed in the recent intrepid upload). Thanks!
2008-09-17 14:50:03 Alexander Sack ia32-libs: statusexplanation \sh, can you remove libflashsupport.so from ia32-libs too? (probably just missed in the recent intrepid upload). Thanks! removing libflashsupport.so from ia32-libs has already been dragged for such a long time. milestoning the removal of libflashsupport.so for beta (but please upload asap anyway).
2008-09-17 14:50:03 Alexander Sack ia32-libs: milestone ubuntu-8.10-beta
2008-09-17 17:03:44 Stephan Ruegamer ia32-libs: status Triaged In Progress
2008-09-17 17:03:44 Stephan Ruegamer ia32-libs: statusexplanation
2008-09-18 09:25:06 Launchpad Janitor ia32-libs: status In Progress Fix Released
2008-09-24 11:40:35 Alexander Sack firefox: status Incomplete Invalid
2008-09-24 11:40:35 Alexander Sack firefox: statusexplanation not a firefox issue.
2008-10-08 11:39:47 Alexander Sack libflashsupport: status Confirmed Won't Fix
2008-10-08 11:39:47 Alexander Sack libflashsupport: statusexplanation we wont be able to fix libflashsupport. setting task to wont fix. In intrepid libflashsupport should not be required anymore and since its even gone from ia32-libs there is no important bug we can fix here anymore.
2008-10-16 15:42:24 Daniel T Chen libflashsupport: status Confirmed Fix Released
2008-10-16 15:42:24 Daniel T Chen libflashsupport: statusexplanation flashplugin-nonfree now Conflicts with libflashsupport.
2008-11-14 10:52:36 Launchpad Janitor displayname Bug #192888 Bug #192888 (lambie)
2008-11-14 10:52:36 Launchpad Janitor name lambie
2009-01-22 11:03:29 Michael Nagel libflashsupport: status New Invalid
2009-01-22 11:03:29 Michael Nagel libflashsupport: statusexplanation
2009-01-22 11:04:01 Michael Nagel ia32-libs: status New Invalid
2009-01-22 11:04:01 Michael Nagel ia32-libs: statusexplanation
2009-04-09 13:54:09 Jeroen bug watch added http://pulseaudio.org/ticket/267
2009-04-09 18:47:43 Brett Alton removed subscriber Brett Alton
2009-04-10 00:17:55 ktp420 removed subscriber ktp420
2009-06-09 21:34:45 Jacob Peddicord removed subscriber Jacob Peddicord
2009-06-09 22:04:10 ubuntu.diego removed subscriber ubuntu.diego
2009-06-09 22:22:46 Alex Falcone removed subscriber Alex Falcone
2009-06-10 05:10:54 chowder removed subscriber absolutezero1287
2009-06-10 06:39:24 Matt Austin removed subscriber Matt Austin
2009-06-10 07:14:22 Jeroen removed subscriber Jeroen
2009-08-07 16:45:15 Launchpad Janitor branch linked lp:ubuntu/karmic/flashplugin-nonfree
2010-01-07 18:40:28 Launchpad Janitor branch linked lp:ubuntu/ia32-libs