aplay record file failed always.

Bug #1824103 reported by Gabriel Zhi Chen on 2019-04-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Critical
Hui Wang

Bug Description

Test machine: ThinkPad X1 Carbon
Image: Ubuntu Disco 19.04
CPU: Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz (family: 0x6, model: 0x8e, stepping: 0xa)
GPU: Intel Corporation Device [8086:5917] (rev 07) (prog-if 00 [VGA controller])
BIOS: N23ET55W (1.30 )

Steps:
1. Install image 19.04
2. Login as default user
3. Open a terminal and type "$ arecord abc.wav"
4. Say something and let laptop recorded your words
5. Cancel the record, please press 'Ctrl + C'
6. Please type "$ aplay abc.wav" in terminal

Expected result:
The voice played smoothly.

Actual result:
Step 3,
u@u-ThinkPad-X1-Carbon-6th:~$ arecord abc.wav
Recording WAVE 'abc.wav' : Unsigned 8 bit, Rate 8000 Hz, Mono
^CAborted by signal Interrupt...
arecord: pcm_read:2145: read error: Interrupted system call

Step 6,
u@u-ThinkPad-X1-Carbon-6th:~$ aplay abc.wav
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
aplay: main:828: audio open error: Device or resource busy

Gabriel Zhi Chen (gabrielzchen) wrote :
Gabriel Zhi Chen (gabrielzchen) wrote :
Gabriel Zhi Chen (gabrielzchen) wrote :

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1824103

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

Just tested, the voice recorded is OK.

But there is some difference between 19.04 and 18.04, after installing 18.04, the aplay/arecord default device pulseaudio, while after installing the 19.04, the aplay/arecord default device is hw sound card.

Please install 19.04 to a different machine (not x1 carbon), let us see if the default device will change to pulseaudio or not.

Hui Wang (hui.wang) on 2019-04-16
Changed in linux (Ubuntu):
assignee: nobody → Hui Wang (hui.wang)
importance: Undecided → Critical
summary: - The vioce which recored by Internal microphone gets noisy
+ aplay record file failed always.
description: updated
Will Cooke (willcooke) wrote :

Is there a step missing in the reproducer steps? On a new 19.04 install on a random Dell Inspiron arecord fails with:

ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
arecord: main:828: audio open error: No such file or directory

Hui Wang (hui.wang) wrote :

Yes, this is because the alsa-lib has a new change but the pulseaudio has not changed accordingly.

commit 93e03bdc2a3dcd5d12516f5de78e14d88a32ff2c
Author: Jaroslav Kysela <email address hidden>
Date: Wed Apr 4 09:58:12 2018 +0200

    alsa.conf: change the location for add-on configs to /etc/alsa/conf.d

    The add-on configuration files should be placed to a volatile place.

    Signed-off-by: Jaroslav Kysela <email address hidden>

The steps to reproduce it:
install ubuntu 19.04 on a machine (any machines with audio capablilities)
after booting up, cd /tmp; arecord test.wav; aplay test.wav, then the aplay will fail. And from then on, both aplay and arecord can't work anymore.

Hui Wang (hui.wang) wrote :

The commit of #7 is in the alsa-lib from 1.1.7, so it only affects 19.04 Disco, the Cosmic and lower version works fine.

affects: linux (Ubuntu) → pulseaudio (Ubuntu)
Will Cooke (willcooke) wrote :

@infinity has found a fix for this in Debian and is looking at syncing it now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:12.2-2ubuntu3

---------------
pulseaudio (1:12.2-2ubuntu3) disco; urgency=medium

  * debian/pulseaudio.links: chmod +x so that dh-exec actually works.

pulseaudio (1:12.2-2ubuntu2) disco; urgency=medium

  * Cherrypick changes from 12.2-3 to stop compiling with -ffast-math
    and to fix alsa/pulseaudio config file integration (LP: #1824103)

 -- Adam Conrad <email address hidden> Tue, 16 Apr 2019 07:54:26 -0600

Changed in pulseaudio (Ubuntu):
status: Incomplete → Fix Released

Retest the issue on Yoda2-2, image : Disco-Daily-20190416, it can not reproduce anymore.

The test.wav file can record and play normally.

When executing commands arecord and aplay, there is no error info feedback also.

tags: added: cqa-verified
Betty Lin (bettyl) wrote :

Can't reproduce the bug on XPS13 with Disco Final 0416.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers