Please include pavucontrol in default desktop seed

Bug #179095 reported by Roderic Jones on 2007-12-28
44
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Ubuntu Audio Team
pavucontrol (Ubuntu)
Wishlist
Ubuntu Audio Team
pulseaudio (Ubuntu)
Undecided
Ubuntu Audio Team
ubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Fresh install of Hardy Heron A2 produces no sound. I had problems with previous distributions because I have onboard sound (ASUS A8N SLI SE) but these problems have been cured by turning off the onboard sound in the BIOS. I have Gutsy still installed on a different hard disc and this works OK.

Stanley Sokolow (overbyte) wrote :

Do you have sound when playing the Examples .ogg files? See comments by Stanley Sokolow (me) in bug #162336 . Do they describe your problem?

Thank you for your email.

I am sorry to say that there is no sound at all. I have a large
collection of flac files and these do not play. Incidentally I
installed the 64 bit version fromn the alt cd

Rod Jones

On 29/12/2007, Stanley Sokolow <email address hidden> wrote:
> Do you have sound when playing the Examples .ogg files? See comments
> by Stanley Sokolow (me) in bug #162336 . Do they describe your
> problem?
>
> --
> No sound with Audigy card in Hardy Heron - works OK in Gutsy. Card recognised by "sound Preferences"
> https://bugs.launchpad.net/bugs/179095
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Roderic Jones

I'm running Ubuntu 8.04 alpha-2 for i386 32-bit desktop on my testing
machine. I found a web page with links to flac music files for testing:
http://ff123.net/samples.html . I clicked on a link there. Ubuntu
popped up a window asking for permission to open it in Movie Player,
which I accepted. The player asked for permission to download the
missing codec, which I approved and it did. The flac file played
perfectly. (I have elsewhere reported that system sounds and midi files
don't play sound but .ogg and flash videos do play sound on my system.)

>From what I've seen in other users' comments, the 64-bit versions of
Linux are not as well supported with drivers and codecs as the 32-bit
version, so many users have said they will stay with the 32-bit releases
on their x64 64-bit-capable computers until the situation improves. If
you do re-install Ubuntu with the i386 version, please add a comment
here to report the results with your flac files.

Stan

------------
On Sat, 2007-12-29 at 14:51 +0000, Roderic Jones wrote:
> Thank you for your email.
>
> I am sorry to say that there is no sound at all. I have a large
> collection of flac files and these do not play. Incidentally I
> installed the 64 bit version fromn the alt cd
>
> Rod Jones
>
> On 29/12/2007, Stanley Sokolow <email address hidden> wrote:
> > Do you have sound when playing the Examples .ogg files? See comments
> > by Stanley Sokolow (me) in bug #162336 . Do they describe your
> > problem?
> >
> > --
> > No sound with Audigy card in Hardy Heron - works OK in Gutsy. Card recognised by "sound Preferences"
> > https://bugs.launchpad.net/bugs/179095
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
>
> --
> Roderic Jones
>

Can confirm no sound after upgrading to hardy

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Thom Pischke (thom-pischke) wrote :

This seems to have fixed itself for me after a fresh reboot.

Thank you for your email.

I have installed the 32 bit version. Flac files now play OK but there
are still no system sounds - e.g. Logon or Logoff. Sounds will not
play from the sounds preferences menu.

Best widhes

Rod Jones

On 29/12/2007, Stanley Sokolow <email address hidden> wrote:
> I'm running Ubuntu 8.04 alpha-2 for i386 32-bit desktop on my testing
> machine. I found a web page with links to flac music files for testing:
> http://ff123.net/samples.html . I clicked on a link there. Ubuntu
> popped up a window asking for permission to open it in Movie Player,
> which I accepted. The player asked for permission to download the
> missing codec, which I approved and it did. The flac file played
> perfectly. (I have elsewhere reported that system sounds and midi files
> don't play sound but .ogg and flash videos do play sound on my system.)
>
> >From what I've seen in other users' comments, the 64-bit versions of
> Linux are not as well supported with drivers and codecs as the 32-bit
> version, so many users have said they will stay with the 32-bit releases
> on their x64 64-bit-capable computers until the situation improves. If
> you do re-install Ubuntu with the i386 version, please add a comment
> here to report the results with your flac files.
>
> Stan
>
> ------------
> On Sat, 2007-12-29 at 14:51 +0000, Roderic Jones wrote:
> > Thank you for your email.
> >
> > I am sorry to say that there is no sound at all. I have a large
> > collection of flac files and these do not play. Incidentally I
> > installed the 64 bit version fromn the alt cd
> >
> > Rod Jones
> >
> > On 29/12/2007, Stanley Sokolow <email address hidden> wrote:
> > > Do you have sound when playing the Examples .ogg files? See comments
> > > by Stanley Sokolow (me) in bug #162336 . Do they describe your
> > > problem?
> > >
> > > --
> > > No sound with Audigy card in Hardy Heron - works OK in Gutsy. Card recognised by "sound Preferences"
> > > https://bugs.launchpad.net/bugs/179095
> > > You received this bug notification because you are a direct subscriber
> > > of the bug.
> > >
> >
> >
> > --
> > Roderic Jones
> >
>
> --
> No sound with Audigy card in Hardy Heron - works OK in Gutsy. Card recognised by "sound Preferences"
> https://bugs.launchpad.net/bugs/179095
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Roderic Jones

Telephone 01873 890050

After fresh updates sound card device has removed from system.
And I can't plug it to system.. Ubuntu think that my laptop don't have a sound card...

Scott Beamer (angrykeyboarder) wrote :

Ditto here. I have the Audigy 2 ZS.

I did a fresh install of Hardy (Daily Live CD from 21 March) on 21 March.

$ cat /proc/interrupts
           CPU0
  0: 285 IO-APIC-edge timer
  1: 8828 IO-APIC-edge i8042
  3: 2 IO-APIC-edge
  4: 2 IO-APIC-edge
  6: 7 IO-APIC-edge floppy
  7: 0 IO-APIC-edge parport0
  8: 3 IO-APIC-edge rtc
  9: 0 IO-APIC-fasteoi acpi
 12: 1125381 IO-APIC-edge i8042
 14: 227673 IO-APIC-edge ide0
 16: 1886015 IO-APIC-fasteoi ohci1394, ivtv0, nvidia
 17: 128773 IO-APIC-fasteoi eth0, ivtv1
 18: 113143 IO-APIC-fasteoi sata_promise, EMU10K1
 19: 162478 IO-APIC-fasteoi sata_via
 20: 664123 IO-APIC-fasteoi uhci_hcd:usb1, uhci_hcd:usb2, uhci_hcd:usb3, uhci_hcd:usb4, ehci_hcd:usb5
 21: 9729 IO-APIC-fasteoi ohci1394, ohci1394
 22: 636178 IO-APIC-fasteoi VIA8237
NMI: 0 Non-maskable interrupts
LOC: 6844690 Local timer interrupts
RES: 0 Rescheduling interrupts
CAL: 0 function call interrupts
TLB: 0 TLB shootdowns
TRM: 0 Thermal event interrupts
SPU: 0 Spurious interrupts
ERR: 0
MIS: 0

I'd give you the output of alsa-info.sh but I can't get the script right now. http://www.linux-sound.info is down. If anyone can send me the script (see my page here on Launchpad for my email) I'll gladly post the output of the script here as well.

Scott Beamer (angrykeyboarder) wrote :

UPDATE: I located a copy of the script at http://hg.alsa-project.org/alsa/raw-file/tip/alsa-info.sh

See attached results

Marshall C (marshall-c) wrote :

Another confirmation, my Soundblaster Audigy SE is no longer being detected after a devel-release update from 7.10 to 8.04.

malaeum (malaeum) wrote :

from lspci -v:

01:00.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
 Subsystem: Creative Labs SB0090 Audigy Player
 Flags: bus master, medium devsel, latency 64, IRQ 17
 I/O ports at d880 [size=32]
 Capabilities: [dc] Power Management version 2

I also have no sound. Installed off of the normal 64-bit installer CD, Beta 1. Checked for bugs a while back, none file, glad to see that I'm not the only one. If there is any other info required please do not hesitate to ask, I'll gladly provide it. I might try building the kernel driver into the kernel instead of loading the module, if that works (or if it doesn't) I'll report back. Haven't rolled my own kernel yet since moving to Ubuntu 6 months ago so might take a bit of effort, but I should be able to do it tonight.

Thanks!

malaeum (malaeum) wrote :

Well I seem to have fixed this issue. I did not build the driver into the kernel. Instead I just went ahead and fired up synaptic and reinstalled every package that was found by searching the name and description for "alsa". I didn't bother uninstalling, just went ahead and reinstalled them. Rebooted the system, not technically necessary, but easiest way for my lazy self. Going into System-->Preferences-->Sound I set the device to "Audgy 1[SB0090] (Alsa mixer)". Clearly this device will vary depending on your hardware, choose the Audigy card. From there I set all of the options above to ALSA. The last step I took was to open gnome-volume-control, made sure that File-->Change Device had the Audigy card selected, then on the switched tab de-selected the Analog/Digital Output option as I am not using a digital output. You should have this selected ONLY if you are using an optical or digital coaxial output AFAIK.

Seeing as how I had a similar issue as many others here I hope that this helps you guys out as well.

Cheers,
Matt

Craig Huffstetler (xq) wrote :

No sound here either after the upgrade to the current Hardy Heron Beta release. Please find attached lspci -v output. alsa-info.sh confirmed the same as the above user's unfortunately.

I had sound in 7.10 fine (without any issues at all). No sound works output from speakers. I am attempting to use ALSA as my driver (OR Auto Detect); however, NEITHER work.

I have tried the above method (Matt's) to no avail.

(My system is a Dell XPS 720; Soundblaster Audigy XS card, with onboard sound as well. However, NEITHER onboard nor the Audigy outputs work). I prefer to use the regular output because at his time I do not use digital...(just an FYI).

Sincerely,

xq / Craig Huffstetler

Changed in alsa-driver:
assignee: nobody → ubuntu-audio
Luke Yelavich (themuso) wrote :

I think this has something to do with pulseaudio. Could you all try disabling the software sound mixing option in the GNOME sound preferences, and try playing music/video? Yes you won't get sound events, but you should still get sound for everything else.

Craig Huffstetler (xq) wrote :

Nope, did not correct.

Luke Yelavich (themuso) wrote :

Scott, try looking in either /var/log/syslog or .xsession-errors for any alsa related error messages you get. According to your alsa info output, pulseaudio should work, due to your audigy having the right mixer elements needed, but obviously there is something else. If you could get that output and attach to this bug, that would be much appreciated.

na033681 (na033681) wrote :

I also have no system sounds using an Audigy 2 ZS sound card. Movies and music play fine.

As for malaeum's comment about the Analog/Digital Output option, if I de-select it I lose all sound.

I did a upgrade from Gusty where I had system sound working.

I looked in my syslog and couldn't find any alsa errors. As for .xsession-errors, I found alsa mentioned a few times.

Scott Beamer (angrykeyboarder) wrote :

Since sound was working "out of the box" in Fedora 9 beta1, I decided to take a close look at the settings there.

The first thing I noticed is that Ubuntu does NOT have pavucontrol installed by default (as does Fedora - and Mandriva 2008.1 as well).

So, to correct this I ....

 $sudo apt-get install pavucontrol

Then I back to "Applications-->Sound And Video" and found it was now installed.

Still no sound, but I was quickly able to remedy that by selecting my Audigy as the default.

I logged out and there were the bongo drums! w00t!

At last, sound.

Fast forward several days and several updates and I was back to no sound again.

So I checked the menu and strangely pavucontrol was gone.

To double check, checked to see if in fact the package was sill installed. It was, but the pavucontrol.desktop file now had a "NoDisplay=true" (!) line it it. So....

I right-click on the applications menu, selected "Edit" and....

....It was there but not checked. So, I checked it and back it was on the menu.

I then had to make the adjustments *again* to for the proper defaults for my card. And now I'm back in business.

With luck when Hardy is final, pavucontrol *will* be installed by default (as it is in the latest version of Mandriva and the upcoming version of Fedora) and if we're even luckier it will have right settings in it's .desktop file and last but not least, sound will work out of the box.

My second choice would be all of the above, with no initial sound, but easily remedied via the "PulseAudio Volume Control" applet can be found in the "Sound And Video" section of the Applications menu....

Screenshots are attached to illustrate some of the above.

Now I may be crazy and this might not work for anybody else who was in my predicament. But give it a shot. If you get the same result, then it looks as if I was right. If not, I guess it's just me.

I know next to nothing about ALSA and even less about PulseAudio.

Anyway, thanks for your attention.

Scott :)

Scott Beamer (angrykeyboarder) wrote :

One more thing...

I've been having problems with this card in Linux since I got this computer (back in late 2004). It's been hit or miss and lots of tweaking (in the pre-PulseAudio) days.

And in Windows Vista it's almost as bad.

So, I decided to switch to a (hopefully) better card. I'm getting an M-Audio Revolution 5.1 in a few days.. We will see how that goes.

My point being that I won't be able to contribute any more to this bug.

Thanks.

Scott Beamer (angrykeyboarder) wrote :

UPDATE: disregard previous remarks. I'm still running the Audigy card for the time being.

I suppose thix bug will still be around after Hardy is released... :(

Changed in alsa-driver:
status: New → Confirmed
assignee: nobody → ubuntu-audio
Changed in pavucontrol:
status: New → Confirmed
assignee: nobody → ubuntu-audio
Roberto Leinardi (leinardi) wrote :

I had the same problem after upgrading from Gusty to Hardy.

I solved by eliminating the check from Audigy Analog/Digital Output Jack in Alsa Mixer.

ikester8 (ihall) wrote :

@JD:

You rock! That did it for me too, and it had been driving me nuts.

Daniel T Chen (crimsun) wrote :

Not a PulseAudio issue. This is the well known mixer element toggle issue. Please complain to Creative.

Changed in pulseaudio:
status: Confirmed → Invalid
Changed in pavucontrol:
status: Confirmed → Invalid
Changed in alsa-driver:
status: Confirmed → Invalid

Daniel T Chen wrote:
> Not a PulseAudio issue. This is the well known mixer element toggle
> issue. Please complain to Creative.
>

I'd rather complain to you. :)

I can tell you Mandriva and Fedora have pavucontrol installed and I get
my Audigy 2 ZS working that way. It is not installed in Ubuntu (by
default) and until I did, I could not get sound working.

Why would Mandriva and Fedora feel it necessary to include pavucontrol?
Regardless of my report, One loses major PulseAudio functionality
without it.

The inclusion of pavucontrol by default in Fedora and Mandriva makes this problem easily solvable by the end user. And since I knew that I "sudo apt-get install pavucontrol" in Ubuntu to achieve the same thing.

pavucontrol needs to be installed by default.

Changed in pavucontrol:
status: Invalid → New
a bowen (a-bowen) wrote :

I'm new to linux so probably shouldn't be here but... I installed Ubuntu 8.04 last week on a new second hard drive in a (now mixed OS) Dell Windows XP 2002 - and there's no sound. The sound card is a Creative SB Audigy 2. It seems to be quite a common problem and so I've tried various of the suggested ways of resolving the problem and none seem to help me out...
- Opening the volume control and toggling the Audigy Analog/Digital Output Jack
- System – Audio – Devices – Changing all the drivers to “ALSA Advanced”
- Using the Terminal command aplay -l
Ubuntu sees the card on card 1
**** List of PLAYBACK Hardware Devices ****
card 0: ICH5 [Intel ICH5], device 0: Intel ICH [Intel ICH5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: ICH5 [Intel ICH5], device 4: Intel ICH - IEC958 [Intel ICH5 - IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audigy2 [Audigy 2 ZS [SB0353]], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
  Subdevices: 32/32
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
  Subdevice #8: subdevice #8
  Subdevice #9: subdevice #9
  Subdevice #10: subdevice #10
  Subdevice #11: subdevice #11
  Subdevice #12: subdevice #12
  Subdevice #13: subdevice #13
  Subdevice #14: subdevice #14
  Subdevice #15: subdevice #15
  Subdevice #16: subdevice #16
  Subdevice #17: subdevice #17
  Subdevice #18: subdevice #18
  Subdevice #19: subdevice #19
  Subdevice #20: subdevice #20
  Subdevice #21: subdevice #21
  Subdevice #22: subdevice #22
  Subdevice #23: subdevice #23
  Subdevice #24: subdevice #24
  Subdevice #25: subdevice #25
  Subdevice #26: subdevice #26
  Subdevice #27: subdevice #27
  Subdevice #28: subdevice #28
  Subdevice #29: subdevice #29
  Subdevice #30: subdevice #30
  Subdevice #31: subdevice #31
card 1: Audigy2 [Audigy 2 ZS [SB0353]], device 2: emu10k1 efx [Multichannel Capture/PT Playback]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 1: Audigy2 [Audigy 2 ZS [SB0353]], device 3: emu10k1 [Multichannel Playback]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audigy2 [Audigy 2 ZS [SB0353]], device 4: p16v [p16v]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Using the Terminal Command: alsamixer
and adjusting the 25 levels does not seem to make any difference
Going to ALSA's webpage and looking for the driver it indicates the “emu10k1” as shown in Terminal – vedi: card 1: Audigy2 [Audigy 2 ZS [SB0353]], device 3: emu10k1

On the original Dell installed CD from Sound Blaster it has the Build as: SBA2-DLS1D-W3-LB. Is this “emu10k1” the right driver for this?

Please could someone help as I'm lost and in over my head.

Thanks

Download full text (3.5 KiB)

Have you tried turning on board sound off in the bios? This will probably work.

Rod Jones

2008/10/7 a bowen <email address hidden>:
> I'm new to linux so probably shouldn't be here but... I installed Ubuntu 8.04 last week on a new second hard drive in a (now mixed OS) Dell Windows XP 2002 - and there's no sound. The sound card is a Creative SB Audigy 2. It seems to be quite a common problem and so I've tried various of the suggested ways of resolving the problem and none seem to help me out...
> - Opening the volume control and toggling the Audigy Analog/Digital Output Jack
> - System – Audio – Devices – Changing all the drivers to "ALSA Advanced"
> - Using the Terminal command aplay -l
> Ubuntu sees the card on card 1
> **** List of PLAYBACK Hardware Devices ****
> card 0: ICH5 [Intel ICH5], device 0: Intel ICH [Intel ICH5]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> card 0: ICH5 [Intel ICH5], device 4: Intel ICH - IEC958 [Intel ICH5 - IEC958]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> card 1: Audigy2 [Audigy 2 ZS [SB0353]], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
> Subdevices: 32/32
> Subdevice #0: subdevice #0
> Subdevice #1: subdevice #1
> Subdevice #2: subdevice #2
> Subdevice #3: subdevice #3
> Subdevice #4: subdevice #4
> Subdevice #5: subdevice #5
> Subdevice #6: subdevice #6
> Subdevice #7: subdevice #7
> Subdevice #8: subdevice #8
> Subdevice #9: subdevice #9
> Subdevice #10: subdevice #10
> Subdevice #11: subdevice #11
> Subdevice #12: subdevice #12
> Subdevice #13: subdevice #13
> Subdevice #14: subdevice #14
> Subdevice #15: subdevice #15
> Subdevice #16: subdevice #16
> Subdevice #17: subdevice #17
> Subdevice #18: subdevice #18
> Subdevice #19: subdevice #19
> Subdevice #20: subdevice #20
> Subdevice #21: subdevice #21
> Subdevice #22: subdevice #22
> Subdevice #23: subdevice #23
> Subdevice #24: subdevice #24
> Subdevice #25: subdevice #25
> Subdevice #26: subdevice #26
> Subdevice #27: subdevice #27
> Subdevice #28: subdevice #28
> Subdevice #29: subdevice #29
> Subdevice #30: subdevice #30
> Subdevice #31: subdevice #31
> card 1: Audigy2 [Audigy 2 ZS [SB0353]], device 2: emu10k1 efx [Multichannel Capture/PT Playback]
> Subdevices: 8/8
> Subdevice #0: subdevice #0
> Subdevice #1: subdevice #1
> Subdevice #2: subdevice #2
> Subdevice #3: subdevice #3
> Subdevice #4: subdevice #4
> Subdevice #5: subdevice #5
> Subdevice #6: subdevice #6
> Subdevice #7: subdevice #7
> card 1: Audigy2 [Audigy 2 ZS [SB0353]], device 3: emu10k1 [Multichannel Playback]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> card 1: Audigy2 [Audigy 2 ZS [SB0353]], device 4: p16v [p16v]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
>
> Using the Terminal Command: alsamixer
> and adjusting the 25 levels does not seem to make any difference
> Going to ALSA's webpage and looking for the driver it indicates the "emu10k1" as shown in Terminal – vedi: card 1: Audigy2 [Audigy 2 ZS [SB0353]], device 3: emu10k1
>
> On the original Dell installed CD from Sound Blaster it has the Build
> as: SBA2-DLS1D-W3-LB. Is this "emu10k1" the right driver for this?
>
> Please could someone help as I'm los...

Read more...

I also saw on the forums the option from Terminal to enter 'asoundconf' then 'asoundconf set-default-card x' but I haven't tried that as your suggestion to turn off the on-board sound in bios worked. Now I'm a happy man, thanks Rod and hope you have a great week.

Daniel T Chen (crimsun) on 2008-10-07
Changed in pavucontrol:
importance: Undecided → Wishlist
Mark Falcey (mfalcey) wrote :

After spending the last 6 months helping people on the forums with sound problems i have come to the conclusion that about 60% of them would never have happened if pavucontrol was included in the default desktop seed for Hardy and now Intrepid.

Someone needs to get a grip on this insane state of affairs.

Jarno Suni (jarnos) wrote :

But Ubuntu comes with gnome-volume-control (in gnome-media package) by which you can do the same settings, right?

Changed in pavucontrol (Ubuntu):
status: New → Confirmed
Logan Rosen (logan) wrote :

Making this affect ubuntu-meta instead of pavucontrol, as ubuntu-meta would be where this dependency would be located.

Changed in pavucontrol (Ubuntu):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers