pulseaudio --dump-conf prints the wrong value of avoid-resampling (opposite to the real value)

Bug #1789089 reported by Mark on 2018-08-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Low
Unassigned

Bug Description

https://gitlab.freedesktop.org/pulseaudio/pulseaudio/issues/568

---

So PulseAudio on Ubuntu 18.04 apparently does not honor the "avoid-resampling = yes" configuration option. That is the option to allow native sample rate playback with PulseAudio. When I set the option to either "yes" or "true" (tried both) in /etc/pulse/daemon.conf, restart PulseAudio and check to see the active configuration (using --dump-conf), I get "avoid-resampling = no" every time.

I tried disabling PulseAudio daemonize mode and manually starting it from terminal, I tried setting the option globally and in ~/.config/pulse, I tried restarting the system after setting the option. No difference.

I believe this is a bug, as the option should definitely work, as it is available since PulseAudio 11. I'm running version 11.1.

Steps to reproduce the issue:

1. Edit the /etc/pulse/daemon.conf file and add the following line, or uncomment the commented default and change it to "yes" (or "true"):

avoid-resampling = yes

2. Restart PulseAudio daemon

3. Print the loaded PulseAudio configuration by running pulseaudio --dump-conf

4. Observe that it prints "avoid-resampling = no" every time

Mark (marko7fcb) on 2018-08-26
description: updated
description: updated
Daniel van Vugt (vanvugt) wrote :

Please report this bug to the PulseAudio developers here:

  https://gitlab.freedesktop.org/groups/pulseaudio/-/issues

and then tell us the new bug ID.

tags: added: bionic
Changed in pulseaudio (Ubuntu):
status: New → Incomplete
Mark (marko7fcb) wrote :

Bug reported to PulseAudio GitLab. ID: 568

https://gitlab.freedesktop.org/pulseaudio/pulseaudio/issues/568

Daniel van Vugt (vanvugt) wrote :

Thanks

Changed in pulseaudio (Ubuntu):
status: Incomplete → New
description: updated
Daniel van Vugt (vanvugt) wrote :
summary: - PulseAudio does not honor the "avoid-resampling" setting
+ pulseaudio --dump-conf prints the wrong value of avoid-resampling
+ (opposite to the real value)
Changed in pulseaudio (Ubuntu):
importance: Undecided → Low
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions