[USB-Audio - SteelSeries Arctis 7, playback] No stereo playback only mono playback

Bug #1758736 reported by Kaj Printz Madsen on 2018-03-25
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Status tracked in Disco
Bionic
Low
Dave Chiluk
Cosmic
Low
Dave Chiluk
Disco
Low
Dave Chiluk

Bug Description

[Impact]

 * User is only able to get mono audio from steelseries headsets because they provide both a stereo and mono output. PA selects the mono output by default.

 * This should be backported to stable releases because this fix is
   isolated to code that only applies to the affected headsets.
   Additionally other gaming headsets may be more easily enabled by adding
ATTRS{idVendor}=="<VENDOR>", ATTRS{idProduct}=="<PRODUCT>", ENV{PULSE_PROFILE_SET}="steelseries-arctis-7-usb-audio.conf"
   to /lib/udev/rules.d/90-pulseaudio.rules now. Such as the Lucidsound
   LS31 which I own.

 * The upload fixes the bug by conditionally setting a pulseaudio profile for the headset based on specific usb vendor and product ids in the udev rules.

[Test Case]

 1. Acquire headset.
 2. Open sound settings, and click test speakers.
 3. Only option available will be mono sound

[Regression Potential]

 * Risk of regressions should be mitigated to those who own the headset. In which case it is likely that their headset is already not working.

[Other Info]

 * All patches originate from upstream pulseaudio, and are documented as
   such including the shas.

 * I will be pursuing enabling other similar headsets in the coming weeks.
 * I plan to work with upstream pulseaudio to enable my own headset and to
   also make the headset templates backported here more generic.

---------------- Original Description -------------------------

There is not stereo playback only mono playback

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: pulseaudio 1:10.0-2ubuntu3.1
ProcVersionSignature: Ubuntu 4.13.0-37.42-generic 4.13.13
Uname: Linux 4.13.0-37-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC1D0p: kaj 1755 F...m pulseaudio
 /dev/snd/controlC1: kaj 1755 F.... pulseaudio
 /dev/snd/pcmC0D0c: kaj 1755 F...m pulseaudio
 /dev/snd/controlC0: kaj 1755 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Sun Mar 25 21:30:50 2018
InstallationDate: Installed on 2018-03-08 (17 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20180105.1)
SourcePackage: pulseaudio
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:S7 successful
Symptom_Card: SteelSeries Arctis 7 - SteelSeries Arctis 7
Symptom_PulsePlaybackTest: PulseAudio playback test failed
Symptom_Type: No sound at all
Title: [USB-Audio - SteelSeries Arctis 7, playback] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/09/2016
dmi.bios.vendor: LENOVO
dmi.bios.version: R06ET35W (1.09 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20FMS2AV00
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40697 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrR06ET35W(1.09):bd03/09/2016:svnLENOVO:pn20FMS2AV00:pvrThinkPadT460:rvnLENOVO:rn20FMS2AV00:rvrSDK0J40697WIN:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad T460
dmi.product.name: 20FMS2AV00
dmi.product.version: ThinkPad T460
dmi.sys.vendor: LENOVO

Kaj Printz Madsen (kajprintz) wrote :
summary: - [USB-Audio - SteelSeries Arctis 7, playback] No sound at all
+ [USB-Audio - SteelSeries Arctis 7, playback] No stereo playback only
+ mono playback
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pulseaudio (Ubuntu):
status: New → Confirmed
hugue (hugue) wrote :

Can confirm the bug on 17.10.
Bug still exists in the 18.04 release.

tags: added: bionic
Dave Chiluk (chiluk) on 2019-01-23
Changed in pulseaudio (Ubuntu):
assignee: nobody → Dave Chiluk (chiluk)
importance: Undecided → Low
Changed in pulseaudio (Ubuntu Cosmic):
importance: Undecided → Low
Changed in pulseaudio (Ubuntu Bionic):
importance: Undecided → Low
Changed in pulseaudio (Ubuntu Cosmic):
assignee: nobody → Dave Chiluk (chiluk)
Changed in pulseaudio (Ubuntu Bionic):
assignee: nobody → Dave Chiluk (chiluk)
tags: removed: artful
Dave Chiluk (chiluk) wrote :

Can someone on this bug please test the packages from
https://launchpad.net/~chiluk/+archive/ubuntu/lp1758736
on Bionic?

Dave Chiluk (chiluk) wrote :

Basically what I did was backport all the required Arctis stuff that seemed to be required in order to get my lucid sound headphones working.

Changed in pulseaudio (Ubuntu Bionic):
status: New → In Progress
Changed in pulseaudio (Ubuntu Cosmic):
status: New → Confirmed
Dave Chiluk (chiluk) wrote :

Looking at pulseaudio upstream, it looks like 12.2 has
15386a710c1500f70085a6312fb4d84be4d254c9 and
c7fe78c9f73ded2c3428666722ec9c1af4b82812
  but not
83675b3745c64bd738400eae44eb4daa195ed88a
fe6a9a8f59932f29cc77eac2a7e2c6bd07c8c7d0
3454c19f3c277d5d0099f17e7ebf5d2005afa4b0

Bionic will needs all of the above sha's.

Dave Chiluk (chiluk) wrote :

@Kaj Printz Madsen

I know you opened this a long time ago, but is there any chance you could test the ppa for me?

Thanks.

Yeah I will.

On Tue, 5 Feb 2019 at 19:25, Dave Chiluk <email address hidden> wrote:

> @Kaj Printz Madsen
>
> I know you opened this a long time ago, but is there any chance you
> could test the ppa for me?
>
> Thanks.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1758736
>
> Title:
> [USB-Audio - SteelSeries Arctis 7, playback] No stereo playback only
> mono playback
>
> Status in pulseaudio package in Ubuntu:
> Confirmed
> Status in pulseaudio source package in Bionic:
> In Progress
> Status in pulseaudio source package in Cosmic:
> Confirmed
> Status in pulseaudio source package in Disco:
> Confirmed
>
> Bug description:
> There is not stereo playback only mono playback
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.10
> Package: pulseaudio 1:10.0-2ubuntu3.1
> ProcVersionSignature: Ubuntu 4.13.0-37.42-generic 4.13.13
> Uname: Linux 4.13.0-37-generic x86_64
> ApportVersion: 2.20.7-0ubuntu3.7
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/pcmC1D0p: kaj 1755 F...m pulseaudio
> /dev/snd/controlC1: kaj 1755 F.... pulseaudio
> /dev/snd/pcmC0D0c: kaj 1755 F...m pulseaudio
> /dev/snd/controlC0: kaj 1755 F.... pulseaudio
> CurrentDesktop: ubuntu:GNOME
> Date: Sun Mar 25 21:30:50 2018
> InstallationDate: Installed on 2018-03-08 (17 days ago)
> InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64
> (20180105.1)
> SourcePackage: pulseaudio
> Symptom: audio
> Symptom_AlsaPlaybackTest: ALSA playback test through plughw:S7 successful
> Symptom_Card: SteelSeries Arctis 7 - SteelSeries Arctis 7
> Symptom_PulsePlaybackTest: PulseAudio playback test failed
> Symptom_Type: No sound at all
> Title: [USB-Audio - SteelSeries Arctis 7, playback] No sound at all
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 03/09/2016
> dmi.bios.vendor: LENOVO
> dmi.bios.version: R06ET35W (1.09 )
> dmi.board.asset.tag: Not Available
> dmi.board.name: 20FMS2AV00
> dmi.board.vendor: LENOVO
> dmi.board.version: SDK0J40697 WIN
> dmi.chassis.asset.tag: No Asset Information
> dmi.chassis.type: 10
> dmi.chassis.vendor: LENOVO
> dmi.chassis.version: None
> dmi.modalias:
> dmi:bvnLENOVO:bvrR06ET35W(1.09):bd03/09/2016:svnLENOVO:pn20FMS2AV00:pvrThinkPadT460:rvnLENOVO:rn20FMS2AV00:rvrSDK0J40697WIN:cvnLENOVO:ct10:cvrNone:
> dmi.product.family: ThinkPad T460
> dmi.product.name: 20FMS2AV00
> dmi.product.version: ThinkPad T460
> dmi.sys.vendor: LENOVO
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1758736/+subscriptions
>

Kaj Printz Madsen (kajprintz) wrote :
Download full text (3.2 KiB)

As the picture shows the ppa seems to be working fine. The stereo device
has the profiles, "Analog Stereo Output" and "Analog Mono Output + Analog
Stereo Output + Analog Mono Input" but selecting the former profile
automatically selects the mono device which is confusing to me.

[image: Screenshot from 2019-02-07 19-37-11.png]

On Thu, 7 Feb 2019 at 19:21, Kaj Printz Madsen <email address hidden> wrote:

> Yeah I will.
>
> On Tue, 5 Feb 2019 at 19:25, Dave Chiluk <email address hidden>
> wrote:
>
>> @Kaj Printz Madsen
>>
>> I know you opened this a long time ago, but is there any chance you
>> could test the ppa for me?
>>
>> Thanks.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1758736
>>
>> Title:
>> [USB-Audio - SteelSeries Arctis 7, playback] No stereo playback only
>> mono playback
>>
>> Status in pulseaudio package in Ubuntu:
>> Confirmed
>> Status in pulseaudio source package in Bionic:
>> In Progress
>> Status in pulseaudio source package in Cosmic:
>> Confirmed
>> Status in pulseaudio source package in Disco:
>> Confirmed
>>
>> Bug description:
>> There is not stereo playback only mono playback
>>
>> ProblemType: Bug
>> DistroRelease: Ubuntu 17.10
>> Package: pulseaudio 1:10.0-2ubuntu3.1
>> ProcVersionSignature: Ubuntu 4.13.0-37.42-generic 4.13.13
>> Uname: Linux 4.13.0-37-generic x86_64
>> ApportVersion: 2.20.7-0ubuntu3.7
>> Architecture: amd64
>> AudioDevicesInUse:
>> USER PID ACCESS COMMAND
>> /dev/snd/pcmC1D0p: kaj 1755 F...m pulseaudio
>> /dev/snd/controlC1: kaj 1755 F.... pulseaudio
>> /dev/snd/pcmC0D0c: kaj 1755 F...m pulseaudio
>> /dev/snd/controlC0: kaj 1755 F.... pulseaudio
>> CurrentDesktop: ubuntu:GNOME
>> Date: Sun Mar 25 21:30:50 2018
>> InstallationDate: Installed on 2018-03-08 (17 days ago)
>> InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64
>> (20180105.1)
>> SourcePackage: pulseaudio
>> Symptom: audio
>> Symptom_AlsaPlaybackTest: ALSA playback test through plughw:S7
>> successful
>> Symptom_Card: SteelSeries Arctis 7 - SteelSeries Arctis 7
>> Symptom_PulsePlaybackTest: PulseAudio playback test failed
>> Symptom_Type: No sound at all
>> Title: [USB-Audio - SteelSeries Arctis 7, playback] No sound at all
>> UpgradeStatus: No upgrade log present (probably fresh install)
>> dmi.bios.date: 03/09/2016
>> dmi.bios.vendor: LENOVO
>> dmi.bios.version: R06ET35W (1.09 )
>> dmi.board.asset.tag: Not Available
>> dmi.board.name: 20FMS2AV00
>> dmi.board.vendor: LENOVO
>> dmi.board.version: SDK0J40697 WIN
>> dmi.chassis.asset.tag: No Asset Information
>> dmi.chassis.type: 10
>> dmi.chassis.vendor: LENOVO
>> dmi.chassis.version: None
>> dmi.modalias:
>> dmi:bvnLENOVO:bvrR06ET35W(1.09):bd03/09/2016:svnLENOVO:pn20FMS2AV00:pvrThinkPadT460:rvnLENOVO:rn20FMS2AV00:rvrSDK0J40697WIN:cvnLENOVO:ct10:cvrNone:
>> dmi.product.family: ThinkPad T460
>> dmi.product.name: 20FMS2AV00
>> dmi.product.version: ThinkPad T460
>> dmi.sys.vendor: LENOVO
>>
>> To manage notifications about this bug go to:
>>
>...

Read more...

Kaj Printz Madsen (kajprintz) wrote :
Download full text (3.5 KiB)

Another thing I noticed is a noticeably lower max output volume when using
the stereo output device, I'm no sure if that's a bug or intended but now
you know.

On Thu, 7 Feb 2019 at 19:45, Kaj Printz Madsen <email address hidden> wrote:

> As the picture shows the ppa seems to be working fine. The stereo device
> has the profiles, "Analog Stereo Output" and "Analog Mono Output + Analog
> Stereo Output + Analog Mono Input" but selecting the former profile
> automatically selects the mono device which is confusing to me.
>
>
>
> [image: Screenshot from 2019-02-07 19-37-11.png]
>
>
>
> On Thu, 7 Feb 2019 at 19:21, Kaj Printz Madsen <email address hidden>
> wrote:
>
>> Yeah I will.
>>
>> On Tue, 5 Feb 2019 at 19:25, Dave Chiluk <email address hidden>
>> wrote:
>>
>>> @Kaj Printz Madsen
>>>
>>> I know you opened this a long time ago, but is there any chance you
>>> could test the ppa for me?
>>>
>>> Thanks.
>>>
>>> --
>>> You received this bug notification because you are subscribed to the bug
>>> report.
>>> https://bugs.launchpad.net/bugs/1758736
>>>
>>> Title:
>>> [USB-Audio - SteelSeries Arctis 7, playback] No stereo playback only
>>> mono playback
>>>
>>> Status in pulseaudio package in Ubuntu:
>>> Confirmed
>>> Status in pulseaudio source package in Bionic:
>>> In Progress
>>> Status in pulseaudio source package in Cosmic:
>>> Confirmed
>>> Status in pulseaudio source package in Disco:
>>> Confirmed
>>>
>>> Bug description:
>>> There is not stereo playback only mono playback
>>>
>>> ProblemType: Bug
>>> DistroRelease: Ubuntu 17.10
>>> Package: pulseaudio 1:10.0-2ubuntu3.1
>>> ProcVersionSignature: Ubuntu 4.13.0-37.42-generic 4.13.13
>>> Uname: Linux 4.13.0-37-generic x86_64
>>> ApportVersion: 2.20.7-0ubuntu3.7
>>> Architecture: amd64
>>> AudioDevicesInUse:
>>> USER PID ACCESS COMMAND
>>> /dev/snd/pcmC1D0p: kaj 1755 F...m pulseaudio
>>> /dev/snd/controlC1: kaj 1755 F.... pulseaudio
>>> /dev/snd/pcmC0D0c: kaj 1755 F...m pulseaudio
>>> /dev/snd/controlC0: kaj 1755 F.... pulseaudio
>>> CurrentDesktop: ubuntu:GNOME
>>> Date: Sun Mar 25 21:30:50 2018
>>> InstallationDate: Installed on 2018-03-08 (17 days ago)
>>> InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64
>>> (20180105.1)
>>> SourcePackage: pulseaudio
>>> Symptom: audio
>>> Symptom_AlsaPlaybackTest: ALSA playback test through plughw:S7
>>> successful
>>> Symptom_Card: SteelSeries Arctis 7 - SteelSeries Arctis 7
>>> Symptom_PulsePlaybackTest: PulseAudio playback test failed
>>> Symptom_Type: No sound at all
>>> Title: [USB-Audio - SteelSeries Arctis 7, playback] No sound at all
>>> UpgradeStatus: No upgrade log present (probably fresh install)
>>> dmi.bios.date: 03/09/2016
>>> dmi.bios.vendor: LENOVO
>>> dmi.bios.version: R06ET35W (1.09 )
>>> dmi.board.asset.tag: Not Available
>>> dmi.board.name: 20FMS2AV00
>>> dmi.board.vendor: LENOVO
>>> dmi.board.version: SDK0J40697 WIN
>>> dmi.chassis.asset.tag: No Asset Information
>>> dmi.chassis.type: 10
>>> dmi.chassis.vendor: LENOVO
>>> dmi.chassis.version: None
>>> dmi.modalias:
>>> dmi:bvnLENOVO:...

Read more...

Dave Chiluk (chiluk) wrote :

I'm pretty sure you need to adjust the "chat mix" knob on your headset as the audio will now be playing through a separate audio device on the headset. Basically previously it was using the mono "chat"/mono output on the headphones. Now with the ppa it's primarily using the "game"/stereo output. AFAIU the knob adjusts the mix between the two outputs on the headphones themselves.

Dave Chiluk (chiluk) on 2019-02-08
Changed in pulseaudio (Ubuntu Cosmic):
status: Confirmed → In Progress
Changed in pulseaudio (Ubuntu Disco):
status: Confirmed → In Progress
Dave Chiluk (chiluk) wrote :

I uploaded test packages for cosmic and disco to my ppa today. If someone with the headset could test either of those as well that would be awesome. I should be getting a headset here soon to test with.

Dave Chiluk (chiluk) on 2019-02-12
description: updated
Dave Chiluk (chiluk) wrote :

I uploaded the changes to disco this morning.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:12.2-2ubuntu1

---------------
pulseaudio (1:12.2-2ubuntu1) disco; urgency=medium

  * Add steelseries headset support. This provides sufficient support to
    enable the Steelseries Arctis 5 and 7 Gaming Headsets (LP: #1758736).

 -- Dave Chiluk <email address hidden> Tue, 12 Feb 2019 00:50:27 -0600

Changed in pulseaudio (Ubuntu Disco):
status: In Progress → Fix Released
Dave Chiluk (chiluk) wrote :

I uploaded these changes for bionic and cosmic. Just waiting on sru approval now.

Luke Meissner (adhdluke) wrote :

Until the fix gets pushed to bionic and cosmic, you should able to get stereo playback using the headphone jack adapter for the headsets that should be included with them. Cable's a bit short, but it works.

Hello Kaj, or anyone else affected,

Accepted pulseaudio into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pulseaudio/1:12.2-0ubuntu5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in pulseaudio (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Changed in pulseaudio (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Brian Murray (brian-murray) wrote :

Hello Kaj, or anyone else affected,

Accepted pulseaudio into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pulseaudio/1:11.1-1ubuntu7.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Dave Chiluk (chiluk) wrote :

I have tested bionic and cosmic myself, but I'd like to hear from a user or two. I have experienced the low-volume issue, but that appears to be correctable by launching alsamixer. All in all it's a better experience than before imho.

Hans V. Rasmussen (decclo) wrote :

I only tested bionic, the stereo playback works seemingly flawless. The low volume problem is indeed still present, but as Dave pointed out, changing the headphone gain from -16 (50%) to 0 (100%) solves it (Thanks Dave!).

Dave Chiluk (chiluk) on 2019-03-03
tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:12.2-0ubuntu5

---------------
pulseaudio (1:12.2-0ubuntu5) cosmic; urgency=medium

  * Add steelseries headset support. This provides sufficient support to
    enable the Steelseries Arctis 5 and 7 Gaming Headsets (LP: #1758736).

 -- Dave Chiluk <email address hidden> Tue, 12 Feb 2019 00:44:03 -0600

Changed in pulseaudio (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for pulseaudio has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:11.1-1ubuntu7.2

---------------
pulseaudio (1:11.1-1ubuntu7.2) bionic; urgency=medium

  * Add steelseries headset support. This provides sufficient support to
    enable the Steelseries Arctis 5 and 7 Gaming Headsets (LP: #1758736).

 -- Dave Chiluk <email address hidden> Wed, 23 Jan 2019 00:54:58 -0600

Changed in pulseaudio (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers